source: projects/specs/trunk/O/OpenImageIO/OpenImageIO-vl.spec @ 12387

Revision 12387, 8.9 KB checked in by tomop, 4 years ago (diff)

updated 10 packages

Field3D-1.7.3-1

OpenImageIO-2.1.10.1-1

ekiga-4.0.1-11

galera-26.4.3-2

gnucash-3.10-1

libboost-1.72.0-1

nghttp2-1.40.0-2

opal-3.10.11-1

ptlib-2.10.11-1

source-highlight-3.1.8-2

Line 
1%global subname oiio
2
3Name:           OpenImageIO
4Version:        2.1.10.1
5Release:        1%{?_dist_release}
6Summary:        Library for reading and writing images
7Group:          System Environment/Libraries
8Vendor:         Project Vine
9Distribution:   Vine Linux
10
11License:        BSD
12URL:            https://sites.google.com/site/openimageio/home
13Source0:        https://github.com/%{name}/%{subname}/archive/Release-%{version}/%{subname}-Release-%{version}.tar.gz
14# Images for test suite
15#Source1:        oiio-images.tar.gz
16
17BuildRequires:  cmake
18BuildRequires:  git
19BuildRequires:  txt2man
20BuildRequires:  qt5-qtbase-devel
21BuildRequires:  libboost-devel
22BuildRequires:  libboost-python3
23BuildRequires:  libboost-filesystem
24BuildRequires:  glew-devel
25BuildRequires:  OpenEXR-devel
26BuildRequires:  python3-devel
27BuildRequires:  python3-rpm-macros
28# BuildRequires:  openssl-devel
29BuildRequires:  libpng-devel libtiff-devel openjpeg2-devel giflib-devel
30BuildRequires:  libwebp-devel
31BuildRequires:  Field3D-devel
32BuildRequires:  hdf5-devel
33BuildRequires:  zlib-devel
34BuildRequires:  jasper-devel
35BuildRequires:  LibRaw-devel
36BuildRequires:  pugixml-devel
37
38# WARNING: OpenColorIO and OpenImageIO are cross dependent.
39# If an ABI incompatible update is done in one, the other also needs to be
40# rebuilt.
41BuildRequires:  OpenColorIO-devel
42
43Obsoletes:      python-OpenImageIO
44
45# We don't want to provide private python extension libs
46%{?filter_setup:
47%filter_provides_in %{python3_sitearch}/.*\.so$
48%filter_setup
49}
50
51
52%description
53OpenImageIO is a library for reading and writing images, and a bunch of related
54classes, utilities, and applications. Main features include:
55- Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
56  writing 2D images that is format agnostic.
57- Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
58  DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
59  PNM/PPM/PGM/PBM, Field3d.
60- An ImageCache class that transparently manages a cache so that it can access
61  truly vast amounts of image data.
62
63
64%package -n python3-%{name}
65Summary:        Python 3 bindings for %{name}
66Requires:       %{name} = %{version}-%{release}
67
68%description -n python3-%{name}
69Python3 bindings for %{name}.
70
71
72%package utils
73Summary:        Command line utilities for %{name}
74Requires:       %{name} = %{version}-%{release}
75
76%description utils
77Command-line tools to manipulate and get information on images using the
78%{name} library.
79
80
81%package iv
82Summary:        %{name} based image viewer
83Requires:       %{name} = %{version}-%{release}
84
85%description iv
86A really nice image viewer, iv, based on %{name} classes (and so will work
87with any formats for which plugins are available).
88
89
90%package devel
91Summary:        Documentation for %{name}
92Group:          Development/Libraries
93Requires:       %{name} = %{version}-%{release}
94
95%description devel
96Development files for package %{name}
97
98
99%prep
100%setup -q -n oiio-Release-%{version}
101
102# Remove bundled pugixml
103%{__rm} -f src/include/pugixml.hpp \
104        src/include/pugiconfig.hpp \
105        src/libutil/pugixml.cpp
106
107# Remove bundled tbb
108%{__rm} -rf src/include/tbb
109
110# Install test images
111#rm -rf ../oiio-images && mkdir ../oiio-images && pushd ../oiio-images
112#tar --strip-components=1 -xzf %{SOURCE1}
113
114
115%build
116%{__rm} -rf build/linux && %{__mkdir_p} build/linux && pushd build/linux
117
118export PYTHON=%{__python3}
119export PYTHON_LIBRARIES=%(%{__python3} -c "import distutils.sysconfig as sysconfig; print(sysconfig.get_config_var('LIBDIR'))")
120export PYTHON_INCLUDE_DIRS=%(%{__python3} -c "from distutils.sysconfig import get_python_inc; print(get_python_inc())")
121
122# CMAKE_SKIP_RPATH is OK here because it is set to FALSE internally and causes
123# CMAKE_INSTALL_RPATH to be cleared, which is the desiered result.
124%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
125       -DCMAKE_SKIP_RPATH:BOOL=TRUE \
126       -DINCLUDE_INSTALL_DIR:PATH=/usr/include/%{name} \
127       -DPYTHON_VERSION=3.5 \
128       -DPYTHON_EXECUTABLE=%{__python3} \
129       -DPYTHON_LIBRARY=$PYTHON_LIBRARIES \
130       -DPYLIB_INSTALL_DIR:PATH=%{python3_sitearch} \
131       -DINSTALL_DOCS:BOOL=FALSE \
132       -DINSTALL_FONTS:BOOL=FALSE \
133       -DUSE_EXTERNAL_PUGIXML:BOOL=TRUE \
134       -DUSE_TBB:BOOL=FALSE \
135       -DUSE_OPENSSL:BOOL=TRUE \
136       -DSTOP_ON_WARNING:BOOL=FALSE \
137       -DUSE_CPP:STRING=14 \
138%ifarch ppc ppc64
139       -DNOTHREADS:BOOL=FALSE \
140%endif
141       -DJPEG_INCLUDE_DIR=%{_includedir} \
142       -DVERBOSE=TRUE \
143       ../../
144
145%{__make} %{?_smp_mflags}
146popd
147
148%install
149pushd build/linux
150%{make_install}
151popd
152
153# # Move man pages to the right directory
154# mkdir -p %{buildroot}%{_mandir}/man1
155# cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
156
157%post -p %{_syssbindir}/ldconfig
158%postun -p %{_syssbindir}/ldconfig
159
160
161%files
162%license LICENSE*
163%doc CHANGES.md CONTRIBUTING.md README.md
164%{_libdir}/libOpenImageIO.so.*
165%{_libdir}/libOpenImageIO_Util.so.*
166
167%files -n python3-%{name}
168%{python3_sitearch}/OpenImageIO.so
169
170%files utils
171%exclude %{_bindir}/iv
172%{_bindir}/*
173# %exclude %{_mandir}/man1/iv.1.gz
174# %{_mandir}/man1/*.1.gz
175
176%files iv
177%{_bindir}/iv
178# %{_mandir}/man1/iv.1.gz
179
180%files devel
181%doc src/doc/*.pdf
182%{_libdir}/libOpenImageIO.so
183%{_libdir}/libOpenImageIO_Util.so
184%dir %{_libdir}/pkgconfig
185%{_libdir}/pkgconfig/OpenImageIO.pc
186%dir %{_datadir}/cmake
187%dir %{_datadir}/cmake/Modules
188%dir %{_libdir}/cmake/OpenImageIO
189%{_datadir}/cmake/Modules/FindOpenImageIO.cmake
190%{_libdir}/cmake/OpenImageIO/*
191%{_includedir}/*
192
193
194%changelog
195* Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.10.1-1
196- new upstream release.
197- built with boost-1.72.0.
198
199* Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.11-1
200- new upstream release.
201
202* Sun Sep 08 2019 Toshiaki Ara <ara_t@384.jp> 1.8.17-1
203- update to 1.8.17
204
205* Tue Nov 06 2018 Toshiaki Ara <ara_t@384.jp> 1.8.16-1
206- update to 1.8.16
207- change BuildRequires: qt4-devel to qt5-qtbase-devel
208- drop BuildRequires: openssl-devel
209
210* Fri Aug 24 2018 Toshiaki Ara <ara_t@384.jp> 1.7.19-3
211- update to 1.7.19
212- using macro
213
214* Sat Aug 04 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-2
215- rebuild with hdf5-1.8.20
216
217* Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-1
218- update to 1.7.17
219
220* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.14-3
221- rebuilt with LibRaw-0.17.2.
222
223* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-2
224- rebuild with gcc-5.4.0
225
226* Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
227- new upstream release
228
229* Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.13-1
230- new upstream release
231- remove Patch0
232- create python-%%{name} subpackage
233
234* Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-2
235- rebuild with glew-1.13.0
236
237* Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-1
238- initial build for Vine Linux
239- add Patch0 (oiio-Release-1.4.15-sign-compare.patch)
240
241
242* Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.15-2
243- rebuild (openexr)
244
245* Tue Nov 25 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.15-1
246- Update to latest upstream release.
247
248* Fri Nov 14 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.14-1
249- Update to latest upstream release.
250
251* Fri Sep  5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-4
252- Rebuild for Field3D 1.4.3.
253
254* Thu Sep 04 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4.12-3
255- Rebuild for pugixml 1.4
256
257* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.12-2
258- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
259
260* Fri Aug  1 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-1
261- Update to latest upstream release.
262
263* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-4
264- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
265
266* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.7-3
267- Rebuild for boost 1.55.0
268
269* Fri May 23 2014 David Tardon <dtardon@redhat.com> - 1.4.7-2
270- rebuild for boost 1.55.0
271
272* Mon May 19 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.7-1
273- Update to latest upstream release.
274
275* Tue Jan  7 2014 Richard Shaw <hobbes1069@gmail.com> - 1.3.10-1
276- Update to latest upstream release.
277- Add libgif as build requirement.
278
279* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> - 1.2.3-3
280- rebuild (openexr)
281
282* Mon Nov 18 2013 Dave Airlie <airlied@redhat.com> - 1.2.3-2
283- rebuilt for GLEW 1.10
284
285* Wed Nov  6 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.3-1
286- Update to latest upstream release.
287- Fix ppc builds (BZ#1021977).
288- Add conditionals to build requirements for EPEL 6.
289
290* Wed Oct  2 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.2-1
291- Update to latest upstream release.
292
293* Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.2.1-2
294- rebuild (ilmbase/openexr)
295
296* Thu Aug  8 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
297- Update to latest upstream release.
298
299* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
300- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
301
302* Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1.2.0-2
303- Rebuild for boost 1.54.0
Note: See TracBrowser for help on using the repository browser.