source: projects/specs/trunk/O/OpenImageIO/OpenImageIO-vl.spec @ 12286

Revision 12286, 8.7 KB checked in by tomop, 5 years ago (diff)

updated 10 packages

Field3D-1.7.2-2

ImageMagick?-6.9.10.69-1

OpenColorIO-1.1.1-1

OpenEXR-2.4.0-1

OpenImageIO-2.0.11-1

babl-0.1.72-1

e2fsprogs-1.45.4-1

elfutils-0.177-1

gegl04-0.4.16-1

python3-3.5.7-5

Line 
1%global subname oiio
2
3Name:           OpenImageIO
4Version:        2.0.11
5Release:        1%{?_dist_release}
6Summary:        Library for reading and writing images
7Group:          System Environment/Libraries
8
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        BSD
13URL:            https://sites.google.com/site/openimageio/home
14
15Source0:        https://github.com/%{name}/%{subname}/archive/Release-%{version}/%{subname}-Release-%{version}.tar.gz
16# Images for test suite
17#Source1:        oiio-images.tar.gz
18
19BuildRequires:  cmake
20BuildRequires:  git
21BuildRequires:  txt2man
22BuildRequires:  qt5-qtbase-devel
23BuildRequires:  libboost-devel
24BuildRequires:  libboost-python3
25BuildRequires:  libboost-filesystem
26BuildRequires:  glew-devel
27BuildRequires:  OpenEXR-devel
28BuildRequires:  python3-devel
29BuildRequires:  python3-rpm-macros
30# BuildRequires:  openssl-devel
31BuildRequires:  libpng-devel libtiff-devel openjpeg2-devel giflib-devel
32BuildRequires:  libwebp-devel
33BuildRequires:  Field3D-devel
34BuildRequires:  hdf5-devel
35BuildRequires:  zlib-devel
36BuildRequires:  jasper-devel
37BuildRequires:  LibRaw-devel
38BuildRequires:  pugixml-devel
39
40# WARNING: OpenColorIO and OpenImageIO are cross dependent.
41# If an ABI incompatible update is done in one, the other also needs to be
42# rebuilt.
43BuildRequires:  OpenColorIO-devel
44
45Obsoletes:      python-OpenImageIO
46
47# We don't want to provide private python extension libs
48%{?filter_setup:
49%filter_provides_in %{python3_sitearch}/.*\.so$
50%filter_setup
51}
52
53
54%description
55OpenImageIO is a library for reading and writing images, and a bunch of related
56classes, utilities, and applications. Main features include:
57- Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
58  writing 2D images that is format agnostic.
59- Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
60  DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
61  PNM/PPM/PGM/PBM, Field3d.
62- An ImageCache class that transparently manages a cache so that it can access
63  truly vast amounts of image data.
64
65
66%package -n python3-%{name}
67Summary:        Python 3 bindings for %{name}
68Requires:       %{name} = %{version}-%{release}
69
70%description -n python3-%{name}
71Python3 bindings for %{name}.
72
73
74%package utils
75Summary:        Command line utilities for %{name}
76Requires:       %{name} = %{version}-%{release}
77
78%description utils
79Command-line tools to manipulate and get information on images using the
80%{name} library.
81
82
83%package iv
84Summary:        %{name} based image viewer
85Requires:       %{name} = %{version}-%{release}
86
87%description iv
88A really nice image viewer, iv, based on %{name} classes (and so will work
89with any formats for which plugins are available).
90
91
92%package devel
93Summary:        Documentation for %{name}
94Group:          Development/Libraries
95Requires:       %{name} = %{version}-%{release}
96
97%description devel
98Development files for package %{name}
99
100
101%prep
102%setup -q -n oiio-Release-%{version}
103
104# Remove bundled pugixml
105%{__rm} -f src/include/pugixml.hpp \
106        src/include/pugiconfig.hpp \
107        src/libutil/pugixml.cpp
108
109# Remove bundled tbb
110%{__rm} -rf src/include/tbb
111
112# Install test images
113#rm -rf ../oiio-images && mkdir ../oiio-images && pushd ../oiio-images
114#tar --strip-components=1 -xzf %{SOURCE1}
115
116
117%build
118%{__rm} -rf build/linux && %{__mkdir_p} build/linux && pushd build/linux
119
120export PYTHON=%{__python3}
121export PYTHON_LIBRARIES=%(%{__python3} -c "import distutils.sysconfig as sysconfig; print(sysconfig.get_config_var('LIBDIR'))")
122export PYTHON_INCLUDE_DIRS=%(%{__python3} -c "from distutils.sysconfig import get_python_inc; print(get_python_inc())")
123
124# CMAKE_SKIP_RPATH is OK here because it is set to FALSE internally and causes
125# CMAKE_INSTALL_RPATH to be cleared, which is the desiered result.
126%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
127       -DCMAKE_SKIP_RPATH:BOOL=TRUE \
128       -DINCLUDE_INSTALL_DIR:PATH=/usr/include/%{name} \
129       -DPYTHON_VERSION=3.5 \
130       -DPYTHON_EXECUTABLE=%{__python3} \
131       -DPYTHON_LIBRARY=$PYTHON_LIBRARIES \
132       -DPYLIB_INSTALL_DIR:PATH=%{python3_sitearch} \
133       -DINSTALL_DOCS:BOOL=FALSE \
134       -DINSTALL_FONTS:BOOL=FALSE \
135       -DUSE_EXTERNAL_PUGIXML:BOOL=TRUE \
136       -DUSE_TBB:BOOL=FALSE \
137       -DUSE_OPENSSL:BOOL=TRUE \
138       -DSTOP_ON_WARNING:BOOL=FALSE \
139       -DUSE_CPP:STRING=14 \
140%ifarch ppc ppc64
141       -DNOTHREADS:BOOL=FALSE \
142%endif
143       -DJPEG_INCLUDE_DIR=%{_includedir} \
144       -DVERBOSE=TRUE \
145       ../../
146
147%{__make} %{?_smp_mflags}
148popd
149
150%install
151pushd build/linux
152%{make_install}
153popd
154
155# # Move man pages to the right directory
156# mkdir -p %{buildroot}%{_mandir}/man1
157# cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
158
159%post -p %{_syssbindir}/ldconfig
160%postun -p %{_syssbindir}/ldconfig
161
162
163%files
164%license LICENSE*
165%doc CHANGES.md CONTRIBUTING.md README.md
166%{_libdir}/libOpenImageIO.so.*
167%{_libdir}/libOpenImageIO_Util.so.*
168
169%files -n python3-%{name}
170%{python3_sitearch}/OpenImageIO.so
171
172%files utils
173%exclude %{_bindir}/iv
174%{_bindir}/*
175# %exclude %{_mandir}/man1/iv.1.gz
176# %{_mandir}/man1/*.1.gz
177
178%files iv
179%{_bindir}/iv
180# %{_mandir}/man1/iv.1.gz
181
182%files devel
183%doc src/doc/*.pdf
184%{_libdir}/libOpenImageIO.so
185%{_libdir}/libOpenImageIO_Util.so
186%dir %{_libdir}/pkgconfig
187%{_libdir}/pkgconfig/OpenImageIO.pc
188%dir %{_datadir}/cmake
189%dir %{_datadir}/cmake/Modules
190%{_datadir}/cmake/Modules/FindOpenImageIO.cmake
191%{_includedir}/*
192
193
194%changelog
195* Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.11-1
196- new upstream release.
197
198* Sun Sep 08 2019 Toshiaki Ara <ara_t@384.jp> 1.8.17-1
199- update to 1.8.17
200
201* Tue Nov 06 2018 Toshiaki Ara <ara_t@384.jp> 1.8.16-1
202- update to 1.8.16
203- change BuildRequires: qt4-devel to qt5-qtbase-devel
204- drop BuildRequires: openssl-devel
205
206* Fri Aug 24 2018 Toshiaki Ara <ara_t@384.jp> 1.7.19-3
207- update to 1.7.19
208- using macro
209
210* Sat Aug 04 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-2
211- rebuild with hdf5-1.8.20
212
213* Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-1
214- update to 1.7.17
215
216* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.14-3
217- rebuilt with LibRaw-0.17.2.
218
219* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-2
220- rebuild with gcc-5.4.0
221
222* Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
223- new upstream release
224
225* Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.13-1
226- new upstream release
227- remove Patch0
228- create python-%%{name} subpackage
229
230* Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-2
231- rebuild with glew-1.13.0
232
233* Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-1
234- initial build for Vine Linux
235- add Patch0 (oiio-Release-1.4.15-sign-compare.patch)
236
237
238* Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.15-2
239- rebuild (openexr)
240
241* Tue Nov 25 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.15-1
242- Update to latest upstream release.
243
244* Fri Nov 14 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.14-1
245- Update to latest upstream release.
246
247* Fri Sep  5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-4
248- Rebuild for Field3D 1.4.3.
249
250* Thu Sep 04 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4.12-3
251- Rebuild for pugixml 1.4
252
253* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.12-2
254- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
255
256* Fri Aug  1 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-1
257- Update to latest upstream release.
258
259* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-4
260- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
261
262* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.7-3
263- Rebuild for boost 1.55.0
264
265* Fri May 23 2014 David Tardon <dtardon@redhat.com> - 1.4.7-2
266- rebuild for boost 1.55.0
267
268* Mon May 19 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.7-1
269- Update to latest upstream release.
270
271* Tue Jan  7 2014 Richard Shaw <hobbes1069@gmail.com> - 1.3.10-1
272- Update to latest upstream release.
273- Add libgif as build requirement.
274
275* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> - 1.2.3-3
276- rebuild (openexr)
277
278* Mon Nov 18 2013 Dave Airlie <airlied@redhat.com> - 1.2.3-2
279- rebuilt for GLEW 1.10
280
281* Wed Nov  6 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.3-1
282- Update to latest upstream release.
283- Fix ppc builds (BZ#1021977).
284- Add conditionals to build requirements for EPEL 6.
285
286* Wed Oct  2 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.2-1
287- Update to latest upstream release.
288
289* Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.2.1-2
290- rebuild (ilmbase/openexr)
291
292* Thu Aug  8 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
293- Update to latest upstream release.
294
295* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
296- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
297
298* Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1.2.0-2
299- Rebuild for boost 1.54.0
Note: See TracBrowser for help on using the repository browser.