source: projects/specs/trunk/O/OpenImageIO/OpenImageIO-vl.spec @ 9767

Revision 9767, 6.6 KB checked in by Takemikaduchi, 9 years ago (diff)

blender,glew,mesa-demos: new upstream release
others: rebuild with glew-1.13.0

Line 
1%global subname oiio
2
3Name:           OpenImageIO
4Version:        1.4.15
5Release:        2%{?_dist_release}
6Summary:        Library for reading and writing images
7
8Group:          System Environment/Libraries
9License:        BSD
10URL:            https://sites.google.com/site/openimageio/home
11
12Source0:        https://github.com/%{name}/%{subname}/archive/Release-%{version}/%{subname}-Release-%{version}.tar.gz
13# Images for test suite
14#Source1:        oiio-images.tar.gz
15
16Patch0:                 oiio-Release-1.4.15-sign-compare.patch
17
18BuildRequires:  cmake
19BuildRequires:  txt2man
20BuildRequires:  qt4-devel
21BuildRequires:  libboost-devel
22BuildRequires:  libboost-python
23BuildRequires:  libboost-filesystem
24BuildRequires:  glew-devel
25BuildRequires:  OpenEXR-devel ilmbase-devel
26BuildRequires:  python-devel
27BuildRequires:  openssl-devel
28BuildRequires:  libpng-devel libtiff-devel openjpeg-devel giflib-devel
29BuildRequires:  libwebp-devel
30BuildRequires:  Field3D-devel
31BuildRequires:  hdf5-devel
32BuildRequires:  zlib-devel
33BuildRequires:  jasper-devel
34BuildRequires:  LibRaw-devel
35BuildRequires:  pugixml-devel
36
37# WARNING: OpenColorIO and OpenImageIO are cross dependent.
38# If an ABI incompatible update is done in one, the other also needs to be
39# rebuilt.
40BuildRequires:  OpenColorIO-devel
41
42# We don't want to provide private python extension libs
43%{?filter_setup:
44%filter_provides_in %{python_sitearch}/.*\.so$
45%filter_setup
46}
47
48
49%description
50OpenImageIO is a library for reading and writing images, and a bunch of related
51classes, utilities, and applications. Main features include:
52- Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
53  writing 2D images that is format agnostic.
54- Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
55  DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
56  PNM/PPM/PGM/PBM, Field3d.
57- An ImageCache class that transparently manages a cache so that it can access
58  truly vast amounts of image data.
59
60
61%package utils
62Summary:        Command line utilities for %{name}
63Requires:       %{name} = %{version}-%{release}
64
65%description utils
66Command-line tools to manipulate and get information on images using the
67%{name} library.
68
69
70%package iv
71Summary:        %{name} based image viewer
72Requires:       %{name} = %{version}-%{release}
73
74%description iv
75A really nice image viewer, iv, based on %{name} classes (and so will work
76with any formats for which plugins are available).
77
78
79%package devel
80Summary:        Documentation for %{name}
81Group:          Development/Libraries
82Requires:       %{name} = %{version}-%{release}
83
84%description devel
85Development files for package %{name}
86
87
88%prep
89%setup -q -n oiio-Release-%{version}
90%patch0 -p1
91
92# Remove bundled pugixml
93rm -f src/include/pugixml.hpp \
94      src/include/pugiconfig.hpp \
95      src/libutil/pugixml.cpp
96
97# Remove bundled tbb
98rm -rf src/include/tbb
99
100# Install test images
101#rm -rf ../oiio-images && mkdir ../oiio-images && pushd ../oiio-images
102#tar --strip-components=1 -xzf %{SOURCE1}
103
104
105%build
106rm -rf build/linux && mkdir -p build/linux && pushd build/linux
107# CMAKE_SKIP_RPATH is OK here because it is set to FALSE internally and causes
108# CMAKE_INSTALL_RPATH to be cleared, which is the desiered result.
109%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
110       -DCMAKE_SKIP_RPATH:BOOL=TRUE \
111       -DINCLUDE_INSTALL_DIR:PATH=/usr/include/%{name} \
112       -DPYLIB_INSTALL_DIR:PATH=%{python_sitearch} \
113       -DINSTALL_DOCS:BOOL=FALSE \
114       -DUSE_EXTERNAL_PUGIXML:BOOL=TRUE \
115       -DUSE_TBB:BOOL=FALSE \
116%ifarch ppc ppc64
117       -DNOTHREADS:BOOL=FALSE \
118%endif
119       -DVERBOSE=TRUE \
120       ../../
121
122make %{?_smp_mflags}
123
124
125%install
126pushd build/linux
127make DESTDIR=%{buildroot} install
128
129# Move man pages to the right directory
130mkdir -p %{buildroot}%{_mandir}/man1
131cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
132
133
134%post -p /sbin/ldconfig
135%postun -p /sbin/ldconfig
136
137
138
139%files
140%doc CHANGES LICENSE
141%{_libdir}/libOpenImageIO.so.*
142%{_libdir}/libOpenImageIO_Util.so.*
143%{python_sitearch}/OpenImageIO.so
144
145%files utils
146%exclude %{_bindir}/iv
147%{_bindir}/*
148%exclude %{_mandir}/man1/iv.1.gz
149%{_mandir}/man1/*.1.gz
150
151%files iv
152%{_bindir}/iv
153%{_mandir}/man1/iv.1.gz
154
155%files devel
156%doc src/doc/*.pdf
157%{_libdir}/libOpenImageIO.so
158%{_libdir}/libOpenImageIO_Util.so
159%{_includedir}/*
160
161
162%changelog
163* Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-2
164- rebuild with glew-1.13.0
165
166* Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-1
167- initial build for Vine Linux
168- add Patch0 (oiio-Release-1.4.15-sign-compare.patch)
169
170
171* Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.15-2
172- rebuild (openexr)
173
174* Tue Nov 25 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.15-1
175- Update to latest upstream release.
176
177* Fri Nov 14 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.14-1
178- Update to latest upstream release.
179
180* Fri Sep  5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-4
181- Rebuild for Field3D 1.4.3.
182
183* Thu Sep 04 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4.12-3
184- Rebuild for pugixml 1.4
185
186* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.12-2
187- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
188
189* Fri Aug  1 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-1
190- Update to latest upstream release.
191
192* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-4
193- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
194
195* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.7-3
196- Rebuild for boost 1.55.0
197
198* Fri May 23 2014 David Tardon <dtardon@redhat.com> - 1.4.7-2
199- rebuild for boost 1.55.0
200
201* Mon May 19 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.7-1
202- Update to latest upstream release.
203
204* Tue Jan  7 2014 Richard Shaw <hobbes1069@gmail.com> - 1.3.10-1
205- Update to latest upstream release.
206- Add libgif as build requirement.
207
208* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> - 1.2.3-3
209- rebuild (openexr)
210
211* Mon Nov 18 2013 Dave Airlie <airlied@redhat.com> - 1.2.3-2
212- rebuilt for GLEW 1.10
213
214* Wed Nov  6 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.3-1
215- Update to latest upstream release.
216- Fix ppc builds (BZ#1021977).
217- Add conditionals to build requirements for EPEL 6.
218
219* Wed Oct  2 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.2-1
220- Update to latest upstream release.
221
222* Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.2.1-2
223- rebuild (ilmbase/openexr)
224
225* Thu Aug  8 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
226- Update to latest upstream release.
227
228* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
229- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
230
231* Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1.2.0-2
232- Rebuild for boost 1.54.0
Note: See TracBrowser for help on using the repository browser.