source: projects/specs/trunk/O/OpenImageIO/OpenImageIO-vl.spec @ 10245

Revision 10245, 7.0 KB checked in by Takemikaduchi, 8 years ago (diff)

OpenImageIO,cmake: new upstream release
others: rebuild

Line 
1%global subname oiio
2
3Name:           OpenImageIO
4Version:        1.6.13
5Release:        1%{?_dist_release}
6Summary:        Library for reading and writing images
7
8Group:          System Environment/Libraries
9License:        BSD
10URL:            https://sites.google.com/site/openimageio/home
11
12Source0:        https://github.com/%{name}/%{subname}/archive/Release-%{version}/%{subname}-Release-%{version}.tar.gz
13# Images for test suite
14#Source1:        oiio-images.tar.gz
15
16BuildRequires:  cmake
17BuildRequires:  txt2man
18BuildRequires:  qt4-devel
19BuildRequires:  libboost-devel
20BuildRequires:  libboost-python
21BuildRequires:  libboost-filesystem
22BuildRequires:  glew-devel
23BuildRequires:  OpenEXR-devel ilmbase-devel
24BuildRequires:  python-devel
25BuildRequires:  openssl-devel
26BuildRequires:  libpng-devel libtiff-devel openjpeg-devel giflib-devel
27BuildRequires:  libwebp-devel
28BuildRequires:  Field3D-devel
29BuildRequires:  hdf5-devel
30BuildRequires:  zlib-devel
31BuildRequires:  jasper-devel
32BuildRequires:  LibRaw-devel
33BuildRequires:  pugixml-devel
34
35# WARNING: OpenColorIO and OpenImageIO are cross dependent.
36# If an ABI incompatible update is done in one, the other also needs to be
37# rebuilt.
38BuildRequires:  OpenColorIO-devel
39
40# We don't want to provide private python extension libs
41%{?filter_setup:
42%filter_provides_in %{python_sitearch}/.*\.so$
43%filter_setup
44}
45
46
47%description
48OpenImageIO is a library for reading and writing images, and a bunch of related
49classes, utilities, and applications. Main features include:
50- Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
51  writing 2D images that is format agnostic.
52- Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
53  DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
54  PNM/PPM/PGM/PBM, Field3d.
55- An ImageCache class that transparently manages a cache so that it can access
56  truly vast amounts of image data.
57
58
59%package -n python-%{name}
60Summary:        Python 2 bindings for %{name}
61Requires:       %{name} = %{version}-%{release}
62
63%description -n python-%{name}
64Python bindings for %{name}.
65
66
67%package utils
68Summary:        Command line utilities for %{name}
69Requires:       %{name} = %{version}-%{release}
70
71%description utils
72Command-line tools to manipulate and get information on images using the
73%{name} library.
74
75
76%package iv
77Summary:        %{name} based image viewer
78Requires:       %{name} = %{version}-%{release}
79
80%description iv
81A really nice image viewer, iv, based on %{name} classes (and so will work
82with any formats for which plugins are available).
83
84
85%package devel
86Summary:        Documentation for %{name}
87Group:          Development/Libraries
88Requires:       %{name} = %{version}-%{release}
89
90%description devel
91Development files for package %{name}
92
93
94%prep
95%setup -q -n oiio-Release-%{version}
96
97# Remove bundled pugixml
98rm -f src/include/pugixml.hpp \
99      src/include/pugiconfig.hpp \
100      src/libutil/pugixml.cpp
101
102# Remove bundled tbb
103rm -rf src/include/tbb
104
105# Install test images
106#rm -rf ../oiio-images && mkdir ../oiio-images && pushd ../oiio-images
107#tar --strip-components=1 -xzf %{SOURCE1}
108
109
110%build
111rm -rf build/linux && mkdir -p build/linux && pushd build/linux
112# CMAKE_SKIP_RPATH is OK here because it is set to FALSE internally and causes
113# CMAKE_INSTALL_RPATH to be cleared, which is the desiered result.
114%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
115       -DCMAKE_SKIP_RPATH:BOOL=TRUE \
116       -DINCLUDE_INSTALL_DIR:PATH=/usr/include/%{name} \
117       -DPYLIB_INSTALL_DIR:PATH=%{python_sitearch} \
118       -DINSTALL_DOCS:BOOL=FALSE \
119       -DINSTALL_FONTS:BOOL=FALSE \
120       -DUSE_EXTERNAL_PUGIXML:BOOL=TRUE \
121       -DUSE_TBB:BOOL=FALSE \
122%ifarch ppc ppc64
123       -DNOTHREADS:BOOL=FALSE \
124%endif
125       -DVERBOSE=TRUE \
126       ../../
127
128make %{?_smp_mflags}
129
130
131%install
132pushd build/linux
133make DESTDIR=%{buildroot} install
134
135# Move man pages to the right directory
136mkdir -p %{buildroot}%{_mandir}/man1
137cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
138
139
140%post -p /sbin/ldconfig
141%postun -p /sbin/ldconfig
142
143
144
145%files
146%doc CHANGES LICENSE
147%{_libdir}/libOpenImageIO.so.*
148%{_libdir}/libOpenImageIO_Util.so.*
149
150%files -n python-%{name}
151%{python_sitearch}/OpenImageIO.so
152
153%files utils
154%exclude %{_bindir}/iv
155%{_bindir}/*
156%exclude %{_mandir}/man1/iv.1.gz
157%{_mandir}/man1/*.1.gz
158
159%files iv
160%{_bindir}/iv
161%{_mandir}/man1/iv.1.gz
162
163%files devel
164%doc src/doc/*.pdf
165%{_libdir}/libOpenImageIO.so
166%{_libdir}/libOpenImageIO_Util.so
167%{_includedir}/*
168
169
170%changelog
171* Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.13-1
172- new upstream release
173- remove Patch0
174- create python-%%{name} subpackage
175
176* Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-2
177- rebuild with glew-1.13.0
178
179* Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-1
180- initial build for Vine Linux
181- add Patch0 (oiio-Release-1.4.15-sign-compare.patch)
182
183
184* Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.15-2
185- rebuild (openexr)
186
187* Tue Nov 25 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.15-1
188- Update to latest upstream release.
189
190* Fri Nov 14 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.14-1
191- Update to latest upstream release.
192
193* Fri Sep  5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-4
194- Rebuild for Field3D 1.4.3.
195
196* Thu Sep 04 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4.12-3
197- Rebuild for pugixml 1.4
198
199* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.12-2
200- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
201
202* Fri Aug  1 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-1
203- Update to latest upstream release.
204
205* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-4
206- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
207
208* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.7-3
209- Rebuild for boost 1.55.0
210
211* Fri May 23 2014 David Tardon <dtardon@redhat.com> - 1.4.7-2
212- rebuild for boost 1.55.0
213
214* Mon May 19 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.7-1
215- Update to latest upstream release.
216
217* Tue Jan  7 2014 Richard Shaw <hobbes1069@gmail.com> - 1.3.10-1
218- Update to latest upstream release.
219- Add libgif as build requirement.
220
221* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> - 1.2.3-3
222- rebuild (openexr)
223
224* Mon Nov 18 2013 Dave Airlie <airlied@redhat.com> - 1.2.3-2
225- rebuilt for GLEW 1.10
226
227* Wed Nov  6 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.3-1
228- Update to latest upstream release.
229- Fix ppc builds (BZ#1021977).
230- Add conditionals to build requirements for EPEL 6.
231
232* Wed Oct  2 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.2-1
233- Update to latest upstream release.
234
235* Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.2.1-2
236- rebuild (ilmbase/openexr)
237
238* Thu Aug  8 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
239- Update to latest upstream release.
240
241* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
242- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
243
244* Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1.2.0-2
245- Rebuild for boost 1.54.0
Note: See TracBrowser for help on using the repository browser.