source: projects/specs/trunk/O/OpenIPMI/OpenIPMI-vl.spec @ 12090

Revision 12090, 16.6 KB checked in by tomop, 5 years ago (diff)

OpenIPMI-2.0.27-1

Line 
1# TODO: uses private copy of libedit, should be modified to use system one
2%bcond_without python3
3
4%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
5Summary: IPMI (Intelligent Platform Management Interface) library and tools
6Summary(ja): IPMI (Intelligent Platform Management Interface) ライブラリおよびツール
7Name: OpenIPMI
8Version: 2.0.27
9Release: 1%{?_dist_release}
10License: LGPLv2+ and GPLv2+ or BSD
11Group: System Environment/Base
12URL: http://sourceforge.net/projects/openipmi/
13Source: http://downloads.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
14Source1: openipmi.sysconf
15Source2: openipmi.initscript
16Source3: openipmigui.desktop
17Source4: README.initscript
18#Patch3: 0003-Python3.patch
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20BuildRequires: desktop-file-utils
21BuildRequires: gdbm-devel
22BuildRequires: glib2-devel
23BuildRequires: libedit-devel
24BuildRequires: libxcrypt-devel
25BuildRequires: ncurses-devel
26BuildRequires: net-snmp-devel
27BuildRequires: openssl-devel
28BuildRequires: perl
29BuildRequires: popt-devel
30BuildRequires: swig
31BuildRequires: tcl
32
33%if %{with python3}
34BuildRequires: python3-devel
35BuildRequires: python3-rpm-macros
36BuildRequires: python3-tkinter
37%else
38BuildRequires: python-devel
39BuildRequires: python-rpm-macros
40BuildRequires: tkinter
41%endif
42
43Requires(post): chkconfig
44Requires(preun): chkconfig
45
46Vendor: Project Vine
47Distribution: Vine Linux
48
49%description
50The Open IPMI project aims to develop an open code base to allow access to
51platform information using Intelligent Platform Management Interface (IPMI).
52This package contains the tools of the OpenIPMI project.
53
54%package libs
55Summary: The OpenIPMI runtime libraries
56Summary(ja): OpenIPMI ランタイムライブラリ
57Group: System Environment/Libraries
58
59%description libs
60The OpenIPMI-libs package contains the runtime libraries for shared binaries
61and applications.
62
63%package perl
64Summary: IPMI Perl language bindings
65Summary(ja): IPMI Perl 言語バインディング
66Group: Development/Libraries
67Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
68
69%description perl
70The OpenIPMI-perl package contains the Perl language bindings for OpenIPMI.
71
72%if %{with python3}
73%package -n python3-openipmi
74Group: Development/Libraries
75Summary: IPMI Python3 language bindings
76Summary(ja): IPMI Python3 言語バインディング
77Requires: python3
78Obsoletes: %{name}-python < %{version}-%{release}
79Provides: %{name}-python = %{version}-%{release}
80
81%description -n python3-openipmi
82The OpenIPMI-python3 package contains the Python3 language bindings for OpenIPMI.
83
84%else
85%package python
86Group: Development/Libraries
87Summary: IPMI Python language bindings
88Summary(ja): IPMI Python 言語バインディング
89Requires: python
90
91%description python
92The OpenIPMI-python package contains the Python language bindings for OpenIPMI.
93
94%endif
95
96%package devel
97Summary: The development environment for the OpenIPMI project
98Summary(ja): OpenIPMI の開発キット
99Group: Development/Libraries
100Requires: %{name} = %{version}-%{release}
101Requires: pkgconfig
102
103%description devel
104The OpenIPMI-devel package contains the development libraries and header files
105of the OpenIPMI project.
106
107%package gui
108Summary: IPMI graphical user interface tool
109Summary(ja): IPMI GUI ツール
110Group: System Environment/Base
111Requires: tix
112Requires: tkinter
113%if %{with python3}
114Requires: python3-openipmi = %{version}-%{release}
115%else
116Requires: %{name}-python = %{version}-%{release}
117%endif
118
119%description gui
120The OpenIPMI-gui package contains the graphical user interface to monitor
121and control IPMI-enabled devices.
122
123
124%prep
125%setup -q
126#%patch3 -p1
127rm -rf ./libedit
128
129%build
130export EDIT_CFLAGS=`pkg-config --cflags libedit`
131export EDIT_LIBS=`pkg-config --libs libedit`
132
133export CFLAGS="-fPIC $RPM_OPT_FLAGS"
134
135perl -pi -e 's|readline/readline\.h|editline/readline.h|' cmdlang/ipmish.c
136perl -pi -e 's|-lreadline|-ledit|' cmdlang/Makefile.am
137perl -pi -e 's|-lreadline|-ledit|' sample/Makefile.am
138%if %{with python3}
139perl -pi -e 's|python conftest|%{__python3} conftest|' configure.ac
140%endif
141
142
143autoreconf -vif
144
145%configure \
146  CFLAGS="-fPIC %{optflags} -z now -fno-strict-aliasing" \
147  LDFLAGS="%{?__global_ldflags} -Wl,--as-needed" \
148  --disable-dependency-tracking \
149%if %{with python3}
150  --with-python=%{__python3} \
151  --with-pythoninstall=%{python3_sitearch} \
152%else
153  --with-pythoninstall=%{python_sitearch} \
154%endif
155  --with-tkinter=yes \
156  --with-tcl=no \
157  --with-glib12=no \
158  --disable-static
159# get rid of rpath
160sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
161sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
162sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
163
164make   # not %{?_smp_mflags} safe
165
166%install
167rm -rf $RPM_BUILD_ROOT
168make install DESTDIR=$RPM_BUILD_ROOT
169
170find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
171
172install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
173install -m 644 %SOURCE1 ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/ipmi
174install -d ${RPM_BUILD_ROOT}%{_initrddir}
175install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}%{_initrddir}/ipmi
176
177desktop-file-install --vendor="fedora" --dir=${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE3}
178
179install -m 644 %SOURCE4 .
180
181%post
182/sbin/chkconfig --add ipmi
183
184%preun
185if [ $1 = 0 ]; then
186   service ipmi stop >/dev/null 2>&1
187   /sbin/chkconfig --del ipmi
188fi
189
190%postun
191if [ "$1" -ge "1" ]; then
192    service ipmi condrestart >/dev/null 2>&1 || :
193fi
194
195%post libs -p /sbin/ldconfig
196
197%postun libs -p /sbin/ldconfig
198
199%clean
200rm -rf $RPM_BUILD_ROOT
201
202%files
203%defattr(-,root,root)
204%license COPYING COPYING.BSD COPYING.LIB
205%doc CONFIGURING_FOR_LAN FAQ README README.Force README.MotorolaMXP README.initscript
206%config(noreplace) %{_sysconfdir}/ipmi/ipmisim1.emu
207%config(noreplace) %{_sysconfdir}/ipmi/lan.conf
208%config(noreplace) %{_sysconfdir}/sysconfig/ipmi
209%{_initrddir}/ipmi
210%{_bindir}/ipmicmd
211%{_bindir}/ipmilan
212%{_bindir}/ipmish
213%{_bindir}/ipmi_sim
214%{_bindir}/ipmi_ui
215%{_bindir}/openipmicmd
216%{_bindir}/openipmish
217%{_bindir}/rmcp_ping
218%{_bindir}/sdrcomp
219%{_bindir}/solterm
220%{_bindir}/openipmi_eventd
221%{_mandir}/man1/ipmi_*
222%{_mandir}/man1/openipmicmd*
223%{_mandir}/man1/openipmish*
224%{_mandir}/man1/rmcp_ping*
225%{_mandir}/man1/solterm*
226%{_mandir}/man5/ipmi_*
227%{_mandir}/man1/openipmi_eventd*
228%{_mandir}/man7/ipmi_cmdlang*
229%{_mandir}/man7/openipmi_conparms*
230%{_mandir}/man8/ipmilan*
231
232%files perl
233%defattr(-,root,root)
234%attr(644,root,root) %{perl_vendorarch}/OpenIPMI.pm
235%{perl_vendorarch}/auto/OpenIPMI/
236
237%if %{with python3}
238%files -n python3-openipmi
239%defattr(-,root,root)
240%{python3_sitearch}/*OpenIPMI*
241%else
242%files python
243%defattr(-,root,root)
244%{python_sitearch}/*OpenIPMI*
245%endif
246
247%files libs
248%defattr(-,root,root)
249%{_libdir}/*.so.*
250
251%files devel
252%defattr(-,root,root)
253%{_includedir}/OpenIPMI
254%{_libdir}/*.so
255%{_libdir}/pkgconfig/*.pc
256
257%files gui
258%defattr(-,root,root)
259%{_bindir}/openipmigui
260%{_mandir}/man1/openipmigui*
261%if %{with python3}
262%{python3_sitearch}/openipmigui
263%else
264%{python_sitearch}/openipmigui
265%endif
266%{_datadir}/applications/fedora-openipmigui.desktop
267
268%changelog
269* Mon May 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.27-1
270- updated to 2.0.27.
271- dropped Patch2 (fixed in upstream).
272- added BR:libxcrypt-devel.
273- switched to python3.
274
275* Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.25-1
276- updated to 2.0.25.
277- dropped Patch1 (fixed in upstream).
278- imported Patch2 from rawhide.
279- added BR:libedit-devel.
280
281* Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.21-3
282- rebuild with openssl-1.0.2
283
284* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.21-2
285- remove *.la files
286
287* Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0.21-1
288- updated to 2.0.21
289- rebuilt with perl-5.16.3
290
291* Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-5
292- rebuild with net-snmp-5.7.1
293
294* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-4
295- rebuild with python-2.7.2
296
297* Sat May 21 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.18-3
298- build with perl 5.12.3
299- add Vendor and Distribution tags
300
301* Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-2
302- rebuild with openssl-1.0.0d
303
304* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.18-1
305- initial build for Vine Linux
306
307* Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.0.18-2
308- Mass rebuild with perl-5.12.0
309
310* Wed May  5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.18-1
311- updated to OpenIPMI-2.0.18
312- fixed OpenIPMIpthread pkgconfig file (#468067)
313
314* Mon May  3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.17-1
315- updated to OpenIPMI-2.0.17
316
317* Thu Mar 18 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-12
318- implemented mandatory 'force-reload' command in ipmi service
319
320* Thu Mar 11 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-11
321- rebuild against new gdbm
322
323* Wed Mar  3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-10
324- add README.initscript describing /etc/init.d/ipmi initscript exit codes
325  (#562151)
326
327* Mon Feb 22 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-9
328- fix package License: field, there *are* sources with BSD header
329- distribute README files and COPYING in package
330
331* Tue Jan  5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-8
332- fix package License: field, there is no source with BSD header
333
334* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 2.0.16-7
335- rebuild against perl 5.10.1
336
337* Tue Dec  1 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-6
338- fix package compilation to remove rpmlint errors
339
340* Wed Sep 30 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-5
341- rebuilt with new net-snmp
342
343* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.16-4
344- rebuilt with new openssl
345
346* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.16-3
347- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
348
349* Wed Apr 15 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-2
350- fix compilation flags, debuginfo package is correctly generated now
351
352* Thu Mar 19 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-1
353- new upstream release
354
355* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.14-11
356- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
357
358* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.14-10
359- rebuild with new openssl
360
361* Thu Dec 11 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-9
362- fix linking without rpath, prelink won't screw up the libraries
363  anymore (#475265)
364
365* Wed Dec 10 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-8
366- shorter probe interval is used in init script, making the service startup
367  quicker in most situations (#475101)
368
369* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.14-7
370- Rebuild for Python 2.6
371
372* Thu Oct 30 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-6
373- removed static libraries from the -devel subpackage
374- fixed openipmigui.desktop file
375
376* Thu Oct 23 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-5
377- fixed typos in the descriptions
378- added .desktop file for openipmigui tool
379
380* Mon Oct 20 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-4
381- fixed description of the package
382
383* Thu Oct 16 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-3
384- split ipmitool to separate package
385- added 'reload' functionality to init script
386- added seraparate -gui subpackage
387
388* Wed Jul 30 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-2
389- Fixed rpath problem in libOpenIPMIposix.so.0.0.1
390
391* Tue Jul 29 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-1
392- Fixed several specfile problems (#453751)
393- Update to OpenIPMI-2.0.14
394
395* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.13-2
396- Autorebuild for GCC 4.3
397
398* Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.13-1
399- Updated to OpenIPMI-2.0.13
400- Rebuild due to new openssl
401
402* Wed Oct 10 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-3
403- Added missing perl-devel buildrequires
404
405* Mon Sep 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
406- Added missing popt-devel buildrequires
407
408* Fri Aug 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
409- Fix rebuild problems due to glibc change
410- License review and fixes
411
412* Tue Apr 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-1
413- Update to OpenIPMI-2.0.11
414
415* Tue Feb 27 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-8
416- Update for ipmitool-1.8.9
417
418* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.0.6-7
419- rebuild for python 2.5
420
421* Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-6.fc7
422- Update due to new net-snmp-5.4
423- Some specfile updates
424
425* Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-5
426- Fixed check for udev in initscript (#197956)
427
428* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.6-4.1
429- rebuild
430
431* Fri Jun 16 2006 Bill Nottingham <notting@redhat.com> 2.0.6-4
432- don't include <linux/compiler.h>
433
434* Fri Jun 16 2006 Jon Masters <jcm@redhat.com> 2.0.6-3
435- Fix a build requires (needs glibc-kernheaders)
436
437* Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> 2.0.6-2
438- Bump for new glib2
439
440* Tue May 16 2006 Phil Knirsch <pknirsch@redhat.com> 2.0.6-1
441- Fixed bug with type conversion in ipmitool (#191091)
442- Added python bindings
443- Split off perl and python bindings in separate subpackages
444- Dropped obsolete patches
445- Added missing buildprereq on readline-devel
446- Made it install the python bindings properly on 64bit archs
447
448* Mon May 15 2006 Phil Knirsch <pknirsch@redhat.com>
449- Updated ipmitool to 1.8.8
450- Updated OpenIPMI to 2.0.6
451
452* Fri Feb 17 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-19
453- Added missing PreReq for chkconfig
454
455* Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2.1
456- rebump for build order issues during double-long bump
457
458* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2
459- bump again for double-long bug on ppc(64)
460
461* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.1
462- rebuilt for new gcc4.1 snapshot and glibc changes
463
464* Mon Feb 06 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-18
465- Updated ipmitool to latest upstream version.
466- Removed 3 patches for already fixed bugs in latest ipmitool.
467- Adapted warning message fix for ipmitool for latest version.
468
469* Tue Jan 24 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-17
470- Fixed some minor things in initscripts.
471
472* Mon Jan 09 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-16
473- Included FRU fix for displaying FRUs with ipmitool
474- Included patch for new option to specify a BMC password for IPMI 2.0 sessions
475
476* Tue Jan 03 2006 Radek Vokal <rvokal@redhat.com> 1.4.14-15
477- Rebuilt against new libnetsnmp
478
479* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
480- rebuilt
481
482* Wed Nov 23 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-14
483- Some more initscript and sysconfig updates from Dell.
484
485* Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-13
486- Rebuilt to link against latest openssl libs.
487- Fixed ipmitool not setting session privilege level (#172312)
488
489* Wed Nov 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-11
490- Rebuild to link against new net-snmp libs.
491
492* Tue Oct 11 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-10
493- Updated initscript to fix missing redhat-lsb bug (#169901)
494
495* Thu Sep 08 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-9
496- Another update to latest initscripts from Dell
497- Fixed some missing return statements for non-void functions (#164138)
498
499* Thu Sep 01 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-8
500- Updated initscript to latest version from Dell
501
502* Fri Aug 12 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-7
503- Fixed the unwanted output of failed module loading of the initscript. Behaves
504  now like all our other initscripts (#165476)
505
506* Fri Aug 05 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-6
507- Fixed build problem on 64bit machines
508
509* Fri Jul 15 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-5
510- Fixed missing change to not autostart in the initscript
511
512* Wed Jul 06 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-4
513- Made the initscript a replacing configfile
514
515* Mon Jul 04 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-3
516- Updated versions of the initscripts and sysconf files
517- Fixed typo in preun script and changelog
518
519* Mon Jun 27 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-2
520- Updated to OpenIPMI-1.4.14
521- Split the main package into normal and libs package for multilib support
522- Added ipmitool-1.8.2 to OpenIPMI and put it in tools package
523- Added sysconf and initscript (#158270)
524- Fixed oob subscripts (#149142)
525
526* Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-5
527- Correctly put libs in the proper packages
528
529* Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-4
530- gcc4 rebuild fixes
531- Added missing gdbm-devel buildprereq
532
533* Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-3
534- bump release and rebuild with gcc 4
535
536* Tue Feb 08 2005 Karsten Hopp <karsten@redhat.de> 1.4.11-2
537- update
538
539* Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
540- Initial version
Note: See TracBrowser for help on using the repository browser.