source: projects/specs/trunk/O/OpenIPMI/OpenIPMI-vl.spec @ 11878

Revision 11878, 15.1 KB checked in by tomop, 6 years ago (diff)

OpenIPMI-2.0.25-1

Line 
1# TODO: uses private copy of libedit, should be modified to use system one
2
3%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
4Summary: IPMI (Intelligent Platform Management Interface) library and tools
5Summary(ja): IPMI (Intelligent Platform Management Interface) ライブラリおよびツール
6Name: OpenIPMI
7Version: 2.0.25
8Release: 1%{?_dist_release}
9License: LGPLv2+ and GPLv2+ or BSD
10Group: System Environment/Base
11URL: http://sourceforge.net/projects/openipmi/
12Source: http://downloads.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
13Source1: openipmi.sysconf
14Source2: openipmi.initscript
15Source3: openipmigui.desktop
16Source4: README.initscript
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: desktop-file-utils
19BuildRequires: gdbm-devel
20BuildRequires: glib2-devel
21BuildRequires: libedit-devel
22BuildRequires: ncurses-devel
23BuildRequires: net-snmp-devel
24BuildRequires: openssl-devel
25BuildRequires: perl
26BuildRequires: popt-devel
27BuildRequires: python-devel
28BuildRequires: swig
29BuildRequires: tcl
30BuildRequires: tkinter
31Requires(post): chkconfig
32Requires(preun): chkconfig
33
34Patch2: 0002-nobundle.patch
35
36Vendor: Project Vine
37Distribution: Vine Linux
38
39%description
40The Open IPMI project aims to develop an open code base to allow access to
41platform information using Intelligent Platform Management Interface (IPMI).
42This package contains the tools of the OpenIPMI project.
43
44%package libs
45Summary: The OpenIPMI runtime libraries
46Summary(ja): OpenIPMI ランタイムライブラリ
47Group: System Environment/Libraries
48
49%description libs
50The OpenIPMI-libs package contains the runtime libraries for shared binaries
51and applications.
52
53%package perl
54Summary: IPMI Perl language bindings
55Summary(ja): IPMI Perl 言語バインディング
56Group: Development/Libraries
57Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
58
59%description perl
60The OpenIPMI-perl package contains the Perl language bindings for OpenIPMI.
61
62%package python
63Group: Development/Libraries
64Summary: IPMI Python language bindings
65Summary(ja): IPMI Python 言語バインディング
66Requires: python
67
68%description python
69The OpenIPMI-python package contains the Python language bindings for OpenIPMI.
70
71%package devel
72Summary: The development environment for the OpenIPMI project
73Summary(ja): OpenIPMI の開発キット
74Group: Development/Libraries
75Requires: %{name} = %{version}-%{release}
76Requires: pkgconfig
77
78%description devel
79The OpenIPMI-devel package contains the development libraries and header files
80of the OpenIPMI project.
81
82%package gui
83Summary: IPMI graphical user interface tool
84Summary(ja): IPMI GUI ツール
85Group: System Environment/Base
86Requires: tix
87Requires: tkinter
88Requires: %{name}-python = %{version}-%{release}
89
90%description gui
91The OpenIPMI-gui package contains the graphical user interface to monitor
92and control IPMI-enabled devices.
93
94
95%prep
96%setup -q
97%patch2 -p1
98rm -rf ./libedit
99
100%build
101export EDIT_CFLAGS=`pkg-config --cflags libedit`
102export EDIT_LIBS=`pkg-config --libs libedit`
103
104export CFLAGS="-fPIC $RPM_OPT_FLAGS"
105
106autoreconf -vif
107
108%configure \
109  CFLAGS="-fPIC %{optflags} -z now -fno-strict-aliasing" \
110  LDFLAGS="%{?__global_ldflags} -Wl,--as-needed" \
111  --with-pythoninstall=%{python_sitearch} \
112  --disable-dependency-tracking \
113  --with-tcl=no \
114  --with-glib12=no \
115  --disable-static
116# get rid of rpath
117sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
118sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
119
120make   # not %{?_smp_mflags} safe
121
122%install
123rm -rf $RPM_BUILD_ROOT
124make install DESTDIR=$RPM_BUILD_ROOT
125
126find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
127
128install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
129install -m 644 %SOURCE1 ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/ipmi
130install -d ${RPM_BUILD_ROOT}%{_initrddir}
131install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}%{_initrddir}/ipmi
132
133desktop-file-install --vendor="fedora" --dir=${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE3}
134
135install -m 644 %SOURCE4 .
136
137%post
138/sbin/chkconfig --add ipmi
139
140%preun
141if [ $1 = 0 ]; then
142   service ipmi stop >/dev/null 2>&1
143   /sbin/chkconfig --del ipmi
144fi
145
146%postun
147if [ "$1" -ge "1" ]; then
148    service ipmi condrestart >/dev/null 2>&1 || :
149fi
150
151%post libs -p /sbin/ldconfig
152
153%postun libs -p /sbin/ldconfig
154
155%clean
156rm -rf $RPM_BUILD_ROOT
157
158%files
159%defattr(-,root,root)
160%doc CONFIGURING_FOR_LAN COPYING COPYING.BSD COPYING.LIB FAQ README README.Force README.MotorolaMXP README.initscript
161%config(noreplace) %{_sysconfdir}/ipmi/ipmisim1.emu
162%config(noreplace) %{_sysconfdir}/ipmi/lan.conf
163%config(noreplace) %{_sysconfdir}/sysconfig/ipmi
164%{_initrddir}/ipmi
165%{_bindir}/ipmicmd
166%{_bindir}/ipmilan
167%{_bindir}/ipmish
168%{_bindir}/ipmi_sim
169%{_bindir}/ipmi_ui
170%{_bindir}/openipmicmd
171%{_bindir}/openipmish
172%{_bindir}/rmcp_ping
173%{_bindir}/sdrcomp
174%{_bindir}/solterm
175%{_bindir}/openipmi_eventd
176%{_mandir}/man1/ipmi_*
177%{_mandir}/man1/openipmicmd*
178%{_mandir}/man1/openipmish*
179%{_mandir}/man1/rmcp_ping*
180%{_mandir}/man1/solterm*
181%{_mandir}/man5/ipmi_*
182%{_mandir}/man1/openipmi_eventd*
183%{_mandir}/man7/ipmi_cmdlang*
184%{_mandir}/man7/openipmi_conparms*
185%{_mandir}/man8/ipmilan*
186
187%files perl
188%defattr(-,root,root)
189%attr(644,root,root) %{perl_vendorarch}/OpenIPMI.pm
190%{perl_vendorarch}/auto/OpenIPMI/
191
192%files python
193%defattr(-,root,root)
194%{python_sitearch}/*OpenIPMI*
195
196%files libs
197%defattr(-,root,root)
198%{_libdir}/*.so.*
199
200%files devel
201%defattr(-,root,root)
202%{_includedir}/OpenIPMI
203%{_libdir}/*.so
204%{_libdir}/pkgconfig/*.pc
205
206%files gui
207%defattr(-,root,root)
208%{_bindir}/openipmigui
209%{_mandir}/man1/openipmigui*
210%{python_sitearch}/openipmigui
211%{_datadir}/applications/fedora-openipmigui.desktop
212
213%changelog
214* Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.25-1
215- updated to 2.0.25.
216- dropped Patch1 (fixed in upstream).
217- imported Patch2 from rawhide.
218- added BR:libedit-devel.
219
220* Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.21-3
221- rebuild with openssl-1.0.2
222
223* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.21-2
224- remove *.la files
225
226* Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0.21-1
227- updated to 2.0.21
228- rebuilt with perl-5.16.3
229
230* Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-5
231- rebuild with net-snmp-5.7.1
232
233* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-4
234- rebuild with python-2.7.2
235
236* Sat May 21 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.18-3
237- build with perl 5.12.3
238- add Vendor and Distribution tags
239
240* Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-2
241- rebuild with openssl-1.0.0d
242
243* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.18-1
244- initial build for Vine Linux
245
246* Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.0.18-2
247- Mass rebuild with perl-5.12.0
248
249* Wed May  5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.18-1
250- updated to OpenIPMI-2.0.18
251- fixed OpenIPMIpthread pkgconfig file (#468067)
252
253* Mon May  3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.17-1
254- updated to OpenIPMI-2.0.17
255
256* Thu Mar 18 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-12
257- implemented mandatory 'force-reload' command in ipmi service
258
259* Thu Mar 11 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-11
260- rebuild against new gdbm
261
262* Wed Mar  3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-10
263- add README.initscript describing /etc/init.d/ipmi initscript exit codes
264  (#562151)
265
266* Mon Feb 22 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-9
267- fix package License: field, there *are* sources with BSD header
268- distribute README files and COPYING in package
269
270* Tue Jan  5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-8
271- fix package License: field, there is no source with BSD header
272
273* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 2.0.16-7
274- rebuild against perl 5.10.1
275
276* Tue Dec  1 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-6
277- fix package compilation to remove rpmlint errors
278
279* Wed Sep 30 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-5
280- rebuilt with new net-snmp
281
282* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.16-4
283- rebuilt with new openssl
284
285* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.16-3
286- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
287
288* Wed Apr 15 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-2
289- fix compilation flags, debuginfo package is correctly generated now
290
291* Thu Mar 19 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-1
292- new upstream release
293
294* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.14-11
295- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
296
297* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.14-10
298- rebuild with new openssl
299
300* Thu Dec 11 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-9
301- fix linking without rpath, prelink won't screw up the libraries
302  anymore (#475265)
303
304* Wed Dec 10 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-8
305- shorter probe interval is used in init script, making the service startup
306  quicker in most situations (#475101)
307
308* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.14-7
309- Rebuild for Python 2.6
310
311* Thu Oct 30 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-6
312- removed static libraries from the -devel subpackage
313- fixed openipmigui.desktop file
314
315* Thu Oct 23 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-5
316- fixed typos in the descriptions
317- added .desktop file for openipmigui tool
318
319* Mon Oct 20 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-4
320- fixed description of the package
321
322* Thu Oct 16 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-3
323- split ipmitool to separate package
324- added 'reload' functionality to init script
325- added seraparate -gui subpackage
326
327* Wed Jul 30 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-2
328- Fixed rpath problem in libOpenIPMIposix.so.0.0.1
329
330* Tue Jul 29 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-1
331- Fixed several specfile problems (#453751)
332- Update to OpenIPMI-2.0.14
333
334* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.13-2
335- Autorebuild for GCC 4.3
336
337* Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.13-1
338- Updated to OpenIPMI-2.0.13
339- Rebuild due to new openssl
340
341* Wed Oct 10 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-3
342- Added missing perl-devel buildrequires
343
344* Mon Sep 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
345- Added missing popt-devel buildrequires
346
347* Fri Aug 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
348- Fix rebuild problems due to glibc change
349- License review and fixes
350
351* Tue Apr 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-1
352- Update to OpenIPMI-2.0.11
353
354* Tue Feb 27 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-8
355- Update for ipmitool-1.8.9
356
357* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.0.6-7
358- rebuild for python 2.5
359
360* Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-6.fc7
361- Update due to new net-snmp-5.4
362- Some specfile updates
363
364* Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-5
365- Fixed check for udev in initscript (#197956)
366
367* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.6-4.1
368- rebuild
369
370* Fri Jun 16 2006 Bill Nottingham <notting@redhat.com> 2.0.6-4
371- don't include <linux/compiler.h>
372
373* Fri Jun 16 2006 Jon Masters <jcm@redhat.com> 2.0.6-3
374- Fix a build requires (needs glibc-kernheaders)
375
376* Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> 2.0.6-2
377- Bump for new glib2
378
379* Tue May 16 2006 Phil Knirsch <pknirsch@redhat.com> 2.0.6-1
380- Fixed bug with type conversion in ipmitool (#191091)
381- Added python bindings
382- Split off perl and python bindings in separate subpackages
383- Dropped obsolete patches
384- Added missing buildprereq on readline-devel
385- Made it install the python bindings properly on 64bit archs
386
387* Mon May 15 2006 Phil Knirsch <pknirsch@redhat.com>
388- Updated ipmitool to 1.8.8
389- Updated OpenIPMI to 2.0.6
390
391* Fri Feb 17 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-19
392- Added missing PreReq for chkconfig
393
394* Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2.1
395- rebump for build order issues during double-long bump
396
397* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2
398- bump again for double-long bug on ppc(64)
399
400* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.1
401- rebuilt for new gcc4.1 snapshot and glibc changes
402
403* Mon Feb 06 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-18
404- Updated ipmitool to latest upstream version.
405- Removed 3 patches for already fixed bugs in latest ipmitool.
406- Adapted warning message fix for ipmitool for latest version.
407
408* Tue Jan 24 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-17
409- Fixed some minor things in initscripts.
410
411* Mon Jan 09 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-16
412- Included FRU fix for displaying FRUs with ipmitool
413- Included patch for new option to specify a BMC password for IPMI 2.0 sessions
414
415* Tue Jan 03 2006 Radek Vokal <rvokal@redhat.com> 1.4.14-15
416- Rebuilt against new libnetsnmp
417
418* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
419- rebuilt
420
421* Wed Nov 23 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-14
422- Some more initscript and sysconfig updates from Dell.
423
424* Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-13
425- Rebuilt to link against latest openssl libs.
426- Fixed ipmitool not setting session privilege level (#172312)
427
428* Wed Nov 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-11
429- Rebuild to link against new net-snmp libs.
430
431* Tue Oct 11 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-10
432- Updated initscript to fix missing redhat-lsb bug (#169901)
433
434* Thu Sep 08 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-9
435- Another update to latest initscripts from Dell
436- Fixed some missing return statements for non-void functions (#164138)
437
438* Thu Sep 01 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-8
439- Updated initscript to latest version from Dell
440
441* Fri Aug 12 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-7
442- Fixed the unwanted output of failed module loading of the initscript. Behaves
443  now like all our other initscripts (#165476)
444
445* Fri Aug 05 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-6
446- Fixed build problem on 64bit machines
447
448* Fri Jul 15 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-5
449- Fixed missing change to not autostart in the initscript
450
451* Wed Jul 06 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-4
452- Made the initscript a replacing configfile
453
454* Mon Jul 04 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-3
455- Updated versions of the initscripts and sysconf files
456- Fixed typo in preun script and changelog
457
458* Mon Jun 27 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-2
459- Updated to OpenIPMI-1.4.14
460- Split the main package into normal and libs package for multilib support
461- Added ipmitool-1.8.2 to OpenIPMI and put it in tools package
462- Added sysconf and initscript (#158270)
463- Fixed oob subscripts (#149142)
464
465* Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-5
466- Correctly put libs in the proper packages
467
468* Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-4
469- gcc4 rebuild fixes
470- Added missing gdbm-devel buildprereq
471
472* Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-3
473- bump release and rebuild with gcc 4
474
475* Tue Feb 08 2005 Karsten Hopp <karsten@redhat.de> 1.4.11-2
476- update
477
478* Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
479- Initial version
Note: See TracBrowser for help on using the repository browser.