source: projects/specs/trunk/O/OpenIPMI/OpenIPMI-vl.spec @ 1317

Revision 1317, 13.5 KB checked in by daisuke, 14 years ago (diff)

OpenIPMI: new package, 2.0.18

Line 
1# TODO: uses private copy of libedit, should be modified to use system one
2
3%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
4Summary: IPMI (Intelligent Platform Management Interface) library and tools
5Summary(ja): IPMI (Intelligent Platform Management Interface) ライブラリおよびツール
6Name: OpenIPMI
7Version: 2.0.18
8Release: 1%{?_dist_release}
9License: LGPLv2+ and GPLv2+ or BSD
10Group: System Environment/Base
11URL: http://sourceforge.net/projects/openipmi/
12Source: http://downloads.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
13Source1: openipmi.sysconf
14Source2: openipmi.initscript
15Source3: openipmigui.desktop
16Source4: README.initscript
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: gdbm-devel swig glib2-devel net-snmp-devel ncurses-devel
19BuildRequires: openssl-devel python-devel perl tcl tkinter
20BuildRequires: desktop-file-utils popt-devel
21Requires(post): chkconfig
22Requires(preun): chkconfig
23
24Patch1: OpenIPMI-2.0.18-pthread-pkgconfig.patch
25
26%description
27The Open IPMI project aims to develop an open code base to allow access to
28platform information using Intelligent Platform Management Interface (IPMI).
29This package contains the tools of the OpenIPMI project.
30
31%package libs
32Group: Development/Libraries
33Summary: The OpenIPMI runtime libraries
34Summary(ja): OpenIPMI ランタイムライブラリ
35
36%description libs
37The OpenIPMI-libs package contains the runtime libraries for shared binaries
38and applications.
39
40%package perl
41Group: Development/Libraries
42Summary: IPMI Perl language bindings
43Summary(ja): IPMI Perl 言語バインディング
44Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
45
46%description perl
47The OpenIPMI-perl package contains the Perl language bindings for OpenIPMI.
48
49%package python
50Group: Development/Libraries
51Summary: IPMI Python language bindings
52Summary(ja): IPMI Python 言語バインディング
53
54%description python
55The OpenIPMI-python package contains the Python language bindings for OpenIPMI.
56
57%package devel
58Group: Development/Libraries
59Summary: The development environment for the OpenIPMI project
60Summary(ja): OpenIPMIの開発キット
61Requires: pkgconfig
62Requires: %{name} = %{version}-%{release}
63
64%description devel
65The OpenIPMI-devel package contains the development libraries and header files
66of the OpenIPMI project.
67
68%package gui
69Group: System Environment/Base
70Summary: IPMI graphical user interface tool
71Summary(ja): IPMI GUI ツール
72Requires: tix tkinter %{name}-python = %{version}-%{release}
73
74%description gui
75The OpenIPMI-gui package contains the graphical user interface to monitor
76and control IPMI-enabled devices.
77
78
79%prep
80%setup -q
81%patch1 -p1
82
83%build
84export CFLAGS="-fPIC $RPM_OPT_FLAGS"
85%configure \
86  --with-pythoninstall=%{python_sitearch} \
87  --disable-dependency-tracking \
88  --with-tcl=no \
89  --with-glib12=no \
90  --disable-static
91# get rid of rpath
92sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
93sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
94
95make   # not %{?_smp_mflags} safe
96
97%install
98rm -rf $RPM_BUILD_ROOT
99make install DESTDIR=$RPM_BUILD_ROOT
100rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la
101
102install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
103install -m 644 %SOURCE1 ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/ipmi
104install -d ${RPM_BUILD_ROOT}%{_initrddir}
105install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}%{_initrddir}/ipmi
106
107desktop-file-install --vendor="fedora" --dir=${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE3}
108
109install -m 644 %SOURCE4 .
110
111%post
112/sbin/chkconfig --add ipmi
113
114%preun
115if [ $1 = 0 ]; then
116   service ipmi stop >/dev/null 2>&1
117   /sbin/chkconfig --del ipmi
118fi
119
120%postun
121if [ "$1" -ge "1" ]; then
122    service ipmi condrestart >/dev/null 2>&1 || :
123fi
124
125%post libs -p /sbin/ldconfig
126
127%postun libs -p /sbin/ldconfig
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132%files
133%defattr(-,root,root)
134%doc CONFIGURING_FOR_LAN COPYING COPYING.BSD COPYING.LIB FAQ README README.Force README.MotorolaMXP README.initscript
135%config(noreplace) %{_sysconfdir}/sysconfig/ipmi
136%{_initrddir}/ipmi
137%{_bindir}/ipmicmd
138%{_bindir}/ipmilan
139%{_bindir}/ipmish
140%{_bindir}/ipmi_ui
141%{_bindir}/openipmicmd
142%{_bindir}/openipmish
143%{_bindir}/rmcp_ping
144%{_bindir}/solterm
145%{_mandir}/man1/ipmi_ui*
146%{_mandir}/man1/openipmicmd*
147%{_mandir}/man1/openipmish*
148%{_mandir}/man1/rmcp_ping*
149%{_mandir}/man1/solterm*
150%{_mandir}/man7/ipmi_cmdlang*
151%{_mandir}/man7/openipmi_conparms*
152%{_mandir}/man8/ipmilan*
153
154%files perl
155%defattr(-,root,root)
156%attr(644,root,root) %{perl_vendorarch}/OpenIPMI.pm
157%{perl_vendorarch}/auto/OpenIPMI/
158
159%files python
160%defattr(-,root,root)
161%{python_sitearch}/*OpenIPMI*
162
163%files libs
164%defattr(-,root,root)
165%{_libdir}/*.so.*
166
167%files devel
168%defattr(-,root,root)
169%{_includedir}/OpenIPMI
170%{_libdir}/*.so
171%{_libdir}/pkgconfig/*.pc
172
173%files gui
174%defattr(-,root,root)
175%{_bindir}/openipmigui
176%{_mandir}/man1/openipmigui*
177%{python_sitearch}/openipmigui
178%{_datadir}/applications/fedora-openipmigui.desktop
179
180%changelog
181* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.18-1
182- initial build for Vine Linux
183
184* Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.0.18-2
185- Mass rebuild with perl-5.12.0
186
187* Wed May  5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.18-1
188- updated to OpenIPMI-2.0.18
189- fixed OpenIPMIpthread pkgconfig file (#468067)
190
191* Mon May  3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.17-1
192- updated to OpenIPMI-2.0.17
193
194* Thu Mar 18 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-12
195- implemented mandatory 'force-reload' command in ipmi service
196
197* Thu Mar 11 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-11
198- rebuild against new gdbm
199
200* Wed Mar  3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-10
201- add README.initscript describing /etc/init.d/ipmi initscript exit codes
202  (#562151)
203
204* Mon Feb 22 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-9
205- fix package License: field, there *are* sources with BSD header
206- distribute README files and COPYING in package
207
208* Tue Jan  5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-8
209- fix package License: field, there is no source with BSD header
210
211* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 2.0.16-7
212- rebuild against perl 5.10.1
213
214* Tue Dec  1 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-6
215- fix package compilation to remove rpmlint errors
216
217* Wed Sep 30 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-5
218- rebuilt with new net-snmp
219
220* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.16-4
221- rebuilt with new openssl
222
223* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.16-3
224- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
225
226* Wed Apr 15 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-2
227- fix compilation flags, debuginfo package is correctly generated now
228
229* Thu Mar 19 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-1
230- new upstream release
231
232* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.14-11
233- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
234
235* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.14-10
236- rebuild with new openssl
237
238* Thu Dec 11 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-9
239- fix linking without rpath, prelink won't screw up the libraries
240  anymore (#475265)
241
242* Wed Dec 10 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-8
243- shorter probe interval is used in init script, making the service startup
244  quicker in most situations (#475101)
245
246* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.14-7
247- Rebuild for Python 2.6
248
249* Thu Oct 30 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-6
250- removed static libraries from the -devel subpackage
251- fixed openipmigui.desktop file
252
253* Thu Oct 23 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-5
254- fixed typos in the descriptions
255- added .desktop file for openipmigui tool
256
257* Mon Oct 20 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-4
258- fixed description of the package
259
260* Thu Oct 16 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-3
261- split ipmitool to separate package
262- added 'reload' functionality to init script
263- added seraparate -gui subpackage
264
265* Wed Jul 30 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-2
266- Fixed rpath problem in libOpenIPMIposix.so.0.0.1
267
268* Tue Jul 29 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-1
269- Fixed several specfile problems (#453751)
270- Update to OpenIPMI-2.0.14
271
272* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.13-2
273- Autorebuild for GCC 4.3
274
275* Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.13-1
276- Updated to OpenIPMI-2.0.13
277- Rebuild due to new openssl
278
279* Wed Oct 10 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-3
280- Added missing perl-devel buildrequires
281
282* Mon Sep 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
283- Added missing popt-devel buildrequires
284
285* Fri Aug 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
286- Fix rebuild problems due to glibc change
287- License review and fixes
288
289* Tue Apr 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-1
290- Update to OpenIPMI-2.0.11
291
292* Tue Feb 27 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-8
293- Update for ipmitool-1.8.9
294
295* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.0.6-7
296- rebuild for python 2.5
297
298* Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-6.fc7
299- Update due to new net-snmp-5.4
300- Some specfile updates
301
302* Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-5
303- Fixed check for udev in initscript (#197956)
304
305* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.6-4.1
306- rebuild
307
308* Fri Jun 16 2006 Bill Nottingham <notting@redhat.com> 2.0.6-4
309- don't include <linux/compiler.h>
310
311* Fri Jun 16 2006 Jon Masters <jcm@redhat.com> 2.0.6-3
312- Fix a build requires (needs glibc-kernheaders)
313
314* Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> 2.0.6-2
315- Bump for new glib2
316
317* Tue May 16 2006 Phil Knirsch <pknirsch@redhat.com> 2.0.6-1
318- Fixed bug with type conversion in ipmitool (#191091)
319- Added python bindings
320- Split off perl and python bindings in separate subpackages
321- Dropped obsolete patches
322- Added missing buildprereq on readline-devel
323- Made it install the python bindings properly on 64bit archs
324
325* Mon May 15 2006 Phil Knirsch <pknirsch@redhat.com>
326- Updated ipmitool to 1.8.8
327- Updated OpenIPMI to 2.0.6
328
329* Fri Feb 17 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-19
330- Added missing PreReq for chkconfig
331
332* Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2.1
333- rebump for build order issues during double-long bump
334
335* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2
336- bump again for double-long bug on ppc(64)
337
338* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.1
339- rebuilt for new gcc4.1 snapshot and glibc changes
340
341* Mon Feb 06 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-18
342- Updated ipmitool to latest upstream version.
343- Removed 3 patches for already fixed bugs in latest ipmitool.
344- Adapted warning message fix for ipmitool for latest version.
345
346* Tue Jan 24 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-17
347- Fixed some minor things in initscripts.
348
349* Mon Jan 09 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-16
350- Included FRU fix for displaying FRUs with ipmitool
351- Included patch for new option to specify a BMC password for IPMI 2.0 sessions
352
353* Tue Jan 03 2006 Radek Vokal <rvokal@redhat.com> 1.4.14-15
354- Rebuilt against new libnetsnmp
355
356* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
357- rebuilt
358
359* Wed Nov 23 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-14
360- Some more initscript and sysconfig updates from Dell.
361
362* Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-13
363- Rebuilt to link against latest openssl libs.
364- Fixed ipmitool not setting session privilege level (#172312)
365
366* Wed Nov 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-11
367- Rebuild to link against new net-snmp libs.
368
369* Tue Oct 11 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-10
370- Updated initscript to fix missing redhat-lsb bug (#169901)
371
372* Thu Sep 08 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-9
373- Another update to latest initscripts from Dell
374- Fixed some missing return statements for non-void functions (#164138)
375
376* Thu Sep 01 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-8
377- Updated initscript to latest version from Dell
378
379* Fri Aug 12 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-7
380- Fixed the unwanted output of failed module loading of the initscript. Behaves
381  now like all our other initscripts (#165476)
382
383* Fri Aug 05 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-6
384- Fixed build problem on 64bit machines
385
386* Fri Jul 15 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-5
387- Fixed missing change to not autostart in the initscript
388
389* Wed Jul 06 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-4
390- Made the initscript a replacing configfile
391
392* Mon Jul 04 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-3
393- Updated versions of the initscripts and sysconf files
394- Fixed typo in preun script and changelog
395
396* Mon Jun 27 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-2
397- Updated to OpenIPMI-1.4.14
398- Split the main package into normal and libs package for multilib support
399- Added ipmitool-1.8.2 to OpenIPMI and put it in tools package
400- Added sysconf and initscript (#158270)
401- Fixed oob subscripts (#149142)
402
403* Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-5
404- Correctly put libs in the proper packages
405
406* Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-4
407- gcc4 rebuild fixes
408- Added missing gdbm-devel buildprereq
409
410* Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-3
411- bump release and rebuild with gcc 4
412
413* Tue Feb 08 2005 Karsten Hopp <karsten@redhat.de> 1.4.11-2
414- update
415
416* Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
417- Initial version
Note: See TracBrowser for help on using the repository browser.