source: projects/specs/trunk/O/OpenIPMI/OpenIPMI-vl.spec @ 3022

Revision 3022, 13.6 KB checked in by Takemikaduchi, 13 years ago (diff)

libxml++: rebuild vine5 package, others: rebuild with openssl-1.0.0d

Line 
1# TODO: uses private copy of libedit, should be modified to use system one
2
3%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
4Summary: IPMI (Intelligent Platform Management Interface) library and tools
5Summary(ja): IPMI (Intelligent Platform Management Interface) ライブラリおよびツール
6Name: OpenIPMI
7Version: 2.0.18
8Release: 2%{?_dist_release}
9License: LGPLv2+ and GPLv2+ or BSD
10Group: System Environment/Base
11URL: http://sourceforge.net/projects/openipmi/
12Source: http://downloads.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
13Source1: openipmi.sysconf
14Source2: openipmi.initscript
15Source3: openipmigui.desktop
16Source4: README.initscript
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: gdbm-devel swig glib2-devel net-snmp-devel ncurses-devel
19BuildRequires: openssl-devel python-devel perl tcl tkinter
20BuildRequires: desktop-file-utils popt-devel
21Requires(post): chkconfig
22Requires(preun): chkconfig
23
24Patch1: OpenIPMI-2.0.18-pthread-pkgconfig.patch
25
26%description
27The Open IPMI project aims to develop an open code base to allow access to
28platform information using Intelligent Platform Management Interface (IPMI).
29This package contains the tools of the OpenIPMI project.
30
31%package libs
32Group: Development/Libraries
33Summary: The OpenIPMI runtime libraries
34Summary(ja): OpenIPMI ランタイムライブラリ
35
36%description libs
37The OpenIPMI-libs package contains the runtime libraries for shared binaries
38and applications.
39
40%package perl
41Group: Development/Libraries
42Summary: IPMI Perl language bindings
43Summary(ja): IPMI Perl 言語バインディング
44Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
45
46%description perl
47The OpenIPMI-perl package contains the Perl language bindings for OpenIPMI.
48
49%package python
50Group: Development/Libraries
51Summary: IPMI Python language bindings
52Summary(ja): IPMI Python 言語バインディング
53
54%description python
55The OpenIPMI-python package contains the Python language bindings for OpenIPMI.
56
57%package devel
58Group: Development/Libraries
59Summary: The development environment for the OpenIPMI project
60Summary(ja): OpenIPMIの開発キット
61Requires: pkgconfig
62Requires: %{name} = %{version}-%{release}
63
64%description devel
65The OpenIPMI-devel package contains the development libraries and header files
66of the OpenIPMI project.
67
68%package gui
69Group: System Environment/Base
70Summary: IPMI graphical user interface tool
71Summary(ja): IPMI GUI ツール
72Requires: tix tkinter %{name}-python = %{version}-%{release}
73
74%description gui
75The OpenIPMI-gui package contains the graphical user interface to monitor
76and control IPMI-enabled devices.
77
78
79%prep
80%setup -q
81%patch1 -p1
82
83%build
84export CFLAGS="-fPIC $RPM_OPT_FLAGS"
85%configure \
86  --with-pythoninstall=%{python_sitearch} \
87  --disable-dependency-tracking \
88  --with-tcl=no \
89  --with-glib12=no \
90  --disable-static
91# get rid of rpath
92sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
93sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
94
95make   # not %{?_smp_mflags} safe
96
97%install
98rm -rf $RPM_BUILD_ROOT
99make install DESTDIR=$RPM_BUILD_ROOT
100rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la
101
102install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
103install -m 644 %SOURCE1 ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/ipmi
104install -d ${RPM_BUILD_ROOT}%{_initrddir}
105install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}%{_initrddir}/ipmi
106
107desktop-file-install --vendor="fedora" --dir=${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE3}
108
109install -m 644 %SOURCE4 .
110
111%post
112/sbin/chkconfig --add ipmi
113
114%preun
115if [ $1 = 0 ]; then
116   service ipmi stop >/dev/null 2>&1
117   /sbin/chkconfig --del ipmi
118fi
119
120%postun
121if [ "$1" -ge "1" ]; then
122    service ipmi condrestart >/dev/null 2>&1 || :
123fi
124
125%post libs -p /sbin/ldconfig
126
127%postun libs -p /sbin/ldconfig
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132%files
133%defattr(-,root,root)
134%doc CONFIGURING_FOR_LAN COPYING COPYING.BSD COPYING.LIB FAQ README README.Force README.MotorolaMXP README.initscript
135%config(noreplace) %{_sysconfdir}/sysconfig/ipmi
136%{_initrddir}/ipmi
137%{_bindir}/ipmicmd
138%{_bindir}/ipmilan
139%{_bindir}/ipmish
140%{_bindir}/ipmi_ui
141%{_bindir}/openipmicmd
142%{_bindir}/openipmish
143%{_bindir}/rmcp_ping
144%{_bindir}/solterm
145%{_mandir}/man1/ipmi_ui*
146%{_mandir}/man1/openipmicmd*
147%{_mandir}/man1/openipmish*
148%{_mandir}/man1/rmcp_ping*
149%{_mandir}/man1/solterm*
150%{_mandir}/man7/ipmi_cmdlang*
151%{_mandir}/man7/openipmi_conparms*
152%{_mandir}/man8/ipmilan*
153
154%files perl
155%defattr(-,root,root)
156%attr(644,root,root) %{perl_vendorarch}/OpenIPMI.pm
157%{perl_vendorarch}/auto/OpenIPMI/
158
159%files python
160%defattr(-,root,root)
161%{python_sitearch}/*OpenIPMI*
162
163%files libs
164%defattr(-,root,root)
165%{_libdir}/*.so.*
166
167%files devel
168%defattr(-,root,root)
169%{_includedir}/OpenIPMI
170%{_libdir}/*.so
171%{_libdir}/pkgconfig/*.pc
172
173%files gui
174%defattr(-,root,root)
175%{_bindir}/openipmigui
176%{_mandir}/man1/openipmigui*
177%{python_sitearch}/openipmigui
178%{_datadir}/applications/fedora-openipmigui.desktop
179
180%changelog
181* Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-2
182- rebuild with openssl-1.0.0d
183
184* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.18-1
185- initial build for Vine Linux
186
187* Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.0.18-2
188- Mass rebuild with perl-5.12.0
189
190* Wed May  5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.18-1
191- updated to OpenIPMI-2.0.18
192- fixed OpenIPMIpthread pkgconfig file (#468067)
193
194* Mon May  3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.17-1
195- updated to OpenIPMI-2.0.17
196
197* Thu Mar 18 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-12
198- implemented mandatory 'force-reload' command in ipmi service
199
200* Thu Mar 11 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-11
201- rebuild against new gdbm
202
203* Wed Mar  3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-10
204- add README.initscript describing /etc/init.d/ipmi initscript exit codes
205  (#562151)
206
207* Mon Feb 22 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-9
208- fix package License: field, there *are* sources with BSD header
209- distribute README files and COPYING in package
210
211* Tue Jan  5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-8
212- fix package License: field, there is no source with BSD header
213
214* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 2.0.16-7
215- rebuild against perl 5.10.1
216
217* Tue Dec  1 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-6
218- fix package compilation to remove rpmlint errors
219
220* Wed Sep 30 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-5
221- rebuilt with new net-snmp
222
223* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.16-4
224- rebuilt with new openssl
225
226* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.16-3
227- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
228
229* Wed Apr 15 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-2
230- fix compilation flags, debuginfo package is correctly generated now
231
232* Thu Mar 19 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-1
233- new upstream release
234
235* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.14-11
236- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
237
238* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.14-10
239- rebuild with new openssl
240
241* Thu Dec 11 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-9
242- fix linking without rpath, prelink won't screw up the libraries
243  anymore (#475265)
244
245* Wed Dec 10 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-8
246- shorter probe interval is used in init script, making the service startup
247  quicker in most situations (#475101)
248
249* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.14-7
250- Rebuild for Python 2.6
251
252* Thu Oct 30 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-6
253- removed static libraries from the -devel subpackage
254- fixed openipmigui.desktop file
255
256* Thu Oct 23 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-5
257- fixed typos in the descriptions
258- added .desktop file for openipmigui tool
259
260* Mon Oct 20 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-4
261- fixed description of the package
262
263* Thu Oct 16 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-3
264- split ipmitool to separate package
265- added 'reload' functionality to init script
266- added seraparate -gui subpackage
267
268* Wed Jul 30 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-2
269- Fixed rpath problem in libOpenIPMIposix.so.0.0.1
270
271* Tue Jul 29 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-1
272- Fixed several specfile problems (#453751)
273- Update to OpenIPMI-2.0.14
274
275* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.13-2
276- Autorebuild for GCC 4.3
277
278* Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.13-1
279- Updated to OpenIPMI-2.0.13
280- Rebuild due to new openssl
281
282* Wed Oct 10 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-3
283- Added missing perl-devel buildrequires
284
285* Mon Sep 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
286- Added missing popt-devel buildrequires
287
288* Fri Aug 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
289- Fix rebuild problems due to glibc change
290- License review and fixes
291
292* Tue Apr 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-1
293- Update to OpenIPMI-2.0.11
294
295* Tue Feb 27 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-8
296- Update for ipmitool-1.8.9
297
298* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.0.6-7
299- rebuild for python 2.5
300
301* Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-6.fc7
302- Update due to new net-snmp-5.4
303- Some specfile updates
304
305* Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-5
306- Fixed check for udev in initscript (#197956)
307
308* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.6-4.1
309- rebuild
310
311* Fri Jun 16 2006 Bill Nottingham <notting@redhat.com> 2.0.6-4
312- don't include <linux/compiler.h>
313
314* Fri Jun 16 2006 Jon Masters <jcm@redhat.com> 2.0.6-3
315- Fix a build requires (needs glibc-kernheaders)
316
317* Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> 2.0.6-2
318- Bump for new glib2
319
320* Tue May 16 2006 Phil Knirsch <pknirsch@redhat.com> 2.0.6-1
321- Fixed bug with type conversion in ipmitool (#191091)
322- Added python bindings
323- Split off perl and python bindings in separate subpackages
324- Dropped obsolete patches
325- Added missing buildprereq on readline-devel
326- Made it install the python bindings properly on 64bit archs
327
328* Mon May 15 2006 Phil Knirsch <pknirsch@redhat.com>
329- Updated ipmitool to 1.8.8
330- Updated OpenIPMI to 2.0.6
331
332* Fri Feb 17 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-19
333- Added missing PreReq for chkconfig
334
335* Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2.1
336- rebump for build order issues during double-long bump
337
338* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2
339- bump again for double-long bug on ppc(64)
340
341* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.1
342- rebuilt for new gcc4.1 snapshot and glibc changes
343
344* Mon Feb 06 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-18
345- Updated ipmitool to latest upstream version.
346- Removed 3 patches for already fixed bugs in latest ipmitool.
347- Adapted warning message fix for ipmitool for latest version.
348
349* Tue Jan 24 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-17
350- Fixed some minor things in initscripts.
351
352* Mon Jan 09 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-16
353- Included FRU fix for displaying FRUs with ipmitool
354- Included patch for new option to specify a BMC password for IPMI 2.0 sessions
355
356* Tue Jan 03 2006 Radek Vokal <rvokal@redhat.com> 1.4.14-15
357- Rebuilt against new libnetsnmp
358
359* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
360- rebuilt
361
362* Wed Nov 23 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-14
363- Some more initscript and sysconfig updates from Dell.
364
365* Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-13
366- Rebuilt to link against latest openssl libs.
367- Fixed ipmitool not setting session privilege level (#172312)
368
369* Wed Nov 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-11
370- Rebuild to link against new net-snmp libs.
371
372* Tue Oct 11 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-10
373- Updated initscript to fix missing redhat-lsb bug (#169901)
374
375* Thu Sep 08 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-9
376- Another update to latest initscripts from Dell
377- Fixed some missing return statements for non-void functions (#164138)
378
379* Thu Sep 01 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-8
380- Updated initscript to latest version from Dell
381
382* Fri Aug 12 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-7
383- Fixed the unwanted output of failed module loading of the initscript. Behaves
384  now like all our other initscripts (#165476)
385
386* Fri Aug 05 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-6
387- Fixed build problem on 64bit machines
388
389* Fri Jul 15 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-5
390- Fixed missing change to not autostart in the initscript
391
392* Wed Jul 06 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-4
393- Made the initscript a replacing configfile
394
395* Mon Jul 04 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-3
396- Updated versions of the initscripts and sysconf files
397- Fixed typo in preun script and changelog
398
399* Mon Jun 27 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-2
400- Updated to OpenIPMI-1.4.14
401- Split the main package into normal and libs package for multilib support
402- Added ipmitool-1.8.2 to OpenIPMI and put it in tools package
403- Added sysconf and initscript (#158270)
404- Fixed oob subscripts (#149142)
405
406* Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-5
407- Correctly put libs in the proper packages
408
409* Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-4
410- gcc4 rebuild fixes
411- Added missing gdbm-devel buildprereq
412
413* Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-3
414- bump release and rebuild with gcc 4
415
416* Tue Feb 08 2005 Karsten Hopp <karsten@redhat.de> 1.4.11-2
417- update
418
419* Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
420- Initial version
Note: See TracBrowser for help on using the repository browser.