source: projects/specs/trunk/O/OpenEXR/OpenEXR-vl.spec @ 521

Revision 521, 5.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A high dynamic-range (HDR) image file format
2Summary(ja): 高ダイナミックレンジ(HDR)画像ファイルフォーマット
3
4Name:    OpenEXR
5Version: 1.6.1
6Release: 2%{?_dist_release}
7
8Group:   System Environment/Libraries
9License: BSD
10URL:     http://www.openexr.com/
11Source0: http://download.savannah.nongnu.org/releases/openexr/openexr-%{version}.tar.gz
12Source1: http://download.savannah.nongnu.org/releases/openexr/openexr-%{version}.tar.gz.sig
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15Obsoletes: openexr < %{version}-%{release}
16Provides:  openexr = %{version}-%{release}
17
18Patch1: OpenEXR-1.6.1-pkgconfig.patch
19Patch2: openexr-1.6.1-gcc43.patch
20
21## security fix patches
22Patch100: openexr-1.6.1-CVE-2009-1720-1.patch
23Patch101: openexr-1.6.1-CVE-2009-1720-2.patch
24Patch102: openexr-1.6.1-CVE-2009-1721.patch
25
26BuildRequires:  automake libtool
27BuildRequires:  ilmbase-devel
28BuildRequires:  zlib-devel
29
30Requires: %{name}-libs = %{version}-%{release}
31
32%description
33OpenEXR is a high dynamic-range (HDR) image file format developed by Industrial
34Light & Magic for use in computer imaging applications. This package contains
35libraries and sample applications for handling the format.
36
37%package devel
38Summary: Development files for %{name}
39Summary(ja): %{name} の開発ファイル
40Group:   Development/Libraries
41Obsoletes: openexr-devel < %{version}-%{release}
42Provides:  openexr-devel = %{version}-%{release}
43Requires: %{name}-libs = %{version}-%{release}
44Requires: ilmbase-devel
45Requires: pkgconfig
46%description devel
47%{summary}.
48
49%package libs
50Summary: %{name} runtime libraries
51Summary(ja): %{name} runtime libraries
52Group:   System Environment/Libraries
53%description libs
54%{summary}.
55
56
57%prep
58%setup -q -n openexr-%{version}
59
60%patch1 -p1 -b .pkgconfig
61%patch2 -p1 -b .gcc43
62
63%patch100 -p1 -b .CVE-2009-1720-1
64%patch101 -p1 -b .CVE-2009-1720-2
65%patch102 -p1 -b .CVE-2009-1721
66
67# work to remove rpaths, recheck on new releases
68aclocal -Im4
69libtoolize --force
70rm -f configure
71autoconf
72
73
74%build
75%configure --disable-static
76
77# hack to omit unused-direct-shlib-dependencies
78sed -i -e 's! -shared ! -Wl,--as-needed\0!g' libtool
79
80make %{?_smp_mflags}
81
82
83%install
84rm -rf $RPM_BUILD_ROOT
85
86make install DESTDIR=$RPM_BUILD_ROOT
87
88# unpackaged files
89rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
90rm -f  $RPM_BUILD_ROOT%{_libdir}/lib*.la
91
92# prepare docs
93mkdir -p rpmdocs
94cp -a IlmImfExamples rpmdocs/examples
95rm -rf rpmdocs/examples/.deps
96
97
98%check
99# Not enabled, by default, takes a *very* long time. -- Rex
100%{?_with_check:make check}
101
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106
107%post libs -p /sbin/ldconfig
108
109%postun libs -p /sbin/ldconfig
110
111
112%files
113%defattr(-,root,root,-)
114%{_bindir}/*
115
116%files libs
117%defattr(-,root,root,-)
118%doc AUTHORS ChangeLog LICENSE NEWS README
119%{_libdir}/lib*.so.*
120
121%files devel
122%defattr(-,root,root,-)
123%{_datadir}/aclocal/*
124%{_includedir}/OpenEXR/*
125%{_libdir}/lib*.so
126%{_libdir}/pkgconfig/*
127
128
129%changelog
130* Wed Aug  5 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.1-2
131- add Patch100,101 for fix CVE-2009-1720 (Integer BOF)
132- add Patch102 for fix CVE-2009-1721
133- Patch100-102 are from FC11
134
135* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-1
136- initial build for Vine Linux
137
138* Fri May 09 2008 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-4
139- drop: Obsoletes: OpenEXR-utils (see OpenEXR_Viewers review, bug #428228c3)
140
141* Fri Feb 01 2008 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-3
142- gcc43 patch
143- purge rpaths
144
145* Wed Jan 09 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.1-2
146- hack to omit unused-direct-shlib-dependencies
147- conditionalize -libs (f8+)
148
149* Mon Jan 07 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.1-1
150- openexr-1.6.1
151
152* Mon Oct 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-5
153- multiarch conflicts in OpenEXR (#342781)
154- don't own %%_includedir/OpenEXR (leave that to ilmbase)
155
156* Mon Oct 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-4
157- -libs: %%post/%%postun -p /sbin/ldconfig
158
159* Fri Oct 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-2
160- openexr-1.6.0
161
162* Mon Sep 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.0a-6
163- libs: -Requires: %%name
164
165* Wed Aug 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.0a-5
166- -libs: new subpkg to be multilib friendly
167- -utils: package exrdisplay separately (separate fltk dep)
168
169* Sat Oct 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-4
170- Obsoletes/Provides: openexr(-devel) (rpmforge compatibility)
171
172* Thu Sep 14 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-3
173- pkgconfig patch to use Libs.private
174
175* Thu Sep 14 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-2
176- -devel: +Requires: pkgconfig
177
178* Tue Aug 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-1
179- openexr-1.4.0a
180
181* Sat Feb 18 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-7
182- Further zlib fixes (#165729)
183
184* Mon Feb 13 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-6
185- Rebuild for Fedora Extras 5
186
187* Wed Aug 17 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-5
188- Remove *.a from %%files devel
189
190* Tue Aug 16 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-4
191- Removed -devel dep on zlib-devel (#165729)
192- Added --disable-static to %%configure
193- Fixed build with GCC 4.0.1
194- Added .so links to -devel
195
196* Wed May 18 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-3
197- Add zlib-devel to BR
198- Delete all .la files (#157652)
199
200* Mon May  9 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-2
201- Add disttag
202
203* Sun May  8 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-2
204- Fix BuildRequires
205- Fix Requires on -devel
206- Add %%post[un] scriptlets
207- Fix ownership in -devel
208- Don't have .deps files in %%doc
209
210* Wed Mar 30 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-1
211- Initial RPM release
Note: See TracBrowser for help on using the repository browser.