source: projects/specs/trunk/O/OpenEXR/OpenEXR-vl.spec @ 12510

Revision 12510, 7.8 KB checked in by tomop, 3 years ago (diff)

updated 11 packages

Field3D-1.7.3-2

ImageMagick?-6.9.11.48-1

OpenEXR-2.5.3-1

OpenImageIO-2.2.9.0-1

babl-0.1.82-1

fmt-7.1.3-2

gegl04-0.4.26-2

gimp-2.10.22-1

hdf5-1.12.0-1

opencv-4.5.0-1

robin-map-0.6.3-4

Line 
1%bcond_with check
2
3Name:           OpenEXR
4Summary:        A high dynamic-range (HDR) image file format
5Summary(ja):    高ダイナミックレンジ(HDR)画像ファイルフォーマット
6Version:        2.5.3
7Release:        1%{?_dist_release}
8Group:          graphics
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        BSD
13URL:            http://www.openexr.com/
14Source0:        https://github.com/openexr/openexr/archive/v%{version}.tar.gz#/openexr-%{version}.tar.gz
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildRequires: cmake
18BuildRequires: zlib-devel
19BuildRequires: pkgconfig
20# https://github.com/openexr/openexr/issues/130
21BuildConflicts: OpenEXR-devel < 2.2.0
22
23Requires: %{name}-libs = %{version}-%{release}
24
25Obsoletes: openexr < %{version}-%{release}
26Provides:  openexr = %{version}-%{release}
27
28%description
29OpenEXR is a high dynamic-range (HDR) image file format developed by Industrial
30Light & Magic for use in computer imaging applications. This package contains
31sample applications for handling the format.
32
33%package        libs
34Summary:        %{name} runtime libraries
35Summary(ja):    %{name} のランタイムライブラリ
36Group:          system
37
38%description    libs
39%{summary}.
40
41
42%package        devel
43Summary:        Development files for %{name}
44Summary(ja):    %{name} の開発用ファイル
45Group:          programming
46Requires:       %{name}-libs = %{version}-%{release}
47Requires:       ilmbase-devel
48Obsoletes:      openexr-devel < %{version}-%{release}
49Provides:       openexr-devel = %{version}-%{release}
50
51%description devel
52%{summary}.
53
54
55%package -n     ilmbase
56Summary:        Abraction/convenience libraries
57Group:          system
58BuildRequires:  libGL-devel
59BuildRequires:  libGLU-devel
60
61%description -n ilmbase
62Half is a class that encapsulates the ilm 16-bit floating-point format.
63
64IlmThread is a thread abstraction library for use with OpenEXR
65and other software packages.
66
67Imath implements 2D and 3D vectors, 3x3 and 4x4 matrices, quaternions
68and other useful 2D and 3D math functions.
69
70Iex is an exception-handling library.
71
72
73%package -n     ilmbase-devel
74Summary:        Headers and libraries for building apps that use ilmbase
75Summary(ja):    ilmbaseを使うアプリケーションをビルドするためのヘッダファイル及びライブラリ
76Group:          programming
77Requires:       ilmbase = %{version}-%{release}
78Requires:       pkgconfig
79Requires:       libGL-devel
80Requires:       libGLU-devel
81
82%description -n ilmbase-devel
83Headers and libraries for building apps that use ilmbase.
84
85
86%debug_package
87
88
89%prep
90%setup -q -n openexr-%{version}
91
92
93%build
94
95mkdir build
96pushd build
97%cmake \
98        -DPYILMBASE_ENABLE=no \
99        -DOPENEXR_VIEWERS_ENABLE=no \
100        ..
101make %{?_smp_mflags}
102popd
103
104
105%install
106rm -rf %{buildroot}
107
108pushd build
109make install DESTDIR=%{buildroot}
110popd
111
112# prepare docs
113mkdir -p rpmdocs
114cp -a %{buildroot}%{_docdir}/OpenEXR/* rpmdocs/
115rm -rf %{buildroot}%{_docdir}/OpenEXR
116
117
118%if %{with check}
119%check
120pushd build
121%ifarch %{ix86}
122make %{_smp_mflags} test ||:
123%else
124make %{_smp_mflags} test
125%endif
126popd
127%endif
128
129
130%clean
131rm -rf %{buildroot}
132
133
134%post libs -p /sbin/ldconfig
135
136%postun libs -p /sbin/ldconfig
137
138
139%files
140%defattr(-,root,root,-)
141%license LICENSE.md
142%doc README.md
143%{_bindir}/*
144
145%files libs
146%defattr(-,root,root,-)
147%license LICENSE.md
148%doc OpenEXR/README.md
149%doc rpmdocs/*
150%{_libdir}/libIlmImf*.so.*
151
152%files devel
153%defattr(-,root,root,-)
154%{_includedir}/OpenEXR/Imf*.h
155%{_includedir}/OpenEXR/OpenEXRConfig.h
156%{_libdir}/lib*.so
157%dir %{_libdir}/pkgconfig
158%{_libdir}/pkgconfig/OpenEXR.pc
159%dir %{_libdir}/cmake
160%{_libdir}/cmake/OpenEXR
161
162%files -n ilmbase
163%doc IlmBase/README.md
164%license LICENSE.md
165%{_libdir}/lib*.so.*
166%exclude %{_libdir}/libIlmImf*.so.*
167
168%files -n ilmbase-devel
169%dir %{_includedir}/OpenEXR/
170%{_includedir}/OpenEXR/Iex*.h
171%{_includedir}/OpenEXR/Ilm*.h
172%{_includedir}/OpenEXR/Imath*.h
173%{_includedir}/OpenEXR/half*.h
174%{_libdir}/lib*.so
175%exclude %{_libdir}/libIlmImf*.so
176%dir %{_libdir}/pkgconfig
177%{_libdir}/pkgconfig/IlmBase.pc
178%dir %{_libdir}/cmake
179%{_libdir}/cmake/IlmBase
180
181
182%changelog
183* Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.5.3-1
184- new upstream release.
185
186* Fri Jul 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.2-1
187- new upstream release.
188
189* Sat Apr 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-1
190- new upstream release.
191
192* Fri Oct 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.0-1
193- new upstream release.
194- unified IlmBase into OpenEXR.
195
196* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-2
197- rebuild with gcc-5.4.0
198
199* Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.0-1
200- new upstream release
201- removed Patch100 and 101
202- built with ilmbase 2.2.0
203
204* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
205- new upstream release
206- remove Patch1,2,102
207- update Patch100 (openexr-2.1.0-CVE-2009-1720-1.patch)
208- update Patch101 (openexr-2.1.0-CVE-2009-1720-2.patch)
209
210* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-3
211- rebuilt with rpm-4.8.1 for pkg-config
212
213* Wed Aug  5 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.1-2
214- add Patch100,101 for fix CVE-2009-1720 (Integer BOF)
215- add Patch102 for fix CVE-2009-1721
216- Patch100-102 are from FC11
217
218* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-1
219- initial build for Vine Linux
220
221* Fri May 09 2008 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-4
222- drop: Obsoletes: OpenEXR-utils (see OpenEXR_Viewers review, bug #428228c3)
223
224* Fri Feb 01 2008 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-3
225- gcc43 patch
226- purge rpaths
227
228* Wed Jan 09 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.1-2
229- hack to omit unused-direct-shlib-dependencies
230- conditionalize -libs (f8+)
231
232* Mon Jan 07 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.1-1
233- openexr-1.6.1
234
235* Tue Oct 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-5
236- multiarch conflicts in OpenEXR (#342781)
237- don't own %%_includedir/OpenEXR (leave that to ilmbase)
238
239* Mon Oct 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-4
240- -libs: %%post/%%postun -p /sbin/ldconfig
241
242* Fri Oct 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-2
243- openexr-1.6.0
244
245* Mon Sep 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.0a-6
246- libs: -Requires: %%name
247
248* Wed Aug 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.0a-5
249- -libs: new subpkg to be multilib friendly
250- -utils: package exrdisplay separately (separate fltk dep)
251
252* Sat Oct 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-4
253- Obsoletes/Provides: openexr(-devel) (rpmforge compatibility)
254
255* Thu Sep 14 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-3
256- pkgconfig patch to use Libs.private
257
258* Thu Sep 14 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-2
259- -devel: +Requires: pkgconfig
260
261* Tue Aug 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-1
262- openexr-1.4.0a
263
264* Sat Feb 18 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-7
265- Further zlib fixes (#165729)
266
267* Mon Feb 13 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-6
268- Rebuild for Fedora Extras 5
269
270* Wed Aug 17 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-5
271- Remove *.a from %%files devel
272
273* Tue Aug 16 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-4
274- Removed -devel dep on zlib-devel (#165729)
275- Added --disable-static to %%configure
276- Fixed build with GCC 4.0.1
277- Added .so links to -devel
278
279* Wed May 18 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-3
280- Add zlib-devel to BR
281- Delete all .la files (#157652)
282
283* Mon May  9 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-2
284- Add disttag
285
286* Sun May  8 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-2
287- Fix BuildRequires
288- Fix Requires on -devel
289- Add %%post[un] scriptlets
290- Fix ownership in -devel
291- Don't have .deps files in %%doc
292
293* Wed Mar 30 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-1
294- Initial RPM release
Note: See TracBrowser for help on using the repository browser.