source: projects/specs/trunk/O/OpenEXR/OpenEXR-vl.spec @ 12286

Revision 12286, 8.0 KB checked in by tomop, 5 years ago (diff)

updated 10 packages

Field3D-1.7.2-2

ImageMagick?-6.9.10.69-1

OpenColorIO-1.1.1-1

OpenEXR-2.4.0-1

OpenImageIO-2.0.11-1

babl-0.1.72-1

e2fsprogs-1.45.4-1

elfutils-0.177-1

gegl04-0.4.16-1

python3-3.5.7-5

Line 
1%bcond_with check
2
3Name:           OpenEXR
4Summary:        A high dynamic-range (HDR) image file format
5Summary(ja):    高ダイナミックレンジ(HDR)画像ファイルフォーマット
6Version:        2.4.0
7Release:        1%{?_dist_release}
8
9License:        BSD
10Group:          Applications/Graphics
11URL:            http://www.openexr.com/
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15
16Source0:        https://github.com/openexr/openexr/archive/v%{version}.tar.gz#/openexr-%{version}.tar.gz
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: cmake
20BuildRequires: zlib-devel
21BuildRequires: pkgconfig
22# https://github.com/openexr/openexr/issues/130
23BuildConflicts: OpenEXR-devel < 2.2.0
24
25Requires: %{name}-libs = %{version}-%{release}
26
27Obsoletes: openexr < %{version}-%{release}
28Provides:  openexr = %{version}-%{release}
29
30%description
31OpenEXR is a high dynamic-range (HDR) image file format developed by Industrial
32Light & Magic for use in computer imaging applications. This package contains
33sample applications for handling the format.
34
35%package        libs
36Summary:        %{name} runtime libraries
37Summary(ja):    %{name} のランタイムライブラリ
38Group:          System Environment/Libraries
39
40%description    libs
41%{summary}.
42
43
44%package        devel
45Summary:        Development files for %{name}
46Summary(ja):    %{name} の開発用ファイル
47Group:          Development/Libraries
48Requires:       %{name}-libs = %{version}-%{release}
49Requires:       ilmbase-devel
50Obsoletes:      openexr-devel < %{version}-%{release}
51Provides:       openexr-devel = %{version}-%{release}
52
53%description devel
54%{summary}.
55
56
57%package -n     ilmbase
58Summary:        Abraction/convenience libraries
59Group:          System Environment/Libraries
60BuildRequires:  libGL-devel
61BuildRequires:  libGLU-devel
62
63%description -n ilmbase
64Half is a class that encapsulates the ilm 16-bit floating-point format.
65
66IlmThread is a thread abstraction library for use with OpenEXR
67and other software packages.
68
69Imath implements 2D and 3D vectors, 3x3 and 4x4 matrices, quaternions
70and other useful 2D and 3D math functions.
71
72Iex is an exception-handling library.
73
74
75%package -n     ilmbase-devel
76Summary:        Headers and libraries for building apps that use ilmbase
77Summary(ja):    ilmbaseを使うアプリケーションをビルドするためのヘッダファイル及びライブラリ
78Group:          Development/Libraries
79Requires:       ilmbase = %{version}-%{release}
80Requires:       pkgconfig
81Requires:       libGL-devel
82Requires:       libGLU-devel
83
84%description -n ilmbase-devel
85Headers and libraries for building apps that use ilmbase.
86
87
88%prep
89%setup -q -n openexr-%{version}
90
91pushd IlmBase
92echo "Requires.private: gl glu" >> IlmBase.pc.in
93popd
94
95# *.pc built by cmake is broken
96# https://github.com/openexr/openexr/issues/595
97sed -i \
98        -e 's,@exec_prefix@,${prefix}/@exec_prefix@,' \
99        -e 's,@libdir@,\${prefix}/@libdir@,' \
100        -e 's,@includedir@,${prefix}/@includedir@,' \
101        IlmBase/IlmBase.pc.in
102sed -i \
103        -e 's,@exec_prefix@,${prefix}/@exec_prefix@,' \
104        -e 's,@libdir@,\${prefix}/@libdir@,' \
105        -e 's,@includedir@,${prefix}/@includedir@,' \
106        OpenEXR/OpenEXR.pc.in
107
108
109%build
110
111mkdir build
112pushd build
113%cmake \
114        -DPYILMBASE_ENABLE=no \
115        -DOPENEXR_VIEWERS_ENABLE=no \
116        ..
117make %{?_smp_mflags}
118popd
119
120
121%install
122rm -rf %{buildroot}
123
124pushd build
125make install DESTDIR=%{buildroot}
126popd
127
128# prepare docs
129mkdir -p rpmdocs
130cp -a %{buildroot}%{_docdir}/OpenEXR/* rpmdocs/
131rm -rf %{buildroot}%{_docdir}/OpenEXR
132
133
134%if %{with check}
135%check
136pushd build
137%ifarch %{ix86}
138make %{_smp_mflags} test ||:
139%else
140make %{_smp_mflags} test
141%endif
142popd
143%endif
144
145
146%clean
147rm -rf %{buildroot}
148
149
150%post libs -p /sbin/ldconfig
151
152%postun libs -p /sbin/ldconfig
153
154
155%files
156%defattr(-,root,root,-)
157%license LICENSE.md
158%doc README.md
159%{_bindir}/*
160
161%files libs
162%defattr(-,root,root,-)
163%license LICENSE.md
164%doc OpenEXR/README.md
165%doc rpmdocs/*
166%{_libdir}/libIlmImf*.so.*
167
168%files devel
169%defattr(-,root,root,-)
170%{_includedir}/OpenEXR/Imf*.h
171%{_includedir}/OpenEXR/OpenEXRConfig.h
172%{_libdir}/lib*.so
173%dir %{_libdir}/pkgconfig
174%{_libdir}/pkgconfig/OpenEXR.pc
175%dir %{_libdir}/cmake
176%{_libdir}/cmake/OpenEXR
177
178%files -n ilmbase
179%doc IlmBase/README.md
180%license LICENSE.md
181%{_libdir}/lib*.so.*
182%exclude %{_libdir}/libIlmImf*.so.*
183
184%files -n ilmbase-devel
185%dir %{_includedir}/OpenEXR/
186%{_includedir}/OpenEXR/Iex*.h
187%{_includedir}/OpenEXR/Ilm*.h
188%{_includedir}/OpenEXR/Imath*.h
189%{_includedir}/OpenEXR/half*.h
190%{_libdir}/lib*.so
191%exclude %{_libdir}/libIlmImf*.so
192%dir %{_libdir}/pkgconfig
193%{_libdir}/pkgconfig/IlmBase.pc
194%dir %{_libdir}/cmake
195%{_libdir}/cmake/IlmBase
196
197
198%changelog
199* Fri Oct 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.0-1
200- new upstream release.
201- unified IlmBase into OpenEXR.
202
203* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-2
204- rebuild with gcc-5.4.0
205
206* Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.0-1
207- new upstream release
208- removed Patch100 and 101
209- built with ilmbase 2.2.0
210
211* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
212- new upstream release
213- remove Patch1,2,102
214- update Patch100 (openexr-2.1.0-CVE-2009-1720-1.patch)
215- update Patch101 (openexr-2.1.0-CVE-2009-1720-2.patch)
216
217* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-3
218- rebuilt with rpm-4.8.1 for pkg-config
219
220* Wed Aug  5 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.1-2
221- add Patch100,101 for fix CVE-2009-1720 (Integer BOF)
222- add Patch102 for fix CVE-2009-1721
223- Patch100-102 are from FC11
224
225* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-1
226- initial build for Vine Linux
227
228* Fri May 09 2008 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-4
229- drop: Obsoletes: OpenEXR-utils (see OpenEXR_Viewers review, bug #428228c3)
230
231* Fri Feb 01 2008 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-3
232- gcc43 patch
233- purge rpaths
234
235* Wed Jan 09 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.1-2
236- hack to omit unused-direct-shlib-dependencies
237- conditionalize -libs (f8+)
238
239* Mon Jan 07 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.1-1
240- openexr-1.6.1
241
242* Tue Oct 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-5
243- multiarch conflicts in OpenEXR (#342781)
244- don't own %%_includedir/OpenEXR (leave that to ilmbase)
245
246* Mon Oct 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-4
247- -libs: %%post/%%postun -p /sbin/ldconfig
248
249* Fri Oct 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-2
250- openexr-1.6.0
251
252* Mon Sep 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.0a-6
253- libs: -Requires: %%name
254
255* Wed Aug 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.0a-5
256- -libs: new subpkg to be multilib friendly
257- -utils: package exrdisplay separately (separate fltk dep)
258
259* Sat Oct 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-4
260- Obsoletes/Provides: openexr(-devel) (rpmforge compatibility)
261
262* Thu Sep 14 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-3
263- pkgconfig patch to use Libs.private
264
265* Thu Sep 14 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-2
266- -devel: +Requires: pkgconfig
267
268* Tue Aug 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-1
269- openexr-1.4.0a
270
271* Sat Feb 18 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-7
272- Further zlib fixes (#165729)
273
274* Mon Feb 13 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-6
275- Rebuild for Fedora Extras 5
276
277* Wed Aug 17 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-5
278- Remove *.a from %%files devel
279
280* Tue Aug 16 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-4
281- Removed -devel dep on zlib-devel (#165729)
282- Added --disable-static to %%configure
283- Fixed build with GCC 4.0.1
284- Added .so links to -devel
285
286* Wed May 18 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-3
287- Add zlib-devel to BR
288- Delete all .la files (#157652)
289
290* Mon May  9 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-2
291- Add disttag
292
293* Sun May  8 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-2
294- Fix BuildRequires
295- Fix Requires on -devel
296- Add %%post[un] scriptlets
297- Fix ownership in -devel
298- Don't have .deps files in %%doc
299
300* Wed Mar 30 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-1
301- Initial RPM release
Note: See TracBrowser for help on using the repository browser.