source: projects/specs/trunk/O/ORBit2/ORBit2-vl.spec @ 521

Revision 521, 11.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define libidl_version 0.8.11
2%define glib2_version 2.20.0
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4
5Summary: A high-performance CORBA Object Request Broker.
6Summary(ja): 高性能な CORBA Object Request Broker.
7Name: ORBit2
8Version: 2.14.17
9Release: 3%{?_dist_release}
10Group: System Environment/Libraries
11License: LGPL/GPL
12URL: http://www.labs.redhat.com/orbit/
13
14Source: %{name}-%{version}.tar.bz2
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: libIDL-devel >= %{libidl_version}
18BuildRequires: glib2-devel >= %{glib2_version}
19BuildRequires: gtk-doc
20
21%description
22ORBit is a high-performance CORBA (Common Object Request Broker
23Architecture) ORB (object request broker). It allows programs to
24send requests and receive replies from other programs, regardless
25of the locations of the two programs. CORBA is an architecture that
26enables communication between program objects, regardless of the
27programming language they're written in or the operating system they
28run on.
29
30You will need to install this package and ORBit-devel if you want to
31write programs that use CORBA technology.
32#'
33
34%package devel
35Summary: Development libraries, header files and utilities for ORBit.
36Summary(ja): ORBit の開発用ライブラリ,ヘッダファイル,ユーテリティ
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39Requires: indent
40Requires: libIDL-devel >= %{libidl_version}
41Requires: glib2-devel >= %{glib2_version}
42Conflicts: ORBit-devel <= 0.5.8
43
44%description devel
45ORBit is a high-performance CORBA (Common Object Request Broker
46Architecture) ORB (object request broker) with support for the
47C language.
48
49This package contains the header files, libraries and utilities
50necessary to write programs that use CORBA technology. If you want to
51write such programs, you'll also need to install the ORBIT package.
52#'
53
54%package -n compat32-%{name}
55Summary: A high-performance CORBA Object Request Broker.
56Summary(ja): 高性能な CORBA Object Request Broker.
57Group: System Environment/Libraries
58Requires: %{name} = %{version}-%{release}
59
60%description -n compat32-%{name}
61ORBit is a high-performance CORBA (Common Object Request Broker
62Architecture) ORB (object request broker). It allows programs to
63send requests and receive replies from other programs, regardless
64of the locations of the two programs. CORBA is an architecture that
65enables communication between program objects, regardless of the
66programming language they're written in or the operating system they
67run on.
68
69You will need to install this package and ORBit-devel if you want to
70write programs that use CORBA technology.
71#'
72
73%package -n compat32-%{name}-devel
74Summary: Development libraries, header files and utilities for ORBit.
75Summary(ja): ORBit の開発用ライブラリ,ヘッダファイル,ユーテリティ
76Group: Development/Libraries
77Requires: %{name}-devel = %{version}-%{release}
78Requires: compat32-%{name} = %{version}-%{release}
79Requires: compat32-libIDL-devel >= %{libidl_version}
80Requires: compat32-glib2-devel >= %{glib2_version}
81
82%description -n compat32-%{name}-devel
83ORBit is a high-performance CORBA (Common Object Request Broker
84Architecture) ORB (object request broker) with support for the
85C language.
86
87This package contains the header files, libraries and utilities
88necessary to write programs that use CORBA technology. If you want to
89write such programs, you'll also need to install the ORBIT package.
90#'
91
92%prep
93%setup -q
94
95echo "glib-2.0 version is `pkg-config --modversion glib-2.0`"
96
97%build
98%configure --enable-gtk-doc
99# don't use smp flags
100export tagname=CC
101make LIBTOOL=/usr/bin/libtool
102
103%install
104rm -rf $RPM_BUILD_ROOT
105export tagname=CC
106%makeinstall LIBTOOL=/usr/bin/libtool
107
108rm -f $RPM_BUILD_ROOT%{_libdir}/libORBit*.{a,la}
109rm -f $RPM_BUILD_ROOT%{_libdir}/ORBit-2.0/*.*a
110rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.*a
111
112rm -f $RPM_BUILD_ROOT%{_bindir}/linc-cleanup-sockets
113
114%post -p /sbin/ldconfig
115
116%postun -p /sbin/ldconfig
117
118%post -n compat32-%{name} -p /sbin/ldconfig
119
120%postun -n compat32-%{name} -p /sbin/ldconfig
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%files
126%defattr(-,root,root)
127%doc AUTHORS COPYING ChangeLog NEWS README TODO
128%{_libdir}/*.so.*
129%{_libdir}/orbit-2.0/*.so*
130
131%files devel
132%defattr(-,root,root)
133%{_libdir}/*.so
134# this is needed by libbonobo
135%{_libdir}/libname-server-2.a
136%{_libdir}/pkgconfig/*
137%{_bindir}/orbit-idl-2
138%{_bindir}/typelib-dump
139%{_bindir}/orbit2-config
140%{_bindir}/ior-decode-2
141#%{_bindir}/linc-cleanup-sockets
142%{_includedir}/*
143%{_datadir}/aclocal/*.m4
144%{_datadir}/idl/orbit-2.0/
145%{_datadir}/gtk-doc/html/ORBit2
146
147# compat32
148%if %{build_compat32}
149%files -n compat32-%{name}
150%defattr(-,root,root)
151%{_libdir}/*.so.*
152%{_libdir}/orbit-2.0/*.so*
153
154%files -n compat32-%{name}-devel
155%defattr(-,root,root)
156%{_libdir}/*.so
157# this is needed by libbonobo
158%{_libdir}/libname-server-2.a
159%{_libdir}/pkgconfig/*
160%endif
161
162%changelog
163* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.14.17-3
164- added compat32 package for x86_64 arch support
165- added BuildRequires: gtk-doc
166- re-added a static library, %%{_libdir}/libname-server-2.a that is needed by libbonobo
167
168* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.17-2
169- remove static libs
170
171* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.17-1
172- new upstream release
173
174* Tue Sep 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.16-1
175- new upstream release
176- built with libIDL-0.8.11
177- spec in UTF-8
178
179* Sat Jul 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.12-2vl5
180- rebuilt without libIDL-2.la
181
182* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.12-1vl5
183- new upstream release
184- built with libIDL-0.8.10
185- remove BuildRequires: automake16
186
187* Sat Jan 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.11-0vl1
188- new upstream release
189
190* Mon Jan 14 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.10-0vl2
191- dropt %%{_smp_mflags} to make
192
193* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.10-0vl1
194- new upstream release
195
196* Tue Oct  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.9-0vl1
197- new upstream release
198- changed Group to System Environment/Libraries
199
200* Fri Mar 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.7-0vl1
201- new upstream release
202
203* Sun Oct 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
204- new upstream release
205
206* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
207- new upstream release
208
209* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.3-0vl1
210- new upstream release
211
212* Sun Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.5-0vl1
213- new upstream release
214
215* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.4-0vl1
216- new upstream release
217
218* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
219- new upstream release
220
221* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
222- new upstream release
223- added gtk-doc directory
224
225* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
226- new upstream release
227
228* Fri Oct 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.8-0vl1
229- new upstream release
230
231* Tue Feb 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.3-0vl3
232- add patch0 from fedora
233
234* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl2
235- rebuild with new toolchains
236
237* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
238- new upstream release
239- rebuild with new toolchains
240
241* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
242- new upstream release
243
244* Tue Sep 02 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
245- new upstream release
246
247* Fri Jul 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.3-0vl1
248- new upstream release
249
250* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-0vl1
251- new upstream release
252
253* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-0vl1
254- new upstream release
255
256* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-0vl1
257- build for Vine Linux
258
259* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
260- 2.4.1
261
262* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
263- automated rebuild
264
265* Thu Jun 06 2002 Havoc Pennington <hp@redhat.com>
266- rebuild in different environment
267
268* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
269- 2.4.0
270
271* Sun May 26 2002 Tim Powers <timp@redhat.com>
272- automated rebuild
273
274* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
275- rebuild in different environment
276
277* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
278- 2.3.109
279
280* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
281- 2.3.108
282
283* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
284- 2.3.107
285
286* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
287- 2.3.105
288
289* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
290- Version 2.3.103
291- Rebuild for dependencies
292
293* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
294- automated rebuild
295
296* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
297- build system somehow built against libglib-1.3.so.11
298  even though pkg-config found 1.3.12? wtf?
299  trying again
300
301* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
302- 2.3.100.90 snap
303
304* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
305- 2.3.99
306
307* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
308- new snap 2.3.97.90, rebuild for glib 1.3.11
309
310* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
311- new snap, glib 1.3.10 rebuild
312
313* Tue Oct  9 2001 Havoc Pennington <hp@redhat.com>
314- check rebuild against new linc with headers moved
315- remove epoch, that was a screwup
316
317* Thu Oct  4 2001 Havoc Pennington <hp@redhat.com>
318- cvs snap
319- require specific glib2
320
321* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
322- 2.3.95 tarball
323- depend on new standalone libIDL, remove all libIDL stuff from file list
324
325* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
326- require specific linc version, unrequire specific glib version since
327  we get that via linc
328
329* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
330- newer orbit2 from CVS
331
332* Thu Sep 13 2001 Havoc Pennington <hp@redhat.com>
333- conflict with old orbit with headers not moved
334
335* Wed Sep 12 2001 Havoc Pennington <hp@redhat.com>
336- renaming more things
337- remove smp flags, doesn't work atm
338- fix .pc file, trying to get bonobo-activation to build
339
340* Tue Sep 11 2001 Havoc Pennington <hp@redhat.com>
341- kill all file conflicts with ORBit1
342
343* Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
344- convert to ORBit2 spec file (from ORBit original)
345
346* Tue Jul 24 2001 Alexander Larsson <alexl@redhat.com>
347- Added glib-devel BuildRequires
348
349* Thu Jun 21 2001 Elliot Lee <sopwith@redhat.com> 0.5.8-2
350- Use _smp_mflags if possible.
351
352* Mon May 14 2001 Jonathan Blandford <jrb@redhat.com>
353- bumped version
354
355* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
356- Rebuild for GTK+-1.2.9
357
358* Tue Jan 30 2001 Elliot Lee <sopwith@redhat.com>
359- 0.5.7 for real
360
361* Thu Jan 18 2001 Elliot Lee <sopwith@redhat.com>
362- 0.5.7
363
364* Tue Dec 19 2000 Elliot Lee <sopwith@redhat.com>
365- 0.5.6
366
367* Thu Nov 30 2000 Elliot Lee <sopwith@redhat.com>
368- 0.5.5
369
370* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
371- Up Epoch and release
372
373* Tue Jul 25 2000 Elliot Lee <sopwith@redhat.com>
374- 0.5.3
375
376* Wed Jul 19 2000 Jonathan Blandford <jrb@redhat.com>
377- fixed to work with new cpp.
378
379* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
380- automatic rebuild
381
382* Tue Jul 11 2000 Jonathan Blandford <jrb@redhat.com>
383- Upgraded to 0.5.2 - a bug fix release.
384
385* Tue Jun 27 2000 Havoc Pennington <hp@redhat.com>
386- Trying to build the package for Preston and the build
387  system wants a new changelog entry
388
389* Sat Jun 24 2000 Preston Brown <pbrown@redhat.com>
390- defattr the devel pkg
391- FHS paths
392
393* Fri May 19 2000 Jonathan Blandford <jrb@redhat.com>
394- Upgraded to 0.5.1
395
396* Tue Feb  3 2000 Elliot Lee <sopwith@redhat.com> 0.5.0-3
397- Strip shared libraries
398
399* Mon Aug 30 1999 Elliot Lee <sopwith@redhat.com> 0.4.94-1
400- Spec file fixes from RHL 6.0.
401
402* Wed Jun 2 1999  Jose Mercado <jmercado@mit.edu>
403- Fixed configure.in so spec.in could be used.
404
405* Mon Nov 23 1998 Pablo Saratxaga <srtxg@chanae.alphanet.ch>
406
407- improved %files section, and added use of %{prefix} and install-info
408  (well,... no. The info file has not dir info inside, commented out)
Note: See TracBrowser for help on using the repository browser.