source: projects/specs/trunk/M/MySQL/MySQL-vl.spec @ 6160

Revision 6160, 32.5 KB checked in by tomop, 12 years ago (diff)

MySQL-5.5.24-1

Line 
1%define mysqld_user             mysql
2%define mysqld_group            mysql
3%define server_suffix -community
4%define mysqldatadir /var/lib/mysql
5
6%{?_with_static:%define STATIC_BUILD 1}
7%{!?_with_static:%define STATIC_BUILD 0}
8
9# Working around perl dependency problem
10%define __perl_requires %{SOURCE998}
11
12# We don't package all files installed into the build root by intention -
13# See BUG#998 for details.
14%define _unpackaged_files_terminate_build 0
15
16%define see_base For a description of MySQL see the base MySQL RPM or http://www.mysql.com
17
18%define mysql_version           5.5.24
19%define client_version          18
20
21%if %{?_dist_release}!="vl5"
22%define libpkgname libmysqlclient%{client_version}
23%else
24%define libpkgname MySQL-shared
25%endif
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager:       tomop
30
31Name: MySQL
32Summary:        MySQL: a very fast and reliable SQL database server
33Version:        %{mysql_version}
34Release:        1%{_dist_release}
35
36Group:          Applications/Databases
37# exceptions allow client libraries to be linked with most open source SW,
38# not only GPL code.
39License:        GPLv2 with exceptions
40URL:            http://www.mysql.com/
41
42Source:         mysql-%{version}.tar.gz
43# Don't depend on lib::mtr*
44Source998:      perl-requires-%{name}.sh
45Patch0:         mysql-5.5.15-jp-all.patch
46
47# lib64 patch for vine
48Patch200:       pysql-5.1.44-lib64.patch
49
50BuildRoot:      %{_tmppath}/%{name}-%{version}-root
51BuildRequires:  perl, readline-devel, libaio-devel
52BuildRequires:  gcc-c++, ncurses-devel, zlib-devel, openssl-devel
53BuildRequires:  groff, cmake, bison
54Requires:       fileutils sh-utils
55Provides:       msqlormysql MySQL-server mysql
56Obsoletes:      mysql MySQL5
57
58# From the manual
59%description
60The MySQL(TM) software delivers a very fast, multi-threaded, multi-user,
61and robust SQL (Structured Query Language) database server. MySQL Server
62is intended for mission-critical, heavy-load production systems as well
63as for embedding into mass-deployed software. MySQL is a trademark of
64Sun Microsystems, Inc.
65
66Copyright 2000-2008 MySQL AB, 2009 Sun Microsystems, Inc.  All rights reserved.
67Use is subject to license terms.
68
69This software comes with ABSOLUTELY NO WARRANTY. This is free software,
70and you are welcome to modify and redistribute it under the GPL license.
71
72The MySQL web site (http://www.mysql.com/) provides the latest
73news and information about the MySQL software. Also please see the
74documentation and the manual for more information.
75
76%package server
77Release: %{release}
78Summary:        MySQL: a very fast and reliable SQL database server
79Group:          Applications/Databases
80Requires:       fileutils sh-utils net-tools
81Provides:       msqlormysql mysql-server mysql MySQL MySQL5-server
82Obsoletes:      MySQL mysql mysql-server MySQL5-server MySQL-Max
83
84%description server
85The MySQL(TM) software delivers a very fast, multi-threaded, multi-user,
86and robust SQL (Structured Query Language) database server. MySQL Server
87is intended for mission-critical, heavy-load production systems as well
88as for embedding into mass-deployed software. MySQL is a trademark of
89Sun Microsystems, Inc.
90
91Copyright 2000-2008 MySQL AB, 2009 Sun Microsystems, Inc.  All rights reserved.
92Use is subject to license terms.
93
94This software comes with ABSOLUTELY NO WARRANTY. This is free software,
95and you are welcome to modify and redistribute it under the GPL license.
96
97The MySQL web site (http://www.mysql.com/) provides the latest
98news and information about the MySQL software. Also please see the
99documentation and the manual for more information.
100
101This package includes the MySQL server binary (incl. InnoDB) as well
102as related utilities to run and administrate a MySQL server.
103
104If you want to access and work with the database, you have to install
105package "MySQL-client" as well!
106
107%package client
108Summary: MySQL - Client
109Group: Applications/Databases
110Obsoletes: mysql-client MySQL5-client
111Provides: mysql-client MySQL5-client
112
113%description client
114This package contains the standard MySQL clients and administration tools.
115
116%{see_base}
117
118%package test
119Requires: %{name}-client = %{version}-%{release} perl-DBI perl
120Summary: MySQL - Test suite
121Group: Applications/Databases
122Obsoletes: mysql-bench MySQL5-bench MySQL-bench
123Provides: perl(mtr_misc.pl)
124
125%description test
126This package contains the MySQL regression test suite.
127
128%{see_base}
129
130
131%package devel
132Summary: MySQL - Development header files and libraries
133Group: Development/Libraries
134Requires: %{libpkgname} = %{version}-%{release}
135Requires: openssl-devel, zlib-devel
136Provides: mysql-devel MySQL5-devel
137Obsoletes: mysql-devel MySQL5-devel
138
139%description devel
140This package contains the development header files and libraries
141necessary to develop MySQL client applications.
142
143%{see_base}
144
145%package -n %{libpkgname}
146Summary: The shared libraries required for MySQL clients
147Group: System Environment/Libraries
148%if %{?_dist_release}!="vl5"
149Obsoletes: MySQL-shared < %{version}
150%endif
151
152%description -n %{libpkgname}
153This package contains the shared libraries (*.so*) which certain
154languages and applications need to dynamically load and use MySQL.
155
156
157#%package embedded
158#Summary: MySQL as an embeddable library
159#Group: System Environment/Libraries
160#Obsoletes: mysql-embedded MySQL5-embedded
161#Provides: mysql-embedded MySQL5-embedded
162
163#%description embedded
164#MySQL is a multi-user, multi-threaded SQL database server. This
165#package contains a version of the MySQL server that can be embedded
166#into a client application instead of running as a separate process.
167
168#%{see_base}
169
170%package embedded-devel
171Summary: Development files for MySQL as an embeddable library
172Group: Development/Libraries
173Requires: %{name}-devel = %{version}-%{release}
174
175%description embedded-devel
176MySQL is a multi-user, multi-threaded SQL database server. This
177package contains files needed for developing and testing with
178the embedded version of the MySQL server.
179
180%{see_base}
181
182%prep
183%setup -q -n mysql-%{version}
184
185%patch0 -p1 -b .jp
186#%if %{_lib} == lib64
187#%patch200 -p0 -b .lib64
188#%endif
189#aclocal
190#autoheader
191#libtoolize --automake --force
192#automake --add-missing --copy
193#autoconf
194#perl -pi -e 's/-Werror"/"/' configure
195
196
197%build
198
199# Be strict about variables, bail at earliest opportunity, etc.
200set -eu
201
202# Optional package files
203touch optional-files-devel
204
205export PATH=${MYSQL_BUILD_PATH:-$PATH}
206export CC=${MYSQL_BUILD_CC:-${CC:-gcc}}
207export CXX=${MYSQL_BUILD_CXX:-${CXX:-gcc}}
208export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
209export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
210export LDFLAGS=${MYSQL_BUILD_LDFLAGS:-${LDFLAGS:-}}
211export CMAKE=${MYSQL_BUILD_CMAKE:-${CMAKE:-cmake}}
212export MAKE_JFLAG=${MYSQL_BUILD_MAKE_JFLAG:-}
213
214# Build full release
215mkdir release
216(
217  cd release
218  # XXX: MYSQL_UNIX_ADDR should be in cmake/* but mysql_version is included before
219  # XXX: install_layout so we can't just set it based on INSTALL_LAYOUT=RPM
220  ${CMAKE} ../ -DBUILD_CONFIG=mysql_release -DINSTALL_LAYOUT=RPM \
221           -DCMAKE_BUILD_TYPE=RelWithDebInfo \
222           -DMYSQL_UNIX_ADDR="/var/lib/mysql/mysql.sock" \
223           -DFEATURE_SET="community" \
224           -DCOMPILATION_COMMENT="VineLinux MySQL RPM" \
225           -DMYSQL_SERVER_SUFFIX="%{server_suffix}" \
226           -DWITH_PIC="ON" \
227           -DWITH_ZLIB="system" \
228           -DWITH_EMBEDDED_SERVER="ON" \
229           -DWITH_SSL="yes"
230  echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
231  make %{?_smp_mflags} VERBOSE=1
232)
233
234# Use the build root for temporary storage of the shared libraries.
235RBR=$RPM_BUILD_ROOT
236
237# Clean up the BuildRoot first
238[ "$RBR" != "/" ] && [ -d "$RBR" ] && rm -rf "$RBR";
239
240# For gcc builds, include libgcc.a in the devel subpackage (BUG 4921).  This
241# needs to be during build phase as $CC is not set during install.
242if "$CC" -v 2>&1 | grep '^gcc.version' >/dev/null 2>&1
243then
244  libgcc=`$CC $CFLAGS --print-libgcc-file`
245  if [ -f $libgcc ]
246  then
247    mkdir -p $RBR%{_libdir}/mysql
248#    install -m 644 $libgcc $RBR%{_libdir}/mysql/libmygcc.a
249#    echo "%{_libdir}/mysql/libmygcc.a" >>optional-files-devel
250  fi
251fi
252
253##############################################################################
254%install
255RBR=$RPM_BUILD_ROOT
256MBD=$RPM_BUILD_DIR/mysql-%{mysql_version}
257
258rm -rf $RBR
259
260# Ensure that needed directories exists
261install -d $RBR%{_sysconfdir}/{logrotate.d,init.d}
262install -d $RBR%{mysqldatadir}/mysql
263install -d $RBR%{_datadir}/mysql-test
264install -d $RBR%{_includedir}
265install -d $RBR%{_libdir}
266install -d $RBR%{_mandir}
267install -d $RBR%{_sbindir}
268
269# Install all binaries
270# Install all binaries
271(
272  cd $MBD/release
273  make DESTDIR=$RBR install
274)
275
276# Install logrotate and autostart
277install -m 644 $MBD/release/support-files/mysql-log-rotate $RBR%{_sysconfdir}/logrotate.d/mysql
278install -m 755 $MBD/release/support-files/mysql.server $RBR%{_sysconfdir}/init.d/mysql
279
280# Create a symlink "rcmysql", pointing to the init.script. SuSE users
281# will appreciate that, as all services usually offer this.
282ln -s %{_sysconfdir}/init.d/mysql $RBR%{_sbindir}/rcmysql
283
284# Touch the place where the my.cnf config file might be located
285# Just to make sure it's in the file list and marked as a config file
286touch $RBR%{_sysconfdir}/my.cnf
287
288# Remove man pages we explicitly do not want to package, avoids 'unpackaged
289# files' warning.
290rm -f $RBR%{_mandir}/man1/make_win_bin_dist.1*
291
292##############################################################################
293
294
295%pre server
296# Shut down a previously installed server first
297if test -x %{_sysconfdir}/init.d/mysql
298then
299  %{_sysconfdir}/init.d/mysql stop > /dev/null 2>&1
300  echo "Giving mysqld a couple of seconds to exit nicely"
301  sleep 5
302elif test -x %{_sysconfdir}/rc.d/init.d/mysql
303then
304  %{_sysconfdir}/rc.d/init.d/mysql stop > /dev/null 2>&1
305  echo "Giving mysqld a couple of seconds to exit nicely"
306  sleep 5
307fi
308
309%post server
310mysql_datadir=%{mysqldatadir}
311
312# Create data directory if needed
313if test ! -d $mysql_datadir; then mkdir -m 755 $mysql_datadir; fi
314if test ! -d $mysql_datadir/mysql; then mkdir $mysql_datadir/mysql; fi
315if test ! -d $mysql_datadir/test; then mkdir $mysql_datadir/test; fi
316
317# Make MySQL start/shutdown automatically when the machine does it.
318# use insserv for older SuSE Linux versions
319if test -x /sbin/insserv
320then
321        /sbin/insserv %{_sysconfdir}/init.d/mysql
322# use chkconfig on Red Hat and newer SuSE releases
323elif test -x /sbin/chkconfig
324then
325        /sbin/chkconfig --add mysql
326fi
327
328# Create a MySQL user and group. Do not report any problems if it already
329# exists.
330groupadd -r %{mysqld_group} 2> /dev/null || true
331useradd -M -r -d $mysql_datadir -s /bin/bash -c "MySQL server" -g %{mysqld_group} %{mysqld_user} 2> /dev/null || true
332# The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
333usermod -g %{mysqld_group} %{mysqld_user} 2> /dev/null || true
334
335# Change permissions so that the user that will run the MySQL daemon
336# owns all database files.
337chown -R %{mysqld_user}:%{mysqld_group} $mysql_datadir
338
339# Initiate databases if needed
340%{_bindir}/mysql_install_db --rpm --user=%{mysqld_user}
341
342# Upgrade databases if needed would go here - but it cannot be automated yet
343
344# Change permissions again to fix any new files.
345chown -R %{mysqld_user}:%{mysqld_group} $mysql_datadir
346
347# Fix permissions for the permission database so that only the user
348# can read them.
349chmod -R og-rw $mysql_datadir/mysql
350
351# Restart in the same way that mysqld will be started normally.
352%{_sysconfdir}/init.d/mysql start
353
354# Allow mysqld_safe to start mysqld and print a message before we exit
355sleep 2
356
357#echo "Thank you for installing the MySQL Community Server! For Production
358#systems, we recommend MySQL Enterprise, which contains enterprise-ready
359#software, intelligent advisory services, and full production support with
360#scheduled service packs and more.  Visit www.mysql.com/enterprise for more
361#information."
362
363%preun server
364if test $1 = 0
365then
366  # Stop MySQL before uninstalling it
367  if test -x %{_sysconfdir}/init.d/mysql
368  then
369    %{_sysconfdir}/init.d/mysql stop > /dev/null
370
371    # Remove autostart of mysql
372    # for older SuSE Linux versions
373    if test -x /sbin/insserv
374    then
375      /sbin/insserv -r %{_sysconfdir}/init.d/mysql
376    # use chkconfig on Red Hat and newer SuSE releases
377    elif test -x /sbin/chkconfig
378    then
379      /sbin/chkconfig --del mysql
380    fi
381  fi
382fi
383
384# We do not remove the mysql user since it may still own a lot of
385# database files.
386
387%post -n %{libpkgname}
388/sbin/ldconfig
389
390%postun -n %{libpkgname}
391/sbin/ldconfig
392
393# Clean up the BuildRoot
394%clean
395[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
396
397%files server
398%defattr(-,root,root,0755)
399
400%doc COPYING README
401%doc Docs/ChangeLog
402%doc Docs/INFO_SRC*
403%doc release/Docs/INFO_BIN*
404%doc release/support-files/my-*.cnf
405
406%doc %attr(644, root, root) %{_infodir}/mysql.info*
407
408%doc %attr(644, root, man) %{_mandir}/man1/innochecksum.1*
409%doc %attr(644, root, man) %{_mandir}/man1/my_print_defaults.1*
410%doc %attr(644, root, man) %{_mandir}/man1/myisam_ftdump.1*
411%doc %attr(644, root, man) %{_mandir}/man1/myisamchk.1*
412%doc %attr(644, root, man) %{_mandir}/man1/myisamlog.1*
413%doc %attr(644, root, man) %{_mandir}/man1/myisampack.1*
414%doc %attr(644, root, man) %{_mandir}/man1/mysql_convert_table_format.1*
415%doc %attr(644, root, man) %{_mandir}/man1/mysql_fix_extensions.1*
416%doc %attr(644, root, man) %{_mandir}/man8/mysqld.8*
417%doc %attr(644, root, man) %{_mandir}/man1/mysqld_multi.1*
418%doc %attr(644, root, man) %{_mandir}/man1/mysqld_safe.1*
419%doc %attr(644, root, man) %{_mandir}/man1/mysqldumpslow.1*
420%doc %attr(644, root, man) %{_mandir}/man1/mysql_install_db.1*
421%doc %attr(644, root, man) %{_mandir}/man1/mysql_plugin.1*
422%doc %attr(644, root, man) %{_mandir}/man1/mysql_secure_installation.1*
423%doc %attr(644, root, man) %{_mandir}/man1/mysql_setpermission.1*
424%doc %attr(644, root, man) %{_mandir}/man1/mysql_upgrade.1*
425%doc %attr(644, root, man) %{_mandir}/man1/mysqlhotcopy.1*
426%doc %attr(644, root, man) %{_mandir}/man1/mysqlman.1*
427%doc %attr(644, root, man) %{_mandir}/man1/mysql.server.1*
428%doc %attr(644, root, man) %{_mandir}/man1/mysqltest.1*
429%doc %attr(644, root, man) %{_mandir}/man1/mysql_tzinfo_to_sql.1*
430%doc %attr(644, root, man) %{_mandir}/man1/mysql_zap.1*
431%doc %attr(644, root, man) %{_mandir}/man1/mysqlbug.1*
432%doc %attr(644, root, man) %{_mandir}/man1/perror.1*
433%doc %attr(644, root, man) %{_mandir}/man1/replace.1*
434%doc %attr(644, root, man) %{_mandir}/man1/resolve_stack_dump.1*
435%doc %attr(644, root, man) %{_mandir}/man1/resolveip.1*
436
437%ghost %config(noreplace,missingok) %{_sysconfdir}/my.cnf
438
439%attr(755, root, root) %{_bindir}/innochecksum
440%attr(755, root, root) %{_bindir}/my_print_defaults
441%attr(755, root, root) %{_bindir}/myisam_ftdump
442%attr(755, root, root) %{_bindir}/myisamchk
443%attr(755, root, root) %{_bindir}/myisamlog
444%attr(755, root, root) %{_bindir}/myisampack
445%attr(755, root, root) %{_bindir}/mysql_convert_table_format
446%attr(755, root, root) %{_bindir}/mysql_fix_extensions
447%attr(755, root, root) %{_bindir}/mysql_install_db
448%attr(755, root, root) %{_bindir}/mysql_plugin
449%attr(755, root, root) %{_bindir}/mysql_secure_installation
450%attr(755, root, root) %{_bindir}/mysql_setpermission
451%attr(755, root, root) %{_bindir}/mysql_tzinfo_to_sql
452%attr(755, root, root) %{_bindir}/mysql_upgrade
453%attr(755, root, root) %{_bindir}/mysql_zap
454%attr(755, root, root) %{_bindir}/mysqlbug
455%attr(755, root, root) %{_bindir}/mysqld_multi
456%attr(755, root, root) %{_bindir}/mysqld_safe
457%attr(755, root, root) %{_bindir}/mysqldumpslow
458%attr(755, root, root) %{_bindir}/mysqlhotcopy
459%attr(755, root, root) %{_bindir}/mysqltest
460%attr(755, root, root) %{_bindir}/perror
461%attr(755, root, root) %{_bindir}/replace
462%attr(755, root, root) %{_bindir}/resolve_stack_dump
463%attr(755, root, root) %{_bindir}/resolveip
464
465%attr(755, root, root) %{_sbindir}/mysqld
466%attr(755, root, root) %{_sbindir}/rcmysql
467%attr(755, root, root) %{_libdir}/mysql/plugin/*.so
468
469%attr(644, root, root) %config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
470%attr(755, root, root) %{_sysconfdir}/init.d/mysql
471
472%attr(755, root, root) %{_datadir}/mysql/
473
474%files client
475%defattr(-, root, root, 0755)
476%attr(755, root, root) %{_bindir}/msql2mysql
477%attr(755, root, root) %{_bindir}/mysql
478%attr(755, root, root) %{_bindir}/mysql_find_rows
479%attr(755, root, root) %{_bindir}/mysql_waitpid
480%attr(755, root, root) %{_bindir}/mysqlaccess
481# XXX: This should be moved to %{_sysconfdir}
482%attr(644, root, root) %{_bindir}/mysqlaccess.conf
483%attr(755, root, root) %{_bindir}/mysqladmin
484%attr(755, root, root) %{_bindir}/mysqlbinlog
485%attr(755, root, root) %{_bindir}/mysqlcheck
486%attr(755, root, root) %{_bindir}/mysqldump
487%attr(755, root, root) %{_bindir}/mysqlimport
488%attr(755, root, root) %{_bindir}/mysqlshow
489%attr(755, root, root) %{_bindir}/mysqlslap
490
491%doc %attr(644, root, man) %{_mandir}/man1/msql2mysql.1*
492%doc %attr(644, root, man) %{_mandir}/man1/mysql.1*
493%doc %attr(644, root, man) %{_mandir}/man1/mysql_find_rows.1*
494%doc %attr(644, root, man) %{_mandir}/man1/mysql_waitpid.1*
495%doc %attr(644, root, man) %{_mandir}/man1/mysqlaccess.1*
496%doc %attr(644, root, man) %{_mandir}/man1/mysqladmin.1*
497%doc %attr(644, root, man) %{_mandir}/man1/mysqlbinlog.1*
498%doc %attr(644, root, man) %{_mandir}/man1/mysqlcheck.1*
499%doc %attr(644, root, man) %{_mandir}/man1/mysqldump.1*
500%doc %attr(644, root, man) %{_mandir}/man1/mysqlimport.1*
501%doc %attr(644, root, man) %{_mandir}/man1/mysqlshow.1*
502%doc %attr(644, root, man) %{_mandir}/man1/mysqlslap.1*
503
504%files devel -f optional-files-devel
505%defattr(-, root, root, 0755)
506%doc %attr(644, root, man) %{_mandir}/man1/comp_err.1*
507%doc %attr(644, root, man) %{_mandir}/man1/mysql_config.1*
508%attr(755, root, root) %{_bindir}/mysql_config
509%dir %attr(755, root, root) %{_includedir}/mysql
510%dir %attr(755, root, root) %{_libdir}/mysql
511%{_includedir}/mysql/*
512%{_datadir}/aclocal/mysql.m4
513%{_libdir}/*.so
514%exclude %{_libdir}/*.a
515
516%files -n %{libpkgname}
517%defattr(-, root, root, 0755)
518# Shared libraries (omit for architectures that don't support them)
519%{_libdir}/libmysql*.so.*
520#/etc/ld.so.conf.d/*
521
522%files test
523%defattr(-, root, root, 0755)
524%attr(-, root, root) %{_datadir}/mysql-test
525%attr(755, root, root) %{_bindir}/mysql_client_test
526%attr(755, root, root) %{_bindir}/mysql_client_test_embedded
527%attr(755, root, root) %{_bindir}/mysqltest_embedded
528%doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test.1*
529%doc %attr(644, root, man) %{_mandir}/man1/mysql-stress-test.pl.1*
530%doc %attr(644, root, man) %{_mandir}/man1/mysql-test-run.pl.1*
531%doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test_embedded.1*
532%doc %attr(644, root, man) %{_mandir}/man1/mysqltest_embedded.1*
533
534%files embedded-devel
535%defattr(-,root,root)
536#{_libdir}/libmysqld.a
537%{_bindir}/mysql_embedded
538%{_bindir}/mysql_client_test_embedded
539%{_bindir}/mysqltest_embedded
540%doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test_embedded.1*
541%doc %attr(644, root, man) %{_mandir}/man1/mysqltest_embedded.1*
542
543%changelog
544* Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
545- new upstream release.
546
547* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
548- new upstream release.
549- added "Vendor:" and "Distribution:" tag.
550
551* Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
552- new upstream release.
553- removed NDB cluster support.
554
555* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
556- Added "BR: zlib-devel" to MySQL-devel.
557
558* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
559- Added "BR: openssl-devel" to MySQL-devel.
560
561* Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
562- new upstream release.
563
564* Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
565- new upstream release.
566- updated jp-patch.
567- added ssl support.
568
569* Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
570- new upstream release.
571- replaced '%%__find_requires' to '%%__perl_requires'.
572- updated jp-patch.
573
574* Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
575- added mysql-5.1.44-lib64.patch (on x86_64)
576- added -fPIC (on x86_64)
577
578* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
579- made embedded package again
580
581* Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
582- new upstream release.
583- updated jp-patch.
584
585* Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
586- VineSeed: rebuilt with new toolchain.
587
588* Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
589- new upstream release.
590  - fixed CVE-2009-4484.
591
592* Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
593- new upstream release.
594
595* Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
596- added net-tools to 'Requires'.
597- added groff to 'BuildRequires'.
598- renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
599
600* Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
601- new upstream release.
602
603* Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
604- new upstream release.
605
606* Sun Jul  5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
607- new upstream release.
608- dropped %%Patch100 (fixed in upstream).
609
610* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
611- new upstream release.
612- add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
613
614* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
615- new upstream release.
616- rename 'MySQL-bench' to 'MySQL-test'.
617- update Patch0.
618- change default charset to 'utf8'.
619
620* Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
621- new upstream release.
622- update Patch0.
623- add "--with-client-charset=ujis".
624- sync %%files to official RPM.
625- remove MySQL-Max.
626
627* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
628- for VineSeed
629
630* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
631- move shared library from /usr/lib/ to /usr/lib/mysql/
632- add /etc/ld.so.conf.d/*.conf
633- fix broken libmysqlcient*.la files (or should we remove them permanently?)
634
635* Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
636- rebuild <BTS:VineLinux:534>
637
638* Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
639- added -fPIC
640
641* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
642- fixed dependency. <BTS:338>
643
644* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
645- add %%Patch1. <BTS:320>
646
647* Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
648- new upstream release.
649
650* Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
651- new upstream release.
652
653* Sat Jun  3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
654- new upstream release.
655
656* Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
657- release++.
658
659* Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
660- new upstream release.
661- for VineSeed.
662
663* Wed Feb  8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
664- new upstream release.
665- replace Patch0 for MySQL-4.1.16.
666
667* Thu Oct  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
668- new upstream release.
669- add Patch0.
670
671* Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
672- new upstream version
673        -- mysql-4.0.25
674
675* Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
676- new upstream version
677        -- mysql-4.0.23
678
679* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
680- new upstream version
681        -- mysql-4.0.22
682 
683* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
684- new upstream version
685        -- mysql-4.0.21
686 
687* Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
688- new upstream version
689        -- mysql-4.0.20
690 
691* Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
692- modify CFLAGS, CXXFLAGS and configure options for alpha
693
694* Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
695- Upgraded to MySQL-4
696- added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
697- merged to MySQL Official packages
698        -- renamed package "MySQL" to "MySQL-server"
699        -- when using gcc, _always_ use CXX=gcc
700        -- replaced Copyright with License field (Copyright is obsolete)
701        -- added myisam_ftdump to the Server package
702        -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
703        -- fixed file permissions (BUG 1672)
704        -- removed dependency on MySQL-client from the MySQL-devel subpackage
705        -- as it is not really required. (BUG 1610)
706        -- Fixed BUG 1162 (removed macro names from the changelog)
707        -- Really fixed BUG 998 (disable the checking for installed but
708        --  unpackaged files)
709        -- Fixed BUG 959 (libmysqld not being compiled properly)
710        -- Fixed BUG 998 (RPM build errors): added missing files to the
711        -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
712        -- mysql_fix_privilege_tables.1), removed "-n" from install section.
713        -- removed the GIF Icon (file was not included in the sources anyway)
714        -- removed unused variable shared_lib_version
715        -- do not run automake before building the standard binary
716        --  (should not be necessary)
717        -- add server suffix '-standard' to standard binary (to be in line
718        -- with the binary tarball distributions)
719        -- allow overriding CC and CXX (required when building
720        -- with other compilers)
721
722* Thu Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
723- added BuildRequires:  automake16
724                                                                               
725* Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
726- add '-fPIC -DPIC' to CFLAGS on alpha
727- little fix of spec file
728                                                                               
729* Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
730- enable MySQL-shared subpackage for alpha
731- delete 'BuildPrereq: kernel24-headers' for alpha
732- fix shared %files (exclude sparc)
733                                                                               
734* Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
735- new upstream version
736                                                                               
737* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
738- fixed devel %files (dropped *.la files)
739                                                                               
740* Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
741- new upstream version
742- fixed document permission
743                                                                               
744* Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
745- new upstream version
746                                                                               
747* Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
748- dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
749        -- don't work
750                                                                               
751* Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
752- new upstream version
753- diseble-assembler in configure on sparc,sparc64,alpha
754                                                                               
755* Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
756- new upstream version
757- moved some man files to main package
758- added enable-local-infile in configure
759- changed --with-extra-charsets=all in configure
760                                                                               
761* Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
762- fixed changelog
763                                                                               
764* Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
765- updated to mysql-3.23.51
766                                                                               
767* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
768- rebuild on zlib-1.1.4(security fix.)
769                                                                               
770* Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
771- updated to mysql-2.23.49
772                                                                               
773* Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
774- add 'BuildPrereq: kernel24-headers' on alpha
775- remove shared library and max on alpha
776                                                                               
777* Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
778- updated to mysql-3.23.48
779                                                                               
780* Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
781- updated to mysql-3.23.47
782                                                                               
783* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
784- updated to mysql-3.23.46
785                                                                               
786* Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
787- updated to mysql-3.23.45
788                                                                               
789* Tue Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
790- updated to mysql-3.23.44
791                                                                               
792* Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
793- updated to mysql-3.23.43
794- removed shared library and max on sparc
795                                                                               
796* Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
797- updated to mysql-3.23.42
798- changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
799                                                                               
800* Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
801- updated to mysql-3.23.41
802                                                                               
803* Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
804- updated to mysql-3.23.40
805                                                                               
806* Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
807- updated to mysql-3.23.39
808
809* Sat Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
810- added configure --with-charset=ujis
811                                                                               
812* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
813- used some rpmmacro
814                                                                               
815* Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
816- updated to MySQL-3.23.38
817                                                                               
818* Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
819- removed Bench pakages
820                                                                               
821* Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
822- removed pt_BR locale
823- build on Vine Linux
824- partially used rpmmacros
825- added %clean tag
826                                                                               
827* Fri Aug 18 2000 Tim Smith <tim@mysql.com>
828- Added separate libmysql_r directory; now both a threaded
829  and non-threaded library is shipped.
830                                                                               
831* Wed Sep 28 1999 David Axmark <davida@mysql.com>
832- Added the support-files/my-example.cnf to the docs directory.
833- Removed devel dependency on base since it is about client
834  development.
835                                                                               
836* Wed Sep 8 1999 David Axmark <davida@mysql.com>
837- Cleaned up some for 3.23.
838                                                                               
839* Thu Jul 1 1999 David Axmark <davida@mysql.com>
840- Added support for shared libraries in a separate sub
841  package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
842- The --enable-assembler switch is now automatically disables on
843  platforms there assembler code is unavailable. This should allow
844  building this RPM on non i386 systems.
845                                                                               
846* Mon Feb 22 1999 David Axmark <david@detron.se>
847- Removed unportable cc switches from the spec file. The defaults can
848  now be overridden with environment variables. This feature is used
849  to compile the official RPM with optimal (but compiler version
850  specific) switches.
851- Removed the repetitive description parts for the sub rpms. Maybe add
852  again if RPM gets a multiline macro capability.
853- Added support for a pt_BR translation. Translation contributed by
854  Jorge Godoy <jorge@bestway.com.br>.
855                                                                               
856* Wed Nov 4 1998 David Axmark <david@detron.se>
857- A lot of changes in all the rpm and install scripts. This may even
858  be a working RPM :-)
859                                                                               
860* Sun Aug 16 1998 David Axmark <david@detron.se>
861- A developers changelog for MySQL is available in the source RPM. And
862  there is a history of major user visible changed in the Reference
863  Manual.  Only RPM specific changes will be documented here.
864
Note: See TracBrowser for help on using the repository browser.