source: projects/specs/trunk/M/MySQL/MySQL-vl.spec @ 6810

Revision 6810, 33.5 KB checked in by tomop, 12 years ago (diff)

MySQL-5.5.27-1

Line 
1%define mysqld_user             mysql
2%define mysqld_group            mysql
3%define server_suffix -community
4%define mysqldatadir /var/lib/mysql
5
6%{?_with_static:%define STATIC_BUILD 1}
7%{!?_with_static:%define STATIC_BUILD 0}
8
9# Working around perl dependency problem
10%define __perl_requires %{SOURCE998}
11
12# We don't package all files installed into the build root by intention -
13# See BUG#998 for details.
14%define _unpackaged_files_terminate_build 0
15
16%define see_base For a description of MySQL see the base MySQL RPM or http://www.mysql.com
17
18%define mysql_base_version      5.5
19%define mysql_version           5.5.27
20%define client_version          18
21
22%if %{?_dist_release}!="vl5"
23%define libpkgname libmysqlclient%{client_version}
24%else
25%define libpkgname MySQL-shared
26%endif
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager:       tomop
31
32Name: MySQL
33Summary:        MySQL: a very fast and reliable SQL database server
34Version:        %{mysql_version}
35Release:        1%{_dist_release}
36
37Group:          Applications/Databases
38# exceptions allow client libraries to be linked with most open source SW,
39# not only GPL code.
40License:        GPLv2 with exceptions
41URL:            http://www.mysql.com/
42
43Source:         mysql-%{version}.tar.gz
44# Don't depend on lib::mtr*
45Source998:      perl-requires-%{name}.sh
46Source1000:     macros.mysql.in
47Patch0:         mysql-5.5.15-jp-all.patch
48
49# lib64 patch for vine
50Patch200:       pysql-5.1.44-lib64.patch
51
52BuildRoot:      %{_tmppath}/%{name}-%{version}-root
53BuildRequires:  perl, readline-devel, libaio-devel
54BuildRequires:  gcc-c++, ncurses-devel, zlib-devel, openssl-devel
55BuildRequires:  groff, cmake, bison
56Requires:       fileutils sh-utils
57Provides:       msqlormysql MySQL-server mysql
58Obsoletes:      mysql MySQL5
59
60# From the manual
61%description
62The MySQL(TM) software delivers a very fast, multi-threaded, multi-user,
63and robust SQL (Structured Query Language) database server. MySQL Server
64is intended for mission-critical, heavy-load production systems as well
65as for embedding into mass-deployed software. MySQL is a trademark of
66Sun Microsystems, Inc.
67
68Copyright 2000-2008 MySQL AB, 2009 Sun Microsystems, Inc.  All rights reserved.
69Use is subject to license terms.
70
71This software comes with ABSOLUTELY NO WARRANTY. This is free software,
72and you are welcome to modify and redistribute it under the GPL license.
73
74The MySQL web site (http://www.mysql.com/) provides the latest
75news and information about the MySQL software. Also please see the
76documentation and the manual for more information.
77
78%package server
79Release: %{release}
80Summary:        MySQL: a very fast and reliable SQL database server
81Group:          Applications/Databases
82Requires:       fileutils sh-utils net-tools
83Provides:       mysql-server mysql MySQL MySQL5-server mysqlserver-%{mysql_base_version}
84Obsoletes:      MySQL mysql mysql-server MySQL5-server
85
86%description server
87The MySQL(TM) software delivers a very fast, multi-threaded, multi-user,
88and robust SQL (Structured Query Language) database server. MySQL Server
89is intended for mission-critical, heavy-load production systems as well
90as for embedding into mass-deployed software. MySQL is a trademark of
91Sun Microsystems, Inc.
92
93Copyright 2000-2008 MySQL AB, 2009 Sun Microsystems, Inc.  All rights reserved.
94Use is subject to license terms.
95
96This software comes with ABSOLUTELY NO WARRANTY. This is free software,
97and you are welcome to modify and redistribute it under the GPL license.
98
99The MySQL web site (http://www.mysql.com/) provides the latest
100news and information about the MySQL software. Also please see the
101documentation and the manual for more information.
102
103This package includes the MySQL server binary (incl. InnoDB) as well
104as related utilities to run and administrate a MySQL server.
105
106If you want to access and work with the database, you have to install
107package "MySQL-client" as well!
108
109%package client
110Summary: MySQL - Client
111Group: Applications/Databases
112Obsoletes: mysql-client MySQL5-client
113Provides: mysql-client MySQL5-client  mysqlclient-%{mysql_base_version}
114
115%description client
116This package contains the standard MySQL clients and administration tools.
117
118%{see_base}
119
120%package source
121Summary: MySQL - Source
122Group: Development/Libraries
123Requires: MySQL-devel = %{version}-%{release}
124AutoReqProv: no
125
126%description source
127This package contains the sources files of MySQL.
128
129%{see_base}
130
131%package test
132Requires: %{name}-client = %{version}-%{release} perl-DBI perl
133Summary: MySQL - Test suite
134Group: Applications/Databases
135Obsoletes: mysql-bench MySQL5-bench MySQL-bench
136Provides: perl(mtr_misc.pl)
137
138%description test
139This package contains the MySQL regression test suite.
140
141%{see_base}
142
143%package devel
144Summary: MySQL - Development header files and libraries
145Group: Development/Libraries
146Requires: %{libpkgname} = %{version}-%{release}
147Requires: openssl-devel, zlib-devel
148Provides: mysql-devel MySQL5-devel
149Obsoletes: mysql-devel MySQL5-devel
150
151%description devel
152This package contains the development header files and libraries
153necessary to develop MySQL client applications.
154
155%{see_base}
156
157%package -n %{libpkgname}
158Summary: The shared libraries required for MySQL clients
159Group: System Environment/Libraries
160%if %{?_dist_release}!="vl5"
161Obsoletes: MySQL-shared < %{version}
162%endif
163
164%description -n %{libpkgname}
165This package contains the shared libraries (*.so*) which certain
166languages and applications need to dynamically load and use MySQL.
167
168
169#%package embedded
170#Summary: MySQL as an embeddable library
171#Group: System Environment/Libraries
172#Obsoletes: mysql-embedded MySQL5-embedded
173#Provides: mysql-embedded MySQL5-embedded
174
175#%description embedded
176#MySQL is a multi-user, multi-threaded SQL database server. This
177#package contains a version of the MySQL server that can be embedded
178#into a client application instead of running as a separate process.
179
180#%{see_base}
181
182%package embedded-devel
183Summary: Development files for MySQL as an embeddable library
184Group: Development/Libraries
185Requires: %{name}-devel = %{version}-%{release}
186
187%description embedded-devel
188MySQL is a multi-user, multi-threaded SQL database server. This
189package contains files needed for developing and testing with
190the embedded version of the MySQL server.
191
192%{see_base}
193
194%prep
195%setup -q -n mysql-%{version}
196
197%patch0 -p1 -b .jp
198#%if %{_lib} == lib64
199#%patch200 -p0 -b .lib64
200#%endif
201#aclocal
202#autoheader
203#libtoolize --automake --force
204#automake --add-missing --copy
205#autoconf
206#perl -pi -e 's/-Werror"/"/' configure
207
208
209%build
210
211# Be strict about variables, bail at earliest opportunity, etc.
212set -eu
213
214# Optional package files
215touch optional-files-devel
216
217export PATH=${MYSQL_BUILD_PATH:-$PATH}
218export CC=${MYSQL_BUILD_CC:-${CC:-gcc}}
219export CXX=${MYSQL_BUILD_CXX:-${CXX:-gcc}}
220export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
221export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
222export LDFLAGS=${MYSQL_BUILD_LDFLAGS:-${LDFLAGS:-}}
223export CMAKE=${MYSQL_BUILD_CMAKE:-${CMAKE:-cmake}}
224export MAKE_JFLAG=${MYSQL_BUILD_MAKE_JFLAG:-}
225
226# Build full release
227mkdir release
228(
229  cd release
230  # XXX: MYSQL_UNIX_ADDR should be in cmake/* but mysql_version is included before
231  # XXX: install_layout so we can't just set it based on INSTALL_LAYOUT=RPM
232  ${CMAKE} ../ -DBUILD_CONFIG=mysql_release -DINSTALL_LAYOUT=RPM \
233           -DCMAKE_BUILD_TYPE=RelWithDebInfo \
234           -DMYSQL_UNIX_ADDR="/var/lib/mysql/mysql.sock" \
235           -DFEATURE_SET="community" \
236           -DCOMPILATION_COMMENT="VineLinux MySQL RPM" \
237           -DMYSQL_SERVER_SUFFIX="%{server_suffix}" \
238           -DWITH_PIC="ON" \
239           -DWITH_ZLIB="system" \
240           -DWITH_EMBEDDED_SERVER="ON" \
241           -DWITH_SSL="yes"
242  echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
243  make %{?_smp_mflags} VERBOSE=1
244)
245
246# Use the build root for temporary storage of the shared libraries.
247RBR=$RPM_BUILD_ROOT
248
249# Clean up the BuildRoot first
250[ "$RBR" != "/" ] && [ -d "$RBR" ] && rm -rf "$RBR";
251
252# For gcc builds, include libgcc.a in the devel subpackage (BUG 4921).  This
253# needs to be during build phase as $CC is not set during install.
254if "$CC" -v 2>&1 | grep '^gcc.version' >/dev/null 2>&1
255then
256  libgcc=`$CC $CFLAGS --print-libgcc-file`
257  if [ -f $libgcc ]
258  then
259    mkdir -p $RBR%{_libdir}/mysql
260#    install -m 644 $libgcc $RBR%{_libdir}/mysql/libmygcc.a
261#    echo "%{_libdir}/mysql/libmygcc.a" >>optional-files-devel
262  fi
263fi
264
265##############################################################################
266%install
267RBR=$RPM_BUILD_ROOT
268MBD=$RPM_BUILD_DIR/mysql-%{mysql_version}
269
270rm -rf $RBR
271
272# Ensure that needed directories exists
273install -d $RBR%{_sysconfdir}/{logrotate.d,init.d}
274install -d $RBR%{mysqldatadir}/mysql
275install -d $RBR%{_datadir}/mysql-test
276install -d $RBR%{_includedir}
277install -d $RBR%{_libdir}
278install -d $RBR%{_mandir}
279install -d $RBR%{_sbindir}
280
281# Install all binaries
282# Install all binaries
283(
284  cd $MBD/release
285  make DESTDIR=$RBR install
286)
287
288# Install logrotate and autostart
289install -m 644 $MBD/release/support-files/mysql-log-rotate $RBR%{_sysconfdir}/logrotate.d/mysql
290install -m 755 $MBD/release/support-files/mysql.server $RBR%{_sysconfdir}/init.d/mysql
291
292# Create a symlink "rcmysql", pointing to the init.script. SuSE users
293# will appreciate that, as all services usually offer this.
294ln -s %{_sysconfdir}/init.d/mysql $RBR%{_sbindir}/rcmysql
295
296# Touch the place where the my.cnf config file might be located
297# Just to make sure it's in the file list and marked as a config file
298touch $RBR%{_sysconfdir}/my.cnf
299
300# Remove man pages we explicitly do not want to package, avoids 'unpackaged
301# files' warning.
302rm -f $RBR%{_mandir}/man1/make_win_bin_dist.1*
303
304mkdir -p $RBR%{_datadir}/%{name}-source
305pushd $RBR%{_datadir}/%{name}-source
306tar zxf %{SOURCE0}
307find $RBR%{_datadir}/%{name}-source -type f -exec chmod ugo-x {} \;
308popd
309
310mkdir -p $RBR%{_sysconfdir}/rpm
311sed -e 's/@BASEVERSION@/%{mysql_base_version}/' -e 's/@VERSION@/%{version}/' -e 's/@RELEASE@/%{release}/' < %{SOURCE1000} > $RBR%{_sysconfdir}/rpm/macros.mysql
312
313rm -f $RBR%{_libdir}/mysql/plugin/daemon_example.ini
314
315##############################################################################
316
317
318%pre server
319# Shut down a previously installed server first
320if test -x %{_sysconfdir}/init.d/mysql
321then
322  %{_sysconfdir}/init.d/mysql stop > /dev/null 2>&1
323  echo "Giving mysqld a couple of seconds to exit nicely"
324  sleep 5
325elif test -x %{_sysconfdir}/rc.d/init.d/mysql
326then
327  %{_sysconfdir}/rc.d/init.d/mysql stop > /dev/null 2>&1
328  echo "Giving mysqld a couple of seconds to exit nicely"
329  sleep 5
330fi
331
332%post server
333mysql_datadir=%{mysqldatadir}
334
335# Create data directory if needed
336if test ! -d $mysql_datadir; then mkdir -m 755 $mysql_datadir; fi
337if test ! -d $mysql_datadir/mysql; then mkdir $mysql_datadir/mysql; fi
338if test ! -d $mysql_datadir/test; then mkdir $mysql_datadir/test; fi
339
340# Make MySQL start/shutdown automatically when the machine does it.
341# use insserv for older SuSE Linux versions
342if test -x /sbin/insserv
343then
344        /sbin/insserv %{_sysconfdir}/init.d/mysql
345# use chkconfig on Red Hat and newer SuSE releases
346elif test -x /sbin/chkconfig
347then
348        /sbin/chkconfig --add mysql
349fi
350
351# Create a MySQL user and group. Do not report any problems if it already
352# exists.
353groupadd -r %{mysqld_group} 2> /dev/null || true
354useradd -M -r -d $mysql_datadir -s /bin/bash -c "MySQL server" -g %{mysqld_group} %{mysqld_user} 2> /dev/null || true
355# The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
356usermod -g %{mysqld_group} %{mysqld_user} 2> /dev/null || true
357
358# Change permissions so that the user that will run the MySQL daemon
359# owns all database files.
360chown -R %{mysqld_user}:%{mysqld_group} $mysql_datadir
361
362# Initiate databases if needed
363%{_bindir}/mysql_install_db --rpm --user=%{mysqld_user}
364
365# Upgrade databases if needed would go here - but it cannot be automated yet
366
367# Change permissions again to fix any new files.
368chown -R %{mysqld_user}:%{mysqld_group} $mysql_datadir
369
370# Fix permissions for the permission database so that only the user
371# can read them.
372chmod -R og-rw $mysql_datadir/mysql
373
374# Restart in the same way that mysqld will be started normally.
375%{_sysconfdir}/init.d/mysql start
376
377# Allow mysqld_safe to start mysqld and print a message before we exit
378sleep 2
379
380#echo "Thank you for installing the MySQL Community Server! For Production
381#systems, we recommend MySQL Enterprise, which contains enterprise-ready
382#software, intelligent advisory services, and full production support with
383#scheduled service packs and more.  Visit www.mysql.com/enterprise for more
384#information."
385
386%preun server
387if test $1 = 0
388then
389  # Stop MySQL before uninstalling it
390  if test -x %{_sysconfdir}/init.d/mysql
391  then
392    %{_sysconfdir}/init.d/mysql stop > /dev/null
393
394    # Remove autostart of mysql
395    # for older SuSE Linux versions
396    if test -x /sbin/insserv
397    then
398      /sbin/insserv -r %{_sysconfdir}/init.d/mysql
399    # use chkconfig on Red Hat and newer SuSE releases
400    elif test -x /sbin/chkconfig
401    then
402      /sbin/chkconfig --del mysql
403    fi
404  fi
405fi
406
407# We do not remove the mysql user since it may still own a lot of
408# database files.
409
410%post -n %{libpkgname}
411/sbin/ldconfig
412
413%postun -n %{libpkgname}
414/sbin/ldconfig
415
416# Clean up the BuildRoot
417%clean
418[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
419
420%files server
421%defattr(-,root,root,0755)
422
423%doc COPYING README
424%doc Docs/ChangeLog
425%doc Docs/INFO_SRC*
426%doc release/Docs/INFO_BIN*
427%doc release/support-files/my-*.cnf
428
429%doc %attr(644, root, root) %{_infodir}/mysql.info*
430
431%doc %attr(644, root, man) %{_mandir}/man1/innochecksum.1*
432%doc %attr(644, root, man) %{_mandir}/man1/my_print_defaults.1*
433%doc %attr(644, root, man) %{_mandir}/man1/myisam_ftdump.1*
434%doc %attr(644, root, man) %{_mandir}/man1/myisamchk.1*
435%doc %attr(644, root, man) %{_mandir}/man1/myisamlog.1*
436%doc %attr(644, root, man) %{_mandir}/man1/myisampack.1*
437%doc %attr(644, root, man) %{_mandir}/man1/mysql_convert_table_format.1*
438%doc %attr(644, root, man) %{_mandir}/man1/mysql_fix_extensions.1*
439%doc %attr(644, root, man) %{_mandir}/man8/mysqld.8*
440%doc %attr(644, root, man) %{_mandir}/man1/mysqld_multi.1*
441%doc %attr(644, root, man) %{_mandir}/man1/mysqld_safe.1*
442%doc %attr(644, root, man) %{_mandir}/man1/mysqldumpslow.1*
443%doc %attr(644, root, man) %{_mandir}/man1/mysql_install_db.1*
444%doc %attr(644, root, man) %{_mandir}/man1/mysql_plugin.1*
445%doc %attr(644, root, man) %{_mandir}/man1/mysql_secure_installation.1*
446%doc %attr(644, root, man) %{_mandir}/man1/mysql_setpermission.1*
447%doc %attr(644, root, man) %{_mandir}/man1/mysql_upgrade.1*
448%doc %attr(644, root, man) %{_mandir}/man1/mysqlhotcopy.1*
449%doc %attr(644, root, man) %{_mandir}/man1/mysqlman.1*
450%doc %attr(644, root, man) %{_mandir}/man1/mysql.server.1*
451%doc %attr(644, root, man) %{_mandir}/man1/mysqltest.1*
452%doc %attr(644, root, man) %{_mandir}/man1/mysql_tzinfo_to_sql.1*
453%doc %attr(644, root, man) %{_mandir}/man1/mysql_zap.1*
454%doc %attr(644, root, man) %{_mandir}/man1/mysqlbug.1*
455%doc %attr(644, root, man) %{_mandir}/man1/perror.1*
456%doc %attr(644, root, man) %{_mandir}/man1/replace.1*
457%doc %attr(644, root, man) %{_mandir}/man1/resolve_stack_dump.1*
458%doc %attr(644, root, man) %{_mandir}/man1/resolveip.1*
459
460%ghost %config(noreplace,missingok) %{_sysconfdir}/my.cnf
461
462%attr(755, root, root) %{_bindir}/innochecksum
463%attr(755, root, root) %{_bindir}/my_print_defaults
464%attr(755, root, root) %{_bindir}/myisam_ftdump
465%attr(755, root, root) %{_bindir}/myisamchk
466%attr(755, root, root) %{_bindir}/myisamlog
467%attr(755, root, root) %{_bindir}/myisampack
468%attr(755, root, root) %{_bindir}/mysql_convert_table_format
469%attr(755, root, root) %{_bindir}/mysql_fix_extensions
470%attr(755, root, root) %{_bindir}/mysql_install_db
471%attr(755, root, root) %{_bindir}/mysql_plugin
472%attr(755, root, root) %{_bindir}/mysql_secure_installation
473%attr(755, root, root) %{_bindir}/mysql_setpermission
474%attr(755, root, root) %{_bindir}/mysql_tzinfo_to_sql
475%attr(755, root, root) %{_bindir}/mysql_upgrade
476%attr(755, root, root) %{_bindir}/mysql_zap
477%attr(755, root, root) %{_bindir}/mysqlbug
478%attr(755, root, root) %{_bindir}/mysqld_multi
479%attr(755, root, root) %{_bindir}/mysqld_safe
480%attr(755, root, root) %{_bindir}/mysqldumpslow
481%attr(755, root, root) %{_bindir}/mysqlhotcopy
482%attr(755, root, root) %{_bindir}/mysqltest
483%attr(755, root, root) %{_bindir}/perror
484%attr(755, root, root) %{_bindir}/replace
485%attr(755, root, root) %{_bindir}/resolve_stack_dump
486%attr(755, root, root) %{_bindir}/resolveip
487
488%attr(755, root, root) %{_sbindir}/mysqld
489%attr(755, root, root) %{_sbindir}/rcmysql
490%attr(755, root, root) %{_libdir}/mysql/plugin/*.so
491
492%attr(644, root, root) %config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
493%attr(755, root, root) %{_sysconfdir}/init.d/mysql
494
495%attr(755, root, root) %{_datadir}/mysql/
496
497%files client
498%defattr(-, root, root, 0755)
499%attr(755, root, root) %{_bindir}/msql2mysql
500%attr(755, root, root) %{_bindir}/mysql
501%attr(755, root, root) %{_bindir}/mysql_find_rows
502%attr(755, root, root) %{_bindir}/mysql_waitpid
503%attr(755, root, root) %{_bindir}/mysqlaccess
504# XXX: This should be moved to %{_sysconfdir}
505%attr(644, root, root) %{_bindir}/mysqlaccess.conf
506%attr(755, root, root) %{_bindir}/mysqladmin
507%attr(755, root, root) %{_bindir}/mysqlbinlog
508%attr(755, root, root) %{_bindir}/mysqlcheck
509%attr(755, root, root) %{_bindir}/mysqldump
510%attr(755, root, root) %{_bindir}/mysqlimport
511%attr(755, root, root) %{_bindir}/mysqlshow
512%attr(755, root, root) %{_bindir}/mysqlslap
513
514%doc %attr(644, root, man) %{_mandir}/man1/msql2mysql.1*
515%doc %attr(644, root, man) %{_mandir}/man1/mysql.1*
516%doc %attr(644, root, man) %{_mandir}/man1/mysql_find_rows.1*
517%doc %attr(644, root, man) %{_mandir}/man1/mysql_waitpid.1*
518%doc %attr(644, root, man) %{_mandir}/man1/mysqlaccess.1*
519%doc %attr(644, root, man) %{_mandir}/man1/mysqladmin.1*
520%doc %attr(644, root, man) %{_mandir}/man1/mysqlbinlog.1*
521%doc %attr(644, root, man) %{_mandir}/man1/mysqlcheck.1*
522%doc %attr(644, root, man) %{_mandir}/man1/mysqldump.1*
523%doc %attr(644, root, man) %{_mandir}/man1/mysqlimport.1*
524%doc %attr(644, root, man) %{_mandir}/man1/mysqlshow.1*
525%doc %attr(644, root, man) %{_mandir}/man1/mysqlslap.1*
526
527%files source
528%defattr(-, root, root, 0755)
529%{_datadir}/MySQL-source
530
531%files devel -f optional-files-devel
532%defattr(-, root, root, 0755)
533%doc %attr(644, root, man) %{_mandir}/man1/comp_err.1*
534%doc %attr(644, root, man) %{_mandir}/man1/mysql_config.1*
535%attr(755, root, root) %{_bindir}/mysql_config
536%dir %attr(755, root, root) %{_includedir}/mysql
537%dir %attr(755, root, root) %{_libdir}/mysql
538%{_includedir}/mysql/*
539%{_datadir}/aclocal/mysql.m4
540%{_libdir}/*.so
541%{_sysconfdir}/rpm/*
542%exclude %{_libdir}/*.a
543
544%files -n %{libpkgname}
545%defattr(-, root, root, 0755)
546# Shared libraries (omit for architectures that don't support them)
547%{_libdir}/libmysql*.so.*
548#/etc/ld.so.conf.d/*
549
550%files test
551%defattr(-, root, root, 0755)
552%attr(-, root, root) %{_datadir}/mysql-test
553%attr(755, root, root) %{_bindir}/mysql_client_test
554%attr(755, root, root) %{_bindir}/mysql_client_test_embedded
555%attr(755, root, root) %{_bindir}/mysqltest_embedded
556%doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test.1*
557%doc %attr(644, root, man) %{_mandir}/man1/mysql-stress-test.pl.1*
558%doc %attr(644, root, man) %{_mandir}/man1/mysql-test-run.pl.1*
559%doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test_embedded.1*
560%doc %attr(644, root, man) %{_mandir}/man1/mysqltest_embedded.1*
561
562%files embedded-devel
563%defattr(-,root,root)
564#{_libdir}/libmysqld.a
565%{_bindir}/mysql_embedded
566%{_bindir}/mysql_client_test_embedded
567%{_bindir}/mysqltest_embedded
568%doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test_embedded.1*
569%doc %attr(644, root, man) %{_mandir}/man1/mysqltest_embedded.1*
570
571%changelog
572* Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.27-1
573- new upstream release.
574- added a sub-package 'MySQL-source".
575- added some macros for rpm.
576
577* Thu Jun 21 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.25-1
578- new upstream release.
579
580* Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
581- new upstream release.
582
583* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
584- new upstream release.
585- added "Vendor:" and "Distribution:" tag.
586
587* Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
588- new upstream release.
589- removed NDB cluster support.
590
591* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
592- Added "BR: zlib-devel" to MySQL-devel.
593
594* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
595- Added "BR: openssl-devel" to MySQL-devel.
596
597* Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
598- new upstream release.
599
600* Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
601- new upstream release.
602- updated jp-patch.
603- added ssl support.
604
605* Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
606- new upstream release.
607- replaced '%%__find_requires' to '%%__perl_requires'.
608- updated jp-patch.
609
610* Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
611- added mysql-5.1.44-lib64.patch (on x86_64)
612- added -fPIC (on x86_64)
613
614* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
615- made embedded package again
616
617* Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
618- new upstream release.
619- updated jp-patch.
620
621* Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
622- VineSeed: rebuilt with new toolchain.
623
624* Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
625- new upstream release.
626  - fixed CVE-2009-4484.
627
628* Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
629- new upstream release.
630
631* Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
632- added net-tools to 'Requires'.
633- added groff to 'BuildRequires'.
634- renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
635
636* Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
637- new upstream release.
638
639* Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
640- new upstream release.
641
642* Sun Jul  5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
643- new upstream release.
644- dropped %%Patch100 (fixed in upstream).
645
646* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
647- new upstream release.
648- add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
649
650* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
651- new upstream release.
652- rename 'MySQL-bench' to 'MySQL-test'.
653- update Patch0.
654- change default charset to 'utf8'.
655
656* Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
657- new upstream release.
658- update Patch0.
659- add "--with-client-charset=ujis".
660- sync %%files to official RPM.
661- remove MySQL-Max.
662
663* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
664- for VineSeed
665
666* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
667- move shared library from /usr/lib/ to /usr/lib/mysql/
668- add /etc/ld.so.conf.d/*.conf
669- fix broken libmysqlcient*.la files (or should we remove them permanently?)
670
671* Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
672- rebuild <BTS:VineLinux:534>
673
674* Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
675- added -fPIC
676
677* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
678- fixed dependency. <BTS:338>
679
680* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
681- add %%Patch1. <BTS:320>
682
683* Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
684- new upstream release.
685
686* Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
687- new upstream release.
688
689* Sat Jun  3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
690- new upstream release.
691
692* Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
693- release++.
694
695* Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
696- new upstream release.
697- for VineSeed.
698
699* Wed Feb  8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
700- new upstream release.
701- replace Patch0 for MySQL-4.1.16.
702
703* Thu Oct  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
704- new upstream release.
705- add Patch0.
706
707* Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
708- new upstream version
709        -- mysql-4.0.25
710
711* Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
712- new upstream version
713        -- mysql-4.0.23
714
715* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
716- new upstream version
717        -- mysql-4.0.22
718 
719* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
720- new upstream version
721        -- mysql-4.0.21
722 
723* Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
724- new upstream version
725        -- mysql-4.0.20
726 
727* Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
728- modify CFLAGS, CXXFLAGS and configure options for alpha
729
730* Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
731- Upgraded to MySQL-4
732- added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
733- merged to MySQL Official packages
734        -- renamed package "MySQL" to "MySQL-server"
735        -- when using gcc, _always_ use CXX=gcc
736        -- replaced Copyright with License field (Copyright is obsolete)
737        -- added myisam_ftdump to the Server package
738        -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
739        -- fixed file permissions (BUG 1672)
740        -- removed dependency on MySQL-client from the MySQL-devel subpackage
741        -- as it is not really required. (BUG 1610)
742        -- Fixed BUG 1162 (removed macro names from the changelog)
743        -- Really fixed BUG 998 (disable the checking for installed but
744        --  unpackaged files)
745        -- Fixed BUG 959 (libmysqld not being compiled properly)
746        -- Fixed BUG 998 (RPM build errors): added missing files to the
747        -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
748        -- mysql_fix_privilege_tables.1), removed "-n" from install section.
749        -- removed the GIF Icon (file was not included in the sources anyway)
750        -- removed unused variable shared_lib_version
751        -- do not run automake before building the standard binary
752        --  (should not be necessary)
753        -- add server suffix '-standard' to standard binary (to be in line
754        -- with the binary tarball distributions)
755        -- allow overriding CC and CXX (required when building
756        -- with other compilers)
757
758* Thu Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
759- added BuildRequires:  automake16
760                                                                               
761* Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
762- add '-fPIC -DPIC' to CFLAGS on alpha
763- little fix of spec file
764                                                                               
765* Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
766- enable MySQL-shared subpackage for alpha
767- delete 'BuildPrereq: kernel24-headers' for alpha
768- fix shared %files (exclude sparc)
769                                                                               
770* Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
771- new upstream version
772                                                                               
773* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
774- fixed devel %files (dropped *.la files)
775                                                                               
776* Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
777- new upstream version
778- fixed document permission
779                                                                               
780* Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
781- new upstream version
782                                                                               
783* Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
784- dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
785        -- don't work
786                                                                               
787* Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
788- new upstream version
789- diseble-assembler in configure on sparc,sparc64,alpha
790                                                                               
791* Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
792- new upstream version
793- moved some man files to main package
794- added enable-local-infile in configure
795- changed --with-extra-charsets=all in configure
796                                                                               
797* Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
798- fixed changelog
799                                                                               
800* Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
801- updated to mysql-3.23.51
802                                                                               
803* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
804- rebuild on zlib-1.1.4(security fix.)
805                                                                               
806* Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
807- updated to mysql-2.23.49
808                                                                               
809* Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
810- add 'BuildPrereq: kernel24-headers' on alpha
811- remove shared library and max on alpha
812                                                                               
813* Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
814- updated to mysql-3.23.48
815                                                                               
816* Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
817- updated to mysql-3.23.47
818                                                                               
819* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
820- updated to mysql-3.23.46
821                                                                               
822* Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
823- updated to mysql-3.23.45
824                                                                               
825* Tue Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
826- updated to mysql-3.23.44
827                                                                               
828* Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
829- updated to mysql-3.23.43
830- removed shared library and max on sparc
831                                                                               
832* Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
833- updated to mysql-3.23.42
834- changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
835                                                                               
836* Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
837- updated to mysql-3.23.41
838                                                                               
839* Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
840- updated to mysql-3.23.40
841                                                                               
842* Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
843- updated to mysql-3.23.39
844
845* Sat Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
846- added configure --with-charset=ujis
847                                                                               
848* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
849- used some rpmmacro
850                                                                               
851* Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
852- updated to MySQL-3.23.38
853                                                                               
854* Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
855- removed Bench pakages
856                                                                               
857* Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
858- removed pt_BR locale
859- build on Vine Linux
860- partially used rpmmacros
861- added %clean tag
862                                                                               
863* Fri Aug 18 2000 Tim Smith <tim@mysql.com>
864- Added separate libmysql_r directory; now both a threaded
865  and non-threaded library is shipped.
866                                                                               
867* Wed Sep 28 1999 David Axmark <davida@mysql.com>
868- Added the support-files/my-example.cnf to the docs directory.
869- Removed devel dependency on base since it is about client
870  development.
871                                                                               
872* Wed Sep 8 1999 David Axmark <davida@mysql.com>
873- Cleaned up some for 3.23.
874                                                                               
875* Thu Jul 1 1999 David Axmark <davida@mysql.com>
876- Added support for shared libraries in a separate sub
877  package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
878- The --enable-assembler switch is now automatically disables on
879  platforms there assembler code is unavailable. This should allow
880  building this RPM on non i386 systems.
881                                                                               
882* Mon Feb 22 1999 David Axmark <david@detron.se>
883- Removed unportable cc switches from the spec file. The defaults can
884  now be overridden with environment variables. This feature is used
885  to compile the official RPM with optimal (but compiler version
886  specific) switches.
887- Removed the repetitive description parts for the sub rpms. Maybe add
888  again if RPM gets a multiline macro capability.
889- Added support for a pt_BR translation. Translation contributed by
890  Jorge Godoy <jorge@bestway.com.br>.
891                                                                               
892* Wed Nov 4 1998 David Axmark <david@detron.se>
893- A lot of changes in all the rpm and install scripts. This may even
894  be a working RPM :-)
895                                                                               
896* Sun Aug 16 1998 David Axmark <david@detron.se>
897- A developers changelog for MySQL is available in the source RPM. And
898  there is a history of major user visible changed in the Reference
899  Manual.  Only RPM specific changes will be documented here.
900
Note: See TracBrowser for help on using the repository browser.