source: projects/specs/trunk/M/ModemManager/ModemManager-vl.spec @ 9758

Revision 9758, 13.0 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1#%define git_snapshot .git20130607
2%define git_snapshot %{nil}
3#define ppp_version 2.4.7
4%define glib2_version 2.40
5
6Name: ModemManager
7Summary: Mobile broadband modem management service
8Summary(ja): Mobile broadband modem management service
9Version: 1.4.12
10Release: 1%{git_snapshot}%{?_dist_release}
11License: GPLv2+
12Group: System Environment/Base
13URL: http://www.gnome.org/projects/NetworkManager/
14
15#
16# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
17# tarball built with:
18#    ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
19#    make distcheck
20#
21#Source: %{name}-%{version}%{git_snapshot}.tar.bz2
22
23Source: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
24
25Patch0: buildsys-hates-openpty.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28BuildRequires: glib2-devel >= %{glib2_version}
29BuildRequires: eudev-libgudev1-devel
30BuildRequires: automake autoconf intltool libtool
31BuildRequires: gobject-introspection-devel
32BuildRequires: polkit-devel
33BuildRequires: gtk-doc
34# for xsltproc
35BuildRequires: libxslt
36Requires: dbus-glib
37
38%description
39The ModemManager service manages WWAN modems and provides a consistent API for
40interacting with these devices to client applications.
41
42
43%package        devel
44Summary:        Development tools for %{name}
45Summary(ja):    %{name} の開発環境
46Group:          Development/Libraries
47Requires:       %{name} = %{version}-%{release}
48Requires:       pkgconfig
49
50%description    devel
51Header files and libraries for building a extension library for the %{name}.
52
53
54%package        glib
55Summary:        Libraries for adding ModemManager support to applications that use glib.
56Summary(ja):    Glib を使用するアプリケーションに ModemManager サポートを追加するためのライブラリ
57Group:          System Environment/Libraries
58Requires:       glib2 >= %{glib2_version}
59
60%description    glib
61This package contains the libraries that make it easier to use some ModemManager
62functionality from applications that use glib.
63
64
65%package        glib-devel
66Summary:        Development tools for %{name}-glib
67Summary(ja):    %{name}-glib の開発環境
68Group:          Development/Libraries
69Requires:       %{name}-glib = %{version}-%{release}
70Requires:       %{name}-devel = %{version}-%{release}
71Requires:       glib2-devel
72Requires:       pkgconfig
73
74%description    glib-devel
75Header files and libraries for building a extension library for the %{name}-glib.
76
77%prep
78%setup -q
79%patch0 -p1 -b .pty
80
81%build
82autoreconf -if
83intltoolize --force
84#pppddir=`ls -1d %{_libdir}/pppd/2*`
85%configure \
86        --disable-static \
87        --enable-gtk-doc=yes \
88        --enable-vala=no \
89        --enable-more-warnings=yes \
90        --with-udev-base-dir=/lib/udev \
91        --without-mbim \
92        --without-qmi \
93        --with-dist-version=%{version}-%{release}
94
95
96make %{?_smp_mflags}
97
98%check
99make check
100
101%install
102make install DESTDIR=$RPM_BUILD_ROOT
103
104find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
105#rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
106
107%find_lang %{name}
108
109%post
110/sbin/ldconfig
111touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
112
113%postun
114/sbin/ldconfig
115if [ $1 -eq 0 ]; then
116  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
117  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
118fi
119
120%posttrans
121gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
122
123%post   glib -p /sbin/ldconfig
124%postun glib -p /sbin/ldconfig
125
126%files -f %{name}.lang
127%defattr(0644, root, root, 0755)
128%doc COPYING README
129%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
130%{_libdir}/girepository-1.0/ModemManager-1.0.typelib
131%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
132%attr(0755,root,root) %{_sbindir}/ModemManager
133%attr(0755,root,root) %{_bindir}/mmcli
134%dir %{_libdir}/%{name}
135%attr(0755,root,root) %{_libdir}/%{name}/*.so*
136/lib/udev/rules.d/*
137%{_datadir}/dbus-1/interfaces/*.xml
138%{_datadir}/icons/hicolor/22x22/apps/*.png
139%{_datadir}/polkit-1/actions/org.freedesktop.ModemManager1.policy
140%{_mandir}/man8/*
141
142%files devel
143%defattr(0644, root, root, 0755)
144%{_includedir}/ModemManager/*.h
145%dir %{_datadir}/gtk-doc/html/%{name}
146%{_datadir}/gir-1.0/ModemManager-1.0.gir
147%{_datadir}/gtk-doc/html/%{name}/*
148%{_libdir}/pkgconfig/%{name}.pc
149
150%files glib
151%defattr(0644, root, root, 0755)
152%{_libdir}/libmm-glib.so.*
153
154%files glib-devel
155%defattr(0644, root, root, 0755)
156%{_libdir}/libmm-glib.so
157%dir %{_includedir}/libmm-glib
158%{_includedir}/libmm-glib/*.h
159%{_libdir}/pkgconfig/mm-glib.pc
160%dir %{_datadir}/gtk-doc/html/libmm-glib
161%{_datadir}/gtk-doc/html/libmm-glib/*
162
163
164%changelog
165* Fri Oct 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-1
166- new upstream release
167- add BuildRequires: gobject-introspection-devel, polkit-devel
168
169* Sun Jul 26 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.10-1
170- new upstream release
171
172* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.8-1
173- new upstream release
174
175* Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
176- new upstream release
177
178* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
179- new upstream release
180
181* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
182- new upstream release
183
184* Tue Oct  7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-2
185- moved ModemManager-glib to System Environment/Libraries Group
186- removed BR: ppp, ppp-devel and dbus-glib-devel
187
188* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
189- new upstream release
190- remove Patch1 (ModemManager-1.0.0-git20130911.patch)
191
192* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
193- add Patch1 (ModemManager-1.0.0-git20130911.patch)
194
195* Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
196- new upstream release
197- update Patch0
198
199* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
200- update to 0.7.991 snapshot
201- fix spec file based on FC package
202  * Fri Jun  7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
203  - Update to 0.7.991 snapshot
204  - Fix SMS validity parsing
205  - Allow registration changes to 'searching' without disconnecting
206  - Fix reading SMS messages from some QMI-based devices
207  - Increase connection timeout for Novatel E362
208  - Fix PIN retries checking when unlocking Ericsson devices
209  - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
210- add configure option (--enable-gtk-doc=yes, --without-qmi)
211
212* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
213- new upstream release
214
215* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
216- new upstream release
217
218* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
219- delete Patch20
220
221* Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
222- update Patch20 (ModemManager-0.4-git20110428.patch)
223- delete Patch21,22
224
225* Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
226- update to 0.4
227- add Patch20 (ModemManager-0.4-git20100720.patch)
228- add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
229- add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
230
231* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
232- initial build for Vine Linux
233
234* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
235- core: ignore some failures on disconnect (rh #578280)
236- core: add support for platform serial devices
237- gsm: better Blackberry DUN support
238- gsm: periodically poll access technology
239- cdma: prevent crash on modem removal (rh #571921)
240- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
241- novatel: better signal strength reporting on CDMA cards
242- novatel: add access technology and mode preference support on GSM cards
243- zte: fix mode preference retrieval
244- longcheer: add support for Zoom modems (4595, 4596, etc)
245- longcheer: add access technology and mode preference support
246
247* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
248- Silence %%post
249- Update scripts
250
251* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
252- gsm: fix parsing Blackberry supported character sets response
253
254* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
255- mbm: fix retrieval of current allowed mode
256- gsm: fix initialization issues with some devices (like Blackberries)
257
258* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
259- core: fix detection of some generic devices (rh #579247)
260- core: fix detection regression of some Huawei devices in 0.3-5
261- cdma: periodically poll registration state and signal quality
262- cdma: really fix registration detection on various devices (rh #569067)
263
264* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
265- core: fix PPC/SPARC/etc builds
266
267* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
268- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
269- cdma: handle signal quality requests while connected for more devices
270- cdma: handle serving system requests while connected for more devices
271- gsm: determine current access technology earlier
272- huawei: work around automatic registration issues on some devices
273
274* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
275- core: ensure enabled modems are disabled when MM stops
276- core: better capability detection for Blackberry devices (rh #573510)
277- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
278- gsm: don't block modem when it requires PIN2
279- option: fix access technology updates
280
281* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
282- mbm: add device IDs for C3607w
283- mbm: fail earlier during connection failures
284- mbm: fix username/password authentication when checked by the network
285- hso: implement asynchronous signal quality updates
286- option: implement asynchronous signal quality updates
287- novatel: correctly handle CDMA signal quality
288- core: basic PolicyKit support
289- core: fix direct GSM registration information requests
290- core: general GSM PIN/PUK unlock fixes
291- core: poll GSM registration state internally for quicker status updates
292- core: implement GSM 2G/3G preference
293- core: implement GSM roaming allowed/disallowed preference
294- core: emit signals on access technology changes
295- core: better handling of disconnections
296- core: fix simple CDMA status requests
297
298* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
299- core: startup speed improvements
300- core: GSM PIN checking improvements
301- huawei: fix EVDO-only connections on various devices (rh #553199)
302- longcheer: add support for more devices
303
304* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
305- anydata: new plugin for AnyData CDMA modems (rh #547294)
306- core: fix crashes when devices are unplugged during operation (rh #553953)
307- cdma: prefer primary port for status/registration queries
308- core: fix probing/detection of some PIN-locked devices (rh #551376)
309- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
310- gsm: fix Nokia N80 network scan parsing
311
312* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
313- core: fix apparent hangs by limiting retried serial writes
314- gsm: ensure modem state is reset when disabled
315
316* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
317- sierra: fix CDMA registration detection in some cases (rh #547513)
318
319* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
320- sierra: ensure CDMA device is powered up when trying to use it
321- cdma: better signal quality parsing (fixes ex Huawei EC168C)
322- zte: handle unsolicited messages better during probing
323
324* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
325- cdma: fix signal strength reporting on some devices
326- cdma: better registration state detection when dialing (ex Sierra 5275)
327- option: always use the correct tty for dialing commands
328
329* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
330- core: fix reconnect after manual disconnect (rh #541314)
331- core: fix various segfaults during registration
332- core: fix probing of various modems on big-endian architectures (ie PPC)
333- core: implement modem states to avoid duplicate operations
334- hso: fix authentication for Icera-based devices like iCON 505
335- zte: use correct port for new devices
336- nozomi: fix detection
337
338* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
339- Update to latest git
340- core: fix pppd 2.4.5 errors about 'baudrate 0'
341- cdma: wait for network registration before trying to connect
342- gsm: add cell access technology reporting
343- gsm: allow longer-running network scans
344- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
345- nokia: don't power down phones on disconnect
346- hso: fix disconnection/disable
347
348* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
349- Fixes for Motorola and Ericsson devices
350- Fixes for CDMA "serving-system" command parsing
351
352* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
353- Fix a typo in one of the udev rules files
354
355* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
356- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
357
358* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
359- Fix source repo location
360- Fix directory ownership
361
362* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
363- Initial version
364
Note: See TracBrowser for help on using the repository browser.