source: projects/specs/trunk/M/ModemManager/ModemManager-vl.spec @ 9313

Revision 9313, 12.4 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1#%define git_snapshot .git20130607
2%define git_snapshot %{nil}
3#define ppp_version 2.4.7
4%define glib2_version 2.40
5
6Name: ModemManager
7Summary: Mobile broadband modem management service
8Summary(ja): Mobile broadband modem management service
9Version: 1.4.2
10Release: 1%{git_snapshot}%{?_dist_release}
11License: GPLv2+
12Group: System Environment/Base
13URL: http://www.gnome.org/projects/NetworkManager/
14
15#
16# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
17# tarball built with:
18#    ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
19#    make distcheck
20#
21#Source: %{name}-%{version}%{git_snapshot}.tar.bz2
22
23Source: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
24
25Patch0: buildsys-hates-openpty.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28BuildRequires: glib2-devel >= %{glib2_version}
29BuildRequires: eudev-libgudev1-devel
30BuildRequires: automake autoconf intltool libtool
31BuildRequires: gtk-doc
32# for xsltproc
33BuildRequires: libxslt
34Requires: dbus-glib
35
36%description
37The ModemManager service manages WWAN modems and provides a consistent API for
38interacting with these devices to client applications.
39
40
41%package        devel
42Summary:        Development tools for %{name}
43Summary(ja):    %{name} の開発環境
44Group:          Development/Libraries
45Requires:       %{name} = %{version}-%{release}
46Requires:       pkgconfig
47
48%description    devel
49Header files and libraries for building a extension library for the %{name}.
50
51
52%package        glib
53Summary:        Libraries for adding ModemManager support to applications that use glib.
54Summary(ja):    Glib を使用するアプリケーションに ModemManager サポートを追加するためのライブラリ
55Group:          System Environment/Libraries
56Requires:       glib2 >= %{glib2_version}
57
58%description    glib
59This package contains the libraries that make it easier to use some ModemManager
60functionality from applications that use glib.
61
62
63%package        glib-devel
64Summary:        Development tools for %{name}-glib
65Summary(ja):    %{name}-glib の開発環境
66Group:          Development/Libraries
67Requires:       %{name}-glib = %{version}-%{release}
68Requires:       %{name}-devel = %{version}-%{release}
69Requires:       glib2-devel
70Requires:       pkgconfig
71
72%description    glib-devel
73Header files and libraries for building a extension library for the %{name}-glib.
74
75%prep
76%setup -q
77%patch0 -p1 -b .pty
78
79%build
80autoreconf -if
81intltoolize --force
82#pppddir=`ls -1d %{_libdir}/pppd/2*`
83%configure \
84        --disable-static \
85        --enable-gtk-doc=yes \
86        --enable-introspection=no \
87        --enable-vala=no \
88        --enable-more-warnings=yes \
89        --with-udev-base-dir=/lib/udev \
90        --with-polkit=none \
91        --without-mbim \
92        --without-qmi \
93        --with-dist-version=%{version}-%{release}
94
95
96make %{?_smp_mflags}
97
98%check
99make check
100
101%install
102make install DESTDIR=$RPM_BUILD_ROOT
103
104find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
105#rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
106
107%find_lang %{name}
108
109%post
110/sbin/ldconfig
111touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
112
113%postun
114/sbin/ldconfig
115if [ $1 -eq 0 ]; then
116  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
117  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
118fi
119
120%posttrans
121gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
122
123%post   glib -p /sbin/ldconfig
124%postun glib -p /sbin/ldconfig
125
126%files -f %{name}.lang
127%defattr(0644, root, root, 0755)
128%doc COPYING README
129%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
130%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
131%attr(0755,root,root) %{_sbindir}/ModemManager
132%attr(0755,root,root) %{_bindir}/mmcli
133%dir %{_libdir}/%{name}
134%attr(0755,root,root) %{_libdir}/%{name}/*.so*
135/lib/udev/rules.d/*
136%{_datadir}/dbus-1/interfaces/*.xml
137%{_datadir}/icons/hicolor/22x22/apps/*.png
138%{_mandir}/man8/*
139
140%files devel
141%defattr(0644, root, root, 0755)
142%{_includedir}/ModemManager/*.h
143%dir %{_datadir}/gtk-doc/html/%{name}
144%{_datadir}/gtk-doc/html/%{name}/*
145%{_libdir}/pkgconfig/%{name}.pc
146
147%files glib
148%defattr(0644, root, root, 0755)
149%{_libdir}/libmm-glib.so.*
150
151%files glib-devel
152%defattr(0644, root, root, 0755)
153%{_libdir}/libmm-glib.so
154%dir %{_includedir}/libmm-glib
155%{_includedir}/libmm-glib/*.h
156%{_libdir}/pkgconfig/mm-glib.pc
157%dir %{_datadir}/gtk-doc/html/libmm-glib
158%{_datadir}/gtk-doc/html/libmm-glib/*
159
160
161%changelog
162* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
163- new upstream release
164
165* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
166- new upstream release
167
168* Tue Oct  7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-2
169- moved ModemManager-glib to System Environment/Libraries Group
170- removed BR: ppp, ppp-devel and dbus-glib-devel
171
172* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
173- new upstream release
174- remove Patch1 (ModemManager-1.0.0-git20130911.patch)
175
176* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
177- add Patch1 (ModemManager-1.0.0-git20130911.patch)
178
179* Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
180- new upstream release
181- update Patch0
182
183* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
184- update to 0.7.991 snapshot
185- fix spec file based on FC package
186  * Fri Jun  7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
187  - Update to 0.7.991 snapshot
188  - Fix SMS validity parsing
189  - Allow registration changes to 'searching' without disconnecting
190  - Fix reading SMS messages from some QMI-based devices
191  - Increase connection timeout for Novatel E362
192  - Fix PIN retries checking when unlocking Ericsson devices
193  - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
194- add configure option (--enable-gtk-doc=yes, --without-qmi)
195
196* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
197- new upstream release
198
199* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
200- new upstream release
201
202* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
203- delete Patch20
204
205* Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
206- update Patch20 (ModemManager-0.4-git20110428.patch)
207- delete Patch21,22
208
209* Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
210- update to 0.4
211- add Patch20 (ModemManager-0.4-git20100720.patch)
212- add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
213- add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
214
215* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
216- initial build for Vine Linux
217
218* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
219- core: ignore some failures on disconnect (rh #578280)
220- core: add support for platform serial devices
221- gsm: better Blackberry DUN support
222- gsm: periodically poll access technology
223- cdma: prevent crash on modem removal (rh #571921)
224- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
225- novatel: better signal strength reporting on CDMA cards
226- novatel: add access technology and mode preference support on GSM cards
227- zte: fix mode preference retrieval
228- longcheer: add support for Zoom modems (4595, 4596, etc)
229- longcheer: add access technology and mode preference support
230
231* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
232- Silence %%post
233- Update scripts
234
235* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
236- gsm: fix parsing Blackberry supported character sets response
237
238* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
239- mbm: fix retrieval of current allowed mode
240- gsm: fix initialization issues with some devices (like Blackberries)
241
242* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
243- core: fix detection of some generic devices (rh #579247)
244- core: fix detection regression of some Huawei devices in 0.3-5
245- cdma: periodically poll registration state and signal quality
246- cdma: really fix registration detection on various devices (rh #569067)
247
248* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
249- core: fix PPC/SPARC/etc builds
250
251* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
252- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
253- cdma: handle signal quality requests while connected for more devices
254- cdma: handle serving system requests while connected for more devices
255- gsm: determine current access technology earlier
256- huawei: work around automatic registration issues on some devices
257
258* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
259- core: ensure enabled modems are disabled when MM stops
260- core: better capability detection for Blackberry devices (rh #573510)
261- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
262- gsm: don't block modem when it requires PIN2
263- option: fix access technology updates
264
265* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
266- mbm: add device IDs for C3607w
267- mbm: fail earlier during connection failures
268- mbm: fix username/password authentication when checked by the network
269- hso: implement asynchronous signal quality updates
270- option: implement asynchronous signal quality updates
271- novatel: correctly handle CDMA signal quality
272- core: basic PolicyKit support
273- core: fix direct GSM registration information requests
274- core: general GSM PIN/PUK unlock fixes
275- core: poll GSM registration state internally for quicker status updates
276- core: implement GSM 2G/3G preference
277- core: implement GSM roaming allowed/disallowed preference
278- core: emit signals on access technology changes
279- core: better handling of disconnections
280- core: fix simple CDMA status requests
281
282* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
283- core: startup speed improvements
284- core: GSM PIN checking improvements
285- huawei: fix EVDO-only connections on various devices (rh #553199)
286- longcheer: add support for more devices
287
288* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
289- anydata: new plugin for AnyData CDMA modems (rh #547294)
290- core: fix crashes when devices are unplugged during operation (rh #553953)
291- cdma: prefer primary port for status/registration queries
292- core: fix probing/detection of some PIN-locked devices (rh #551376)
293- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
294- gsm: fix Nokia N80 network scan parsing
295
296* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
297- core: fix apparent hangs by limiting retried serial writes
298- gsm: ensure modem state is reset when disabled
299
300* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
301- sierra: fix CDMA registration detection in some cases (rh #547513)
302
303* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
304- sierra: ensure CDMA device is powered up when trying to use it
305- cdma: better signal quality parsing (fixes ex Huawei EC168C)
306- zte: handle unsolicited messages better during probing
307
308* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
309- cdma: fix signal strength reporting on some devices
310- cdma: better registration state detection when dialing (ex Sierra 5275)
311- option: always use the correct tty for dialing commands
312
313* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
314- core: fix reconnect after manual disconnect (rh #541314)
315- core: fix various segfaults during registration
316- core: fix probing of various modems on big-endian architectures (ie PPC)
317- core: implement modem states to avoid duplicate operations
318- hso: fix authentication for Icera-based devices like iCON 505
319- zte: use correct port for new devices
320- nozomi: fix detection
321
322* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
323- Update to latest git
324- core: fix pppd 2.4.5 errors about 'baudrate 0'
325- cdma: wait for network registration before trying to connect
326- gsm: add cell access technology reporting
327- gsm: allow longer-running network scans
328- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
329- nokia: don't power down phones on disconnect
330- hso: fix disconnection/disable
331
332* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
333- Fixes for Motorola and Ericsson devices
334- Fixes for CDMA "serving-system" command parsing
335
336* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
337- Fix a typo in one of the udev rules files
338
339* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
340- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
341
342* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
343- Fix source repo location
344- Fix directory ownership
345
346* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
347- Initial version
348
Note: See TracBrowser for help on using the repository browser.