source: projects/specs/trunk/M/ModemManager/ModemManager-vl.spec @ 9002

Revision 9002, 12.2 KB checked in by inagaki, 10 years ago (diff)

2014-10-09 Ryoichi INAGAKI <ryo1@…>


Line 
1#%define git_snapshot .git20130607
2%define git_snapshot %{nil}
3#define ppp_version 2.4.7
4%define glib2_version 2.40
5
6Name: ModemManager
7Summary: Mobile broadband modem management service
8Summary(ja): Mobile broadband modem management service
9Version: 1.2.0
10Release: 2%{git_snapshot}%{?_dist_release}
11License: GPLv2+
12Group: System Environment/Base
13URL: http://www.gnome.org/projects/NetworkManager/
14
15#
16# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
17# tarball built with:
18#    ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
19#    make distcheck
20#
21#Source: %{name}-%{version}%{git_snapshot}.tar.bz2
22
23Source: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
24
25Patch0: buildsys-hates-openpty.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28BuildRequires: glib2-devel >= %{glib2_version}
29BuildRequires: eudev-libgudev1-devel
30BuildRequires: automake autoconf intltool libtool
31BuildRequires: gtk-doc
32# for xsltproc
33BuildRequires: libxslt
34Requires: dbus-glib
35
36%description
37The ModemManager service manages WWAN modems and provides a consistent API for
38interacting with these devices to client applications.
39
40
41%package        devel
42Summary:        Development tools for %{name}
43Summary(ja):    %{name} の開発環境
44Group:          Development/Libraries
45Requires:       %{name} = %{version}-%{release}
46Requires:       pkgconfig
47
48%description    devel
49Header files and libraries for building a extension library for the %{name}.
50
51
52%package        glib
53Summary:        Libraries for adding ModemManager support to applications that use glib.
54Summary(ja):    Glib を使用するアプリケーションに ModemManager サポートを追加するためのライブラリ
55Group:          System Environment/Libraries
56Requires:       glib2 >= %{glib2_version}
57
58%description    glib
59This package contains the libraries that make it easier to use some ModemManager
60functionality from applications that use glib.
61
62
63%package        glib-devel
64Summary:        Development tools for %{name}-glib
65Summary(ja):    %{name}-glib の開発環境
66Group:          Development/Libraries
67Requires:       %{name}-glib = %{version}-%{release}
68Requires:       %{name}-devel = %{version}-%{release}
69Requires:       glib2-devel
70Requires:       pkgconfig
71
72%description    glib-devel
73Header files and libraries for building a extension library for the %{name}-glib.
74
75%prep
76%setup -q
77%patch0 -p1 -b .pty
78
79%build
80autoreconf -if
81intltoolize --force
82#pppddir=`ls -1d %{_libdir}/pppd/2*`
83%configure \
84        --disable-static \
85        --enable-gtk-doc=yes \
86        --enable-introspection=no \
87        --enable-vala=no \
88        --enable-more-warnings=yes \
89        --with-udev-base-dir=/lib/udev \
90        --with-polkit=none \
91        --without-mbim \
92        --without-qmi \
93        --with-dist-version=%{version}-%{release}
94
95
96make %{?_smp_mflags}
97
98%check
99make check
100
101%install
102make install DESTDIR=$RPM_BUILD_ROOT
103
104find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
105#rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
106
107%find_lang %{name}
108
109%post
110/sbin/ldconfig
111touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
112
113%postun
114/sbin/ldconfig
115if [ $1 -eq 0 ]; then
116  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
117  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
118fi
119
120%posttrans
121gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
122
123%post   glib -p /sbin/ldconfig
124%postun glib -p /sbin/ldconfig
125
126%files -f %{name}.lang
127%defattr(0644, root, root, 0755)
128%doc COPYING README
129%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
130%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
131%attr(0755,root,root) %{_sbindir}/ModemManager
132%attr(0755,root,root) %{_bindir}/mmcli
133%dir %{_libdir}/%{name}
134%attr(0755,root,root) %{_libdir}/%{name}/*.so*
135/lib/udev/rules.d/*
136%{_datadir}/dbus-1/interfaces/*.xml
137%{_datadir}/icons/hicolor/22x22/apps/*.png
138%{_mandir}/man8/*
139
140%files devel
141%defattr(0644, root, root, 0755)
142%{_includedir}/ModemManager/*.h
143%dir %{_datadir}/gtk-doc/html/%{name}
144%{_datadir}/gtk-doc/html/%{name}/*
145%{_libdir}/pkgconfig/%{name}.pc
146
147%files glib
148%defattr(0644, root, root, 0755)
149%{_libdir}/libmm-glib.so.*
150
151%files glib-devel
152%defattr(0644, root, root, 0755)
153%{_libdir}/libmm-glib.so
154%dir %{_includedir}/libmm-glib
155%{_includedir}/libmm-glib/*.h
156%{_libdir}/pkgconfig/mm-glib.pc
157%dir %{_datadir}/gtk-doc/html/libmm-glib
158%{_datadir}/gtk-doc/html/libmm-glib/*
159
160
161%changelog
162* Tue Oct  7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-2
163- moved ModemManager-glib to System Environment/Libraries Group
164- removed BR: ppp, ppp-devel and dbus-glib-devel
165
166* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
167- new upstream release
168- remove Patch1 (ModemManager-1.0.0-git20130911.patch)
169
170* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
171- add Patch1 (ModemManager-1.0.0-git20130911.patch)
172
173* Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
174- new upstream release
175- update Patch0
176
177* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
178- update to 0.7.991 snapshot
179- fix spec file based on FC package
180  * Fri Jun  7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
181  - Update to 0.7.991 snapshot
182  - Fix SMS validity parsing
183  - Allow registration changes to 'searching' without disconnecting
184  - Fix reading SMS messages from some QMI-based devices
185  - Increase connection timeout for Novatel E362
186  - Fix PIN retries checking when unlocking Ericsson devices
187  - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
188- add configure option (--enable-gtk-doc=yes, --without-qmi)
189
190* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
191- new upstream release
192
193* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
194- new upstream release
195
196* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
197- delete Patch20
198
199* Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
200- update Patch20 (ModemManager-0.4-git20110428.patch)
201- delete Patch21,22
202
203* Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
204- update to 0.4
205- add Patch20 (ModemManager-0.4-git20100720.patch)
206- add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
207- add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
208
209* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
210- initial build for Vine Linux
211
212* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
213- core: ignore some failures on disconnect (rh #578280)
214- core: add support for platform serial devices
215- gsm: better Blackberry DUN support
216- gsm: periodically poll access technology
217- cdma: prevent crash on modem removal (rh #571921)
218- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
219- novatel: better signal strength reporting on CDMA cards
220- novatel: add access technology and mode preference support on GSM cards
221- zte: fix mode preference retrieval
222- longcheer: add support for Zoom modems (4595, 4596, etc)
223- longcheer: add access technology and mode preference support
224
225* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
226- Silence %%post
227- Update scripts
228
229* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
230- gsm: fix parsing Blackberry supported character sets response
231
232* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
233- mbm: fix retrieval of current allowed mode
234- gsm: fix initialization issues with some devices (like Blackberries)
235
236* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
237- core: fix detection of some generic devices (rh #579247)
238- core: fix detection regression of some Huawei devices in 0.3-5
239- cdma: periodically poll registration state and signal quality
240- cdma: really fix registration detection on various devices (rh #569067)
241
242* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
243- core: fix PPC/SPARC/etc builds
244
245* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
246- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
247- cdma: handle signal quality requests while connected for more devices
248- cdma: handle serving system requests while connected for more devices
249- gsm: determine current access technology earlier
250- huawei: work around automatic registration issues on some devices
251
252* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
253- core: ensure enabled modems are disabled when MM stops
254- core: better capability detection for Blackberry devices (rh #573510)
255- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
256- gsm: don't block modem when it requires PIN2
257- option: fix access technology updates
258
259* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
260- mbm: add device IDs for C3607w
261- mbm: fail earlier during connection failures
262- mbm: fix username/password authentication when checked by the network
263- hso: implement asynchronous signal quality updates
264- option: implement asynchronous signal quality updates
265- novatel: correctly handle CDMA signal quality
266- core: basic PolicyKit support
267- core: fix direct GSM registration information requests
268- core: general GSM PIN/PUK unlock fixes
269- core: poll GSM registration state internally for quicker status updates
270- core: implement GSM 2G/3G preference
271- core: implement GSM roaming allowed/disallowed preference
272- core: emit signals on access technology changes
273- core: better handling of disconnections
274- core: fix simple CDMA status requests
275
276* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
277- core: startup speed improvements
278- core: GSM PIN checking improvements
279- huawei: fix EVDO-only connections on various devices (rh #553199)
280- longcheer: add support for more devices
281
282* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
283- anydata: new plugin for AnyData CDMA modems (rh #547294)
284- core: fix crashes when devices are unplugged during operation (rh #553953)
285- cdma: prefer primary port for status/registration queries
286- core: fix probing/detection of some PIN-locked devices (rh #551376)
287- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
288- gsm: fix Nokia N80 network scan parsing
289
290* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
291- core: fix apparent hangs by limiting retried serial writes
292- gsm: ensure modem state is reset when disabled
293
294* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
295- sierra: fix CDMA registration detection in some cases (rh #547513)
296
297* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
298- sierra: ensure CDMA device is powered up when trying to use it
299- cdma: better signal quality parsing (fixes ex Huawei EC168C)
300- zte: handle unsolicited messages better during probing
301
302* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
303- cdma: fix signal strength reporting on some devices
304- cdma: better registration state detection when dialing (ex Sierra 5275)
305- option: always use the correct tty for dialing commands
306
307* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
308- core: fix reconnect after manual disconnect (rh #541314)
309- core: fix various segfaults during registration
310- core: fix probing of various modems on big-endian architectures (ie PPC)
311- core: implement modem states to avoid duplicate operations
312- hso: fix authentication for Icera-based devices like iCON 505
313- zte: use correct port for new devices
314- nozomi: fix detection
315
316* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
317- Update to latest git
318- core: fix pppd 2.4.5 errors about 'baudrate 0'
319- cdma: wait for network registration before trying to connect
320- gsm: add cell access technology reporting
321- gsm: allow longer-running network scans
322- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
323- nokia: don't power down phones on disconnect
324- hso: fix disconnection/disable
325
326* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
327- Fixes for Motorola and Ericsson devices
328- Fixes for CDMA "serving-system" command parsing
329
330* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
331- Fix a typo in one of the udev rules files
332
333* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
334- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
335
336* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
337- Fix source repo location
338- Fix directory ownership
339
340* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
341- Initial version
342
Note: See TracBrowser for help on using the repository browser.