source: projects/specs/trunk/M/ModemManager/ModemManager-vl.spec @ 4650

Revision 4650, 9.2 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.1.5

Line 
1#%define snapshot .git20100720
2%define snapshot %{nil}
3%define ppp_version 2.4.5
4
5Summary: Mobile broadband modem management service
6Summary(ja): Mobile broadband modem management service
7Name: ModemManager
8Version: 0.5
9Release: 1%{?snapshot}%{?_dist_release}
10License: GPLv2+
11Group: System Environment/Base
12URL: http://www.gnome.org/projects/NetworkManager/
13
14#
15# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
16# tarball built with:
17#    ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
18#    make distcheck
19#
20Source: %{name}-%{version}%{?snapshot}.tar.xz
21Patch1: %{name}-0.3-jp-modems.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
24Requires: dbus-glib
25Requires: glib2
26BuildRequires: glib2-devel >= 2.26.1
27BuildRequires: dbus-glib-devel >= 0.92
28BuildRequires: libgudev-devel >= 143
29BuildRequires: ppp = %{ppp_version}
30BuildRequires: ppp-devel = %{ppp_version}
31BuildRequires: polkit-devel
32BuildRequires: automake autoconf intltool libtool
33# for xsltproc
34BuildRequires: libxslt
35
36%description
37The ModemManager service provides a consistent API to operate many different
38modems, including mobile broadband (3G) devices.
39
40%prep
41%setup -q
42%patch1 -p1 -b .jp-modems
43
44%build
45autoreconf -i
46pppddir=`ls -1d %{_libdir}/pppd/2*`
47%configure \
48        --enable-more-warnings=yes \
49        --with-udev-base-dir=/lib/udev \
50        --with-tests=yes \
51        --with-docs=yes \
52        --disable-static \
53        --with-pppd-plugin-dir=$pppddir \
54        --with-polkit=no
55
56make %{?_smp_mflags}
57
58%check
59make check
60
61%install
62make install DESTDIR=$RPM_BUILD_ROOT
63
64rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
65rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.la
66rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
67rm -f $RPM_BUILD_ROOT%{_includedir}/mm/mm-modem.h
68
69%post
70/sbin/ldconfig
71touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
72
73%postun
74/sbin/ldconfig
75if [ $1 -eq 0 ]; then
76  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
77  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
78fi
79
80%posttrans
81gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
82
83%files
84%defattr(0644, root, root, 0755)
85%doc COPYING README
86%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager.conf
87%{_datadir}/dbus-1/interfaces/*.xml
88%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager.service
89%attr(0755,root,root) %{_sbindir}/modem-manager
90%dir %{_libdir}/%{name}
91%attr(0755,root,root) %{_libdir}/%{name}/*.so*
92/lib/udev/rules.d/*
93%{_datadir}/polkit-1/actions/*.policy
94%{_datadir}/icons/hicolor/22x22/apps/modem-manager.png
95
96%changelog
97* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
98- new upstream release
99
100* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
101- delete Patch20
102
103* Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
104- update Patch20 (ModemManager-0.4-git20110428.patch)
105- delete Patch21,22
106
107* Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
108- update to 0.4
109- add Patch20 (ModemManager-0.4-git20100720.patch)
110- add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
111- add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
112
113* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
114- initial build for Vine Linux
115
116* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
117- core: ignore some failures on disconnect (rh #578280)
118- core: add support for platform serial devices
119- gsm: better Blackberry DUN support
120- gsm: periodically poll access technology
121- cdma: prevent crash on modem removal (rh #571921)
122- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
123- novatel: better signal strength reporting on CDMA cards
124- novatel: add access technology and mode preference support on GSM cards
125- zte: fix mode preference retrieval
126- longcheer: add support for Zoom modems (4595, 4596, etc)
127- longcheer: add access technology and mode preference support
128
129* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
130- Silence %%post
131- Update scripts
132
133* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
134- gsm: fix parsing Blackberry supported character sets response
135
136* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
137- mbm: fix retrieval of current allowed mode
138- gsm: fix initialization issues with some devices (like Blackberries)
139
140* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
141- core: fix detection of some generic devices (rh #579247)
142- core: fix detection regression of some Huawei devices in 0.3-5
143- cdma: periodically poll registration state and signal quality
144- cdma: really fix registration detection on various devices (rh #569067)
145
146* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
147- core: fix PPC/SPARC/etc builds
148
149* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
150- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
151- cdma: handle signal quality requests while connected for more devices
152- cdma: handle serving system requests while connected for more devices
153- gsm: determine current access technology earlier
154- huawei: work around automatic registration issues on some devices
155
156* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
157- core: ensure enabled modems are disabled when MM stops
158- core: better capability detection for Blackberry devices (rh #573510)
159- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
160- gsm: don't block modem when it requires PIN2
161- option: fix access technology updates
162
163* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
164- mbm: add device IDs for C3607w
165- mbm: fail earlier during connection failures
166- mbm: fix username/password authentication when checked by the network
167- hso: implement asynchronous signal quality updates
168- option: implement asynchronous signal quality updates
169- novatel: correctly handle CDMA signal quality
170- core: basic PolicyKit support
171- core: fix direct GSM registration information requests
172- core: general GSM PIN/PUK unlock fixes
173- core: poll GSM registration state internally for quicker status updates
174- core: implement GSM 2G/3G preference
175- core: implement GSM roaming allowed/disallowed preference
176- core: emit signals on access technology changes
177- core: better handling of disconnections
178- core: fix simple CDMA status requests
179
180* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
181- core: startup speed improvements
182- core: GSM PIN checking improvements
183- huawei: fix EVDO-only connections on various devices (rh #553199)
184- longcheer: add support for more devices
185
186* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
187- anydata: new plugin for AnyData CDMA modems (rh #547294)
188- core: fix crashes when devices are unplugged during operation (rh #553953)
189- cdma: prefer primary port for status/registration queries
190- core: fix probing/detection of some PIN-locked devices (rh #551376)
191- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
192- gsm: fix Nokia N80 network scan parsing
193
194* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
195- core: fix apparent hangs by limiting retried serial writes
196- gsm: ensure modem state is reset when disabled
197
198* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
199- sierra: fix CDMA registration detection in some cases (rh #547513)
200
201* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
202- sierra: ensure CDMA device is powered up when trying to use it
203- cdma: better signal quality parsing (fixes ex Huawei EC168C)
204- zte: handle unsolicited messages better during probing
205
206* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
207- cdma: fix signal strength reporting on some devices
208- cdma: better registration state detection when dialing (ex Sierra 5275)
209- option: always use the correct tty for dialing commands
210
211* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
212- core: fix reconnect after manual disconnect (rh #541314)
213- core: fix various segfaults during registration
214- core: fix probing of various modems on big-endian architectures (ie PPC)
215- core: implement modem states to avoid duplicate operations
216- hso: fix authentication for Icera-based devices like iCON 505
217- zte: use correct port for new devices
218- nozomi: fix detection
219
220* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
221- Update to latest git
222- core: fix pppd 2.4.5 errors about 'baudrate 0'
223- cdma: wait for network registration before trying to connect
224- gsm: add cell access technology reporting
225- gsm: allow longer-running network scans
226- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
227- nokia: don't power down phones on disconnect
228- hso: fix disconnection/disable
229
230* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
231- Fixes for Motorola and Ericsson devices
232- Fixes for CDMA "serving-system" command parsing
233
234* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
235- Fix a typo in one of the udev rules files
236
237* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
238- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
239
240* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
241- Fix source repo location
242- Fix directory ownership
243
244* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
245- Initial version
246
Note: See TracBrowser for help on using the repository browser.