source: projects/specs/trunk/M/ModemManager/ModemManager-vl.spec @ 10195

Revision 10195, 13.3 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1#%define git_snapshot .git20130607
2%define git_snapshot %{nil}
3#define ppp_version 2.4.7
4%define glib2_version 2.40
5
6Name: ModemManager
7Summary: Mobile broadband modem management service
8Summary(ja): Mobile broadband modem management service
9Version: 1.4.14
10Release: 1%{git_snapshot}%{?_dist_release}
11License: GPLv2+
12Group: System Environment/Base
13URL: http://www.gnome.org/projects/NetworkManager/
14
15#
16# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
17# tarball built with:
18#    ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
19#    make distcheck
20#
21#Source: %{name}-%{version}%{git_snapshot}.tar.bz2
22
23Source: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
24
25Patch0: buildsys-hates-openpty.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28BuildRequires: glib2-devel >= %{glib2_version}
29BuildRequires: libgudev-devel
30BuildRequires: automake autoconf intltool libtool
31BuildRequires: gobject-introspection-devel
32BuildRequires: polkit-devel
33BuildRequires: gtk-doc
34# for xsltproc
35BuildRequires: libxslt
36Requires: dbus-glib
37
38%description
39The ModemManager service manages WWAN modems and provides a consistent API for
40interacting with these devices to client applications.
41
42
43%package        devel
44Summary:        Development tools for %{name}
45Summary(ja):    %{name} の開発環境
46Group:          Development/Libraries
47Requires:       %{name} = %{version}-%{release}
48Requires:       pkgconfig
49
50%description    devel
51Header files and libraries for building a extension library for the %{name}.
52
53
54%package        glib
55Summary:        Libraries for adding ModemManager support to applications that use glib.
56Summary(ja):    Glib を使用するアプリケーションに ModemManager サポートを追加するためのライブラリ
57Group:          System Environment/Libraries
58Requires:       glib2 >= %{glib2_version}
59
60%description    glib
61This package contains the libraries that make it easier to use some ModemManager
62functionality from applications that use glib.
63
64
65%package        glib-devel
66Summary:        Development tools for %{name}-glib
67Summary(ja):    %{name}-glib の開発環境
68Group:          Development/Libraries
69Requires:       %{name}-glib = %{version}-%{release}
70Requires:       %{name}-devel = %{version}-%{release}
71Requires:       glib2-devel
72Requires:       pkgconfig
73
74%description    glib-devel
75Header files and libraries for building a extension library for the %{name}-glib.
76
77%prep
78%setup -q
79%patch0 -p1 -b .pty
80
81%build
82aclocal
83autoconf
84automake
85#pppddir=`ls -1d %{_libdir}/pppd/2*`
86%configure \
87        --disable-static \
88        --enable-gtk-doc=yes \
89        --enable-vala=no \
90        --enable-more-warnings=yes \
91        --with-udev-base-dir=/lib/udev \
92        --without-mbim \
93        --without-qmi \
94        --with-dist-version=%{version}-%{release}
95
96
97make %{?_smp_mflags}
98
99%check
100make check
101
102%install
103make install DESTDIR=$RPM_BUILD_ROOT
104
105find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
106#rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
107
108%find_lang %{name}
109
110%post
111/sbin/ldconfig
112touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
113
114%postun
115/sbin/ldconfig
116if [ $1 -eq 0 ]; then
117  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
118  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
119fi
120
121%posttrans
122gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
123
124%post   glib -p /sbin/ldconfig
125%postun glib -p /sbin/ldconfig
126
127%files -f %{name}.lang
128%defattr(-,root, root,-)
129%doc COPYING README
130%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
131%{_libdir}/girepository-1.0/ModemManager-1.0.typelib
132%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
133%attr(0755,root,root) %{_sbindir}/ModemManager
134%attr(0755,root,root) %{_bindir}/mmcli
135%dir %{_libdir}/%{name}
136%attr(0755,root,root) %{_libdir}/%{name}/*.so*
137/lib/udev/rules.d/*
138%{_datadir}/dbus-1/interfaces/*.xml
139%{_datadir}/icons/hicolor/22x22/apps/*.png
140%{_datadir}/polkit-1/actions/org.freedesktop.ModemManager1.policy
141%{_mandir}/man8/*
142
143%files devel
144%defattr(-,root,root,-)
145%{_includedir}/ModemManager/*.h
146%dir %{_datadir}/gtk-doc/html/%{name}
147%{_datadir}/gir-1.0/ModemManager-1.0.gir
148%{_datadir}/gtk-doc/html/%{name}/*
149%{_libdir}/pkgconfig/%{name}.pc
150
151%files glib
152%defattr(-,root,root,-)
153%{_libdir}/libmm-glib.so.*
154
155%files glib-devel
156%defattr(-,root,root,-)
157%{_libdir}/libmm-glib.so
158%dir %{_includedir}/libmm-glib
159%{_includedir}/libmm-glib/*.h
160%{_libdir}/pkgconfig/mm-glib.pc
161%dir %{_datadir}/gtk-doc/html/libmm-glib
162%{_datadir}/gtk-doc/html/libmm-glib/*
163
164
165%changelog
166* Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
167- new upstream release
168- change BuildRequires: libgudev-devel instead of eudev-libgudev1-devel
169
170* Sun Feb 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-3
171- fix spec file
172
173* Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-2
174- fix spec file
175
176* Fri Oct 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-1
177- new upstream release
178- add BuildRequires: gobject-introspection-devel, polkit-devel
179
180* Sun Jul 26 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.10-1
181- new upstream release
182
183* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.8-1
184- new upstream release
185
186* Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
187- new upstream release
188
189* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
190- new upstream release
191
192* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
193- new upstream release
194
195* Tue Oct  7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-2
196- moved ModemManager-glib to System Environment/Libraries Group
197- removed BR: ppp, ppp-devel and dbus-glib-devel
198
199* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
200- new upstream release
201- remove Patch1 (ModemManager-1.0.0-git20130911.patch)
202
203* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
204- add Patch1 (ModemManager-1.0.0-git20130911.patch)
205
206* Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
207- new upstream release
208- update Patch0
209
210* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
211- update to 0.7.991 snapshot
212- fix spec file based on FC package
213  * Fri Jun  7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
214  - Update to 0.7.991 snapshot
215  - Fix SMS validity parsing
216  - Allow registration changes to 'searching' without disconnecting
217  - Fix reading SMS messages from some QMI-based devices
218  - Increase connection timeout for Novatel E362
219  - Fix PIN retries checking when unlocking Ericsson devices
220  - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
221- add configure option (--enable-gtk-doc=yes, --without-qmi)
222
223* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
224- new upstream release
225
226* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
227- new upstream release
228
229* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
230- delete Patch20
231
232* Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
233- update Patch20 (ModemManager-0.4-git20110428.patch)
234- delete Patch21,22
235
236* Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
237- update to 0.4
238- add Patch20 (ModemManager-0.4-git20100720.patch)
239- add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
240- add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
241
242* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
243- initial build for Vine Linux
244
245* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
246- core: ignore some failures on disconnect (rh #578280)
247- core: add support for platform serial devices
248- gsm: better Blackberry DUN support
249- gsm: periodically poll access technology
250- cdma: prevent crash on modem removal (rh #571921)
251- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
252- novatel: better signal strength reporting on CDMA cards
253- novatel: add access technology and mode preference support on GSM cards
254- zte: fix mode preference retrieval
255- longcheer: add support for Zoom modems (4595, 4596, etc)
256- longcheer: add access technology and mode preference support
257
258* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
259- Silence %%post
260- Update scripts
261
262* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
263- gsm: fix parsing Blackberry supported character sets response
264
265* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
266- mbm: fix retrieval of current allowed mode
267- gsm: fix initialization issues with some devices (like Blackberries)
268
269* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
270- core: fix detection of some generic devices (rh #579247)
271- core: fix detection regression of some Huawei devices in 0.3-5
272- cdma: periodically poll registration state and signal quality
273- cdma: really fix registration detection on various devices (rh #569067)
274
275* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
276- core: fix PPC/SPARC/etc builds
277
278* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
279- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
280- cdma: handle signal quality requests while connected for more devices
281- cdma: handle serving system requests while connected for more devices
282- gsm: determine current access technology earlier
283- huawei: work around automatic registration issues on some devices
284
285* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
286- core: ensure enabled modems are disabled when MM stops
287- core: better capability detection for Blackberry devices (rh #573510)
288- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
289- gsm: don't block modem when it requires PIN2
290- option: fix access technology updates
291
292* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
293- mbm: add device IDs for C3607w
294- mbm: fail earlier during connection failures
295- mbm: fix username/password authentication when checked by the network
296- hso: implement asynchronous signal quality updates
297- option: implement asynchronous signal quality updates
298- novatel: correctly handle CDMA signal quality
299- core: basic PolicyKit support
300- core: fix direct GSM registration information requests
301- core: general GSM PIN/PUK unlock fixes
302- core: poll GSM registration state internally for quicker status updates
303- core: implement GSM 2G/3G preference
304- core: implement GSM roaming allowed/disallowed preference
305- core: emit signals on access technology changes
306- core: better handling of disconnections
307- core: fix simple CDMA status requests
308
309* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
310- core: startup speed improvements
311- core: GSM PIN checking improvements
312- huawei: fix EVDO-only connections on various devices (rh #553199)
313- longcheer: add support for more devices
314
315* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
316- anydata: new plugin for AnyData CDMA modems (rh #547294)
317- core: fix crashes when devices are unplugged during operation (rh #553953)
318- cdma: prefer primary port for status/registration queries
319- core: fix probing/detection of some PIN-locked devices (rh #551376)
320- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
321- gsm: fix Nokia N80 network scan parsing
322
323* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
324- core: fix apparent hangs by limiting retried serial writes
325- gsm: ensure modem state is reset when disabled
326
327* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
328- sierra: fix CDMA registration detection in some cases (rh #547513)
329
330* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
331- sierra: ensure CDMA device is powered up when trying to use it
332- cdma: better signal quality parsing (fixes ex Huawei EC168C)
333- zte: handle unsolicited messages better during probing
334
335* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
336- cdma: fix signal strength reporting on some devices
337- cdma: better registration state detection when dialing (ex Sierra 5275)
338- option: always use the correct tty for dialing commands
339
340* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
341- core: fix reconnect after manual disconnect (rh #541314)
342- core: fix various segfaults during registration
343- core: fix probing of various modems on big-endian architectures (ie PPC)
344- core: implement modem states to avoid duplicate operations
345- hso: fix authentication for Icera-based devices like iCON 505
346- zte: use correct port for new devices
347- nozomi: fix detection
348
349* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
350- Update to latest git
351- core: fix pppd 2.4.5 errors about 'baudrate 0'
352- cdma: wait for network registration before trying to connect
353- gsm: add cell access technology reporting
354- gsm: allow longer-running network scans
355- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
356- nokia: don't power down phones on disconnect
357- hso: fix disconnection/disable
358
359* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
360- Fixes for Motorola and Ericsson devices
361- Fixes for CDMA "serving-system" command parsing
362
363* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
364- Fix a typo in one of the udev rules files
365
366* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
367- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
368
369* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
370- Fix source repo location
371- Fix directory ownership
372
373* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
374- Initial version
375
Note: See TracBrowser for help on using the repository browser.