source: projects/specs/trunk/M/MAKEDEV/MAKEDEV-vl.spec @ 521

Revision 521, 6.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A script for creating the device files in /dev.
2Summary(ja): /dev 以下のデバイスファイルを作成するスクリプト
3Name: MAKEDEV
4Version: 3.24
5Release: 2%{?_dist_release}
6License: GPLv2
7Group: System Environment/Base
8URL: http://www.lanana.org/docs/device-list/
9
10Source: MAKEDEV-%{version}-1.tar.gz
11Source10: fedora-changelog
12Patch10: MAKEDEV-3.24-vine.patch
13
14BuildRoot: %{_tmppath}/%{name}-root
15Requires(pre): shadow-utils
16Requires(pre): sed, coreutils, mktemp
17
18%description
19This package contains the MAKEDEV program, which makes it easier to create
20and maintain the files in the /dev directory.  /dev directory files
21correspond to a particular device supported by Linux (serial or printer
22ports, scanners, sound cards, tape drives, CD-ROM drives, hard drives,
23etc.) and interface with the drivers in the kernel.
24
25You should install the MAKEDEV package because the MAKEDEV utility makes
26it easy to manage the /dev directory device files.
27
28%description -l ja
29このパッケージには MAKEDEV スクリプトが含まれています。これは /dev ディレ
30クトリ以下のファイルを簡単に作成するものです。/dev ディレクトリのファイル
31は、それぞれ Linux がサポートしているデバイス (シリアル/プリンタポート、
32スキャナ、サウンドカード、テープデバイス、CD-ROM ドライブ、ハードディスク
33等) に対応しており、カーネルのドライバがこれらのファイルを介してデバイス
34にアクセスします。
35
36MAKEDEV ユーティリティは /dev ディレクトリ以下のデバイスファイルを簡単に
37作成すことができますので MAKEDEV パッケージをインストールしてください。
38
39%prep
40%setup -q
41%patch10 -p1 -b .vine
42cp %{SOURCE10} .
43
44%build
45%__make OPTFLAGS="$RPM_OPT_FLAGS"
46
47%install
48%__make install DESTDIR=$RPM_BUILD_ROOT devdir=/dev makedevdir=/sbin
49rm -f $RPM_BUILD_ROOT/dev/MAKEDEV
50
51%clean
52rm -fr $RPM_BUILD_ROOT
53
54%pre
55# Add the floppy group and the vcsa user.
56getent group floppy >/dev/null || groupadd -g 19 -r floppy
57getent passwd vcsa >/dev/null || \
58useradd -r -d /dev -s /sbin/nologin -u 69 \
59    -c "virtual console memory owner" vcsa
60exit 0
61
62%triggerpostun -- dev < 3.22
63if [ -x /sbin/MAKEDEV ]; then
64    /sbin/MAKEDEV null
65    /sbin/MAKEDEV console
66else
67    /bin/mknod /dev/null c 1 3
68    /bin/mknod /dev/console c 5 1
69fi
70if [ "$(/sbin/kernelversion)" == "2.4" ] ||
71   ( [ "$(/sbin/kernelversion)" == "2.6" ] &&
72     [ $(($(uname -r |cut -f1 -d-|cut -f3 -d.))) -lt 16 ] )
73then
74    mount --bind /.dev.static /dev ||:
75    if [ -x /sbin/pam_console_apply ] ; then
76        /sbin/pam_console_apply
77    fi
78fi
79
80%files
81%defattr(-,root,root)
82%doc COPYING devices-2.6+.txt fedora-changelog
83/sbin/MAKEDEV
84%{_mandir}/man8/*
85%{_sbindir}/mksock
86%config(noreplace) %{_sysconfdir}/makedev.d
87
88%changelog
89* Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.24-2
90- rebuilt with new toolchain
91
92* Mon Mar 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.24-1
93- new upstream release
94- remove dev package.
95
96* Thu Oct 16 2008 Shu KONNO <owa@bg.wakwak.com> 3.22-1vl5
97- applied new versioning policy, spec in utf-8
98
99* Thu Apr 05 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.22-0vl5
100- explicitly PreReq: coreutils instead of textutils and fileutils
101
102* Sun Aug 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.22-0vl4
103- make vcsa/floppy device on MAKEDEV's %%pre script.
104
105* Wed Jul 19 2006 Shu KONNO <owa@bg.wakwak.com> 3.22-0vl3
106- rebuild for x86_64
107
108* Sun May 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.22-0vl2
109- make null/console device in triggerpostun scripts
110
111* Sat May 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.22-0vl1
112- add dev subpackage for static device files.
113  - initscripts will mount /.dev.static to /dev
114    if kernel is not support udev.
115- import changes from FC
116
117* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.21-1vl1
118- update to 3.21-3 from FC
119
120* Sat May 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.3.13-1vl3
121- include /dev/mouse (a symlink to /dev/input/mice) in the dev package
122  please note this change (or revert) only applies to ppc archtecture
123
124* Wed May 12 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3.13-1vl2
125- do not make mount a symlink to input/mice on non-ppc architecture.
126- add "console" and "ptmx" to "generic" device
127- add dv1394 device
128- change linux1394 device owner from '$ROOT' to '$CONSOLE'.
129
130* Mon May 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3.13-1vl1
131- merged with fedora package
132  see %{_docdir}/%{name}-%{version}/fedora-changelog for detail.
133
134* Wed Nov 14 2001 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
135- 2.5.2-1vl4
136- fix change log
137
138* Sun Nov 11 2001 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
139- 2.5.2-1vl3
140- support /dev/hdi - hdt
141
142* Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
143- 2.5.2-1vl2
144- rebuild with new %%{_mandir} definition
145- added Japanese summary and description
146
147* Sat Nov 18 2000 MACHINO, Satoshi <machino@vinelinux.org> 2.5.2-1vl1
148- build with gcc-2.95.3
149- partially used rpmmacros
150
151* Wed Mar 01 2000 Nalin Dahyabhai <nalin@redhat.com>
152- add audioctl
153
154* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
155- make vbi a symlink to vbi0
156- make vtx a symlink to vtx0, use vtx from video4linux
157
158* Sat Apr 17 1999 Michael K. Johnson <johnsonm@redhat.com>
159- create version 2.5 with a great many devices added from the 2.2 kernel
160  devices.txt
161
162* Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
163- close bug #2157
164
165* Thu Mar 25 1999 Michael Johnson <johnsonm@redhat.com>
166- sg unification
167- nb devices
168
169* Thu Mar 25 1999 Jakub Jelinek <jj@ultra.linux.cz>
170- create correct /dev/console (c 5 1), support for SCSI
171  disk devices sdi - sddx
172
173* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
174- auto rebuild in the new build environment (release 9)
175
176* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
177- glibc 2.1
178
179* Thu Aug 13 1998 Jeff Johnson <jbj@redhat.com>
180- build root
181
182* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
183- translations modified for de
184
185* Thu Apr 23 1998 Prospector System <bugs@redhat.com>
186- translations modified for fr, tr
187
188* Thu Apr 23 1998 Erik Troan <ewt@redhat.com>
189- fixed group add script (had -r instead of -o)
190
191* Fri Apr 17 1998 Erik Troan <ewt@redhat.com>
192- put -o option on groupadd after -g -- I hope Christian can tell me why
193
194* Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
195- redirect groupadd call so that we're more quiet
196
197* Fri Oct 24 1997 Michael K. Johnson <johnsonm@redhat.com>
198- 2.3.1: use /usr/sbin/groupadd from new shadow utils
199
200* Mon Sep 29 1997 Michael K. Johnson <johnsonm@redhat.com>
201- Updated to 2.3, as Nick agreed to me making an interim release while
202  he figures out whether he wants to be the maintainer.
203
204* Wed Sep 03 1997 Erik Troan <ewt@redhat.com>
205- made a noarch package
206
207* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
208- added dependencies
Note: See TracBrowser for help on using the repository browser.