source: projects/specs/trunk/M/MAKEDEV/MAKEDEV-vl.spec @ 3527

Revision 3527, 6.9 KB checked in by daisuke, 13 years ago (diff)

MAKEDEV: rebuild for Vine6

Line 
1Summary: A script for creating the device files in /dev.
2Summary(ja): /dev 以下のデバイスファイルを作成するスクリプト
3Name: MAKEDEV
4Version: 3.24
5Release: 3%{?_dist_release}
6License: GPLv2
7Group: System Environment/Base
8URL: http://www.lanana.org/docs/device-list/
9
10Source: MAKEDEV-%{version}-1.tar.gz
11Source10: fedora-changelog
12Patch10: MAKEDEV-3.24-vine.patch
13
14BuildRoot: %{_tmppath}/%{name}-root
15Requires(pre): shadow-utils
16Requires(pre): sed, coreutils, mktemp
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: daisuke
21
22%description
23This package contains the MAKEDEV program, which makes it easier to create
24and maintain the files in the /dev directory.  /dev directory files
25correspond to a particular device supported by Linux (serial or printer
26ports, scanners, sound cards, tape drives, CD-ROM drives, hard drives,
27etc.) and interface with the drivers in the kernel.
28
29You should install the MAKEDEV package because the MAKEDEV utility makes
30it easy to manage the /dev directory device files.
31
32%description -l ja
33このパッケージには MAKEDEV スクリプトが含まれています。これは /dev ディレ
34クトリ以下のファイルを簡単に作成するものです。/dev ディレクトリのファイル
35は、それぞれ Linux がサポートしているデバイス (シリアル/プリンタポート、
36スキャナ、サウンドカード、テープデバイス、CD-ROM ドライブ、ハードディスク
37等) に対応しており、カーネルのドライバがこれらのファイルを介してデバイス
38にアクセスします。
39
40MAKEDEV ユーティリティは /dev ディレクトリ以下のデバイスファイルを簡単に
41作成すことができますので MAKEDEV パッケージをインストールしてください。
42
43%prep
44%setup -q
45%patch10 -p1 -b .vine
46cp %{SOURCE10} .
47
48%build
49%__make OPTFLAGS="$RPM_OPT_FLAGS"
50
51%install
52%__make install DESTDIR=$RPM_BUILD_ROOT devdir=/dev makedevdir=/sbin
53rm -f $RPM_BUILD_ROOT/dev/MAKEDEV
54
55%clean
56rm -fr $RPM_BUILD_ROOT
57
58%pre
59# Add the floppy group and the vcsa user.
60getent group floppy >/dev/null || groupadd -g 19 -r floppy
61getent passwd vcsa >/dev/null || \
62useradd -r -d /dev -s /sbin/nologin -u 69 \
63    -c "virtual console memory owner" vcsa
64exit 0
65
66%triggerpostun -- dev < 3.22
67if [ -x /sbin/MAKEDEV ]; then
68    /sbin/MAKEDEV null
69    /sbin/MAKEDEV console
70else
71    /bin/mknod /dev/null c 1 3
72    /bin/mknod /dev/console c 5 1
73fi
74if [ "$(/sbin/kernelversion)" == "2.4" ] ||
75   ( [ "$(/sbin/kernelversion)" == "2.6" ] &&
76     [ $(($(uname -r |cut -f1 -d-|cut -f3 -d.))) -lt 16 ] )
77then
78    mount --bind /.dev.static /dev ||:
79    if [ -x /sbin/pam_console_apply ] ; then
80        /sbin/pam_console_apply
81    fi
82fi
83
84%files
85%defattr(-,root,root)
86%doc COPYING devices-2.6+.txt fedora-changelog
87/sbin/MAKEDEV
88%{_mandir}/man8/*
89%{_sbindir}/mksock
90%config(noreplace) %{_sysconfdir}/makedev.d
91
92%changelog
93* Sun Apr 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.24-3
94- rebuild for Vine 6
95
96* Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.24-2
97- rebuilt with new toolchain
98
99* Mon Mar 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.24-1
100- new upstream release
101- remove dev package.
102
103* Thu Oct 16 2008 Shu KONNO <owa@bg.wakwak.com> 3.22-1vl5
104- applied new versioning policy, spec in utf-8
105
106* Thu Apr 05 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.22-0vl5
107- explicitly PreReq: coreutils instead of textutils and fileutils
108
109* Sun Aug 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.22-0vl4
110- make vcsa/floppy device on MAKEDEV's %%pre script.
111
112* Wed Jul 19 2006 Shu KONNO <owa@bg.wakwak.com> 3.22-0vl3
113- rebuild for x86_64
114
115* Sun May 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.22-0vl2
116- make null/console device in triggerpostun scripts
117
118* Sat May 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.22-0vl1
119- add dev subpackage for static device files.
120  - initscripts will mount /.dev.static to /dev
121    if kernel is not support udev.
122- import changes from FC
123
124* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.21-1vl1
125- update to 3.21-3 from FC
126
127* Sat May 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.3.13-1vl3
128- include /dev/mouse (a symlink to /dev/input/mice) in the dev package
129  please note this change (or revert) only applies to ppc archtecture
130
131* Wed May 12 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3.13-1vl2
132- do not make mount a symlink to input/mice on non-ppc architecture.
133- add "console" and "ptmx" to "generic" device
134- add dv1394 device
135- change linux1394 device owner from '$ROOT' to '$CONSOLE'.
136
137* Mon May 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3.13-1vl1
138- merged with fedora package
139  see %{_docdir}/%{name}-%{version}/fedora-changelog for detail.
140
141* Wed Nov 14 2001 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
142- 2.5.2-1vl4
143- fix change log
144
145* Sun Nov 11 2001 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
146- 2.5.2-1vl3
147- support /dev/hdi - hdt
148
149* Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
150- 2.5.2-1vl2
151- rebuild with new %%{_mandir} definition
152- added Japanese summary and description
153
154* Sat Nov 18 2000 MACHINO, Satoshi <machino@vinelinux.org> 2.5.2-1vl1
155- build with gcc-2.95.3
156- partially used rpmmacros
157
158* Wed Mar 01 2000 Nalin Dahyabhai <nalin@redhat.com>
159- add audioctl
160
161* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
162- make vbi a symlink to vbi0
163- make vtx a symlink to vtx0, use vtx from video4linux
164
165* Sat Apr 17 1999 Michael K. Johnson <johnsonm@redhat.com>
166- create version 2.5 with a great many devices added from the 2.2 kernel
167  devices.txt
168
169* Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
170- close bug #2157
171
172* Thu Mar 25 1999 Michael Johnson <johnsonm@redhat.com>
173- sg unification
174- nb devices
175
176* Thu Mar 25 1999 Jakub Jelinek <jj@ultra.linux.cz>
177- create correct /dev/console (c 5 1), support for SCSI
178  disk devices sdi - sddx
179
180* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
181- auto rebuild in the new build environment (release 9)
182
183* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
184- glibc 2.1
185
186* Thu Aug 13 1998 Jeff Johnson <jbj@redhat.com>
187- build root
188
189* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
190- translations modified for de
191
192* Thu Apr 23 1998 Prospector System <bugs@redhat.com>
193- translations modified for fr, tr
194
195* Thu Apr 23 1998 Erik Troan <ewt@redhat.com>
196- fixed group add script (had -r instead of -o)
197
198* Fri Apr 17 1998 Erik Troan <ewt@redhat.com>
199- put -o option on groupadd after -g -- I hope Christian can tell me why
200
201* Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
202- redirect groupadd call so that we're more quiet
203
204* Fri Oct 24 1997 Michael K. Johnson <johnsonm@redhat.com>
205- 2.3.1: use /usr/sbin/groupadd from new shadow utils
206
207* Mon Sep 29 1997 Michael K. Johnson <johnsonm@redhat.com>
208- Updated to 2.3, as Nick agreed to me making an interim release while
209  he figures out whether he wants to be the maintainer.
210
211* Wed Sep 03 1997 Erik Troan <ewt@redhat.com>
212- made a noarch package
213
214* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
215- added dependencies
Note: See TracBrowser for help on using the repository browser.