source: projects/specs/trunk/J/JF/JF-vl.spec @ 751

Revision 751, 5.0 KB checked in by inagaki, 14 years ago (diff)

upload: JF, jman_pages

Line 
1%define _docdir %{_defaultdocdir}
2
3Summary: HOWTO, FAQ, and other documents in Japanese
4Summary(ja): 日本語のHOWTO, FAQ, その他の文書です
5Name: JF
6Version: 20100222
7Release: 1%{?_dist_release}
8License: distributable
9Group: Applications/Documentation
10URL: http://www.linux.or.jp/JF/
11Source0: http://www.linux.or.jp/JF/JFdocs/JFtxt.tar.bz2
12
13BuildArch: noarch
14Buildroot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: nkf
16
17Vendor: Project Vine
18Distribution: Vine Linux
19
20%description
21Japanese HOWTOs (instructions for how to do things on Linux), FAQs,
22etc. collected from the property of JF (Japanese FAQ) Project.
23There are Japanese translations from English HOWTOs, FAQs, etc. and
24documents that are originally written in Japanese. It's a good idea
25to install this package and look into them for your information.
26
27%description -l ja
28HOWTO (Linux でいろいろなことを実現する方法を書いた文書)や FAQ
29(Frequently Asked Questions:よくある質問と回答)の日本語版など JF
30(Japanese FAQ Project) の資産から、Linuxの基本操作に必要な文書を集めま
31した。英語版 HOWTO, mini-HOWTO, FAQ の和訳、日本固有のドキュメントなど
32が含まれています。必ずインストールして目を通すようにしましょう。
33
34%prep
35%setup -n JFdocs -q
36# remove documents prohibited to distiribute non-commercially...
37# http://www.linux.or.jp/JF/copyright.html
38rm -f Astronomy-HOWTO*
39rm -f Chinese-HOWTO*
40rm -f DHCP*
41rm -f Debian-Jigdo*
42rm -f Ftape-HOWTO*
43rm -f GIS-GRASS*
44rm -f Offline-Mailing*
45rm -f Quota*
46rm -f Scanner-HOWTO-mtekscan*
47rm -f Securing-X-Windows*
48rm -f StarOffice*
49rm -f Swap-Space*
50
51# remove unneeded documents
52rm -f Parted-README.txt
53rm -f BTTV-Mini-HOWTO-0.3.txt
54
55%build
56toUTF8(){
57for i in `find .` ; do
58    if [ -f $i ]; then
59        nkf -w8 -Lu $i >${i%.*}.new
60        mv ${i%.*}.new $i
61    fi
62done
63}
64
65toUTF8
66
67%install
68rm -rf %{buildroot}
69mkdir -p %{buildroot}%{_docdir}/JF
70
71tar cf - . | (cd %{buildroot}%{_docdir}/JF && tar xfBp -)
72
73(cd %{buildroot}%{_docdir}/JF; gzip -r --best *)
74
75%clean
76rm -rf %{buildroot}
77
78%files
79%defattr(-,root,root)
80%{_docdir}/JF/
81
82%changelog
83* Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20100222-1
84- source as of 20100222
85- convert to UTF8 instead of EUC-JP
86- s/BuildPreReq/BuildRequires/
87
88* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20090320-1
89- source as of 20090320
90- spec in utf-8
91
92* Mon Apr 28 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 20080415-1
93- source as of 20080415
94
95* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20070728-0vl1
96- source as of 20070728
97
98* Fri Sep 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20060910-0vl1
99- source as of 20060910
100
101* Sat May 20 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20060412-0vl1
102- source as of 20060520
103
104* Wed Sep 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20050910-0vl1
105- source as of 20050910
106
107* Thu Dec 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20041213-0vl1
108- source as of 20041213
109
110* Sat Sep 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20040924-0vl1
111- source as of 20040924
112- remove Swap-Space
113
114* Sat Mar 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20040316-0vl1
115- source as of 20040316
116- remove Swap-Space
117
118* Wed Sep 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20030914-0vl1
119- source as of 20030914
120- remove Debian-Jigdo
121
122* Fri Jun  6 2003 Jun Nishii <jun@vinelinux.org> 20030415-0vl1
123- fix toEUC
124
125* Wed Apr 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20030415-0vl1
126- source as of 20030415
127- remove Securing-X-Windows
128
129* Tue Feb 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20030216-0vl1
130- source as of 20030216
131
132* Sun Sep 22 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20020905-0vl1
133- source as of 20020905
134- remove Astronomy-HOWTO
135
136* Sun Jun 2 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20020415-0vl1
137- source as of 20020415
138
139* Tue Jan 15 2002 Toru Sagami <sagami@vinelinux.org> 20020115-0vl1
140- source as of 20020115
141
142* Sat Nov 17 2001 Toru Sagami <sagami@vinelinux.org>
143- 20011115-0vl1
144
145* Fri Aug 17 2001 <sagami@vinelinux.org>
146- 20010815-0vl1: introduced %%{_docdir} definition
147
148* Sun Jul 15 2001 <sagami@vinelinux.org>
149- 20010715-0vl1: eliminate CR at the EOL
150
151* Sun May 27 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
152- 20010527-0vl1
153- modified the list of non-free documents
154- comply with RFC2606 (LAN-mini-HOWTO)
155
156* Wed Apr 18 2001 sagami@vinelinux.org
157- 20010415-0vl1
158
159* Mon Dec 25 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
160- 20001225-0vl1
161- added Ethernet-HOWTO, which no longer prevents from commercial distributing
162
163* Mon Sep  4 2000 Jun Nishii <jun@vinelinux.org>
164- 20000831-0vl1
165
166* Wed May 10 2000 Toru Sagami <czs14350@nifty.ne.jp>
167- 20000509-0vl1
168- fixed summary, Buildroot, Distribution
169- fixed description by Yoshihiro Ota
170
171* Thu Jan 27 2000 Yasuhide OOMORI <baoying@flatout.org>
172- [JF-20000125-1]
173- updated to 20000125.
174
175* Thu Jul 29 1999 Jun Nishii <jun@flatout.org>
176- updated to 199907
177
178* Mon Feb 15 1999 Jun Nishii <jun@flatout.org>
179- updated to 199902
180- use JFeuc.tar.bz2
181
182* Tue Feb 2 1999 Jun Nishii <jun@flatout.org>
183- updated to 199901
184- Now we use version number yyyymm instead of yymmdd
185  to avoid 2000 y problem B)
Note: See TracBrowser for help on using the repository browser.