source: projects/specs/trunk/J/JF/JF-vl.spec @ 521

Revision 521, 4.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _docdir %{_defaultdocdir}
2
3Summary: HOWTO, FAQ, and other documents in Japanese
4Summary(ja): 日本語のHOWTO, FAQ, その他の文書です
5Name: JF
6Version: 20090320
7Release: 1%{?_dist_release}
8License: distributable
9Group: Applications/Documentation
10URL: http://www.linux.or.jp/JF/
11Source0: http://www.linux.or.jp/JF/JFdocs/JFtxt.tar.bz2
12BuildPreReq: nkf
13BuildArch: noarch
14Buildroot: %{_tmppath}/%{name}-%{version}-root
15Vendor: Project Vine
16Distribution: Vine Linux
17
18%description
19Japanese HOWTOs (instructions for how to do things on Linux), FAQs,
20etc. collected from the property of JF (Japanese FAQ) Project.
21There are Japanese translations from English HOWTOs, FAQs, etc. and
22documents that are originally written in Japanese. It's a good idea
23to install this package and look into them for your information.
24
25#'
26%description -l ja
27HOWTO (Linux でいろいろなことを実現する方法を書いた文書)や FAQ
28(Frequently Asked Questions:よくある質問と回答)の日本語版など JF
29(Japanese FAQ Project) の資産から、Linuxの基本操作に必要な文書を集めま
30した。英語版 HOWTO, mini-HOWTO, FAQ の和訳、日本固有のドキュメントなど
31が含まれています。必ずインストールして目を通すようにしましょう。
32
33%prep
34%setup -n JFdocs -q
35# remove documents prohibited to distiribute non-commercially...
36# http://www.linux.or.jp/JF/copyright.html
37rm -f Astronomy-HOWTO*
38rm -f Chinese-HOWTO*
39rm -f DHCP*
40rm -f Debian-Jigdo*
41rm -f Ftape-HOWTO*
42rm -f GIS-GRASS*
43rm -f Offline-Mailing*
44rm -f Quota*
45rm -f Scanner-HOWTO-mtekscan*
46rm -f Securing-X-Windows*
47rm -f StarOffice*
48rm -f Swap-Space*
49
50# remove unneeded documents
51rm -f Parted-README.txt
52rm -f BTTV-Mini-HOWTO-0.3.txt
53
54%build
55toEuc(){
56for i in `find .` ; do
57    if [ -f $i ]; then
58        nkf -e -Lu $i >${i%.*}.new
59        mv ${i%.*}.new $i
60    fi
61done
62}
63
64toEuc
65
66%install
67rm -rf %{buildroot}
68mkdir -p %{buildroot}%{_docdir}/JF
69
70tar cf - . | (cd %{buildroot}%{_docdir}/JF && tar xfBp -)
71
72(cd %{buildroot}%{_docdir}/JF; gzip -r --best *)
73
74%clean
75rm -rf %{buildroot}
76
77%files
78%defattr(-,root,root)
79%{_docdir}/JF/
80
81%changelog
82* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20090320-1
83- source as of 20090320
84- spec in utf-8
85
86* Mon Apr 28 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 20080415-1
87- source as of 20080415
88
89* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20070728-0vl1
90- source as of 20070728
91
92* Fri Sep 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20060910-0vl1
93- source as of 20060910
94
95* Sat May 20 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20060412-0vl1
96- source as of 20060520
97
98* Wed Sep 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20050910-0vl1
99- source as of 20050910
100
101* Thu Dec 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20041213-0vl1
102- source as of 20041213
103
104* Sat Sep 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20040924-0vl1
105- source as of 20040924
106- remove Swap-Space
107
108* Sat Mar 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20040316-0vl1
109- source as of 20040316
110- remove Swap-Space
111
112* Wed Sep 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20030914-0vl1
113- source as of 20030914
114- remove Debian-Jigdo
115
116* Fri Jun  6 2003 Jun Nishii <jun@vinelinux.org> 20030415-0vl1
117- fix toEUC
118
119* Wed Apr 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20030415-0vl1
120- source as of 20030415
121- remove Securing-X-Windows
122
123* Tue Feb 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20030216-0vl1
124- source as of 20030216
125
126* Sun Sep 22 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20020905-0vl1
127- source as of 20020905
128- remove Astronomy-HOWTO
129
130* Sun Jun 2 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20020415-0vl1
131- source as of 20020415
132
133* Tue Jan 15 2002 Toru Sagami <sagami@vinelinux.org> 20020115-0vl1
134- source as of 20020115
135
136* Sat Nov 17 2001 Toru Sagami <sagami@vinelinux.org>
137- 20011115-0vl1
138
139* Fri Aug 17 2001 <sagami@vinelinux.org>
140- 20010815-0vl1: introduced %%{_docdir} definition
141
142* Sun Jul 15 2001 <sagami@vinelinux.org>
143- 20010715-0vl1: eliminate CR at the EOL
144
145* Sun May 27 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
146- 20010527-0vl1
147- modified the list of non-free documents
148- comply with RFC2606 (LAN-mini-HOWTO)
149
150* Wed Apr 18 2001 sagami@vinelinux.org
151- 20010415-0vl1
152
153* Mon Dec 25 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
154- 20001225-0vl1
155- added Ethernet-HOWTO, which no longer prevents from commercial distributing
156
157* Mon Sep  4 2000 Jun Nishii <jun@vinelinux.org>
158- 20000831-0vl1
159
160* Wed May 10 2000 Toru Sagami <czs14350@nifty.ne.jp>
161- 20000509-0vl1
162- fixed summary, Buildroot, Distribution
163- fixed description by Yoshihiro Ota
164
165* Thu Jan 27 2000 Yasuhide OOMORI <baoying@flatout.org>
166- [JF-20000125-1]
167- updated to 20000125.
168
169* Thu Jul 29 1999 Jun Nishii <jun@flatout.org>
170- updated to 199907
171
172* Mon Feb 15 1999 Jun Nishii <jun@flatout.org>
173- updated to 199902
174- use JFeuc.tar.bz2
175
176* Tue Feb 2 1999 Jun Nishii <jun@flatout.org>
177- updated to 199901
178- Now we use version number yyyymm instead of yymmdd
179  to avoid 2000 y problem B)
Note: See TracBrowser for help on using the repository browser.