source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 9166

Revision 9166, 29.4 KB checked in by inagaki, 9 years ago (diff)

2014-12-19 Ryoichi INAGAKI <ryo1@…>

  • ImageMagick?, gegl, kdebase-runtime, kdelibs: rebuilt
  • OpenEXR, ilmbase: updated
  • freeimage, kdelibs3: added patch


Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.9.0
5%define Patchlevel 0
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 1%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20URL: http://www.imagemagick.org/
21
22%if "%{Patchlevel}" != ""
23Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
24%else
25Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.xz
26%endif
27#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
28
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30BuildRequires: bzip2-devel
31BuildRequires: cairo-devel
32BuildRequires: pango-devel
33BuildRequires: freetype2-devel >= 2.1.7
34BuildRequires: fontconfig-devel
35BuildRequires: giflib-devel
36BuildRequires: graphviz-devel
37BuildRequires: lcms2-devel
38BuildRequires: libjpeg-turbo-devel
39BuildRequires: libpng-devel >= 1.2.5
40BuildRequires: librsvg2-devel
41BuildRequires: libtiff-devel
42BuildRequires: libxml2-devel
43BuildRequires: libSM-devel
44BuildRequires: libX11-devel
45BuildRequires: libXext-devel
46BuildRequires: OpenEXR-devel
47BuildRequires: perl
48BuildRequires: xorg-x11-server-utils
49BuildRequires: zlib-devel
50BuildRequires: libXt-devel
51BuildRequires: xz-devel
52BuildRequires: xz-lzma-compat
53BuildRequires: libtool-ltdl-devel
54
55Requires: bzip2
56Requires: freetype2
57Requires: giflib
58Requires: graphviz
59Requires: lcms2
60Requires: libjpeg-turbo
61Requires: libpng
62Requires: libtiff
63Requires: libxml2
64Requires: OpenEXR-libs
65Requires: xorg-x11-server-utils
66Requires: zlib
67
68Vendor: Project Vine
69Distribution: Vine Linux
70Packager: inagaki, iwamoto, Takemikaduchi
71
72%description
73ImageMagick(TM) is an image display and manipulation tool for the X
74Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
75and Photo CD image formats. It can resize, rotate, sharpen, color
76reduce, or add special effects to an image, and when finished you can
77either save the completed work in the original format or a different
78one. ImageMagick also includes command line programs for creating
79animated or transparent .gifs, creating composite images, creating
80thumbnail images, and more.
81
82ImageMagick is one of your choices if you need a program to manipulate
83and dis play images. If you want to develop your own applications
84which use ImageMagick code or APIs, you need to install
85ImageMagick-devel as well.
86
87
88%description -l ja
89ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
90ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
91イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
92出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
93オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
94また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
95サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
96
97画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
98も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
99アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
100インストールして下さい.
101
102%package devel
103Summary: Static libraries and header files for ImageMagick app development.
104Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
105Group: Development/Libraries
106Requires: ImageMagick = %{version}-%{release}
107
108%description devel
109Image-Magick-devel contains the static libraries and header files you'll
110need to develop ImageMagick applications. ImageMagick is an image
111manipulation program.
112
113If you want to create applications that will use ImageMagick code or
114APIs, you need to install ImageMagick-devel as well as ImageMagick.
115You do noy need to install it if you just want to use ImageMagick,
116however.
117
118%description devel -l ja
119ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
120これらは ImageMagick アプリケーションの開発の際に必要となります.
121ImageMagick は画像処理プログラムです.
122
123ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
124この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
125する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
126インストールする必要はありません.
127
128%package c++
129Summary: ImageMagick Magick++ library (C++ bindings)
130Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
131Group: System Environment/Libraries
132Requires: ImageMagick = %{version}-%{release}
133
134%description c++
135This package contains the Magick++ library, a C++ binding to the ImageMagick
136graphics manipulation library.
137
138Install ImageMagick-c++ if you want to use any applications that use Magick++.
139
140%description c++
141このパッケージには Magick++ ライブラリが収められています.
142Magick++ とは ImageMagick ライブラリの C++ バインディングです.
143
144Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
145パッケージをインストールして下さい.
146
147%package c++-devel
148Summary: C++ bindings for the ImageMagick library
149Summary(ja): ImageMagick ライブラリの C++ バインディング
150Group: Development/Libraries
151Requires: ImageMagick = %{version}-%{release}
152Requires: ImageMagick-c++ = %{version}-%{release}
153Requires: ImageMagick-devel = %{version}-%{release}
154
155%description c++-devel
156ImageMagick-devel contains the static libraries and header files you'll
157need to develop ImageMagick applications using the Magick++ C++ bindings.
158ImageMagick is an image manipulation program.
159
160If you want to create applications that will use Magick++ code
161or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
162ImageMagick.
163You don't need to install it if you just want to use ImageMagick, or if you
164want to develop/compile applications using the ImageMagick C interface,
165however.
166
167%description c++-devel -l ja
168ImageMagick-c++-devel には Magick++ C++ バインディングを使った
169ImageMagick アプリケーション開発に必要なスタティックライブラリと
170ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
171
172Magick++ コードや API を使ったアプリケーションを開発する場合は,
173ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
174インストールする必要があります.
175ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
176を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
177インストールする必要はありません.
178
179%package -n perl-Image-Magick
180Summary: ImageMagick perl bindings
181Summary(ja): ImageMagick の Perl バインディング
182Group: Development/Libraries
183Requires: ImageMagick = %{version}-%{release}
184Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
185Obsoletes: ImageMagick-perl < %{version}-%{release}
186Provides: ImageMagick-perl = %{version}-%{release}
187
188%description -n perl-Image-Magick
189Perl bindings to ImageMagick.
190
191Install ImageMagick-perl if you want to use any perl scripts that use
192ImageMagick.
193
194%description -n perl-Image-Magick -l ja
195このパッケージは ImageMagick の Perl バインディングです.
196
197ImageMagick を利用する perl スクリプトを使いたい場合は
198ImageMagick-perl パッケージをインストールして下さい.
199
200
201%prep
202%setup -q -n %{name}-%{VER}-%{Patchlevel}
203
204#patch1 -p1 -b .CVE-2006-5456
205
206%build
207%configure \
208    --enable-silent-rules \
209    --enable-shared \
210    --disable-static \
211    --with-modules \
212    --with-quantum-depth=16 \
213    --without-frozenpaths \
214    --with-x \
215    --without-dps \
216    --without-djvu \
217    --without-fftw \
218    --without-jbig \
219    --without-jp2 \
220    --with-lcms2 \
221    --without-wmf \
222    --with-perl \
223    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
224
225# Disable rpath
226sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
227sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
228
229make %{?_smp_mflags}
230
231%install
232rm -rf $RPM_BUILD_ROOT
233
234make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
235
236# perlmagick: fix perl path of demo files
237%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
238
239find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
240find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
241find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
242
243echo "%defattr(-,root,root)" > perl-pkg-files
244find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
245sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
246
247# remove duplicated doc files
248rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
249rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
250
251# remove files conflict with libtools
252rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
253rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
254
255# remove *.la files
256find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
257
258rm -rf $RPM_BUILD_ROOT%{_docdir}/ImageMagick-6
259
260%clean
261rm -rf $RPM_BUILD_ROOT
262
263%post -p /sbin/ldconfig
264
265%post c++ -p /sbin/ldconfig
266
267%postun -p /sbin/ldconfig
268
269%postun c++ -p /sbin/ldconfig
270
271
272%files
273%defattr(-,root,root)
274%doc www images
275%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt NEWS.txt index.html
276%dir %{_libdir}/%{name}-%{VER}
277%dir %{_libdir}/%{name}-%{VER}/config-Q16
278%dir %{_libdir}/%{name}-%{VER}/modules-Q16
279%dir %{_libdir}/%{name}-%{VER}/modules-Q16/*
280%{_sysconfdir}/%{name}-6/*.xml
281%{_libdir}/%{name}-%{VER}/config-Q16/configure.xml
282%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.so
283%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.la
284%{_libdir}/libMagickCore-6.Q16.so.*
285%{_libdir}/libMagickWand-6.Q16.so.*
286%{_bindir}/[a-z]*
287%{_datadir}/%{name}-6/*.xml
288%{_mandir}/man1/ImageMagick.*
289%{_mandir}/man1/[a-z]*
290
291%files devel
292%defattr(-,root,root)
293%{_bindir}/Magick-config
294%{_bindir}/Wand-config
295%{_bindir}/MagickCore-config
296%{_bindir}/MagickWand-config
297%{_libdir}/libMagickCore-6.Q16.so
298%{_libdir}/libMagickWand-6.Q16.so
299%{_libdir}/pkgconfig/ImageMagick-6.Q16.pc
300%{_libdir}/pkgconfig/ImageMagick.pc
301%{_libdir}/pkgconfig/Wand-6.Q16.pc
302%{_libdir}/pkgconfig/Wand.pc
303%{_libdir}/pkgconfig/MagickCore-6.Q16.pc
304%{_libdir}/pkgconfig/MagickCore.pc
305%{_libdir}/pkgconfig/MagickWand-6.Q16.pc
306%{_libdir}/pkgconfig/MagickWand.pc
307%{_includedir}/ImageMagick-6/magick
308%{_includedir}/ImageMagick-6/wand
309%{_mandir}/man1/Magick-config*
310%{_mandir}/man1/Wand-config*
311%{_mandir}/man1/MagickCore-config*
312%{_mandir}/man1/MagickWand-config*
313
314%files c++
315%defattr(-,root,root)
316%{_libdir}/libMagick++-6.Q16.so.*
317
318%files c++-devel
319%defattr(-,root,root)
320%{_bindir}/Magick++-config
321%{_includedir}/ImageMagick-6/Magick++
322%{_includedir}/ImageMagick-6/Magick++.h
323%{_libdir}/libMagick++-6.Q16.so
324%{_libdir}/pkgconfig/ImageMagick++-6.Q16.pc
325%{_libdir}/pkgconfig/ImageMagick++.pc
326%{_libdir}/pkgconfig/Magick++-6.Q16.pc
327%{_libdir}/pkgconfig/Magick++.pc
328%{_mandir}/man1/Magick++-config*
329
330%files -n perl-Image-Magick -f perl-pkg-files
331%defattr(-,root,root)
332%{_mandir}/man3/*
333
334%changelog
335* Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.9.0.0-1
336- new upstream release
337- built with OpenEXR 2.2.0
338
339* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.7-1
340- new upstream release
341
342* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.5-1
343- new upstream release
344
345* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.8.0-1
346- new upstream release
347
348* Sun Dec 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.8-1
349- new upstream release
350
351* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.5-1
352- new upstream release
353
354* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.6.8-1
355- new upstream release
356
357* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.9.3-1
358- new upstream release
359
360* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.8.3-1
361- new upstream release
362
363* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.7.6-1
364- new upstream release
365
366* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.6.8-1
367- new upstream release
368
369* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.5.10-1
370- new upstream release
371- add BuildRequires: pango-devel
372- change BuildRequires: lcms2-devel instead of lcms-devel
373
374* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
375- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
376
377* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
378- built with perl-5.12.3
379- changed perl subpackage name
380
381* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
382- new upstream release
383
384* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
385- rebuilt with graphviz-2.26.3 again
386
387* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
388- new upstream release
389- rebuilt with graphviz-2.26.3
390
391* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
392- new upstream release
393
394* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
395- rebuild with rpm-4.8.1 for pkg-config file
396- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
397- change Requires: libjpeg-turbo instead of libjpeg
398
399* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
400- new upstream release
401- built with new toolchain
402- added --disable-static to %%configure, removed static libraries
403
404* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
405- added --without-djvu --without-fftw
406
407* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
408- new upstream release
409
410* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
411- new upstream release
412
413* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
414- new upstream release
415- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
416- add R: graphviz, OpenEXR-libs, ilmbase
417
418* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
419- new upstream release
420- added Packager tag
421
422* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
423- new upstream release
424
425* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
426- new upstream release
427- updated BuildRequires
428
429* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
430- enabled lcms as default.
431
432* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
433- new upstream release
434
435* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
436- new upstream release
437
438* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
439- new upstream release
440
441* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
442- new upstream release
443
444* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
445- new upstream release
446- spec in UTF-8
447
448* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
449- enabled to build with lcms (use '--with lcms' to enable).
450
451* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
452- new upstream release
453- rebuilt with perl-5.10.0
454
455* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
456- new upstream release
457- removed *.la files from devel packages
458
459* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
460- new upstream release
461- change files section to fit new release
462- build under new versioning policy
463
464* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
465- new upstream release
466
467* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
468- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
469- add BuildPrereq: librsvg2-devel
470- add %{?_smp_mflags} to make command arg
471
472* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
473- new upstream release
474- changed Group to Applications/Graphics
475
476* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
477- rebuilt for VineSeed
478
479* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
480- update patch1 for fix CVE-2007-0770
481
482* Thu Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
483- upstream release
484- add patch1 for fix CVE-2006-5456
485
486* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
487- rebuilt (for ppc) to resolve reference to invalid *la files
488
489* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
490- new upstream release
491
492* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
493- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
494
495* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
496- new upstream release
497- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
498- add --with-perl-options to configure option
499
500* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
501- new upstream release
502- build with XOrg-6.9.0
503
504* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
505- new upstream release
506- add %%{_mandir}/man1/ImageMagick.* to main package
507
508* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
509- source upgrade
510- remove patch1
511- update %%files
512
513* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
514- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
515  (CAN-2004-0981)
516
517* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
518- move $(pkglibdir)/modules-Q16/*/*.la to main package.
519
520* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
521- source upgrade
522- Patch: change default menu font so display can work without XOrg-75dpi-fonts
523- add missing docs
524- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
525- *.pc should be in -devel package
526- add missing pkg{lib,data}dirs to %%files
527
528* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
529- source upgrade
530- add --without-dot to %%configure option
531- update %%files section
532
533* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
534- source upgrade
535
536* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
537- source upgrade
538
539* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
540- add --without-jbig to %%configure option
541
542* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
543- add --without-lcms to %%configure option
544
545* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
546- source upgrade
547- remove commented lines
548
549* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
550- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
551
552* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
553- source upgrade
554- remove patch for freetype2, no need
555- remove commented lines
556- add --with-quantum-depth=16 --with-modules --enable-lzw
557  --without-frozenpaths to %%configure option
558- remove --with-threads --without-xml from %%configure option
559- update %%files
560
561* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
562- patch update
563- add --without-jp2 to configure option
564- change PerlMagick build method
565
566* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
567- rebuild without jasper-devel
568
569* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
570- source upgrade to 5.5.7-15
571
572* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
573- source upgrade to 5.5.7-13
574- add patch0 to build against freetype2-2.1.7
575
576* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
577- source upgrade to 5.5.7-11
578- clean up spec
579- build without previous package (do not require libMagick.so.0)
580
581* Mon Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
582- source upgrade to 5.5.7-9
583- revised name of pkgconfig files
584- remove BuildPrereq: freetype-devel
585
586* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
587- source upgrade to 5.5.7-6
588- disable all patches
589- revised %%files section
590- disable libtoolize and autotools
591- change PerlMagick build method
592- build without previous package (do not require libMagick.so.5)
593
594* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
595- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
596  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
597
598* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
599- rebuild
600
601* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
602- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
603- FIXME: rpm's macro problem?
604
605- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
606  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
607
608  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
609  - remove unnecessary duplicated %%doc files
610  - --without-xml instead of --without-ttf
611  - eliminate libungif(-devel) from BuildReq/Requires
612  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
613
614  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
615  - add delegetes.mgk (and %%{_libdir}/%%{name})
616
617  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
618  - 5.2.9-0vl4
619  - Sorry, the spec was in Shift_JIS. Fixed.
620
621  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
622  - 5.2.9-0vl3
623  - rebuilt with perl-5.6.1
624  - added Japanese summary and description :-P
625  - added --without-ttf in order to disable freetype2 (SeedPlus) support
626  - added --without-wmf in order to disable libwmf (SeedPlus) support
627
628  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
629  - 5.2.9-0vl2
630  - rebuild on Perl-5.6
631  - use %%{perl_sitearch}
632  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
633
634  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
635  - 5.2.9-0vl1
636  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
637
638* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
639- fix perl paths in file list
640
641* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
642- lib64'ize
643- don't throw stuff in /usr/X11R6, that's for X only
644- remove files we aren't shipping
645
646* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
647- rebuilt with gcc-3.2 (we hope)
648
649* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
650- build using gcc-3.2-0.1
651
652* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
653- fix non-cpp headers in -devel package
654- fix #62157 (wrong path for include files in ImageMagick-devel)
655- fix #63897 (use _target instead of _arch) in libtool workaround
656- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
657
658* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
659- update
660- fix localdoc patch
661- fix %%files section
662- disable nonroot patch
663- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
664- fix libtool workaround
665- moved Magick*-config into -devel package (#64249)
666
667* Sun May 26 2002 Tim Powers <timp@redhat.com>
668- automated rebuild
669
670* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
671- 5.4.6
672
673* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
674- Update to pl 11
675
676* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
677- Update to 5.4.3 pl5; this fixes #58080
678
679* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
680- Patchlevel 3
681
682* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
683- automated rebuild
684
685* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
686- Update to 5.4.2-2
687- Fix #57923, also don't hardcode netscape as html viewer
688
689* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
690- 5.4.1
691- Link against new libstdc++
692
693* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
694- 5.4.0.5
695- Make the error message when trying to display an hpgl file more
696  explicit (#55875)
697
698* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
699- 5.4.0.3
700- Fix names of man pages
701
702* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
703- 5.4.0
704- work around build system breakage causing applications to be named
705  %{_arch}-redhat-linux-foo rather than foo
706
707* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
708- 5.3.9
709
710* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
711- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
712  (#52611)
713
714* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
715- Remove Magick++ includes from -devel, they're already in -c++-devel
716  (#51590)
717
718* Sat Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
719- 5.3.8 (bugfix release)
720
721* Fri Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
722- fix to build Perlmagic on s390 s390x
723
724* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
725- Add delegates.mgk to the package (#50725)
726
727* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
728- 5.3.7
729- Fix build without previously installed ImageMagick-devel (#49816)
730- Move perl bindings to a separate package.
731
732* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
733- Fix build as non-root again
734- Shut up rpmlint
735
736* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
737- 5.3.6
738- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
739
740* Sat Jun 16 2001 Than Ngo <than@redhat.com>
741- update to 5.3.5
742- cleanup specfile
743
744* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
745- 5.3.3-respin, fixes #41196
746
747* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
748- 5.3.3
749- Add a desktop file for "display" (RFE#17417)
750
751* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
752- 5.3.2
753- work around bugs in ia64 glibc headers
754
755* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
756- remove patch for s390, it is not necessary
757
758* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
759- 5.2.7
760
761* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
762- 5.2.6
763
764* Mon Dec 18 2000 Than Ngo <than@redhat.com>
765- ported to s390
766
767* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
768- 5.2.4
769- Fix up and package the C++ bindings in the new c++/c++-devel packages.
770
771* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
772- rebuild against new libpng
773
774* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
775- include images with docs (#10312)
776
777* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
778- don't build with -ggdb, use -g instead.
779
780* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
781- automatic rebuild
782
783* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
784- update to 5.2.2 beta
785
786* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
787- update to 5.2.1, redone patches as they failed
788
789* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
790- remove hacks to move perl man pages
791- don't include the perl*/man stuff, these files go in /usr/share/man now.
792
793* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
794- disable optimization on Alpha and Sparc
795
796* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
797- update to 5.2.0
798- update URL
799- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
800
801* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
802- bootstrap rebuilt to nuke broken libbz2 deps
803- add Prefix: tag such that the FHS macros work properly
804
805* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
806- now compiles with bzip2 1.0
807- changed buildroot to include version
808
809* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
810- fix compilation with new perl
811
812* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
813- 5.1.1
814
815* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
816- Rebuild to get compressed man pages
817
818* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
819- ugly hack to print with lpr instead of lp
820
821* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
822- update to 4.2.9
823
824* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
825- update to 4.2.8
826
827* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
828- include the perl man pages as well
829
830* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
831- remove --enable-16bit because it damages interoperability
832
833* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
834- update to 4.2.2
835- change ChangeLog to refer to actual dates.
836- strip binaries
837
838* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
839- add more files. Oops.
840
841* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
842- auto rebuild in the new build environment (release 2)
843
844* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
845- version 4.2.1
846
847* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
848- changed group
849
850* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
851- hacks to make it work with the new perl
852- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
853- make sure the libraries have the x bit on
854
855* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
856- translations modified for de, fr
857
858* Thu May 07 1998 Prospector System <bugs@redhat.com>
859- translations modified for de, fr, tr
860
861* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
862- updated to 4.0.5
863
864* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
865- updated to 4.0.4
866- added BuildRoot
867
868* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
869- updated from 3.8.3 to 3.9.1
870- removed PNG patch (appears to be fixed)
871
872* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
873- build against new libpng
874
875* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
876- built against glibc
877
878* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
879- updated to version 3.8.3.
880- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.