source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 8914

Revision 8914, 29.2 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.8.9
5%define Patchlevel 7
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 1%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.xz
24%endif
25#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
26URL: http://www.imagemagick.org/
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: bzip2-devel
30BuildRequires: cairo-devel
31BuildRequires: pango-devel
32BuildRequires: freetype2-devel >= 2.1.7
33BuildRequires: fontconfig-devel
34BuildRequires: giflib-devel
35BuildRequires: graphviz-devel
36BuildRequires: lcms2-devel
37BuildRequires: libjpeg-turbo-devel
38BuildRequires: libpng-devel >= 1.2.5
39BuildRequires: librsvg2-devel
40BuildRequires: libtiff-devel
41BuildRequires: libxml2-devel
42BuildRequires: libSM-devel
43BuildRequires: libX11-devel
44BuildRequires: libXext-devel
45BuildRequires: OpenEXR-devel
46BuildRequires: perl
47BuildRequires: xorg-x11-server-utils
48BuildRequires: zlib-devel
49BuildRequires: libXt-devel
50BuildRequires: xz-devel
51BuildRequires: xz-lzma-compat
52BuildRequires: libtool-ltdl-devel
53
54Requires: bzip2
55Requires: freetype2
56Requires: giflib
57Requires: graphviz
58Requires: lcms2
59Requires: libjpeg-turbo
60Requires: libpng
61Requires: libtiff
62Requires: libxml2
63Requires: OpenEXR-libs
64Requires: xorg-x11-server-utils
65Requires: zlib
66
67Vendor: Project Vine
68Distribution: Vine Linux
69Packager: inagaki, iwamoto, Takemikaduchi
70
71%description
72ImageMagick(TM) is an image display and manipulation tool for the X
73Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
74and Photo CD image formats. It can resize, rotate, sharpen, color
75reduce, or add special effects to an image, and when finished you can
76either save the completed work in the original format or a different
77one. ImageMagick also includes command line programs for creating
78animated or transparent .gifs, creating composite images, creating
79thumbnail images, and more.
80
81ImageMagick is one of your choices if you need a program to manipulate
82and dis play images. If you want to develop your own applications
83which use ImageMagick code or APIs, you need to install
84ImageMagick-devel as well.
85
86
87%description -l ja
88ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
89ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
90イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
91出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
92オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
93また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
94サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
95
96画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
97も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
98アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
99インストールして下さい.
100
101%package devel
102Summary: Static libraries and header files for ImageMagick app development.
103Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
104Group: Development/Libraries
105Requires: ImageMagick = %{version}-%{release}
106
107%description devel
108Image-Magick-devel contains the static libraries and header files you'll
109need to develop ImageMagick applications. ImageMagick is an image
110manipulation program.
111
112If you want to create applications that will use ImageMagick code or
113APIs, you need to install ImageMagick-devel as well as ImageMagick.
114You do noy need to install it if you just want to use ImageMagick,
115however.
116
117%description devel -l ja
118ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
119これらは ImageMagick アプリケーションの開発の際に必要となります.
120ImageMagick は画像処理プログラムです.
121
122ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
123この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
124する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
125インストールする必要はありません.
126
127%package c++
128Summary: ImageMagick Magick++ library (C++ bindings)
129Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
130Group: System Environment/Libraries
131Requires: ImageMagick = %{version}-%{release}
132
133%description c++
134This package contains the Magick++ library, a C++ binding to the ImageMagick
135graphics manipulation library.
136
137Install ImageMagick-c++ if you want to use any applications that use Magick++.
138
139%description c++
140このパッケージには Magick++ ライブラリが収められています.
141Magick++ とは ImageMagick ライブラリの C++ バインディングです.
142
143Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
144パッケージをインストールして下さい.
145
146%package c++-devel
147Summary: C++ bindings for the ImageMagick library
148Summary(ja): ImageMagick ライブラリの C++ バインディング
149Group: Development/Libraries
150Requires: ImageMagick = %{version}-%{release}
151Requires: ImageMagick-c++ = %{version}-%{release}
152Requires: ImageMagick-devel = %{version}-%{release}
153
154%description c++-devel
155ImageMagick-devel contains the static libraries and header files you'll
156need to develop ImageMagick applications using the Magick++ C++ bindings.
157ImageMagick is an image manipulation program.
158
159If you want to create applications that will use Magick++ code
160or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
161ImageMagick.
162You don't need to install it if you just want to use ImageMagick, or if you
163want to develop/compile applications using the ImageMagick C interface,
164however.
165
166%description c++-devel -l ja
167ImageMagick-c++-devel には Magick++ C++ バインディングを使った
168ImageMagick アプリケーション開発に必要なスタティックライブラリと
169ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
170
171Magick++ コードや API を使ったアプリケーションを開発する場合は,
172ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
173インストールする必要があります.
174ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
175を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
176インストールする必要はありません.
177
178%package -n perl-Image-Magick
179Summary: ImageMagick perl bindings
180Summary(ja): ImageMagick の Perl バインディング
181Group: Development/Libraries
182Requires: ImageMagick = %{version}-%{release}
183Requires: perl >= 5.8.0
184Obsoletes: ImageMagick-perl < %{version}-%{release}
185Provides: ImageMagick-perl = %{version}-%{release}
186
187%description -n perl-Image-Magick
188Perl bindings to ImageMagick.
189
190Install ImageMagick-perl if you want to use any perl scripts that use
191ImageMagick.
192
193%description -n perl-Image-Magick -l ja
194このパッケージは ImageMagick の Perl バインディングです.
195
196ImageMagick を利用する perl スクリプトを使いたい場合は
197ImageMagick-perl パッケージをインストールして下さい.
198
199
200%prep
201%setup -q -n %{name}-%{VER}-%{Patchlevel}
202
203#patch1 -p1 -b .CVE-2006-5456
204
205%build
206%configure \
207    --enable-silent-rules \
208    --enable-shared \
209    --disable-static \
210    --with-modules \
211    --with-quantum-depth=16 \
212    --without-frozenpaths \
213    --with-x \
214    --without-dps \
215    --without-djvu \
216    --without-fftw \
217    --without-jbig \
218    --without-jp2 \
219    --with-lcms2 \
220    --without-wmf \
221    --with-perl \
222    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
223
224# Disable rpath
225sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
226sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
227
228make %{?_smp_mflags}
229
230%install
231rm -rf $RPM_BUILD_ROOT
232
233make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
234
235# perlmagick: fix perl path of demo files
236%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
237
238find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
239find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
240find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
241
242echo "%defattr(-,root,root)" > perl-pkg-files
243find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
244sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
245
246# remove duplicated doc files
247rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
248rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
249
250# remove files conflict with libtools
251rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
252rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
253
254# remove *.la files
255find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
256
257rm -rf $RPM_BUILD_ROOT%{_docdir}/ImageMagick-6
258
259%clean
260rm -rf $RPM_BUILD_ROOT
261
262%post -p /sbin/ldconfig
263
264%post c++ -p /sbin/ldconfig
265
266%postun -p /sbin/ldconfig
267
268%postun c++ -p /sbin/ldconfig
269
270
271%files
272%defattr(-,root,root)
273%doc www images
274%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt NEWS.txt index.html
275%dir %{_libdir}/%{name}-%{VER}
276%dir %{_libdir}/%{name}-%{VER}/config-Q16
277%dir %{_libdir}/%{name}-%{VER}/modules-Q16
278%dir %{_libdir}/%{name}-%{VER}/modules-Q16/*
279%{_sysconfdir}/%{name}-6/*.xml
280%{_libdir}/%{name}-%{VER}/config-Q16/configure.xml
281%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.so
282%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.la
283%{_libdir}/libMagickCore-6.Q16.so.*
284%{_libdir}/libMagickWand-6.Q16.so.*
285%{_bindir}/[a-z]*
286%{_datadir}/%{name}-6/*.xml
287%{_mandir}/man1/ImageMagick.*
288%{_mandir}/man1/[a-z]*
289
290%files devel
291%defattr(-,root,root)
292%{_bindir}/Magick-config
293%{_bindir}/Wand-config
294%{_bindir}/MagickCore-config
295%{_bindir}/MagickWand-config
296%{_libdir}/libMagickCore-6.Q16.so
297%{_libdir}/libMagickWand-6.Q16.so
298%{_libdir}/pkgconfig/ImageMagick-6.Q16.pc
299%{_libdir}/pkgconfig/ImageMagick.pc
300%{_libdir}/pkgconfig/Wand-6.Q16.pc
301%{_libdir}/pkgconfig/Wand.pc
302%{_libdir}/pkgconfig/MagickCore-6.Q16.pc
303%{_libdir}/pkgconfig/MagickCore.pc
304%{_libdir}/pkgconfig/MagickWand-6.Q16.pc
305%{_libdir}/pkgconfig/MagickWand.pc
306%{_includedir}/ImageMagick-6/magick
307%{_includedir}/ImageMagick-6/wand
308%{_mandir}/man1/Magick-config*
309%{_mandir}/man1/Wand-config*
310%{_mandir}/man1/MagickCore-config*
311%{_mandir}/man1/MagickWand-config*
312
313%files c++
314%defattr(-,root,root)
315%{_libdir}/libMagick++-6.Q16.so.*
316
317%files c++-devel
318%defattr(-,root,root)
319%{_bindir}/Magick++-config
320%{_includedir}/ImageMagick-6/Magick++
321%{_includedir}/ImageMagick-6/Magick++.h
322%{_libdir}/libMagick++-6.Q16.so
323%{_libdir}/pkgconfig/ImageMagick++-6.Q16.pc
324%{_libdir}/pkgconfig/ImageMagick++.pc
325%{_libdir}/pkgconfig/Magick++-6.Q16.pc
326%{_libdir}/pkgconfig/Magick++.pc
327%{_mandir}/man1/Magick++-config*
328
329%files -n perl-Image-Magick -f perl-pkg-files
330%defattr(-,root,root)
331%{_mandir}/man3/*
332
333%changelog
334* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.7-1
335- new upstream release
336
337* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.5-1
338- new upstream release
339
340* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.8.0-1
341- new upstream release
342
343* Sun Dec 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.8-1
344- new upstream release
345
346* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.5-1
347- new upstream release
348
349* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.6.8-1
350- new upstream release
351
352* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.9.3-1
353- new upstream release
354
355* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.8.3-1
356- new upstream release
357
358* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.7.6-1
359- new upstream release
360
361* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.6.8-1
362- new upstream release
363
364* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.5.10-1
365- new upstream release
366- add BuildRequires: pango-devel
367- change BuildRequires: lcms2-devel instead of lcms-devel
368
369* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
370- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
371
372* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
373- built with perl-5.12.3
374- changed perl subpackage name
375
376* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
377- new upstream release
378
379* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
380- rebuilt with graphviz-2.26.3 again
381
382* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
383- new upstream release
384- rebuilt with graphviz-2.26.3
385
386* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
387- new upstream release
388
389* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
390- rebuild with rpm-4.8.1 for pkg-config file
391- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
392- change Requires: libjpeg-turbo instead of libjpeg
393
394* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
395- new upstream release
396- built with new toolchain
397- added --disable-static to %%configure, removed static libraries
398
399* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
400- added --without-djvu --without-fftw
401
402* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
403- new upstream release
404
405* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
406- new upstream release
407
408* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
409- new upstream release
410- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
411- add R: graphviz, OpenEXR-libs, ilmbase
412
413* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
414- new upstream release
415- added Packager tag
416
417* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
418- new upstream release
419
420* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
421- new upstream release
422- updated BuildRequires
423
424* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
425- enabled lcms as default.
426
427* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
428- new upstream release
429
430* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
431- new upstream release
432
433* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
434- new upstream release
435
436* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
437- new upstream release
438
439* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
440- new upstream release
441- spec in UTF-8
442
443* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
444- enabled to build with lcms (use '--with lcms' to enable).
445
446* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
447- new upstream release
448- rebuilt with perl-5.10.0
449
450* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
451- new upstream release
452- removed *.la files from devel packages
453
454* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
455- new upstream release
456- change files section to fit new release
457- build under new versioning policy
458
459* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
460- new upstream release
461
462* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
463- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
464- add BuildPrereq: librsvg2-devel
465- add %{?_smp_mflags} to make command arg
466
467* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
468- new upstream release
469- changed Group to Applications/Graphics
470
471* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
472- rebuilt for VineSeed
473
474* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
475- update patch1 for fix CVE-2007-0770
476
477* Thu Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
478- upstream release
479- add patch1 for fix CVE-2006-5456
480
481* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
482- rebuilt (for ppc) to resolve reference to invalid *la files
483
484* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
485- new upstream release
486
487* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
488- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
489
490* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
491- new upstream release
492- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
493- add --with-perl-options to configure option
494
495* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
496- new upstream release
497- build with XOrg-6.9.0
498
499* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
500- new upstream release
501- add %%{_mandir}/man1/ImageMagick.* to main package
502
503* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
504- source upgrade
505- remove patch1
506- update %%files
507
508* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
509- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
510  (CAN-2004-0981)
511
512* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
513- move $(pkglibdir)/modules-Q16/*/*.la to main package.
514
515* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
516- source upgrade
517- Patch: change default menu font so display can work without XOrg-75dpi-fonts
518- add missing docs
519- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
520- *.pc should be in -devel package
521- add missing pkg{lib,data}dirs to %%files
522
523* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
524- source upgrade
525- add --without-dot to %%configure option
526- update %%files section
527
528* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
529- source upgrade
530
531* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
532- source upgrade
533
534* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
535- add --without-jbig to %%configure option
536
537* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
538- add --without-lcms to %%configure option
539
540* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
541- source upgrade
542- remove commented lines
543
544* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
545- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
546
547* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
548- source upgrade
549- remove patch for freetype2, no need
550- remove commented lines
551- add --with-quantum-depth=16 --with-modules --enable-lzw
552  --without-frozenpaths to %%configure option
553- remove --with-threads --without-xml from %%configure option
554- update %%files
555
556* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
557- patch update
558- add --without-jp2 to configure option
559- change PerlMagick build method
560
561* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
562- rebuild without jasper-devel
563
564* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
565- source upgrade to 5.5.7-15
566
567* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
568- source upgrade to 5.5.7-13
569- add patch0 to build against freetype2-2.1.7
570
571* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
572- source upgrade to 5.5.7-11
573- clean up spec
574- build without previous package (do not require libMagick.so.0)
575
576* Mon Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
577- source upgrade to 5.5.7-9
578- revised name of pkgconfig files
579- remove BuildPrereq: freetype-devel
580
581* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
582- source upgrade to 5.5.7-6
583- disable all patches
584- revised %%files section
585- disable libtoolize and autotools
586- change PerlMagick build method
587- build without previous package (do not require libMagick.so.5)
588
589* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
590- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
591  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
592
593* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
594- rebuild
595
596* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
597- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
598- FIXME: rpm's macro problem?
599
600- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
601  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
602
603  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
604  - remove unnecessary duplicated %%doc files
605  - --without-xml instead of --without-ttf
606  - eliminate libungif(-devel) from BuildReq/Requires
607  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
608
609  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
610  - add delegetes.mgk (and %%{_libdir}/%%{name})
611
612  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
613  - 5.2.9-0vl4
614  - Sorry, the spec was in Shift_JIS. Fixed.
615
616  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
617  - 5.2.9-0vl3
618  - rebuilt with perl-5.6.1
619  - added Japanese summary and description :-P
620  - added --without-ttf in order to disable freetype2 (SeedPlus) support
621  - added --without-wmf in order to disable libwmf (SeedPlus) support
622
623  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
624  - 5.2.9-0vl2
625  - rebuild on Perl-5.6
626  - use %%{perl_sitearch}
627  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
628
629  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
630  - 5.2.9-0vl1
631  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
632
633* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
634- fix perl paths in file list
635
636* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
637- lib64'ize
638- don't throw stuff in /usr/X11R6, that's for X only
639- remove files we aren't shipping
640
641* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
642- rebuilt with gcc-3.2 (we hope)
643
644* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
645- build using gcc-3.2-0.1
646
647* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
648- fix non-cpp headers in -devel package
649- fix #62157 (wrong path for include files in ImageMagick-devel)
650- fix #63897 (use _target instead of _arch) in libtool workaround
651- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
652
653* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
654- update
655- fix localdoc patch
656- fix %%files section
657- disable nonroot patch
658- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
659- fix libtool workaround
660- moved Magick*-config into -devel package (#64249)
661
662* Sun May 26 2002 Tim Powers <timp@redhat.com>
663- automated rebuild
664
665* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
666- 5.4.6
667
668* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
669- Update to pl 11
670
671* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
672- Update to 5.4.3 pl5; this fixes #58080
673
674* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
675- Patchlevel 3
676
677* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
678- automated rebuild
679
680* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
681- Update to 5.4.2-2
682- Fix #57923, also don't hardcode netscape as html viewer
683
684* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
685- 5.4.1
686- Link against new libstdc++
687
688* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
689- 5.4.0.5
690- Make the error message when trying to display an hpgl file more
691  explicit (#55875)
692
693* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
694- 5.4.0.3
695- Fix names of man pages
696
697* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
698- 5.4.0
699- work around build system breakage causing applications to be named
700  %{_arch}-redhat-linux-foo rather than foo
701
702* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
703- 5.3.9
704
705* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
706- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
707  (#52611)
708
709* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
710- Remove Magick++ includes from -devel, they're already in -c++-devel
711  (#51590)
712
713* Sat Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
714- 5.3.8 (bugfix release)
715
716* Fri Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
717- fix to build Perlmagic on s390 s390x
718
719* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
720- Add delegates.mgk to the package (#50725)
721
722* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
723- 5.3.7
724- Fix build without previously installed ImageMagick-devel (#49816)
725- Move perl bindings to a separate package.
726
727* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
728- Fix build as non-root again
729- Shut up rpmlint
730
731* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
732- 5.3.6
733- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
734
735* Sat Jun 16 2001 Than Ngo <than@redhat.com>
736- update to 5.3.5
737- cleanup specfile
738
739* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
740- 5.3.3-respin, fixes #41196
741
742* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
743- 5.3.3
744- Add a desktop file for "display" (RFE#17417)
745
746* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
747- 5.3.2
748- work around bugs in ia64 glibc headers
749
750* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
751- remove patch for s390, it is not necessary
752
753* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
754- 5.2.7
755
756* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
757- 5.2.6
758
759* Mon Dec 18 2000 Than Ngo <than@redhat.com>
760- ported to s390
761
762* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
763- 5.2.4
764- Fix up and package the C++ bindings in the new c++/c++-devel packages.
765
766* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
767- rebuild against new libpng
768
769* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
770- include images with docs (#10312)
771
772* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
773- don't build with -ggdb, use -g instead.
774
775* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
776- automatic rebuild
777
778* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
779- update to 5.2.2 beta
780
781* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
782- update to 5.2.1, redone patches as they failed
783
784* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
785- remove hacks to move perl man pages
786- don't include the perl*/man stuff, these files go in /usr/share/man now.
787
788* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
789- disable optimization on Alpha and Sparc
790
791* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
792- update to 5.2.0
793- update URL
794- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
795
796* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
797- bootstrap rebuilt to nuke broken libbz2 deps
798- add Prefix: tag such that the FHS macros work properly
799
800* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
801- now compiles with bzip2 1.0
802- changed buildroot to include version
803
804* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
805- fix compilation with new perl
806
807* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
808- 5.1.1
809
810* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
811- Rebuild to get compressed man pages
812
813* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
814- ugly hack to print with lpr instead of lp
815
816* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
817- update to 4.2.9
818
819* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
820- update to 4.2.8
821
822* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
823- include the perl man pages as well
824
825* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
826- remove --enable-16bit because it damages interoperability
827
828* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
829- update to 4.2.2
830- change ChangeLog to refer to actual dates.
831- strip binaries
832
833* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
834- add more files. Oops.
835
836* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
837- auto rebuild in the new build environment (release 2)
838
839* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
840- version 4.2.1
841
842* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
843- changed group
844
845* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
846- hacks to make it work with the new perl
847- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
848- make sure the libraries have the x bit on
849
850* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
851- translations modified for de, fr
852
853* Thu May 07 1998 Prospector System <bugs@redhat.com>
854- translations modified for de, fr, tr
855
856* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
857- updated to 4.0.5
858
859* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
860- updated to 4.0.4
861- added BuildRoot
862
863* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
864- updated from 3.8.3 to 3.9.1
865- removed PNG patch (appears to be fixed)
866
867* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
868- build against new libpng
869
870* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
871- built against glibc
872
873* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
874- updated to version 3.8.3.
875- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.