source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 521

Revision 521, 26.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.5.7
5%define Patchlevel 3
6
7Summary: X application for displaying and manipulating images.
8Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
9Name: ImageMagick
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 2%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.bz2
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.bz2
24%endif
25#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
26URL: http://www.imagemagick.org/
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: bzip2-devel, libjpeg-devel
30BuildRequires: libtiff-devel, giflib-devel, zlib-devel, perl
31BuildRequires: freetype2-devel >= 2.1.7, libpng-devel >= 1.2.5
32BuildRequires: libX11-devel, libXext-devel
33BuildRequires: xorg-x11-server-utils
34BuildRequires: libxml2-devel, librsvg2-devel
35BuildRequires: lcms-devel
36BuildRequires: graphviz-devel, OpenEXR-devel, ilmbase-devel
37
38Requires: bzip2, freetype2, libjpeg, libpng, libtiff, libungif, zlib
39Requires: xorg-x11-server-utils
40Requires: libxml2
41Requires: lcms
42Requires: graphviz, OpenEXR-libs, ilmbase
43
44Vendor: Project Vine
45Distribution: Vine Linux
46Packager: inagaki, iwamoto
47
48%description
49ImageMagick(TM) is an image display and manipulation tool for the X
50Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
51and Photo CD image formats. It can resize, rotate, sharpen, color
52reduce, or add special effects to an image, and when finished you can
53either save the completed work in the original format or a different
54one. ImageMagick also includes command line programs for creating
55animated or transparent .gifs, creating composite images, creating
56thumbnail images, and more.
57
58ImageMagick is one of your choices if you need a program to manipulate
59and dis play images. If you want to develop your own applications
60which use ImageMagick code or APIs, you need to install
61ImageMagick-devel as well.
62
63
64%description -l ja
65ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
66ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
67イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
68出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
69オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
70また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
71サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
72
73画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
74も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
75アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
76インストールして下さい.
77
78%package devel
79Summary: Static libraries and header files for ImageMagick app development.
80Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
81Group: Development/Libraries
82Requires: ImageMagick = %{version}-%{release}
83
84%description devel
85Image-Magick-devel contains the static libraries and header files you'll
86need to develop ImageMagick applications. ImageMagick is an image
87manipulation program.
88
89If you want to create applications that will use ImageMagick code or
90APIs, you need to install ImageMagick-devel as well as ImageMagick.
91You do noy need to install it if you just want to use ImageMagick,
92however.
93
94%description devel -l ja
95ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
96これらは ImageMagick アプリケーションの開発の際に必要となります.
97ImageMagick は画像処理プログラムです.
98
99ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
100この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
101する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
102インストールする必要はありません.
103
104%package perl
105Summary: ImageMagick perl bindings
106Summary(ja): ImageMagick の Perl バインディング
107Group: Development/Libraries
108Requires: ImageMagick = %{version}-%{release}, perl >= 5.8.0
109
110%description perl
111Perl bindings to ImageMagick.
112
113Install ImageMagick-perl if you want to use any perl scripts that use
114ImageMagick.
115
116%description perl -l ja
117このパッケージは ImageMagick の Perl バインディングです.
118
119ImageMagick を利用する perl スクリプトを使いたい場合は
120ImageMagick-perl パッケージをインストールして下さい.
121
122
123%package c++
124Summary: ImageMagick Magick++ library (C++ bindings)
125Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
126Group: System Environment/Libraries
127Requires: ImageMagick = %{version}-%{release}
128
129%description c++
130This package contains the Magick++ library, a C++ binding to the ImageMagick
131graphics manipulation library.
132
133Install ImageMagick-c++ if you want to use any applications that use Magick++.
134
135%description c++
136このパッケージには Magick++ ライブラリが収められています.
137Magick++ とは ImageMagick ライブラリの C++ バインディングです.
138
139Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
140パッケージをインストールして下さい.
141
142%package c++-devel
143Summary: C++ bindings for the ImageMagick library
144Summary(ja): ImageMagick ライブラリの C++ バインディング
145Group: Development/Libraries
146Requires: ImageMagick = %{version}-%{release}
147Requires: ImageMagick-c++ = %{version}-%{release}
148Requires: ImageMagick-devel = %{version}-%{release}
149
150%description c++-devel
151ImageMagick-devel contains the static libraries and header files you'll
152need to develop ImageMagick applications using the Magick++ C++ bindings.
153ImageMagick is an image manipulation program.
154
155If you want to create applications that will use Magick++ code
156or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
157ImageMagick.
158You don't need to install it if you just want to use ImageMagick, or if you
159want to develop/compile applications using the ImageMagick C interface,
160however.
161
162%description c++-devel -l ja
163ImageMagick-c++-devel には Magick++ C++ バインディングを使った
164ImageMagick アプリケーション開発に必要なスタティックライブラリと
165ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
166
167Magick++ コードや API を使ったアプリケーションを開発する場合は,
168ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
169インストールする必要があります.
170ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
171を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
172インストールする必要はありません.
173
174
175%prep
176%setup -q -n %{name}-%{VER}-%{Patchlevel}
177
178#patch1 -p1 -b .CVE-2006-5456
179
180%build
181%configure --enable-shared \
182           --with-x \
183           --with-quantum-depth=16 \
184           --with-modules --enable-lzw \
185           --without-frozenpaths \
186           --with-perl \
187           --without-wmf \
188           --without-jp2 \
189           --without-jbig \
190           --without-djvu \
191           --without-fftw \
192           --with-lcms \
193           --without-dot \
194           --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
195
196# Disable rpath
197sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
198sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
199
200make %{?_smp_mflags}
201
202%install
203rm -rf $RPM_BUILD_ROOT
204
205make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
206
207# perlmagick: fix perl path of demo files
208%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
209
210# get the perl file list. We know what we need, so this is easy
211perlver=`perl -v |grep built |sed -e "s,.*v,,;s, .*,,"`
212perlmajor=`echo $perlver |sed -e "s,\..*,,"`
213
214find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
215find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
216find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
217
218echo "%defattr(-,root,root)" > perl-pkg-files
219find $RPM_BUILD_ROOT%{_libdir}/perl$perlmajor/vendor_perl/$perlver -type d -name Image >> perl-pkg-files.orig
220sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
221
222# remove duplicated doc files
223rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
224
225# remove files conflict with libtools
226rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
227rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
228
229# remove *.la files
230find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
231
232%clean
233rm -rf $RPM_BUILD_ROOT
234
235%post -p /sbin/ldconfig
236
237%post c++ -p /sbin/ldconfig
238
239%postun -p /sbin/ldconfig
240
241%postun c++ -p /sbin/ldconfig
242
243
244%files
245%defattr(-,root,root)
246%doc www images
247%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt index.html
248%dir %{_libdir}/ImageMagick-%{VER}
249%{_libdir}/ImageMagick-%{VER}/config
250%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16
251%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16/*
252%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.so
253%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.la
254%{_libdir}/libMagickCore.so.*
255%{_libdir}/libMagickWand.so.*
256%{_bindir}/[a-z]*
257%dir %{_datadir}/ImageMagick-%{VER}
258%dir %{_datadir}/ImageMagick-%{VER}/config
259%{_datadir}/ImageMagick-%{VER}/config/*.xml
260%{_datadir}/ImageMagick-%{VER}/config/*.icm
261%{_mandir}/man1/ImageMagick.*
262%{_mandir}/man1/[a-z]*
263
264%files devel
265%defattr(-,root,root)
266%{_bindir}/Magick-config
267%{_bindir}/Wand-config
268%{_bindir}/MagickCore-config
269%{_bindir}/MagickWand-config
270%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.a
271%{_libdir}/libMagickCore.a
272%{_libdir}/libMagickCore.so
273%{_libdir}/libMagickWand.a
274%{_libdir}/libMagickWand.so
275%{_libdir}/pkgconfig/ImageMagick.pc
276%{_libdir}/pkgconfig/Wand.pc
277%{_libdir}/pkgconfig/MagickCore.pc
278%{_libdir}/pkgconfig/MagickWand.pc
279%{_includedir}/ImageMagick/magick
280%{_includedir}/ImageMagick/wand
281%{_mandir}/man1/Magick-config*
282%{_mandir}/man1/Wand-config*
283%{_mandir}/man1/MagickCore-config*
284%{_mandir}/man1/MagickWand-config*
285
286%files c++
287%defattr(-,root,root)
288%{_libdir}/libMagick++.so.*
289
290%files c++-devel
291%defattr(-,root,root)
292%{_bindir}/Magick++-config
293%{_includedir}/ImageMagick/Magick++
294%{_includedir}/ImageMagick/Magick++.h
295%{_libdir}/libMagick++.a
296%{_libdir}/libMagick++.so
297%{_libdir}/pkgconfig/ImageMagick++.pc
298%{_libdir}/pkgconfig/Magick++.pc
299%{_mandir}/man1/Magick++-config*
300
301%files perl -f perl-pkg-files
302%defattr(-,root,root)
303%{_mandir}/man3/*
304
305%changelog
306* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
307- added --without-djvu --without-fftw
308
309* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
310- new upstream release
311
312* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
313- new upstream release
314
315* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
316- new upstream release
317- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
318- add R: graphviz, OpenEXR-libs, ilmbase
319
320* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
321- new upstream release
322- added Packager tag
323
324* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
325- new upstream release
326
327* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
328- new upstream release
329- updated BuildRequires
330
331* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
332- enabled lcms as default.
333
334* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
335- new upstream release
336
337* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
338- new upstream release
339
340* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
341- new upstream release
342
343* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
344- new upstream release
345
346* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
347- new upstream release
348- spec in UTF-8
349
350* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
351- enabled to build with lcms (use '--with lcms' to enable).
352
353* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
354- new upstream release
355- rebuilt with perl-5.10.0
356
357* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
358- new upstream release
359- removed *.la files from devel packages
360
361* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
362- new upstream release
363- change files section to fit new release
364- build under new versioning policy
365
366* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
367- new upstream release
368
369* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
370- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
371- add BuildPrereq: librsvg2-devel
372- add %{?_smp_mflags} to make command arg
373
374* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
375- new upstream release
376- changed Group to Applications/Graphics
377
378* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
379- rebuilt for VineSeed
380
381* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
382- update patch1 for fix CVE-2007-0770
383
384* Wed Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
385- upstream release
386- add patch1 for fix CVE-2006-5456
387
388* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
389- rebuilt (for ppc) to resolve reference to invalid *la files
390
391* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
392- new upstream release
393
394* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
395- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
396
397* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
398- new upstream release
399- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
400- add --with-perl-options to configure option
401
402* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
403- new upstream release
404- build with XOrg-6.9.0
405
406* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
407- new upstream release
408- add %%{_mandir}/man1/ImageMagick.* to main package
409
410* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
411- source upgrade
412- remove patch1
413- update %%files
414
415* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
416- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
417  (CAN-2004-0981)
418
419* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
420- move $(pkglibdir)/modules-Q16/*/*.la to main package.
421
422* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
423- source upgrade
424- Patch: change default menu font so display can work without XOrg-75dpi-fonts
425- add missing docs
426- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
427- *.pc should be in -devel package
428- add missing pkg{lib,data}dirs to %%files
429
430* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
431- source upgrade
432- add --without-dot to %%configure option
433- update %%files section
434
435* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
436- source upgrade
437
438* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
439- source upgrade
440
441* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
442- add --without-jbig to %%configure option
443
444* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
445- add --without-lcms to %%configure option
446
447* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
448- source upgrade
449- remove commented lines
450
451* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
452- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
453
454* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
455- source upgrade
456- remove patch for freetype2, no need
457- remove commented lines
458- add --with-quantum-depth=16 --with-modules --enable-lzw
459  --without-frozenpaths to %%configure option
460- remove --with-threads --without-xml from %%configure option
461- update %%files
462
463* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
464- patch update
465- add --without-jp2 to configure option
466- change PerlMagick build method
467
468* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
469- rebuild without jasper-devel
470
471* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
472- source upgrade to 5.5.7-15
473
474* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
475- source upgrade to 5.5.7-13
476- add patch0 to build against freetype2-2.1.7
477
478* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
479- source upgrade to 5.5.7-11
480- clean up spec
481- build without previous package (do not require libMagick.so.0)
482
483* Sun Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
484- source upgrade to 5.5.7-9
485- revised name of pkgconfig files
486- remove BuildPrereq: freetype-devel
487
488* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
489- source upgrade to 5.5.7-6
490- disable all patches
491- revised %%files section
492- disable libtoolize and autotools
493- change PerlMagick build method
494- build without previous package (do not require libMagick.so.5)
495
496* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
497- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
498  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
499
500* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
501- rebuild
502
503* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
504- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
505- FIXME: rpm's macro problem?
506
507- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
508  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
509
510  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
511  - remove unnecessary duplicated %%doc files
512  - --without-xml instead of --without-ttf
513  - eliminate libungif(-devel) from BuildReq/Requires
514  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
515
516  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
517  - add delegetes.mgk (and %%{_libdir}/%%{name})
518
519  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
520  - 5.2.9-0vl4
521  - Sorry, the spec was in Shift_JIS. Fixed.
522
523  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
524  - 5.2.9-0vl3
525  - rebuilt with perl-5.6.1
526  - added Japanese summary and description :-P
527  - added --without-ttf in order to disable freetype2 (SeedPlus) support
528  - added --without-wmf in order to disable libwmf (SeedPlus) support
529
530  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
531  - 5.2.9-0vl2
532  - rebuild on Perl-5.6
533  - use %%{perl_sitearch}
534  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
535
536  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
537  - 5.2.9-0vl1
538  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
539
540* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
541- fix perl paths in file list
542
543* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
544- lib64'ize
545- don't throw stuff in /usr/X11R6, that's for X only
546- remove files we aren't shipping
547
548* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
549- rebuilt with gcc-3.2 (we hope)
550
551* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
552- build using gcc-3.2-0.1
553
554* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
555- fix non-cpp headers in -devel package
556- fix #62157 (wrong path for include files in ImageMagick-devel)
557- fix #63897 (use _target instead of _arch) in libtool workaround
558- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
559
560* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
561- update
562- fix localdoc patch
563- fix %%files section
564- disable nonroot patch
565- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
566- fix libtool workaround
567- moved Magick*-config into -devel package (#64249)
568
569* Sun May 26 2002 Tim Powers <timp@redhat.com>
570- automated rebuild
571
572* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
573- 5.4.6
574
575* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
576- Update to pl 11
577
578* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
579- Update to 5.4.3 pl5; this fixes #58080
580
581* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
582- Patchlevel 3
583
584* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
585- automated rebuild
586
587* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
588- Update to 5.4.2-2
589- Fix #57923, also don't hardcode netscape as html viewer
590
591* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
592- 5.4.1
593- Link against new libstdc++
594
595* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
596- 5.4.0.5
597- Make the error message when trying to display an hpgl file more
598  explicit (#55875)
599
600* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
601- 5.4.0.3
602- Fix names of man pages
603
604* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
605- 5.4.0
606- work around build system breakage causing applications to be named
607  %{_arch}-redhat-linux-foo rather than foo
608
609* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
610- 5.3.9
611
612* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
613- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
614  (#52611)
615
616* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
617- Remove Magick++ includes from -devel, they're already in -c++-devel
618  (#51590)
619
620* Sun Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
621- 5.3.8 (bugfix release)
622
623* Sat Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
624- fix to build Perlmagic on s390 s390x
625
626* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
627- Add delegates.mgk to the package (#50725)
628
629* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
630- 5.3.7
631- Fix build without previously installed ImageMagick-devel (#49816)
632- Move perl bindings to a separate package.
633
634* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
635- Fix build as non-root again
636- Shut up rpmlint
637
638* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
639- 5.3.6
640- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
641
642* Sat Jun 16 2001 Than Ngo <than@redhat.com>
643- update to 5.3.5
644- cleanup specfile
645
646* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
647- 5.3.3-respin, fixes #41196
648
649* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
650- 5.3.3
651- Add a desktop file for "display" (RFE#17417)
652
653* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
654- 5.3.2
655- work around bugs in ia64 glibc headers
656
657* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
658- remove patch for s390, it is not necessary
659
660* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
661- 5.2.7
662
663* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
664- 5.2.6
665
666* Mon Dec 18 2000 Than Ngo <than@redhat.com>
667- ported to s390
668
669* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
670- 5.2.4
671- Fix up and package the C++ bindings in the new c++/c++-devel packages.
672
673* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
674- rebuild against new libpng
675
676* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
677- include images with docs (#10312)
678
679* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
680- don't build with -ggdb, use -g instead.
681
682* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
683- automatic rebuild
684
685* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
686- update to 5.2.2 beta
687
688* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
689- update to 5.2.1, redone patches as they failed
690
691* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
692- remove hacks to move perl man pages
693- don't include the perl*/man stuff, these files go in /usr/share/man now.
694
695* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
696- disable optimization on Alpha and Sparc
697
698* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
699- update to 5.2.0
700- update URL
701- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
702
703* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
704- bootstrap rebuilt to nuke broken libbz2 deps
705- add Prefix: tag such that the FHS macros work properly
706
707* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
708- now compiles with bzip2 1.0
709- changed buildroot to include version
710
711* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
712- fix compilation with new perl
713
714* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
715- 5.1.1
716
717* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
718- Rebuild to get compressed man pages
719
720* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
721- ugly hack to print with lpr instead of lp
722
723* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
724- update to 4.2.9
725
726* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
727- update to 4.2.8
728
729* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
730- include the perl man pages as well
731
732* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
733- remove --enable-16bit because it damages interoperability
734
735* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
736- update to 4.2.2
737- change ChangeLog to refer to actual dates.
738- strip binaries
739
740* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
741- add more files. Oops.
742
743* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
744- auto rebuild in the new build environment (release 2)
745
746* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
747- version 4.2.1
748
749* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
750- changed group
751
752* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
753- hacks to make it work with the new perl
754- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
755- make sure the libraries have the x bit on
756
757* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
758- translations modified for de, fr
759
760* Thu May 07 1998 Prospector System <bugs@redhat.com>
761- translations modified for de, fr, tr
762
763* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
764- updated to 4.0.5
765
766* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
767- updated to 4.0.4
768- added BuildRoot
769
770* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
771- updated from 3.8.3 to 3.9.1
772- removed PNG patch (appears to be fixed)
773
774* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
775- build against new libpng
776
777* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
778- built against glibc
779
780* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
781- updated to version 3.8.3.
782- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.