source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 8721

Revision 8721, 29.2 KB checked in by Takemikaduchi, 10 years ago (diff)

cinnamon-2.2.14, python-2.7.7, ImageMagick?-6.8.9.5

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.8.9
5%define Patchlevel 5
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 1%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.xz
24%endif
25#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
26URL: http://www.imagemagick.org/
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: bzip2-devel
30BuildRequires: cairo-devel
31BuildRequires: pango-devel
32BuildRequires: freetype2-devel >= 2.1.7
33BuildRequires: fontconfig-devel
34BuildRequires: giflib-devel
35BuildRequires: graphviz-devel
36BuildRequires: lcms2-devel
37BuildRequires: libjpeg-turbo-devel
38BuildRequires: libpng-devel >= 1.2.5
39BuildRequires: librsvg2-devel
40BuildRequires: libtiff-devel
41BuildRequires: libxml2-devel
42BuildRequires: libSM-devel
43BuildRequires: libX11-devel
44BuildRequires: libXext-devel
45BuildRequires: OpenEXR-devel
46BuildRequires: perl
47BuildRequires: xorg-x11-server-utils
48BuildRequires: zlib-devel
49BuildRequires: libXt-devel
50BuildRequires: xz-devel
51BuildRequires: xz-lzma-compat
52BuildRequires: libtool-ltdl-devel
53
54Requires: bzip2
55Requires: freetype2
56Requires: giflib
57Requires: graphviz
58Requires: lcms2
59Requires: libjpeg-turbo
60Requires: libpng
61Requires: libtiff
62Requires: libxml2
63Requires: OpenEXR-libs
64Requires: xorg-x11-server-utils
65Requires: zlib
66
67Vendor: Project Vine
68Distribution: Vine Linux
69Packager: inagaki, iwamoto, Takemikaduchi
70
71%description
72ImageMagick(TM) is an image display and manipulation tool for the X
73Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
74and Photo CD image formats. It can resize, rotate, sharpen, color
75reduce, or add special effects to an image, and when finished you can
76either save the completed work in the original format or a different
77one. ImageMagick also includes command line programs for creating
78animated or transparent .gifs, creating composite images, creating
79thumbnail images, and more.
80
81ImageMagick is one of your choices if you need a program to manipulate
82and dis play images. If you want to develop your own applications
83which use ImageMagick code or APIs, you need to install
84ImageMagick-devel as well.
85
86
87%description -l ja
88ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
89ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
90イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
91出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
92オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
93また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
94サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
95
96画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
97も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
98アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
99インストールして下さい.
100
101%package devel
102Summary: Static libraries and header files for ImageMagick app development.
103Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
104Group: Development/Libraries
105Requires: ImageMagick = %{version}-%{release}
106
107%description devel
108Image-Magick-devel contains the static libraries and header files you'll
109need to develop ImageMagick applications. ImageMagick is an image
110manipulation program.
111
112If you want to create applications that will use ImageMagick code or
113APIs, you need to install ImageMagick-devel as well as ImageMagick.
114You do noy need to install it if you just want to use ImageMagick,
115however.
116
117%description devel -l ja
118ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
119これらは ImageMagick アプリケーションの開発の際に必要となります.
120ImageMagick は画像処理プログラムです.
121
122ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
123この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
124する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
125インストールする必要はありません.
126
127%package c++
128Summary: ImageMagick Magick++ library (C++ bindings)
129Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
130Group: System Environment/Libraries
131Requires: ImageMagick = %{version}-%{release}
132
133%description c++
134This package contains the Magick++ library, a C++ binding to the ImageMagick
135graphics manipulation library.
136
137Install ImageMagick-c++ if you want to use any applications that use Magick++.
138
139%description c++
140このパッケージには Magick++ ライブラリが収められています.
141Magick++ とは ImageMagick ライブラリの C++ バインディングです.
142
143Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
144パッケージをインストールして下さい.
145
146%package c++-devel
147Summary: C++ bindings for the ImageMagick library
148Summary(ja): ImageMagick ライブラリの C++ バインディング
149Group: Development/Libraries
150Requires: ImageMagick = %{version}-%{release}
151Requires: ImageMagick-c++ = %{version}-%{release}
152Requires: ImageMagick-devel = %{version}-%{release}
153
154%description c++-devel
155ImageMagick-devel contains the static libraries and header files you'll
156need to develop ImageMagick applications using the Magick++ C++ bindings.
157ImageMagick is an image manipulation program.
158
159If you want to create applications that will use Magick++ code
160or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
161ImageMagick.
162You don't need to install it if you just want to use ImageMagick, or if you
163want to develop/compile applications using the ImageMagick C interface,
164however.
165
166%description c++-devel -l ja
167ImageMagick-c++-devel には Magick++ C++ バインディングを使った
168ImageMagick アプリケーション開発に必要なスタティックライブラリと
169ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
170
171Magick++ コードや API を使ったアプリケーションを開発する場合は,
172ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
173インストールする必要があります.
174ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
175を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
176インストールする必要はありません.
177
178%package -n perl-Image-Magick
179Summary: ImageMagick perl bindings
180Summary(ja): ImageMagick の Perl バインディング
181Group: Development/Libraries
182Requires: ImageMagick = %{version}-%{release}
183Requires: perl >= 5.8.0
184Obsoletes: ImageMagick-perl < %{version}-%{release}
185Provides: ImageMagick-perl = %{version}-%{release}
186
187%description -n perl-Image-Magick
188Perl bindings to ImageMagick.
189
190Install ImageMagick-perl if you want to use any perl scripts that use
191ImageMagick.
192
193%description -n perl-Image-Magick -l ja
194このパッケージは ImageMagick の Perl バインディングです.
195
196ImageMagick を利用する perl スクリプトを使いたい場合は
197ImageMagick-perl パッケージをインストールして下さい.
198
199
200%prep
201%setup -q -n %{name}-%{VER}-%{Patchlevel}
202
203#patch1 -p1 -b .CVE-2006-5456
204
205%build
206%configure \
207    --enable-silent-rules \
208    --enable-shared \
209    --disable-static \
210    --with-modules \
211    --with-quantum-depth=16 \
212    --without-frozenpaths \
213    --with-x \
214    --without-dps \
215    --without-djvu \
216    --without-fftw \
217    --without-jbig \
218    --without-jp2 \
219    --with-lcms2 \
220    --without-wmf \
221    --with-perl \
222    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
223
224# Disable rpath
225sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
226sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
227
228make %{?_smp_mflags}
229
230%install
231rm -rf $RPM_BUILD_ROOT
232
233make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
234
235# perlmagick: fix perl path of demo files
236%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
237
238find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
239find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
240find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
241
242echo "%defattr(-,root,root)" > perl-pkg-files
243find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
244sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
245
246# remove duplicated doc files
247rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
248rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
249
250# remove files conflict with libtools
251rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
252rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
253
254# remove *.la files
255find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
256
257rm -rf $RPM_BUILD_ROOT%{_docdir}/ImageMagick-6
258
259%clean
260rm -rf $RPM_BUILD_ROOT
261
262%post -p /sbin/ldconfig
263
264%post c++ -p /sbin/ldconfig
265
266%postun -p /sbin/ldconfig
267
268%postun c++ -p /sbin/ldconfig
269
270
271%files
272%defattr(-,root,root)
273%doc www images
274%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt NEWS.txt index.html
275%dir %{_libdir}/%{name}-%{VER}
276%dir %{_libdir}/%{name}-%{VER}/config-Q16
277%dir %{_libdir}/%{name}-%{VER}/modules-Q16
278%dir %{_libdir}/%{name}-%{VER}/modules-Q16/*
279%{_sysconfdir}/%{name}-6/*.xml
280%{_libdir}/%{name}-%{VER}/config-Q16/configure.xml
281%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.so
282%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.la
283%{_libdir}/libMagickCore-6.Q16.so.*
284%{_libdir}/libMagickWand-6.Q16.so.*
285%{_bindir}/[a-z]*
286%{_datadir}/%{name}-6/*.xml
287%{_mandir}/man1/ImageMagick.*
288%{_mandir}/man1/[a-z]*
289
290%files devel
291%defattr(-,root,root)
292%{_bindir}/Magick-config
293%{_bindir}/Wand-config
294%{_bindir}/MagickCore-config
295%{_bindir}/MagickWand-config
296%{_libdir}/libMagickCore-6.Q16.so
297%{_libdir}/libMagickWand-6.Q16.so
298%{_libdir}/pkgconfig/ImageMagick-6.Q16.pc
299%{_libdir}/pkgconfig/ImageMagick.pc
300%{_libdir}/pkgconfig/Wand-6.Q16.pc
301%{_libdir}/pkgconfig/Wand.pc
302%{_libdir}/pkgconfig/MagickCore-6.Q16.pc
303%{_libdir}/pkgconfig/MagickCore.pc
304%{_libdir}/pkgconfig/MagickWand-6.Q16.pc
305%{_libdir}/pkgconfig/MagickWand.pc
306%{_includedir}/ImageMagick-6/magick
307%{_includedir}/ImageMagick-6/wand
308%{_mandir}/man1/Magick-config*
309%{_mandir}/man1/Wand-config*
310%{_mandir}/man1/MagickCore-config*
311%{_mandir}/man1/MagickWand-config*
312
313%files c++
314%defattr(-,root,root)
315%{_libdir}/libMagick++-6.Q16.so.*
316
317%files c++-devel
318%defattr(-,root,root)
319%{_bindir}/Magick++-config
320%{_includedir}/ImageMagick-6/Magick++
321%{_includedir}/ImageMagick-6/Magick++.h
322%{_libdir}/libMagick++-6.Q16.so
323%{_libdir}/pkgconfig/ImageMagick++-6.Q16.pc
324%{_libdir}/pkgconfig/ImageMagick++.pc
325%{_libdir}/pkgconfig/Magick++-6.Q16.pc
326%{_libdir}/pkgconfig/Magick++.pc
327%{_mandir}/man1/Magick++-config*
328
329%files -n perl-Image-Magick -f perl-pkg-files
330%defattr(-,root,root)
331%{_mandir}/man3/*
332
333%changelog
334* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.5-1
335- new upstream release
336
337* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.8.0-1
338- new upstream release
339
340* Sun Dec 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.8-1
341- new upstream release
342
343* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.5-1
344- new upstream release
345
346* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.6.8-1
347- new upstream release
348
349* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.9.3-1
350- new upstream release
351
352* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.8.3-1
353- new upstream release
354
355* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.7.6-1
356- new upstream release
357
358* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.6.8-1
359- new upstream release
360
361* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.5.10-1
362- new upstream release
363- add BuildRequires: pango-devel
364- change BuildRequires: lcms2-devel instead of lcms-devel
365
366* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
367- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
368
369* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
370- built with perl-5.12.3
371- changed perl subpackage name
372
373* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
374- new upstream release
375
376* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
377- rebuilt with graphviz-2.26.3 again
378
379* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
380- new upstream release
381- rebuilt with graphviz-2.26.3
382
383* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
384- new upstream release
385
386* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
387- rebuild with rpm-4.8.1 for pkg-config file
388- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
389- change Requires: libjpeg-turbo instead of libjpeg
390
391* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
392- new upstream release
393- built with new toolchain
394- added --disable-static to %%configure, removed static libraries
395
396* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
397- added --without-djvu --without-fftw
398
399* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
400- new upstream release
401
402* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
403- new upstream release
404
405* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
406- new upstream release
407- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
408- add R: graphviz, OpenEXR-libs, ilmbase
409
410* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
411- new upstream release
412- added Packager tag
413
414* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
415- new upstream release
416
417* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
418- new upstream release
419- updated BuildRequires
420
421* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
422- enabled lcms as default.
423
424* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
425- new upstream release
426
427* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
428- new upstream release
429
430* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
431- new upstream release
432
433* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
434- new upstream release
435
436* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
437- new upstream release
438- spec in UTF-8
439
440* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
441- enabled to build with lcms (use '--with lcms' to enable).
442
443* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
444- new upstream release
445- rebuilt with perl-5.10.0
446
447* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
448- new upstream release
449- removed *.la files from devel packages
450
451* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
452- new upstream release
453- change files section to fit new release
454- build under new versioning policy
455
456* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
457- new upstream release
458
459* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
460- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
461- add BuildPrereq: librsvg2-devel
462- add %{?_smp_mflags} to make command arg
463
464* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
465- new upstream release
466- changed Group to Applications/Graphics
467
468* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
469- rebuilt for VineSeed
470
471* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
472- update patch1 for fix CVE-2007-0770
473
474* Thu Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
475- upstream release
476- add patch1 for fix CVE-2006-5456
477
478* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
479- rebuilt (for ppc) to resolve reference to invalid *la files
480
481* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
482- new upstream release
483
484* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
485- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
486
487* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
488- new upstream release
489- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
490- add --with-perl-options to configure option
491
492* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
493- new upstream release
494- build with XOrg-6.9.0
495
496* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
497- new upstream release
498- add %%{_mandir}/man1/ImageMagick.* to main package
499
500* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
501- source upgrade
502- remove patch1
503- update %%files
504
505* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
506- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
507  (CAN-2004-0981)
508
509* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
510- move $(pkglibdir)/modules-Q16/*/*.la to main package.
511
512* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
513- source upgrade
514- Patch: change default menu font so display can work without XOrg-75dpi-fonts
515- add missing docs
516- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
517- *.pc should be in -devel package
518- add missing pkg{lib,data}dirs to %%files
519
520* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
521- source upgrade
522- add --without-dot to %%configure option
523- update %%files section
524
525* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
526- source upgrade
527
528* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
529- source upgrade
530
531* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
532- add --without-jbig to %%configure option
533
534* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
535- add --without-lcms to %%configure option
536
537* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
538- source upgrade
539- remove commented lines
540
541* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
542- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
543
544* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
545- source upgrade
546- remove patch for freetype2, no need
547- remove commented lines
548- add --with-quantum-depth=16 --with-modules --enable-lzw
549  --without-frozenpaths to %%configure option
550- remove --with-threads --without-xml from %%configure option
551- update %%files
552
553* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
554- patch update
555- add --without-jp2 to configure option
556- change PerlMagick build method
557
558* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
559- rebuild without jasper-devel
560
561* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
562- source upgrade to 5.5.7-15
563
564* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
565- source upgrade to 5.5.7-13
566- add patch0 to build against freetype2-2.1.7
567
568* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
569- source upgrade to 5.5.7-11
570- clean up spec
571- build without previous package (do not require libMagick.so.0)
572
573* Mon Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
574- source upgrade to 5.5.7-9
575- revised name of pkgconfig files
576- remove BuildPrereq: freetype-devel
577
578* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
579- source upgrade to 5.5.7-6
580- disable all patches
581- revised %%files section
582- disable libtoolize and autotools
583- change PerlMagick build method
584- build without previous package (do not require libMagick.so.5)
585
586* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
587- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
588  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
589
590* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
591- rebuild
592
593* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
594- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
595- FIXME: rpm's macro problem?
596
597- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
598  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
599
600  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
601  - remove unnecessary duplicated %%doc files
602  - --without-xml instead of --without-ttf
603  - eliminate libungif(-devel) from BuildReq/Requires
604  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
605
606  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
607  - add delegetes.mgk (and %%{_libdir}/%%{name})
608
609  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
610  - 5.2.9-0vl4
611  - Sorry, the spec was in Shift_JIS. Fixed.
612
613  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
614  - 5.2.9-0vl3
615  - rebuilt with perl-5.6.1
616  - added Japanese summary and description :-P
617  - added --without-ttf in order to disable freetype2 (SeedPlus) support
618  - added --without-wmf in order to disable libwmf (SeedPlus) support
619
620  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
621  - 5.2.9-0vl2
622  - rebuild on Perl-5.6
623  - use %%{perl_sitearch}
624  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
625
626  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
627  - 5.2.9-0vl1
628  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
629
630* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
631- fix perl paths in file list
632
633* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
634- lib64'ize
635- don't throw stuff in /usr/X11R6, that's for X only
636- remove files we aren't shipping
637
638* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
639- rebuilt with gcc-3.2 (we hope)
640
641* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
642- build using gcc-3.2-0.1
643
644* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
645- fix non-cpp headers in -devel package
646- fix #62157 (wrong path for include files in ImageMagick-devel)
647- fix #63897 (use _target instead of _arch) in libtool workaround
648- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
649
650* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
651- update
652- fix localdoc patch
653- fix %%files section
654- disable nonroot patch
655- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
656- fix libtool workaround
657- moved Magick*-config into -devel package (#64249)
658
659* Sun May 26 2002 Tim Powers <timp@redhat.com>
660- automated rebuild
661
662* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
663- 5.4.6
664
665* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
666- Update to pl 11
667
668* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
669- Update to 5.4.3 pl5; this fixes #58080
670
671* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
672- Patchlevel 3
673
674* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
675- automated rebuild
676
677* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
678- Update to 5.4.2-2
679- Fix #57923, also don't hardcode netscape as html viewer
680
681* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
682- 5.4.1
683- Link against new libstdc++
684
685* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
686- 5.4.0.5
687- Make the error message when trying to display an hpgl file more
688  explicit (#55875)
689
690* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
691- 5.4.0.3
692- Fix names of man pages
693
694* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
695- 5.4.0
696- work around build system breakage causing applications to be named
697  %{_arch}-redhat-linux-foo rather than foo
698
699* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
700- 5.3.9
701
702* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
703- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
704  (#52611)
705
706* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
707- Remove Magick++ includes from -devel, they're already in -c++-devel
708  (#51590)
709
710* Sat Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
711- 5.3.8 (bugfix release)
712
713* Fri Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
714- fix to build Perlmagic on s390 s390x
715
716* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
717- Add delegates.mgk to the package (#50725)
718
719* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
720- 5.3.7
721- Fix build without previously installed ImageMagick-devel (#49816)
722- Move perl bindings to a separate package.
723
724* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
725- Fix build as non-root again
726- Shut up rpmlint
727
728* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
729- 5.3.6
730- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
731
732* Sat Jun 16 2001 Than Ngo <than@redhat.com>
733- update to 5.3.5
734- cleanup specfile
735
736* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
737- 5.3.3-respin, fixes #41196
738
739* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
740- 5.3.3
741- Add a desktop file for "display" (RFE#17417)
742
743* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
744- 5.3.2
745- work around bugs in ia64 glibc headers
746
747* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
748- remove patch for s390, it is not necessary
749
750* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
751- 5.2.7
752
753* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
754- 5.2.6
755
756* Mon Dec 18 2000 Than Ngo <than@redhat.com>
757- ported to s390
758
759* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
760- 5.2.4
761- Fix up and package the C++ bindings in the new c++/c++-devel packages.
762
763* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
764- rebuild against new libpng
765
766* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
767- include images with docs (#10312)
768
769* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
770- don't build with -ggdb, use -g instead.
771
772* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
773- automatic rebuild
774
775* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
776- update to 5.2.2 beta
777
778* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
779- update to 5.2.1, redone patches as they failed
780
781* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
782- remove hacks to move perl man pages
783- don't include the perl*/man stuff, these files go in /usr/share/man now.
784
785* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
786- disable optimization on Alpha and Sparc
787
788* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
789- update to 5.2.0
790- update URL
791- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
792
793* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
794- bootstrap rebuilt to nuke broken libbz2 deps
795- add Prefix: tag such that the FHS macros work properly
796
797* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
798- now compiles with bzip2 1.0
799- changed buildroot to include version
800
801* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
802- fix compilation with new perl
803
804* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
805- 5.1.1
806
807* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
808- Rebuild to get compressed man pages
809
810* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
811- ugly hack to print with lpr instead of lp
812
813* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
814- update to 4.2.9
815
816* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
817- update to 4.2.8
818
819* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
820- include the perl man pages as well
821
822* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
823- remove --enable-16bit because it damages interoperability
824
825* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
826- update to 4.2.2
827- change ChangeLog to refer to actual dates.
828- strip binaries
829
830* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
831- add more files. Oops.
832
833* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
834- auto rebuild in the new build environment (release 2)
835
836* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
837- version 4.2.1
838
839* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
840- changed group
841
842* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
843- hacks to make it work with the new perl
844- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
845- make sure the libraries have the x bit on
846
847* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
848- translations modified for de, fr
849
850* Thu May 07 1998 Prospector System <bugs@redhat.com>
851- translations modified for de, fr, tr
852
853* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
854- updated to 4.0.5
855
856* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
857- updated to 4.0.4
858- added BuildRoot
859
860* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
861- updated from 3.8.3 to 3.9.1
862- removed PNG patch (appears to be fixed)
863
864* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
865- build against new libpng
866
867* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
868- built against glibc
869
870* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
871- updated to version 3.8.3.
872- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.