source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 8084

Revision 8084, 29.1 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.8.8
5%define Patchlevel 0
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 1%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.xz
24%endif
25#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
26URL: http://www.imagemagick.org/
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: bzip2-devel
30BuildRequires: cairo-devel
31BuildRequires: pango-devel
32BuildRequires: freetype2-devel >= 2.1.7
33BuildRequires: fontconfig-devel
34BuildRequires: giflib-devel
35BuildRequires: graphviz-devel
36BuildRequires: lcms2-devel
37BuildRequires: libjpeg-turbo-devel
38BuildRequires: libpng-devel >= 1.2.5
39BuildRequires: librsvg2-devel
40BuildRequires: libtiff-devel
41BuildRequires: libxml2-devel
42BuildRequires: libSM-devel
43BuildRequires: libX11-devel
44BuildRequires: libXext-devel
45BuildRequires: OpenEXR-devel
46BuildRequires: perl
47BuildRequires: xorg-x11-server-utils
48BuildRequires: zlib-devel
49BuildRequires: libXt-devel
50BuildRequires: xz-devel
51BuildRequires: xz-lzma-compat
52BuildRequires: libtool-ltdl-devel
53
54Requires: bzip2
55Requires: freetype2
56Requires: giflib
57Requires: graphviz
58Requires: lcms2
59Requires: libjpeg-turbo
60Requires: libpng
61Requires: libtiff
62Requires: libxml2
63Requires: OpenEXR-libs
64Requires: xorg-x11-server-utils
65Requires: zlib
66
67Vendor: Project Vine
68Distribution: Vine Linux
69Packager: inagaki, iwamoto, Takemikaduchi
70
71%description
72ImageMagick(TM) is an image display and manipulation tool for the X
73Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
74and Photo CD image formats. It can resize, rotate, sharpen, color
75reduce, or add special effects to an image, and when finished you can
76either save the completed work in the original format or a different
77one. ImageMagick also includes command line programs for creating
78animated or transparent .gifs, creating composite images, creating
79thumbnail images, and more.
80
81ImageMagick is one of your choices if you need a program to manipulate
82and dis play images. If you want to develop your own applications
83which use ImageMagick code or APIs, you need to install
84ImageMagick-devel as well.
85
86
87%description -l ja
88ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
89ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
90イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
91出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
92オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
93また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
94サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
95
96画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
97も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
98アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
99インストールして下さい.
100
101%package devel
102Summary: Static libraries and header files for ImageMagick app development.
103Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
104Group: Development/Libraries
105Requires: ImageMagick = %{version}-%{release}
106
107%description devel
108Image-Magick-devel contains the static libraries and header files you'll
109need to develop ImageMagick applications. ImageMagick is an image
110manipulation program.
111
112If you want to create applications that will use ImageMagick code or
113APIs, you need to install ImageMagick-devel as well as ImageMagick.
114You do noy need to install it if you just want to use ImageMagick,
115however.
116
117%description devel -l ja
118ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
119これらは ImageMagick アプリケーションの開発の際に必要となります.
120ImageMagick は画像処理プログラムです.
121
122ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
123この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
124する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
125インストールする必要はありません.
126
127%package c++
128Summary: ImageMagick Magick++ library (C++ bindings)
129Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
130Group: System Environment/Libraries
131Requires: ImageMagick = %{version}-%{release}
132
133%description c++
134This package contains the Magick++ library, a C++ binding to the ImageMagick
135graphics manipulation library.
136
137Install ImageMagick-c++ if you want to use any applications that use Magick++.
138
139%description c++
140このパッケージには Magick++ ライブラリが収められています.
141Magick++ とは ImageMagick ライブラリの C++ バインディングです.
142
143Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
144パッケージをインストールして下さい.
145
146%package c++-devel
147Summary: C++ bindings for the ImageMagick library
148Summary(ja): ImageMagick ライブラリの C++ バインディング
149Group: Development/Libraries
150Requires: ImageMagick = %{version}-%{release}
151Requires: ImageMagick-c++ = %{version}-%{release}
152Requires: ImageMagick-devel = %{version}-%{release}
153
154%description c++-devel
155ImageMagick-devel contains the static libraries and header files you'll
156need to develop ImageMagick applications using the Magick++ C++ bindings.
157ImageMagick is an image manipulation program.
158
159If you want to create applications that will use Magick++ code
160or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
161ImageMagick.
162You don't need to install it if you just want to use ImageMagick, or if you
163want to develop/compile applications using the ImageMagick C interface,
164however.
165
166%description c++-devel -l ja
167ImageMagick-c++-devel には Magick++ C++ バインディングを使った
168ImageMagick アプリケーション開発に必要なスタティックライブラリと
169ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
170
171Magick++ コードや API を使ったアプリケーションを開発する場合は,
172ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
173インストールする必要があります.
174ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
175を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
176インストールする必要はありません.
177
178%package -n perl-Image-Magick
179Summary: ImageMagick perl bindings
180Summary(ja): ImageMagick の Perl バインディング
181Group: Development/Libraries
182Requires: ImageMagick = %{version}-%{release}
183Requires: perl >= 5.8.0
184Obsoletes: ImageMagick-perl < %{version}-%{release}
185Provides: ImageMagick-perl = %{version}-%{release}
186
187%description -n perl-Image-Magick
188Perl bindings to ImageMagick.
189
190Install ImageMagick-perl if you want to use any perl scripts that use
191ImageMagick.
192
193%description -n perl-Image-Magick -l ja
194このパッケージは ImageMagick の Perl バインディングです.
195
196ImageMagick を利用する perl スクリプトを使いたい場合は
197ImageMagick-perl パッケージをインストールして下さい.
198
199
200%prep
201%setup -q -n %{name}-%{VER}-%{Patchlevel}
202
203#patch1 -p1 -b .CVE-2006-5456
204
205%build
206%configure \
207    --enable-silent-rules \
208    --enable-shared \
209    --disable-static \
210    --with-modules \
211    --with-quantum-depth=16 \
212    --without-frozenpaths \
213    --with-x \
214    --without-dps \
215    --without-djvu \
216    --without-fftw \
217    --without-jbig \
218    --without-jp2 \
219    --with-lcms2 \
220    --without-wmf \
221    --with-perl \
222    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
223
224# Disable rpath
225sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
226sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
227
228make %{?_smp_mflags}
229
230%install
231rm -rf $RPM_BUILD_ROOT
232
233make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
234
235# perlmagick: fix perl path of demo files
236%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
237
238find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
239find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
240find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
241
242echo "%defattr(-,root,root)" > perl-pkg-files
243find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
244sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
245
246# remove duplicated doc files
247rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
248rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
249
250# remove files conflict with libtools
251rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
252rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
253
254# remove *.la files
255find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
256
257rm -rf $RPM_BUILD_ROOT%{_docdir}/ImageMagick-6
258
259%clean
260rm -rf $RPM_BUILD_ROOT
261
262%post -p /sbin/ldconfig
263
264%post c++ -p /sbin/ldconfig
265
266%postun -p /sbin/ldconfig
267
268%postun c++ -p /sbin/ldconfig
269
270
271%files
272%defattr(-,root,root)
273%doc www images
274%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt NEWS.txt index.html
275%dir %{_libdir}/%{name}-%{VER}
276%dir %{_libdir}/%{name}-%{VER}/config-Q16
277%dir %{_libdir}/%{name}-%{VER}/modules-Q16
278%dir %{_libdir}/%{name}-%{VER}/modules-Q16/*
279%{_sysconfdir}/%{name}-6/*.xml
280%{_libdir}/%{name}-%{VER}/config-Q16/configure.xml
281%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.so
282%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.la
283%{_libdir}/libMagickCore-6.Q16.so.*
284%{_libdir}/libMagickWand-6.Q16.so.*
285%{_bindir}/[a-z]*
286%{_datadir}/%{name}-6/*.xml
287%{_mandir}/man1/ImageMagick.*
288%{_mandir}/man1/[a-z]*
289
290%files devel
291%defattr(-,root,root)
292%{_bindir}/Magick-config
293%{_bindir}/Wand-config
294%{_bindir}/MagickCore-config
295%{_bindir}/MagickWand-config
296%{_libdir}/libMagickCore-6.Q16.so
297%{_libdir}/libMagickWand-6.Q16.so
298%{_libdir}/pkgconfig/ImageMagick-6.Q16.pc
299%{_libdir}/pkgconfig/ImageMagick.pc
300%{_libdir}/pkgconfig/Wand-6.Q16.pc
301%{_libdir}/pkgconfig/Wand.pc
302%{_libdir}/pkgconfig/MagickCore-6.Q16.pc
303%{_libdir}/pkgconfig/MagickCore.pc
304%{_libdir}/pkgconfig/MagickWand-6.Q16.pc
305%{_libdir}/pkgconfig/MagickWand.pc
306%{_includedir}/ImageMagick-6/magick
307%{_includedir}/ImageMagick-6/wand
308%{_mandir}/man1/Magick-config*
309%{_mandir}/man1/Wand-config*
310%{_mandir}/man1/MagickCore-config*
311%{_mandir}/man1/MagickWand-config*
312
313%files c++
314%defattr(-,root,root)
315%{_libdir}/libMagick++-6.Q16.so.*
316
317%files c++-devel
318%defattr(-,root,root)
319%{_bindir}/Magick++-config
320%{_includedir}/ImageMagick-6/Magick++
321%{_includedir}/ImageMagick-6/Magick++.h
322%{_libdir}/libMagick++-6.Q16.so
323%{_libdir}/pkgconfig/ImageMagick++-6.Q16.pc
324%{_libdir}/pkgconfig/ImageMagick++.pc
325%{_libdir}/pkgconfig/Magick++-6.Q16.pc
326%{_libdir}/pkgconfig/Magick++.pc
327%{_mandir}/man1/Magick++-config*
328
329%files -n perl-Image-Magick -f perl-pkg-files
330%defattr(-,root,root)
331%{_mandir}/man3/*
332
333%changelog
334* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.8.0-1
335- new upstream release
336
337* Sun Dec 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.8-1
338- new upstream release
339
340* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.5-1
341- new upstream release
342
343* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.6.8-1
344- new upstream release
345
346* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.9.3-1
347- new upstream release
348
349* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.8.3-1
350- new upstream release
351
352* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.7.6-1
353- new upstream release
354
355* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.6.8-1
356- new upstream release
357
358* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.5.10-1
359- new upstream release
360- add BuildRequires: pango-devel
361- change BuildRequires: lcms2-devel instead of lcms-devel
362
363* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
364- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
365
366* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
367- built with perl-5.12.3
368- changed perl subpackage name
369
370* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
371- new upstream release
372
373* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
374- rebuilt with graphviz-2.26.3 again
375
376* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
377- new upstream release
378- rebuilt with graphviz-2.26.3
379
380* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
381- new upstream release
382
383* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
384- rebuild with rpm-4.8.1 for pkg-config file
385- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
386- change Requires: libjpeg-turbo instead of libjpeg
387
388* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
389- new upstream release
390- built with new toolchain
391- added --disable-static to %%configure, removed static libraries
392
393* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
394- added --without-djvu --without-fftw
395
396* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
397- new upstream release
398
399* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
400- new upstream release
401
402* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
403- new upstream release
404- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
405- add R: graphviz, OpenEXR-libs, ilmbase
406
407* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
408- new upstream release
409- added Packager tag
410
411* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
412- new upstream release
413
414* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
415- new upstream release
416- updated BuildRequires
417
418* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
419- enabled lcms as default.
420
421* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
422- new upstream release
423
424* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
425- new upstream release
426
427* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
428- new upstream release
429
430* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
431- new upstream release
432
433* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
434- new upstream release
435- spec in UTF-8
436
437* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
438- enabled to build with lcms (use '--with lcms' to enable).
439
440* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
441- new upstream release
442- rebuilt with perl-5.10.0
443
444* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
445- new upstream release
446- removed *.la files from devel packages
447
448* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
449- new upstream release
450- change files section to fit new release
451- build under new versioning policy
452
453* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
454- new upstream release
455
456* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
457- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
458- add BuildPrereq: librsvg2-devel
459- add %{?_smp_mflags} to make command arg
460
461* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
462- new upstream release
463- changed Group to Applications/Graphics
464
465* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
466- rebuilt for VineSeed
467
468* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
469- update patch1 for fix CVE-2007-0770
470
471* Thu Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
472- upstream release
473- add patch1 for fix CVE-2006-5456
474
475* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
476- rebuilt (for ppc) to resolve reference to invalid *la files
477
478* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
479- new upstream release
480
481* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
482- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
483
484* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
485- new upstream release
486- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
487- add --with-perl-options to configure option
488
489* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
490- new upstream release
491- build with XOrg-6.9.0
492
493* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
494- new upstream release
495- add %%{_mandir}/man1/ImageMagick.* to main package
496
497* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
498- source upgrade
499- remove patch1
500- update %%files
501
502* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
503- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
504  (CAN-2004-0981)
505
506* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
507- move $(pkglibdir)/modules-Q16/*/*.la to main package.
508
509* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
510- source upgrade
511- Patch: change default menu font so display can work without XOrg-75dpi-fonts
512- add missing docs
513- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
514- *.pc should be in -devel package
515- add missing pkg{lib,data}dirs to %%files
516
517* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
518- source upgrade
519- add --without-dot to %%configure option
520- update %%files section
521
522* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
523- source upgrade
524
525* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
526- source upgrade
527
528* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
529- add --without-jbig to %%configure option
530
531* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
532- add --without-lcms to %%configure option
533
534* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
535- source upgrade
536- remove commented lines
537
538* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
539- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
540
541* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
542- source upgrade
543- remove patch for freetype2, no need
544- remove commented lines
545- add --with-quantum-depth=16 --with-modules --enable-lzw
546  --without-frozenpaths to %%configure option
547- remove --with-threads --without-xml from %%configure option
548- update %%files
549
550* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
551- patch update
552- add --without-jp2 to configure option
553- change PerlMagick build method
554
555* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
556- rebuild without jasper-devel
557
558* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
559- source upgrade to 5.5.7-15
560
561* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
562- source upgrade to 5.5.7-13
563- add patch0 to build against freetype2-2.1.7
564
565* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
566- source upgrade to 5.5.7-11
567- clean up spec
568- build without previous package (do not require libMagick.so.0)
569
570* Mon Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
571- source upgrade to 5.5.7-9
572- revised name of pkgconfig files
573- remove BuildPrereq: freetype-devel
574
575* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
576- source upgrade to 5.5.7-6
577- disable all patches
578- revised %%files section
579- disable libtoolize and autotools
580- change PerlMagick build method
581- build without previous package (do not require libMagick.so.5)
582
583* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
584- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
585  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
586
587* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
588- rebuild
589
590* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
591- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
592- FIXME: rpm's macro problem?
593
594- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
595  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
596
597  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
598  - remove unnecessary duplicated %%doc files
599  - --without-xml instead of --without-ttf
600  - eliminate libungif(-devel) from BuildReq/Requires
601  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
602
603  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
604  - add delegetes.mgk (and %%{_libdir}/%%{name})
605
606  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
607  - 5.2.9-0vl4
608  - Sorry, the spec was in Shift_JIS. Fixed.
609
610  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
611  - 5.2.9-0vl3
612  - rebuilt with perl-5.6.1
613  - added Japanese summary and description :-P
614  - added --without-ttf in order to disable freetype2 (SeedPlus) support
615  - added --without-wmf in order to disable libwmf (SeedPlus) support
616
617  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
618  - 5.2.9-0vl2
619  - rebuild on Perl-5.6
620  - use %%{perl_sitearch}
621  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
622
623  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
624  - 5.2.9-0vl1
625  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
626
627* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
628- fix perl paths in file list
629
630* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
631- lib64'ize
632- don't throw stuff in /usr/X11R6, that's for X only
633- remove files we aren't shipping
634
635* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
636- rebuilt with gcc-3.2 (we hope)
637
638* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
639- build using gcc-3.2-0.1
640
641* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
642- fix non-cpp headers in -devel package
643- fix #62157 (wrong path for include files in ImageMagick-devel)
644- fix #63897 (use _target instead of _arch) in libtool workaround
645- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
646
647* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
648- update
649- fix localdoc patch
650- fix %%files section
651- disable nonroot patch
652- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
653- fix libtool workaround
654- moved Magick*-config into -devel package (#64249)
655
656* Sun May 26 2002 Tim Powers <timp@redhat.com>
657- automated rebuild
658
659* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
660- 5.4.6
661
662* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
663- Update to pl 11
664
665* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
666- Update to 5.4.3 pl5; this fixes #58080
667
668* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
669- Patchlevel 3
670
671* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
672- automated rebuild
673
674* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
675- Update to 5.4.2-2
676- Fix #57923, also don't hardcode netscape as html viewer
677
678* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
679- 5.4.1
680- Link against new libstdc++
681
682* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
683- 5.4.0.5
684- Make the error message when trying to display an hpgl file more
685  explicit (#55875)
686
687* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
688- 5.4.0.3
689- Fix names of man pages
690
691* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
692- 5.4.0
693- work around build system breakage causing applications to be named
694  %{_arch}-redhat-linux-foo rather than foo
695
696* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
697- 5.3.9
698
699* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
700- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
701  (#52611)
702
703* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
704- Remove Magick++ includes from -devel, they're already in -c++-devel
705  (#51590)
706
707* Sat Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
708- 5.3.8 (bugfix release)
709
710* Fri Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
711- fix to build Perlmagic on s390 s390x
712
713* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
714- Add delegates.mgk to the package (#50725)
715
716* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
717- 5.3.7
718- Fix build without previously installed ImageMagick-devel (#49816)
719- Move perl bindings to a separate package.
720
721* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
722- Fix build as non-root again
723- Shut up rpmlint
724
725* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
726- 5.3.6
727- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
728
729* Sat Jun 16 2001 Than Ngo <than@redhat.com>
730- update to 5.3.5
731- cleanup specfile
732
733* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
734- 5.3.3-respin, fixes #41196
735
736* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
737- 5.3.3
738- Add a desktop file for "display" (RFE#17417)
739
740* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
741- 5.3.2
742- work around bugs in ia64 glibc headers
743
744* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
745- remove patch for s390, it is not necessary
746
747* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
748- 5.2.7
749
750* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
751- 5.2.6
752
753* Mon Dec 18 2000 Than Ngo <than@redhat.com>
754- ported to s390
755
756* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
757- 5.2.4
758- Fix up and package the C++ bindings in the new c++/c++-devel packages.
759
760* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
761- rebuild against new libpng
762
763* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
764- include images with docs (#10312)
765
766* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
767- don't build with -ggdb, use -g instead.
768
769* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
770- automatic rebuild
771
772* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
773- update to 5.2.2 beta
774
775* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
776- update to 5.2.1, redone patches as they failed
777
778* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
779- remove hacks to move perl man pages
780- don't include the perl*/man stuff, these files go in /usr/share/man now.
781
782* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
783- disable optimization on Alpha and Sparc
784
785* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
786- update to 5.2.0
787- update URL
788- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
789
790* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
791- bootstrap rebuilt to nuke broken libbz2 deps
792- add Prefix: tag such that the FHS macros work properly
793
794* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
795- now compiles with bzip2 1.0
796- changed buildroot to include version
797
798* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
799- fix compilation with new perl
800
801* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
802- 5.1.1
803
804* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
805- Rebuild to get compressed man pages
806
807* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
808- ugly hack to print with lpr instead of lp
809
810* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
811- update to 4.2.9
812
813* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
814- update to 4.2.8
815
816* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
817- include the perl man pages as well
818
819* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
820- remove --enable-16bit because it damages interoperability
821
822* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
823- update to 4.2.2
824- change ChangeLog to refer to actual dates.
825- strip binaries
826
827* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
828- add more files. Oops.
829
830* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
831- auto rebuild in the new build environment (release 2)
832
833* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
834- version 4.2.1
835
836* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
837- changed group
838
839* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
840- hacks to make it work with the new perl
841- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
842- make sure the libraries have the x bit on
843
844* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
845- translations modified for de, fr
846
847* Thu May 07 1998 Prospector System <bugs@redhat.com>
848- translations modified for de, fr, tr
849
850* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
851- updated to 4.0.5
852
853* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
854- updated to 4.0.4
855- added BuildRoot
856
857* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
858- updated from 3.8.3 to 3.9.1
859- removed PNG patch (appears to be fixed)
860
861* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
862- build against new libpng
863
864* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
865- built against glibc
866
867* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
868- updated to version 3.8.3.
869- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.