source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 6774

Revision 6774, 28.5 KB checked in by Takemikaduchi, 12 years ago (diff)

libalkimia, libdbi: new package
others: new upstream release

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.7.9
5%define Patchlevel 3
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 1%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.xz
24%endif
25#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
26URL: http://www.imagemagick.org/
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: bzip2-devel
30BuildRequires: cairo-devel
31BuildRequires: pango-devel
32BuildRequires: freetype2-devel >= 2.1.7
33BuildRequires: fontconfig-devel
34BuildRequires: giflib-devel
35BuildRequires: graphviz-devel
36BuildRequires: lcms2-devel
37BuildRequires: libjpeg-turbo-devel
38BuildRequires: libpng-devel >= 1.2.5
39BuildRequires: librsvg2-devel
40BuildRequires: libtiff-devel
41BuildRequires: libxml2-devel
42BuildRequires: libSM-devel
43BuildRequires: libX11-devel
44BuildRequires: libXext-devel
45BuildRequires: OpenEXR-devel
46BuildRequires: perl
47BuildRequires: xorg-x11-server-utils
48BuildRequires: zlib-devel
49BuildRequires: libXt-devel
50BuildRequires: xz-devel
51BuildRequires: xz-lzma-compat
52BuildRequires: libtool-ltdl-devel
53
54Requires: bzip2
55Requires: freetype2
56Requires: giflib
57Requires: graphviz
58Requires: lcms2
59Requires: libjpeg-turbo
60Requires: libpng
61Requires: libtiff
62Requires: libxml2
63Requires: OpenEXR-libs
64Requires: xorg-x11-server-utils
65Requires: zlib
66
67Vendor: Project Vine
68Distribution: Vine Linux
69Packager: inagaki, iwamoto
70
71%description
72ImageMagick(TM) is an image display and manipulation tool for the X
73Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
74and Photo CD image formats. It can resize, rotate, sharpen, color
75reduce, or add special effects to an image, and when finished you can
76either save the completed work in the original format or a different
77one. ImageMagick also includes command line programs for creating
78animated or transparent .gifs, creating composite images, creating
79thumbnail images, and more.
80
81ImageMagick is one of your choices if you need a program to manipulate
82and dis play images. If you want to develop your own applications
83which use ImageMagick code or APIs, you need to install
84ImageMagick-devel as well.
85
86
87%description -l ja
88ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
89ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
90イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
91出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
92オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
93また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
94サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
95
96画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
97も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
98アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
99インストールして下さい.
100
101%package devel
102Summary: Static libraries and header files for ImageMagick app development.
103Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
104Group: Development/Libraries
105Requires: ImageMagick = %{version}-%{release}
106
107%description devel
108Image-Magick-devel contains the static libraries and header files you'll
109need to develop ImageMagick applications. ImageMagick is an image
110manipulation program.
111
112If you want to create applications that will use ImageMagick code or
113APIs, you need to install ImageMagick-devel as well as ImageMagick.
114You do noy need to install it if you just want to use ImageMagick,
115however.
116
117%description devel -l ja
118ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
119これらは ImageMagick アプリケーションの開発の際に必要となります.
120ImageMagick は画像処理プログラムです.
121
122ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
123この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
124する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
125インストールする必要はありません.
126
127%package c++
128Summary: ImageMagick Magick++ library (C++ bindings)
129Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
130Group: System Environment/Libraries
131Requires: ImageMagick = %{version}-%{release}
132
133%description c++
134This package contains the Magick++ library, a C++ binding to the ImageMagick
135graphics manipulation library.
136
137Install ImageMagick-c++ if you want to use any applications that use Magick++.
138
139%description c++
140このパッケージには Magick++ ライブラリが収められています.
141Magick++ とは ImageMagick ライブラリの C++ バインディングです.
142
143Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
144パッケージをインストールして下さい.
145
146%package c++-devel
147Summary: C++ bindings for the ImageMagick library
148Summary(ja): ImageMagick ライブラリの C++ バインディング
149Group: Development/Libraries
150Requires: ImageMagick = %{version}-%{release}
151Requires: ImageMagick-c++ = %{version}-%{release}
152Requires: ImageMagick-devel = %{version}-%{release}
153
154%description c++-devel
155ImageMagick-devel contains the static libraries and header files you'll
156need to develop ImageMagick applications using the Magick++ C++ bindings.
157ImageMagick is an image manipulation program.
158
159If you want to create applications that will use Magick++ code
160or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
161ImageMagick.
162You don't need to install it if you just want to use ImageMagick, or if you
163want to develop/compile applications using the ImageMagick C interface,
164however.
165
166%description c++-devel -l ja
167ImageMagick-c++-devel には Magick++ C++ バインディングを使った
168ImageMagick アプリケーション開発に必要なスタティックライブラリと
169ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
170
171Magick++ コードや API を使ったアプリケーションを開発する場合は,
172ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
173インストールする必要があります.
174ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
175を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
176インストールする必要はありません.
177
178%package -n perl-Image-Magick
179Summary: ImageMagick perl bindings
180Summary(ja): ImageMagick の Perl バインディング
181Group: Development/Libraries
182Requires: ImageMagick = %{version}-%{release}
183Requires: perl >= 5.8.0
184Obsoletes: ImageMagick-perl < %{version}-%{release}
185Provides: ImageMagick-perl = %{version}-%{release}
186
187%description -n perl-Image-Magick
188Perl bindings to ImageMagick.
189
190Install ImageMagick-perl if you want to use any perl scripts that use
191ImageMagick.
192
193%description -n perl-Image-Magick -l ja
194このパッケージは ImageMagick の Perl バインディングです.
195
196ImageMagick を利用する perl スクリプトを使いたい場合は
197ImageMagick-perl パッケージをインストールして下さい.
198
199
200%prep
201%setup -q -n %{name}-%{VER}-%{Patchlevel}
202
203#patch1 -p1 -b .CVE-2006-5456
204
205%build
206%configure \
207    --enable-silent-rules \
208    --enable-shared \
209    --disable-static \
210    --with-modules \
211    --with-quantum-depth=16 \
212    --without-frozenpaths \
213    --with-x \
214    --without-dps \
215    --without-djvu \
216    --without-fftw \
217    --without-jbig \
218    --without-jp2 \
219    --with-lcms2 \
220    --without-wmf \
221    --with-perl \
222    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
223
224# Disable rpath
225sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
226sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
227
228make %{?_smp_mflags}
229
230%install
231rm -rf $RPM_BUILD_ROOT
232
233make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
234
235# perlmagick: fix perl path of demo files
236%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
237
238find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
239find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
240find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
241
242echo "%defattr(-,root,root)" > perl-pkg-files
243find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
244sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
245
246# remove duplicated doc files
247rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
248rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
249
250# remove files conflict with libtools
251rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
252rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
253
254# remove *.la files
255find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
256
257rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{VER}
258
259%clean
260rm -rf $RPM_BUILD_ROOT
261
262%post -p /sbin/ldconfig
263
264%post c++ -p /sbin/ldconfig
265
266%postun -p /sbin/ldconfig
267
268%postun c++ -p /sbin/ldconfig
269
270
271%files
272%defattr(-,root,root)
273%doc www images
274%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt NEWS.txt index.html
275%dir %{_libdir}/ImageMagick-%{VER}
276%{_libdir}/ImageMagick-%{VER}/config
277%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16
278%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16/*
279%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.so
280%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.la
281%{_libdir}/libMagickCore.so.*
282%{_libdir}/libMagickWand.so.*
283%{_bindir}/[a-z]*
284%{_sysconfdir}/%{name}/*.xml
285#{_sysconfdir}/%{name}/*.icc
286%{_mandir}/man1/ImageMagick.*
287%{_mandir}/man1/[a-z]*
288
289%files devel
290%defattr(-,root,root)
291%{_bindir}/Magick-config
292%{_bindir}/Wand-config
293%{_bindir}/MagickCore-config
294%{_bindir}/MagickWand-config
295#{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.a
296#{_libdir}/libMagickCore.a
297%{_libdir}/libMagickCore.so
298#{_libdir}/libMagickWand.a
299%{_libdir}/libMagickWand.so
300%{_libdir}/pkgconfig/ImageMagick.pc
301%{_libdir}/pkgconfig/Wand.pc
302%{_libdir}/pkgconfig/MagickCore.pc
303%{_libdir}/pkgconfig/MagickWand.pc
304%{_includedir}/ImageMagick/magick
305%{_includedir}/ImageMagick/wand
306%{_mandir}/man1/Magick-config*
307%{_mandir}/man1/Wand-config*
308%{_mandir}/man1/MagickCore-config*
309%{_mandir}/man1/MagickWand-config*
310
311%files c++
312%defattr(-,root,root)
313%{_libdir}/libMagick++.so.*
314
315%files c++-devel
316%defattr(-,root,root)
317%{_bindir}/Magick++-config
318%{_includedir}/ImageMagick/Magick++
319%{_includedir}/ImageMagick/Magick++.h
320#{_libdir}/libMagick++.a
321%{_libdir}/libMagick++.so
322%{_libdir}/pkgconfig/ImageMagick++.pc
323%{_libdir}/pkgconfig/Magick++.pc
324%{_mandir}/man1/Magick++-config*
325
326%files -n perl-Image-Magick -f perl-pkg-files
327%defattr(-,root,root)
328%{_mandir}/man3/*
329
330%changelog
331* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.9.3-1
332- new upstream release
333
334* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.8.3-1
335- new upstream release
336
337* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.7.6-1
338- new upstream release
339
340* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.6.8-1
341- new upstream release
342
343* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.5.10-1
344- new upstream release
345- add BuildRequires: pango-devel
346- change BuildRequires: lcms2-devel instead of lcms-devel
347
348* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
349- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
350
351* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
352- built with perl-5.12.3
353- changed perl subpackage name
354
355* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
356- new upstream release
357
358* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
359- rebuilt with graphviz-2.26.3 again
360
361* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
362- new upstream release
363- rebuilt with graphviz-2.26.3
364
365* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
366- new upstream release
367
368* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
369- rebuild with rpm-4.8.1 for pkg-config file
370- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
371- change Requires: libjpeg-turbo instead of libjpeg
372
373* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
374- new upstream release
375- built with new toolchain
376- added --disable-static to %%configure, removed static libraries
377
378* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
379- added --without-djvu --without-fftw
380
381* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
382- new upstream release
383
384* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
385- new upstream release
386
387* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
388- new upstream release
389- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
390- add R: graphviz, OpenEXR-libs, ilmbase
391
392* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
393- new upstream release
394- added Packager tag
395
396* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
397- new upstream release
398
399* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
400- new upstream release
401- updated BuildRequires
402
403* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
404- enabled lcms as default.
405
406* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
407- new upstream release
408
409* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
410- new upstream release
411
412* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
413- new upstream release
414
415* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
416- new upstream release
417
418* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
419- new upstream release
420- spec in UTF-8
421
422* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
423- enabled to build with lcms (use '--with lcms' to enable).
424
425* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
426- new upstream release
427- rebuilt with perl-5.10.0
428
429* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
430- new upstream release
431- removed *.la files from devel packages
432
433* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
434- new upstream release
435- change files section to fit new release
436- build under new versioning policy
437
438* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
439- new upstream release
440
441* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
442- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
443- add BuildPrereq: librsvg2-devel
444- add %{?_smp_mflags} to make command arg
445
446* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
447- new upstream release
448- changed Group to Applications/Graphics
449
450* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
451- rebuilt for VineSeed
452
453* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
454- update patch1 for fix CVE-2007-0770
455
456* Wed Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
457- upstream release
458- add patch1 for fix CVE-2006-5456
459
460* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
461- rebuilt (for ppc) to resolve reference to invalid *la files
462
463* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
464- new upstream release
465
466* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
467- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
468
469* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
470- new upstream release
471- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
472- add --with-perl-options to configure option
473
474* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
475- new upstream release
476- build with XOrg-6.9.0
477
478* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
479- new upstream release
480- add %%{_mandir}/man1/ImageMagick.* to main package
481
482* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
483- source upgrade
484- remove patch1
485- update %%files
486
487* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
488- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
489  (CAN-2004-0981)
490
491* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
492- move $(pkglibdir)/modules-Q16/*/*.la to main package.
493
494* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
495- source upgrade
496- Patch: change default menu font so display can work without XOrg-75dpi-fonts
497- add missing docs
498- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
499- *.pc should be in -devel package
500- add missing pkg{lib,data}dirs to %%files
501
502* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
503- source upgrade
504- add --without-dot to %%configure option
505- update %%files section
506
507* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
508- source upgrade
509
510* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
511- source upgrade
512
513* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
514- add --without-jbig to %%configure option
515
516* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
517- add --without-lcms to %%configure option
518
519* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
520- source upgrade
521- remove commented lines
522
523* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
524- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
525
526* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
527- source upgrade
528- remove patch for freetype2, no need
529- remove commented lines
530- add --with-quantum-depth=16 --with-modules --enable-lzw
531  --without-frozenpaths to %%configure option
532- remove --with-threads --without-xml from %%configure option
533- update %%files
534
535* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
536- patch update
537- add --without-jp2 to configure option
538- change PerlMagick build method
539
540* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
541- rebuild without jasper-devel
542
543* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
544- source upgrade to 5.5.7-15
545
546* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
547- source upgrade to 5.5.7-13
548- add patch0 to build against freetype2-2.1.7
549
550* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
551- source upgrade to 5.5.7-11
552- clean up spec
553- build without previous package (do not require libMagick.so.0)
554
555* Sun Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
556- source upgrade to 5.5.7-9
557- revised name of pkgconfig files
558- remove BuildPrereq: freetype-devel
559
560* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
561- source upgrade to 5.5.7-6
562- disable all patches
563- revised %%files section
564- disable libtoolize and autotools
565- change PerlMagick build method
566- build without previous package (do not require libMagick.so.5)
567
568* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
569- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
570  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
571
572* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
573- rebuild
574
575* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
576- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
577- FIXME: rpm's macro problem?
578
579- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
580  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
581
582  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
583  - remove unnecessary duplicated %%doc files
584  - --without-xml instead of --without-ttf
585  - eliminate libungif(-devel) from BuildReq/Requires
586  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
587
588  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
589  - add delegetes.mgk (and %%{_libdir}/%%{name})
590
591  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
592  - 5.2.9-0vl4
593  - Sorry, the spec was in Shift_JIS. Fixed.
594
595  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
596  - 5.2.9-0vl3
597  - rebuilt with perl-5.6.1
598  - added Japanese summary and description :-P
599  - added --without-ttf in order to disable freetype2 (SeedPlus) support
600  - added --without-wmf in order to disable libwmf (SeedPlus) support
601
602  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
603  - 5.2.9-0vl2
604  - rebuild on Perl-5.6
605  - use %%{perl_sitearch}
606  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
607
608  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
609  - 5.2.9-0vl1
610  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
611
612* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
613- fix perl paths in file list
614
615* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
616- lib64'ize
617- don't throw stuff in /usr/X11R6, that's for X only
618- remove files we aren't shipping
619
620* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
621- rebuilt with gcc-3.2 (we hope)
622
623* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
624- build using gcc-3.2-0.1
625
626* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
627- fix non-cpp headers in -devel package
628- fix #62157 (wrong path for include files in ImageMagick-devel)
629- fix #63897 (use _target instead of _arch) in libtool workaround
630- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
631
632* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
633- update
634- fix localdoc patch
635- fix %%files section
636- disable nonroot patch
637- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
638- fix libtool workaround
639- moved Magick*-config into -devel package (#64249)
640
641* Sun May 26 2002 Tim Powers <timp@redhat.com>
642- automated rebuild
643
644* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
645- 5.4.6
646
647* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
648- Update to pl 11
649
650* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
651- Update to 5.4.3 pl5; this fixes #58080
652
653* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
654- Patchlevel 3
655
656* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
657- automated rebuild
658
659* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
660- Update to 5.4.2-2
661- Fix #57923, also don't hardcode netscape as html viewer
662
663* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
664- 5.4.1
665- Link against new libstdc++
666
667* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
668- 5.4.0.5
669- Make the error message when trying to display an hpgl file more
670  explicit (#55875)
671
672* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
673- 5.4.0.3
674- Fix names of man pages
675
676* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
677- 5.4.0
678- work around build system breakage causing applications to be named
679  %{_arch}-redhat-linux-foo rather than foo
680
681* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
682- 5.3.9
683
684* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
685- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
686  (#52611)
687
688* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
689- Remove Magick++ includes from -devel, they're already in -c++-devel
690  (#51590)
691
692* Sun Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
693- 5.3.8 (bugfix release)
694
695* Sat Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
696- fix to build Perlmagic on s390 s390x
697
698* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
699- Add delegates.mgk to the package (#50725)
700
701* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
702- 5.3.7
703- Fix build without previously installed ImageMagick-devel (#49816)
704- Move perl bindings to a separate package.
705
706* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
707- Fix build as non-root again
708- Shut up rpmlint
709
710* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
711- 5.3.6
712- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
713
714* Sat Jun 16 2001 Than Ngo <than@redhat.com>
715- update to 5.3.5
716- cleanup specfile
717
718* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
719- 5.3.3-respin, fixes #41196
720
721* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
722- 5.3.3
723- Add a desktop file for "display" (RFE#17417)
724
725* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
726- 5.3.2
727- work around bugs in ia64 glibc headers
728
729* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
730- remove patch for s390, it is not necessary
731
732* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
733- 5.2.7
734
735* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
736- 5.2.6
737
738* Mon Dec 18 2000 Than Ngo <than@redhat.com>
739- ported to s390
740
741* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
742- 5.2.4
743- Fix up and package the C++ bindings in the new c++/c++-devel packages.
744
745* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
746- rebuild against new libpng
747
748* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
749- include images with docs (#10312)
750
751* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
752- don't build with -ggdb, use -g instead.
753
754* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
755- automatic rebuild
756
757* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
758- update to 5.2.2 beta
759
760* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
761- update to 5.2.1, redone patches as they failed
762
763* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
764- remove hacks to move perl man pages
765- don't include the perl*/man stuff, these files go in /usr/share/man now.
766
767* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
768- disable optimization on Alpha and Sparc
769
770* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
771- update to 5.2.0
772- update URL
773- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
774
775* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
776- bootstrap rebuilt to nuke broken libbz2 deps
777- add Prefix: tag such that the FHS macros work properly
778
779* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
780- now compiles with bzip2 1.0
781- changed buildroot to include version
782
783* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
784- fix compilation with new perl
785
786* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
787- 5.1.1
788
789* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
790- Rebuild to get compressed man pages
791
792* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
793- ugly hack to print with lpr instead of lp
794
795* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
796- update to 4.2.9
797
798* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
799- update to 4.2.8
800
801* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
802- include the perl man pages as well
803
804* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
805- remove --enable-16bit because it damages interoperability
806
807* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
808- update to 4.2.2
809- change ChangeLog to refer to actual dates.
810- strip binaries
811
812* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
813- add more files. Oops.
814
815* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
816- auto rebuild in the new build environment (release 2)
817
818* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
819- version 4.2.1
820
821* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
822- changed group
823
824* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
825- hacks to make it work with the new perl
826- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
827- make sure the libraries have the x bit on
828
829* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
830- translations modified for de, fr
831
832* Thu May 07 1998 Prospector System <bugs@redhat.com>
833- translations modified for de, fr, tr
834
835* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
836- updated to 4.0.5
837
838* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
839- updated to 4.0.4
840- added BuildRoot
841
842* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
843- updated from 3.8.3 to 3.9.1
844- removed PNG patch (appears to be fixed)
845
846* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
847- build against new libpng
848
849* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
850- built against glibc
851
852* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
853- updated to version 3.8.3.
854- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.