source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 6581

Revision 6581, 28.4 KB checked in by Takemikaduchi, 12 years ago (diff)

cogl: bug fix
others: new upstream release

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.7.8
5%define Patchlevel 3
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 1%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.xz
24%endif
25#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
26URL: http://www.imagemagick.org/
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: bzip2-devel
30BuildRequires: cairo-devel
31BuildRequires: pango-devel
32BuildRequires: freetype2-devel >= 2.1.7
33BuildRequires: fontconfig-devel
34BuildRequires: giflib-devel
35BuildRequires: graphviz-devel
36BuildRequires: lcms2-devel
37BuildRequires: libjpeg-turbo-devel
38BuildRequires: libpng-devel >= 1.2.5
39BuildRequires: librsvg2-devel
40BuildRequires: libtiff-devel
41BuildRequires: libxml2-devel
42BuildRequires: libSM-devel
43BuildRequires: libX11-devel
44BuildRequires: libXext-devel
45BuildRequires: OpenEXR-devel
46BuildRequires: perl
47BuildRequires: xorg-x11-server-utils
48BuildRequires: zlib-devel
49BuildRequires: libXt-devel
50BuildRequires: xz-devel
51BuildRequires: xz-lzma-compat
52BuildRequires: libtool-ltdl-devel
53
54Requires: bzip2
55Requires: freetype2
56Requires: giflib
57Requires: graphviz
58Requires: lcms2
59Requires: libjpeg-turbo
60Requires: libpng
61Requires: libtiff
62Requires: libxml2
63Requires: OpenEXR-libs
64Requires: xorg-x11-server-utils
65Requires: zlib
66
67Vendor: Project Vine
68Distribution: Vine Linux
69Packager: inagaki, iwamoto
70
71%description
72ImageMagick(TM) is an image display and manipulation tool for the X
73Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
74and Photo CD image formats. It can resize, rotate, sharpen, color
75reduce, or add special effects to an image, and when finished you can
76either save the completed work in the original format or a different
77one. ImageMagick also includes command line programs for creating
78animated or transparent .gifs, creating composite images, creating
79thumbnail images, and more.
80
81ImageMagick is one of your choices if you need a program to manipulate
82and dis play images. If you want to develop your own applications
83which use ImageMagick code or APIs, you need to install
84ImageMagick-devel as well.
85
86
87%description -l ja
88ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
89ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
90イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
91出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
92オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
93また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
94サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
95
96画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
97も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
98アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
99インストールして下さい.
100
101%package devel
102Summary: Static libraries and header files for ImageMagick app development.
103Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
104Group: Development/Libraries
105Requires: ImageMagick = %{version}-%{release}
106
107%description devel
108Image-Magick-devel contains the static libraries and header files you'll
109need to develop ImageMagick applications. ImageMagick is an image
110manipulation program.
111
112If you want to create applications that will use ImageMagick code or
113APIs, you need to install ImageMagick-devel as well as ImageMagick.
114You do noy need to install it if you just want to use ImageMagick,
115however.
116
117%description devel -l ja
118ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
119これらは ImageMagick アプリケーションの開発の際に必要となります.
120ImageMagick は画像処理プログラムです.
121
122ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
123この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
124する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
125インストールする必要はありません.
126
127%package c++
128Summary: ImageMagick Magick++ library (C++ bindings)
129Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
130Group: System Environment/Libraries
131Requires: ImageMagick = %{version}-%{release}
132
133%description c++
134This package contains the Magick++ library, a C++ binding to the ImageMagick
135graphics manipulation library.
136
137Install ImageMagick-c++ if you want to use any applications that use Magick++.
138
139%description c++
140このパッケージには Magick++ ライブラリが収められています.
141Magick++ とは ImageMagick ライブラリの C++ バインディングです.
142
143Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
144パッケージをインストールして下さい.
145
146%package c++-devel
147Summary: C++ bindings for the ImageMagick library
148Summary(ja): ImageMagick ライブラリの C++ バインディング
149Group: Development/Libraries
150Requires: ImageMagick = %{version}-%{release}
151Requires: ImageMagick-c++ = %{version}-%{release}
152Requires: ImageMagick-devel = %{version}-%{release}
153
154%description c++-devel
155ImageMagick-devel contains the static libraries and header files you'll
156need to develop ImageMagick applications using the Magick++ C++ bindings.
157ImageMagick is an image manipulation program.
158
159If you want to create applications that will use Magick++ code
160or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
161ImageMagick.
162You don't need to install it if you just want to use ImageMagick, or if you
163want to develop/compile applications using the ImageMagick C interface,
164however.
165
166%description c++-devel -l ja
167ImageMagick-c++-devel には Magick++ C++ バインディングを使った
168ImageMagick アプリケーション開発に必要なスタティックライブラリと
169ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
170
171Magick++ コードや API を使ったアプリケーションを開発する場合は,
172ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
173インストールする必要があります.
174ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
175を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
176インストールする必要はありません.
177
178%package -n perl-Image-Magick
179Summary: ImageMagick perl bindings
180Summary(ja): ImageMagick の Perl バインディング
181Group: Development/Libraries
182Requires: ImageMagick = %{version}-%{release}
183Requires: perl >= 5.8.0
184Obsoletes: ImageMagick-perl < %{version}-%{release}
185Provides: ImageMagick-perl = %{version}-%{release}
186
187%description -n perl-Image-Magick
188Perl bindings to ImageMagick.
189
190Install ImageMagick-perl if you want to use any perl scripts that use
191ImageMagick.
192
193%description -n perl-Image-Magick -l ja
194このパッケージは ImageMagick の Perl バインディングです.
195
196ImageMagick を利用する perl スクリプトを使いたい場合は
197ImageMagick-perl パッケージをインストールして下さい.
198
199
200%prep
201%setup -q -n %{name}-%{VER}-%{Patchlevel}
202
203#patch1 -p1 -b .CVE-2006-5456
204
205%build
206%configure \
207    --enable-silent-rules \
208    --enable-shared \
209    --disable-static \
210    --with-modules \
211    --with-quantum-depth=16 \
212    --without-frozenpaths \
213    --with-x \
214    --without-dps \
215    --without-djvu \
216    --without-fftw \
217    --without-jbig \
218    --without-jp2 \
219    --with-lcms2 \
220    --without-wmf \
221    --with-perl \
222    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
223
224# Disable rpath
225sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
226sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
227
228make %{?_smp_mflags}
229
230%install
231rm -rf $RPM_BUILD_ROOT
232
233make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
234
235# perlmagick: fix perl path of demo files
236%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
237
238find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
239find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
240find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
241
242echo "%defattr(-,root,root)" > perl-pkg-files
243find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
244sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
245
246# remove duplicated doc files
247rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
248rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
249
250# remove files conflict with libtools
251rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
252rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
253
254# remove *.la files
255find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
256
257rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{VER}
258
259%clean
260rm -rf $RPM_BUILD_ROOT
261
262%post -p /sbin/ldconfig
263
264%post c++ -p /sbin/ldconfig
265
266%postun -p /sbin/ldconfig
267
268%postun c++ -p /sbin/ldconfig
269
270
271%files
272%defattr(-,root,root)
273%doc www images
274%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt NEWS.txt index.html
275%dir %{_libdir}/ImageMagick-%{VER}
276%{_libdir}/ImageMagick-%{VER}/config
277%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16
278%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16/*
279%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.so
280%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.la
281%{_libdir}/libMagickCore.so.*
282%{_libdir}/libMagickWand.so.*
283%{_bindir}/[a-z]*
284%{_sysconfdir}/%{name}/*.xml
285#{_sysconfdir}/%{name}/*.icc
286%{_mandir}/man1/ImageMagick.*
287%{_mandir}/man1/[a-z]*
288
289%files devel
290%defattr(-,root,root)
291%{_bindir}/Magick-config
292%{_bindir}/Wand-config
293%{_bindir}/MagickCore-config
294%{_bindir}/MagickWand-config
295#{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.a
296#{_libdir}/libMagickCore.a
297%{_libdir}/libMagickCore.so
298#{_libdir}/libMagickWand.a
299%{_libdir}/libMagickWand.so
300%{_libdir}/pkgconfig/ImageMagick.pc
301%{_libdir}/pkgconfig/Wand.pc
302%{_libdir}/pkgconfig/MagickCore.pc
303%{_libdir}/pkgconfig/MagickWand.pc
304%{_includedir}/ImageMagick/magick
305%{_includedir}/ImageMagick/wand
306%{_mandir}/man1/Magick-config*
307%{_mandir}/man1/Wand-config*
308%{_mandir}/man1/MagickCore-config*
309%{_mandir}/man1/MagickWand-config*
310
311%files c++
312%defattr(-,root,root)
313%{_libdir}/libMagick++.so.*
314
315%files c++-devel
316%defattr(-,root,root)
317%{_bindir}/Magick++-config
318%{_includedir}/ImageMagick/Magick++
319%{_includedir}/ImageMagick/Magick++.h
320#{_libdir}/libMagick++.a
321%{_libdir}/libMagick++.so
322%{_libdir}/pkgconfig/ImageMagick++.pc
323%{_libdir}/pkgconfig/Magick++.pc
324%{_mandir}/man1/Magick++-config*
325
326%files -n perl-Image-Magick -f perl-pkg-files
327%defattr(-,root,root)
328%{_mandir}/man3/*
329
330%changelog
331* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.8.3-1
332- new upstream release
333
334* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.7.6-1
335- new upstream release
336
337* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.6.8-1
338- new upstream release
339
340* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.5.10-1
341- new upstream release
342- add BuildRequires: pango-devel
343- change BuildRequires: lcms2-devel instead of lcms-devel
344
345* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
346- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
347
348* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
349- built with perl-5.12.3
350- changed perl subpackage name
351
352* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
353- new upstream release
354
355* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
356- rebuilt with graphviz-2.26.3 again
357
358* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
359- new upstream release
360- rebuilt with graphviz-2.26.3
361
362* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
363- new upstream release
364
365* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
366- rebuild with rpm-4.8.1 for pkg-config file
367- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
368- change Requires: libjpeg-turbo instead of libjpeg
369
370* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
371- new upstream release
372- built with new toolchain
373- added --disable-static to %%configure, removed static libraries
374
375* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
376- added --without-djvu --without-fftw
377
378* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
379- new upstream release
380
381* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
382- new upstream release
383
384* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
385- new upstream release
386- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
387- add R: graphviz, OpenEXR-libs, ilmbase
388
389* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
390- new upstream release
391- added Packager tag
392
393* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
394- new upstream release
395
396* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
397- new upstream release
398- updated BuildRequires
399
400* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
401- enabled lcms as default.
402
403* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
404- new upstream release
405
406* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
407- new upstream release
408
409* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
410- new upstream release
411
412* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
413- new upstream release
414
415* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
416- new upstream release
417- spec in UTF-8
418
419* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
420- enabled to build with lcms (use '--with lcms' to enable).
421
422* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
423- new upstream release
424- rebuilt with perl-5.10.0
425
426* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
427- new upstream release
428- removed *.la files from devel packages
429
430* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
431- new upstream release
432- change files section to fit new release
433- build under new versioning policy
434
435* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
436- new upstream release
437
438* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
439- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
440- add BuildPrereq: librsvg2-devel
441- add %{?_smp_mflags} to make command arg
442
443* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
444- new upstream release
445- changed Group to Applications/Graphics
446
447* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
448- rebuilt for VineSeed
449
450* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
451- update patch1 for fix CVE-2007-0770
452
453* Wed Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
454- upstream release
455- add patch1 for fix CVE-2006-5456
456
457* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
458- rebuilt (for ppc) to resolve reference to invalid *la files
459
460* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
461- new upstream release
462
463* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
464- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
465
466* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
467- new upstream release
468- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
469- add --with-perl-options to configure option
470
471* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
472- new upstream release
473- build with XOrg-6.9.0
474
475* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
476- new upstream release
477- add %%{_mandir}/man1/ImageMagick.* to main package
478
479* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
480- source upgrade
481- remove patch1
482- update %%files
483
484* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
485- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
486  (CAN-2004-0981)
487
488* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
489- move $(pkglibdir)/modules-Q16/*/*.la to main package.
490
491* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
492- source upgrade
493- Patch: change default menu font so display can work without XOrg-75dpi-fonts
494- add missing docs
495- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
496- *.pc should be in -devel package
497- add missing pkg{lib,data}dirs to %%files
498
499* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
500- source upgrade
501- add --without-dot to %%configure option
502- update %%files section
503
504* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
505- source upgrade
506
507* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
508- source upgrade
509
510* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
511- add --without-jbig to %%configure option
512
513* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
514- add --without-lcms to %%configure option
515
516* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
517- source upgrade
518- remove commented lines
519
520* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
521- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
522
523* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
524- source upgrade
525- remove patch for freetype2, no need
526- remove commented lines
527- add --with-quantum-depth=16 --with-modules --enable-lzw
528  --without-frozenpaths to %%configure option
529- remove --with-threads --without-xml from %%configure option
530- update %%files
531
532* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
533- patch update
534- add --without-jp2 to configure option
535- change PerlMagick build method
536
537* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
538- rebuild without jasper-devel
539
540* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
541- source upgrade to 5.5.7-15
542
543* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
544- source upgrade to 5.5.7-13
545- add patch0 to build against freetype2-2.1.7
546
547* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
548- source upgrade to 5.5.7-11
549- clean up spec
550- build without previous package (do not require libMagick.so.0)
551
552* Sun Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
553- source upgrade to 5.5.7-9
554- revised name of pkgconfig files
555- remove BuildPrereq: freetype-devel
556
557* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
558- source upgrade to 5.5.7-6
559- disable all patches
560- revised %%files section
561- disable libtoolize and autotools
562- change PerlMagick build method
563- build without previous package (do not require libMagick.so.5)
564
565* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
566- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
567  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
568
569* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
570- rebuild
571
572* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
573- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
574- FIXME: rpm's macro problem?
575
576- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
577  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
578
579  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
580  - remove unnecessary duplicated %%doc files
581  - --without-xml instead of --without-ttf
582  - eliminate libungif(-devel) from BuildReq/Requires
583  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
584
585  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
586  - add delegetes.mgk (and %%{_libdir}/%%{name})
587
588  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
589  - 5.2.9-0vl4
590  - Sorry, the spec was in Shift_JIS. Fixed.
591
592  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
593  - 5.2.9-0vl3
594  - rebuilt with perl-5.6.1
595  - added Japanese summary and description :-P
596  - added --without-ttf in order to disable freetype2 (SeedPlus) support
597  - added --without-wmf in order to disable libwmf (SeedPlus) support
598
599  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
600  - 5.2.9-0vl2
601  - rebuild on Perl-5.6
602  - use %%{perl_sitearch}
603  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
604
605  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
606  - 5.2.9-0vl1
607  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
608
609* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
610- fix perl paths in file list
611
612* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
613- lib64'ize
614- don't throw stuff in /usr/X11R6, that's for X only
615- remove files we aren't shipping
616
617* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
618- rebuilt with gcc-3.2 (we hope)
619
620* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
621- build using gcc-3.2-0.1
622
623* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
624- fix non-cpp headers in -devel package
625- fix #62157 (wrong path for include files in ImageMagick-devel)
626- fix #63897 (use _target instead of _arch) in libtool workaround
627- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
628
629* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
630- update
631- fix localdoc patch
632- fix %%files section
633- disable nonroot patch
634- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
635- fix libtool workaround
636- moved Magick*-config into -devel package (#64249)
637
638* Sun May 26 2002 Tim Powers <timp@redhat.com>
639- automated rebuild
640
641* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
642- 5.4.6
643
644* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
645- Update to pl 11
646
647* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
648- Update to 5.4.3 pl5; this fixes #58080
649
650* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
651- Patchlevel 3
652
653* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
654- automated rebuild
655
656* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
657- Update to 5.4.2-2
658- Fix #57923, also don't hardcode netscape as html viewer
659
660* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
661- 5.4.1
662- Link against new libstdc++
663
664* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
665- 5.4.0.5
666- Make the error message when trying to display an hpgl file more
667  explicit (#55875)
668
669* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
670- 5.4.0.3
671- Fix names of man pages
672
673* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
674- 5.4.0
675- work around build system breakage causing applications to be named
676  %{_arch}-redhat-linux-foo rather than foo
677
678* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
679- 5.3.9
680
681* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
682- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
683  (#52611)
684
685* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
686- Remove Magick++ includes from -devel, they're already in -c++-devel
687  (#51590)
688
689* Sun Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
690- 5.3.8 (bugfix release)
691
692* Sat Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
693- fix to build Perlmagic on s390 s390x
694
695* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
696- Add delegates.mgk to the package (#50725)
697
698* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
699- 5.3.7
700- Fix build without previously installed ImageMagick-devel (#49816)
701- Move perl bindings to a separate package.
702
703* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
704- Fix build as non-root again
705- Shut up rpmlint
706
707* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
708- 5.3.6
709- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
710
711* Sat Jun 16 2001 Than Ngo <than@redhat.com>
712- update to 5.3.5
713- cleanup specfile
714
715* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
716- 5.3.3-respin, fixes #41196
717
718* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
719- 5.3.3
720- Add a desktop file for "display" (RFE#17417)
721
722* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
723- 5.3.2
724- work around bugs in ia64 glibc headers
725
726* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
727- remove patch for s390, it is not necessary
728
729* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
730- 5.2.7
731
732* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
733- 5.2.6
734
735* Mon Dec 18 2000 Than Ngo <than@redhat.com>
736- ported to s390
737
738* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
739- 5.2.4
740- Fix up and package the C++ bindings in the new c++/c++-devel packages.
741
742* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
743- rebuild against new libpng
744
745* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
746- include images with docs (#10312)
747
748* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
749- don't build with -ggdb, use -g instead.
750
751* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
752- automatic rebuild
753
754* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
755- update to 5.2.2 beta
756
757* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
758- update to 5.2.1, redone patches as they failed
759
760* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
761- remove hacks to move perl man pages
762- don't include the perl*/man stuff, these files go in /usr/share/man now.
763
764* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
765- disable optimization on Alpha and Sparc
766
767* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
768- update to 5.2.0
769- update URL
770- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
771
772* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
773- bootstrap rebuilt to nuke broken libbz2 deps
774- add Prefix: tag such that the FHS macros work properly
775
776* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
777- now compiles with bzip2 1.0
778- changed buildroot to include version
779
780* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
781- fix compilation with new perl
782
783* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
784- 5.1.1
785
786* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
787- Rebuild to get compressed man pages
788
789* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
790- ugly hack to print with lpr instead of lp
791
792* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
793- update to 4.2.9
794
795* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
796- update to 4.2.8
797
798* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
799- include the perl man pages as well
800
801* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
802- remove --enable-16bit because it damages interoperability
803
804* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
805- update to 4.2.2
806- change ChangeLog to refer to actual dates.
807- strip binaries
808
809* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
810- add more files. Oops.
811
812* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
813- auto rebuild in the new build environment (release 2)
814
815* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
816- version 4.2.1
817
818* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
819- changed group
820
821* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
822- hacks to make it work with the new perl
823- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
824- make sure the libraries have the x bit on
825
826* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
827- translations modified for de, fr
828
829* Thu May 07 1998 Prospector System <bugs@redhat.com>
830- translations modified for de, fr, tr
831
832* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
833- updated to 4.0.5
834
835* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
836- updated to 4.0.4
837- added BuildRoot
838
839* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
840- updated from 3.8.3 to 3.9.1
841- removed PNG patch (appears to be fixed)
842
843* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
844- build against new libpng
845
846* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
847- built against glibc
848
849* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
850- updated to version 3.8.3.
851- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.