source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 5879

Revision 5879, 28.1 KB checked in by Takemikaduchi, 12 years ago (diff)

ImageMagick?-6.7.5.10

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.7.5
5%define Patchlevel 10
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 1%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.xz
24%endif
25#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
26URL: http://www.imagemagick.org/
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: bzip2-devel
30BuildRequires: cairo-devel
31BuildRequires: pango-devel
32BuildRequires: freetype2-devel >= 2.1.7
33BuildRequires: fontconfig-devel
34BuildRequires: giflib-devel
35BuildRequires: graphviz-devel
36BuildRequires: lcms2-devel
37BuildRequires: libjpeg-turbo-devel
38BuildRequires: libpng-devel >= 1.2.5
39BuildRequires: librsvg2-devel
40BuildRequires: libtiff-devel
41BuildRequires: libxml2-devel
42BuildRequires: libSM-devel
43BuildRequires: libX11-devel
44BuildRequires: libXext-devel
45BuildRequires: OpenEXR-devel
46BuildRequires: perl
47BuildRequires: xorg-x11-server-utils
48BuildRequires: zlib-devel
49BuildRequires: libXt-devel
50BuildRequires: xz-devel
51BuildRequires: xz-lzma-compat
52BuildRequires: libtool-ltdl-devel
53
54Requires: bzip2
55Requires: freetype2
56Requires: giflib
57Requires: graphviz
58Requires: lcms2
59Requires: libjpeg-turbo
60Requires: libpng
61Requires: libtiff
62Requires: libxml2
63Requires: OpenEXR-libs
64Requires: xorg-x11-server-utils
65Requires: zlib
66
67Vendor: Project Vine
68Distribution: Vine Linux
69Packager: inagaki, iwamoto
70
71%description
72ImageMagick(TM) is an image display and manipulation tool for the X
73Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
74and Photo CD image formats. It can resize, rotate, sharpen, color
75reduce, or add special effects to an image, and when finished you can
76either save the completed work in the original format or a different
77one. ImageMagick also includes command line programs for creating
78animated or transparent .gifs, creating composite images, creating
79thumbnail images, and more.
80
81ImageMagick is one of your choices if you need a program to manipulate
82and dis play images. If you want to develop your own applications
83which use ImageMagick code or APIs, you need to install
84ImageMagick-devel as well.
85
86
87%description -l ja
88ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
89ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
90イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
91出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
92オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
93また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
94サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
95
96画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
97も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
98アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
99インストールして下さい.
100
101%package devel
102Summary: Static libraries and header files for ImageMagick app development.
103Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
104Group: Development/Libraries
105Requires: ImageMagick = %{version}-%{release}
106
107%description devel
108Image-Magick-devel contains the static libraries and header files you'll
109need to develop ImageMagick applications. ImageMagick is an image
110manipulation program.
111
112If you want to create applications that will use ImageMagick code or
113APIs, you need to install ImageMagick-devel as well as ImageMagick.
114You do noy need to install it if you just want to use ImageMagick,
115however.
116
117%description devel -l ja
118ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
119これらは ImageMagick アプリケーションの開発の際に必要となります.
120ImageMagick は画像処理プログラムです.
121
122ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
123この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
124する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
125インストールする必要はありません.
126
127%package c++
128Summary: ImageMagick Magick++ library (C++ bindings)
129Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
130Group: System Environment/Libraries
131Requires: ImageMagick = %{version}-%{release}
132
133%description c++
134This package contains the Magick++ library, a C++ binding to the ImageMagick
135graphics manipulation library.
136
137Install ImageMagick-c++ if you want to use any applications that use Magick++.
138
139%description c++
140このパッケージには Magick++ ライブラリが収められています.
141Magick++ とは ImageMagick ライブラリの C++ バインディングです.
142
143Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
144パッケージをインストールして下さい.
145
146%package c++-devel
147Summary: C++ bindings for the ImageMagick library
148Summary(ja): ImageMagick ライブラリの C++ バインディング
149Group: Development/Libraries
150Requires: ImageMagick = %{version}-%{release}
151Requires: ImageMagick-c++ = %{version}-%{release}
152Requires: ImageMagick-devel = %{version}-%{release}
153
154%description c++-devel
155ImageMagick-devel contains the static libraries and header files you'll
156need to develop ImageMagick applications using the Magick++ C++ bindings.
157ImageMagick is an image manipulation program.
158
159If you want to create applications that will use Magick++ code
160or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
161ImageMagick.
162You don't need to install it if you just want to use ImageMagick, or if you
163want to develop/compile applications using the ImageMagick C interface,
164however.
165
166%description c++-devel -l ja
167ImageMagick-c++-devel には Magick++ C++ バインディングを使った
168ImageMagick アプリケーション開発に必要なスタティックライブラリと
169ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
170
171Magick++ コードや API を使ったアプリケーションを開発する場合は,
172ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
173インストールする必要があります.
174ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
175を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
176インストールする必要はありません.
177
178%package -n perl-Image-Magick
179Summary: ImageMagick perl bindings
180Summary(ja): ImageMagick の Perl バインディング
181Group: Development/Libraries
182Requires: ImageMagick = %{version}-%{release}
183Requires: perl >= 5.8.0
184Obsoletes: ImageMagick-perl < %{version}-%{release}
185Provides: ImageMagick-perl = %{version}-%{release}
186
187%description -n perl-Image-Magick
188Perl bindings to ImageMagick.
189
190Install ImageMagick-perl if you want to use any perl scripts that use
191ImageMagick.
192
193%description -n perl-Image-Magick -l ja
194このパッケージは ImageMagick の Perl バインディングです.
195
196ImageMagick を利用する perl スクリプトを使いたい場合は
197ImageMagick-perl パッケージをインストールして下さい.
198
199
200%prep
201%setup -q -n %{name}-%{VER}-%{Patchlevel}
202
203#patch1 -p1 -b .CVE-2006-5456
204
205%build
206%configure \
207    --enable-silent-rules \
208    --enable-shared \
209    --disable-static \
210    --with-modules \
211    --with-quantum-depth=16 \
212    --without-frozenpaths \
213    --with-x \
214    --without-djvu \
215    --without-fftw \
216    --without-jbig \
217    --without-jp2 \
218    --with-lcms2 \
219    --without-wmf \
220    --with-perl \
221    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
222
223# Disable rpath
224sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
225sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
226
227make %{?_smp_mflags}
228
229%install
230rm -rf $RPM_BUILD_ROOT
231
232make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
233
234# perlmagick: fix perl path of demo files
235%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
236
237find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
238find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
239find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
240
241echo "%defattr(-,root,root)" > perl-pkg-files
242find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
243sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
244
245# remove duplicated doc files
246rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
247rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
248
249# remove files conflict with libtools
250rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
251rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
252
253# remove *.la files
254find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
255
256%clean
257rm -rf $RPM_BUILD_ROOT
258
259%post -p /sbin/ldconfig
260
261%post c++ -p /sbin/ldconfig
262
263%postun -p /sbin/ldconfig
264
265%postun c++ -p /sbin/ldconfig
266
267
268%files
269%defattr(-,root,root)
270%doc www images
271%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt NEWS.txt index.html
272%dir %{_libdir}/ImageMagick-%{VER}
273%{_libdir}/ImageMagick-%{VER}/config
274%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16
275%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16/*
276%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.so
277%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.la
278%{_libdir}/libMagickCore.so.*
279%{_libdir}/libMagickWand.so.*
280%{_bindir}/[a-z]*
281%{_sysconfdir}/%{name}/*.xml
282%{_sysconfdir}/%{name}/*.icc
283%{_mandir}/man1/ImageMagick.*
284%{_mandir}/man1/[a-z]*
285
286%files devel
287%defattr(-,root,root)
288%{_bindir}/Magick-config
289%{_bindir}/Wand-config
290%{_bindir}/MagickCore-config
291%{_bindir}/MagickWand-config
292#{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.a
293#{_libdir}/libMagickCore.a
294%{_libdir}/libMagickCore.so
295#{_libdir}/libMagickWand.a
296%{_libdir}/libMagickWand.so
297%{_libdir}/pkgconfig/ImageMagick.pc
298%{_libdir}/pkgconfig/Wand.pc
299%{_libdir}/pkgconfig/MagickCore.pc
300%{_libdir}/pkgconfig/MagickWand.pc
301%{_includedir}/ImageMagick/magick
302%{_includedir}/ImageMagick/wand
303%{_mandir}/man1/Magick-config*
304%{_mandir}/man1/Wand-config*
305%{_mandir}/man1/MagickCore-config*
306%{_mandir}/man1/MagickWand-config*
307
308%files c++
309%defattr(-,root,root)
310%{_libdir}/libMagick++.so.*
311
312%files c++-devel
313%defattr(-,root,root)
314%{_bindir}/Magick++-config
315%{_includedir}/ImageMagick/Magick++
316%{_includedir}/ImageMagick/Magick++.h
317#{_libdir}/libMagick++.a
318%{_libdir}/libMagick++.so
319%{_libdir}/pkgconfig/ImageMagick++.pc
320%{_libdir}/pkgconfig/Magick++.pc
321%{_mandir}/man1/Magick++-config*
322
323%files -n perl-Image-Magick -f perl-pkg-files
324%defattr(-,root,root)
325%{_mandir}/man3/*
326
327%changelog
328* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.5.10-1
329- new upstream release
330- add BuildRequires: pango-devel
331- change BuildRequires: lcms2-devel instead of lcms-devel
332
333* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
334- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
335
336* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
337- built with perl-5.12.3
338- changed perl subpackage name
339
340* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
341- new upstream release
342
343* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
344- rebuilt with graphviz-2.26.3 again
345
346* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
347- new upstream release
348- rebuilt with graphviz-2.26.3
349
350* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
351- new upstream release
352
353* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
354- rebuild with rpm-4.8.1 for pkg-config file
355- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
356- change Requires: libjpeg-turbo instead of libjpeg
357
358* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
359- new upstream release
360- built with new toolchain
361- added --disable-static to %%configure, removed static libraries
362
363* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
364- added --without-djvu --without-fftw
365
366* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
367- new upstream release
368
369* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
370- new upstream release
371
372* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
373- new upstream release
374- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
375- add R: graphviz, OpenEXR-libs, ilmbase
376
377* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
378- new upstream release
379- added Packager tag
380
381* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
382- new upstream release
383
384* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
385- new upstream release
386- updated BuildRequires
387
388* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
389- enabled lcms as default.
390
391* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
392- new upstream release
393
394* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
395- new upstream release
396
397* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
398- new upstream release
399
400* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
401- new upstream release
402
403* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
404- new upstream release
405- spec in UTF-8
406
407* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
408- enabled to build with lcms (use '--with lcms' to enable).
409
410* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
411- new upstream release
412- rebuilt with perl-5.10.0
413
414* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
415- new upstream release
416- removed *.la files from devel packages
417
418* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
419- new upstream release
420- change files section to fit new release
421- build under new versioning policy
422
423* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
424- new upstream release
425
426* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
427- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
428- add BuildPrereq: librsvg2-devel
429- add %{?_smp_mflags} to make command arg
430
431* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
432- new upstream release
433- changed Group to Applications/Graphics
434
435* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
436- rebuilt for VineSeed
437
438* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
439- update patch1 for fix CVE-2007-0770
440
441* Wed Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
442- upstream release
443- add patch1 for fix CVE-2006-5456
444
445* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
446- rebuilt (for ppc) to resolve reference to invalid *la files
447
448* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
449- new upstream release
450
451* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
452- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
453
454* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
455- new upstream release
456- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
457- add --with-perl-options to configure option
458
459* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
460- new upstream release
461- build with XOrg-6.9.0
462
463* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
464- new upstream release
465- add %%{_mandir}/man1/ImageMagick.* to main package
466
467* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
468- source upgrade
469- remove patch1
470- update %%files
471
472* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
473- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
474  (CAN-2004-0981)
475
476* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
477- move $(pkglibdir)/modules-Q16/*/*.la to main package.
478
479* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
480- source upgrade
481- Patch: change default menu font so display can work without XOrg-75dpi-fonts
482- add missing docs
483- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
484- *.pc should be in -devel package
485- add missing pkg{lib,data}dirs to %%files
486
487* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
488- source upgrade
489- add --without-dot to %%configure option
490- update %%files section
491
492* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
493- source upgrade
494
495* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
496- source upgrade
497
498* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
499- add --without-jbig to %%configure option
500
501* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
502- add --without-lcms to %%configure option
503
504* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
505- source upgrade
506- remove commented lines
507
508* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
509- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
510
511* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
512- source upgrade
513- remove patch for freetype2, no need
514- remove commented lines
515- add --with-quantum-depth=16 --with-modules --enable-lzw
516  --without-frozenpaths to %%configure option
517- remove --with-threads --without-xml from %%configure option
518- update %%files
519
520* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
521- patch update
522- add --without-jp2 to configure option
523- change PerlMagick build method
524
525* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
526- rebuild without jasper-devel
527
528* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
529- source upgrade to 5.5.7-15
530
531* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
532- source upgrade to 5.5.7-13
533- add patch0 to build against freetype2-2.1.7
534
535* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
536- source upgrade to 5.5.7-11
537- clean up spec
538- build without previous package (do not require libMagick.so.0)
539
540* Sun Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
541- source upgrade to 5.5.7-9
542- revised name of pkgconfig files
543- remove BuildPrereq: freetype-devel
544
545* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
546- source upgrade to 5.5.7-6
547- disable all patches
548- revised %%files section
549- disable libtoolize and autotools
550- change PerlMagick build method
551- build without previous package (do not require libMagick.so.5)
552
553* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
554- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
555  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
556
557* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
558- rebuild
559
560* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
561- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
562- FIXME: rpm's macro problem?
563
564- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
565  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
566
567  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
568  - remove unnecessary duplicated %%doc files
569  - --without-xml instead of --without-ttf
570  - eliminate libungif(-devel) from BuildReq/Requires
571  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
572
573  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
574  - add delegetes.mgk (and %%{_libdir}/%%{name})
575
576  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
577  - 5.2.9-0vl4
578  - Sorry, the spec was in Shift_JIS. Fixed.
579
580  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
581  - 5.2.9-0vl3
582  - rebuilt with perl-5.6.1
583  - added Japanese summary and description :-P
584  - added --without-ttf in order to disable freetype2 (SeedPlus) support
585  - added --without-wmf in order to disable libwmf (SeedPlus) support
586
587  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
588  - 5.2.9-0vl2
589  - rebuild on Perl-5.6
590  - use %%{perl_sitearch}
591  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
592
593  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
594  - 5.2.9-0vl1
595  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
596
597* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
598- fix perl paths in file list
599
600* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
601- lib64'ize
602- don't throw stuff in /usr/X11R6, that's for X only
603- remove files we aren't shipping
604
605* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
606- rebuilt with gcc-3.2 (we hope)
607
608* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
609- build using gcc-3.2-0.1
610
611* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
612- fix non-cpp headers in -devel package
613- fix #62157 (wrong path for include files in ImageMagick-devel)
614- fix #63897 (use _target instead of _arch) in libtool workaround
615- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
616
617* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
618- update
619- fix localdoc patch
620- fix %%files section
621- disable nonroot patch
622- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
623- fix libtool workaround
624- moved Magick*-config into -devel package (#64249)
625
626* Sun May 26 2002 Tim Powers <timp@redhat.com>
627- automated rebuild
628
629* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
630- 5.4.6
631
632* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
633- Update to pl 11
634
635* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
636- Update to 5.4.3 pl5; this fixes #58080
637
638* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
639- Patchlevel 3
640
641* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
642- automated rebuild
643
644* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
645- Update to 5.4.2-2
646- Fix #57923, also don't hardcode netscape as html viewer
647
648* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
649- 5.4.1
650- Link against new libstdc++
651
652* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
653- 5.4.0.5
654- Make the error message when trying to display an hpgl file more
655  explicit (#55875)
656
657* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
658- 5.4.0.3
659- Fix names of man pages
660
661* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
662- 5.4.0
663- work around build system breakage causing applications to be named
664  %{_arch}-redhat-linux-foo rather than foo
665
666* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
667- 5.3.9
668
669* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
670- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
671  (#52611)
672
673* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
674- Remove Magick++ includes from -devel, they're already in -c++-devel
675  (#51590)
676
677* Sun Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
678- 5.3.8 (bugfix release)
679
680* Sat Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
681- fix to build Perlmagic on s390 s390x
682
683* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
684- Add delegates.mgk to the package (#50725)
685
686* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
687- 5.3.7
688- Fix build without previously installed ImageMagick-devel (#49816)
689- Move perl bindings to a separate package.
690
691* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
692- Fix build as non-root again
693- Shut up rpmlint
694
695* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
696- 5.3.6
697- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
698
699* Sat Jun 16 2001 Than Ngo <than@redhat.com>
700- update to 5.3.5
701- cleanup specfile
702
703* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
704- 5.3.3-respin, fixes #41196
705
706* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
707- 5.3.3
708- Add a desktop file for "display" (RFE#17417)
709
710* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
711- 5.3.2
712- work around bugs in ia64 glibc headers
713
714* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
715- remove patch for s390, it is not necessary
716
717* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
718- 5.2.7
719
720* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
721- 5.2.6
722
723* Mon Dec 18 2000 Than Ngo <than@redhat.com>
724- ported to s390
725
726* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
727- 5.2.4
728- Fix up and package the C++ bindings in the new c++/c++-devel packages.
729
730* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
731- rebuild against new libpng
732
733* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
734- include images with docs (#10312)
735
736* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
737- don't build with -ggdb, use -g instead.
738
739* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
740- automatic rebuild
741
742* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
743- update to 5.2.2 beta
744
745* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
746- update to 5.2.1, redone patches as they failed
747
748* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
749- remove hacks to move perl man pages
750- don't include the perl*/man stuff, these files go in /usr/share/man now.
751
752* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
753- disable optimization on Alpha and Sparc
754
755* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
756- update to 5.2.0
757- update URL
758- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
759
760* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
761- bootstrap rebuilt to nuke broken libbz2 deps
762- add Prefix: tag such that the FHS macros work properly
763
764* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
765- now compiles with bzip2 1.0
766- changed buildroot to include version
767
768* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
769- fix compilation with new perl
770
771* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
772- 5.1.1
773
774* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
775- Rebuild to get compressed man pages
776
777* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
778- ugly hack to print with lpr instead of lp
779
780* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
781- update to 4.2.9
782
783* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
784- update to 4.2.8
785
786* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
787- include the perl man pages as well
788
789* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
790- remove --enable-16bit because it damages interoperability
791
792* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
793- update to 4.2.2
794- change ChangeLog to refer to actual dates.
795- strip binaries
796
797* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
798- add more files. Oops.
799
800* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
801- auto rebuild in the new build environment (release 2)
802
803* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
804- version 4.2.1
805
806* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
807- changed group
808
809* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
810- hacks to make it work with the new perl
811- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
812- make sure the libraries have the x bit on
813
814* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
815- translations modified for de, fr
816
817* Thu May 07 1998 Prospector System <bugs@redhat.com>
818- translations modified for de, fr, tr
819
820* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
821- updated to 4.0.5
822
823* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
824- updated to 4.0.4
825- added BuildRoot
826
827* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
828- updated from 3.8.3 to 3.9.1
829- removed PNG patch (appears to be fixed)
830
831* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
832- build against new libpng
833
834* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
835- built against glibc
836
837* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
838- updated to version 3.8.3.
839- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.