source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 3149

Revision 3149, 27.9 KB checked in by Takemikaduchi, 13 years ago (diff)

gtk3: new upstream release, ImageMagick?: add BR

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.6.8
5%define Patchlevel 5
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 3%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.bz2
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.bz2
24%endif
25#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
26URL: http://www.imagemagick.org/
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: bzip2-devel
30BuildRequires: cairo-devel
31BuildRequires: freetype2-devel >= 2.1.7
32BuildRequires: fontconfig-devel
33BuildRequires: giflib-devel
34BuildRequires: graphviz-devel
35BuildRequires: lcms-devel
36BuildRequires: libjpeg-turbo-devel
37BuildRequires: libpng-devel >= 1.2.5
38BuildRequires: librsvg2-devel
39BuildRequires: libtiff-devel
40BuildRequires: libxml2-devel
41BuildRequires: libSM-devel
42BuildRequires: libX11-devel
43BuildRequires: libXext-devel
44BuildRequires: OpenEXR-devel
45BuildRequires: perl
46BuildRequires: xorg-x11-server-utils
47BuildRequires: zlib-devel
48BuildRequires: libXt-devel
49BuildRequires: xz-devel
50BuildRequires: xz-lzma-compat
51BuildRequires: libtool-ltdl-devel
52
53Requires: bzip2
54Requires: freetype2
55Requires: giflib
56Requires: graphviz
57Requires: lcms
58Requires: libjpeg-turbo
59Requires: libpng
60Requires: libtiff
61Requires: libxml2
62Requires: OpenEXR-libs
63Requires: xorg-x11-server-utils
64Requires: zlib
65
66Vendor: Project Vine
67Distribution: Vine Linux
68Packager: inagaki, iwamoto
69
70%description
71ImageMagick(TM) is an image display and manipulation tool for the X
72Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
73and Photo CD image formats. It can resize, rotate, sharpen, color
74reduce, or add special effects to an image, and when finished you can
75either save the completed work in the original format or a different
76one. ImageMagick also includes command line programs for creating
77animated or transparent .gifs, creating composite images, creating
78thumbnail images, and more.
79
80ImageMagick is one of your choices if you need a program to manipulate
81and dis play images. If you want to develop your own applications
82which use ImageMagick code or APIs, you need to install
83ImageMagick-devel as well.
84
85
86%description -l ja
87ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
88ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
89イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
90出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
91オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
92また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
93サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
94
95画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
96も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
97アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
98インストールして下さい.
99
100%package devel
101Summary: Static libraries and header files for ImageMagick app development.
102Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
103Group: Development/Libraries
104Requires: ImageMagick = %{version}-%{release}
105
106%description devel
107Image-Magick-devel contains the static libraries and header files you'll
108need to develop ImageMagick applications. ImageMagick is an image
109manipulation program.
110
111If you want to create applications that will use ImageMagick code or
112APIs, you need to install ImageMagick-devel as well as ImageMagick.
113You do noy need to install it if you just want to use ImageMagick,
114however.
115
116%description devel -l ja
117ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
118これらは ImageMagick アプリケーションの開発の際に必要となります.
119ImageMagick は画像処理プログラムです.
120
121ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
122この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
123する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
124インストールする必要はありません.
125
126%package c++
127Summary: ImageMagick Magick++ library (C++ bindings)
128Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
129Group: System Environment/Libraries
130Requires: ImageMagick = %{version}-%{release}
131
132%description c++
133This package contains the Magick++ library, a C++ binding to the ImageMagick
134graphics manipulation library.
135
136Install ImageMagick-c++ if you want to use any applications that use Magick++.
137
138%description c++
139このパッケージには Magick++ ライブラリが収められています.
140Magick++ とは ImageMagick ライブラリの C++ バインディングです.
141
142Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
143パッケージをインストールして下さい.
144
145%package c++-devel
146Summary: C++ bindings for the ImageMagick library
147Summary(ja): ImageMagick ライブラリの C++ バインディング
148Group: Development/Libraries
149Requires: ImageMagick = %{version}-%{release}
150Requires: ImageMagick-c++ = %{version}-%{release}
151Requires: ImageMagick-devel = %{version}-%{release}
152
153%description c++-devel
154ImageMagick-devel contains the static libraries and header files you'll
155need to develop ImageMagick applications using the Magick++ C++ bindings.
156ImageMagick is an image manipulation program.
157
158If you want to create applications that will use Magick++ code
159or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
160ImageMagick.
161You don't need to install it if you just want to use ImageMagick, or if you
162want to develop/compile applications using the ImageMagick C interface,
163however.
164
165%description c++-devel -l ja
166ImageMagick-c++-devel には Magick++ C++ バインディングを使った
167ImageMagick アプリケーション開発に必要なスタティックライブラリと
168ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
169
170Magick++ コードや API を使ったアプリケーションを開発する場合は,
171ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
172インストールする必要があります.
173ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
174を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
175インストールする必要はありません.
176
177%package -n perl-Image-Magick
178Summary: ImageMagick perl bindings
179Summary(ja): ImageMagick の Perl バインディング
180Group: Development/Libraries
181Requires: ImageMagick = %{version}-%{release}
182Requires: perl >= 5.8.0
183Obsoletes: ImageMagick-perl < %{version}-%{release}
184Provides: ImageMagick-perl = %{version}-%{release}
185
186%description -n perl-Image-Magick
187Perl bindings to ImageMagick.
188
189Install ImageMagick-perl if you want to use any perl scripts that use
190ImageMagick.
191
192%description -n perl-Image-Magick -l ja
193このパッケージは ImageMagick の Perl バインディングです.
194
195ImageMagick を利用する perl スクリプトを使いたい場合は
196ImageMagick-perl パッケージをインストールして下さい.
197
198
199%prep
200%setup -q -n %{name}-%{VER}-%{Patchlevel}
201
202#patch1 -p1 -b .CVE-2006-5456
203
204%build
205%configure \
206    --enable-silent-rules \
207    --enable-shared \
208    --disable-static \
209    --with-modules \
210    --with-quantum-depth=16 \
211    --without-frozenpaths \
212    --with-x \
213    --without-djvu \
214    --without-fftw \
215    --without-jbig \
216    --without-jp2 \
217    --without-lcms2 \
218    --without-wmf \
219    --with-perl \
220    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
221
222# Disable rpath
223sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
224sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
225
226make %{?_smp_mflags}
227
228%install
229rm -rf $RPM_BUILD_ROOT
230
231make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
232
233# perlmagick: fix perl path of demo files
234%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
235
236find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
237find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
238find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
239
240echo "%defattr(-,root,root)" > perl-pkg-files
241find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
242sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
243
244# remove duplicated doc files
245rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
246
247# remove files conflict with libtools
248rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
249rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
250
251# remove *.la files
252find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
253
254%clean
255rm -rf $RPM_BUILD_ROOT
256
257%post -p /sbin/ldconfig
258
259%post c++ -p /sbin/ldconfig
260
261%postun -p /sbin/ldconfig
262
263%postun c++ -p /sbin/ldconfig
264
265
266%files
267%defattr(-,root,root)
268%doc www images
269%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt index.html
270%dir %{_libdir}/ImageMagick-%{VER}
271%{_libdir}/ImageMagick-%{VER}/config
272%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16
273%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16/*
274%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.so
275%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.la
276%{_libdir}/libMagickCore.so.*
277%{_libdir}/libMagickWand.so.*
278%{_bindir}/[a-z]*
279%dir %{_datadir}/ImageMagick-%{VER}
280%dir %{_datadir}/ImageMagick-%{VER}/config
281%{_datadir}/ImageMagick-%{VER}/config/*.xml
282%{_datadir}/ImageMagick-%{VER}/config/*.icm
283%{_mandir}/man1/ImageMagick.*
284%{_mandir}/man1/[a-z]*
285
286%files devel
287%defattr(-,root,root)
288%{_bindir}/Magick-config
289%{_bindir}/Wand-config
290%{_bindir}/MagickCore-config
291%{_bindir}/MagickWand-config
292#{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.a
293#{_libdir}/libMagickCore.a
294%{_libdir}/libMagickCore.so
295#{_libdir}/libMagickWand.a
296%{_libdir}/libMagickWand.so
297%{_libdir}/pkgconfig/ImageMagick.pc
298%{_libdir}/pkgconfig/Wand.pc
299%{_libdir}/pkgconfig/MagickCore.pc
300%{_libdir}/pkgconfig/MagickWand.pc
301%{_includedir}/ImageMagick/magick
302%{_includedir}/ImageMagick/wand
303%{_mandir}/man1/Magick-config*
304%{_mandir}/man1/Wand-config*
305%{_mandir}/man1/MagickCore-config*
306%{_mandir}/man1/MagickWand-config*
307
308%files c++
309%defattr(-,root,root)
310%{_libdir}/libMagick++.so.*
311
312%files c++-devel
313%defattr(-,root,root)
314%{_bindir}/Magick++-config
315%{_includedir}/ImageMagick/Magick++
316%{_includedir}/ImageMagick/Magick++.h
317#{_libdir}/libMagick++.a
318%{_libdir}/libMagick++.so
319%{_libdir}/pkgconfig/ImageMagick++.pc
320%{_libdir}/pkgconfig/Magick++.pc
321%{_mandir}/man1/Magick++-config*
322
323%files -n perl-Image-Magick -f perl-pkg-files
324%defattr(-,root,root)
325%{_mandir}/man3/*
326
327%changelog
328* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
329- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
330
331* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
332- built with perl-5.12.3
333- changed perl subpackage name
334
335* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
336- new upstream release
337
338* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
339- rebuilt with graphviz-2.26.3 again
340
341* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
342- new upstream release
343- rebuilt with graphviz-2.26.3
344
345* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
346- new upstream release
347
348* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
349- rebuild with rpm-4.8.1 for pkg-config file
350- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
351- change Requires: libjpeg-turbo instead of libjpeg
352
353* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
354- new upstream release
355- built with new toolchain
356- added --disable-static to %%configure, removed static libraries
357
358* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
359- added --without-djvu --without-fftw
360
361* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
362- new upstream release
363
364* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
365- new upstream release
366
367* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
368- new upstream release
369- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
370- add R: graphviz, OpenEXR-libs, ilmbase
371
372* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
373- new upstream release
374- added Packager tag
375
376* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
377- new upstream release
378
379* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
380- new upstream release
381- updated BuildRequires
382
383* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
384- enabled lcms as default.
385
386* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
387- new upstream release
388
389* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
390- new upstream release
391
392* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
393- new upstream release
394
395* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
396- new upstream release
397
398* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
399- new upstream release
400- spec in UTF-8
401
402* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
403- enabled to build with lcms (use '--with lcms' to enable).
404
405* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
406- new upstream release
407- rebuilt with perl-5.10.0
408
409* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
410- new upstream release
411- removed *.la files from devel packages
412
413* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
414- new upstream release
415- change files section to fit new release
416- build under new versioning policy
417
418* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
419- new upstream release
420
421* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
422- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
423- add BuildPrereq: librsvg2-devel
424- add %{?_smp_mflags} to make command arg
425
426* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
427- new upstream release
428- changed Group to Applications/Graphics
429
430* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
431- rebuilt for VineSeed
432
433* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
434- update patch1 for fix CVE-2007-0770
435
436* Wed Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
437- upstream release
438- add patch1 for fix CVE-2006-5456
439
440* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
441- rebuilt (for ppc) to resolve reference to invalid *la files
442
443* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
444- new upstream release
445
446* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
447- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
448
449* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
450- new upstream release
451- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
452- add --with-perl-options to configure option
453
454* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
455- new upstream release
456- build with XOrg-6.9.0
457
458* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
459- new upstream release
460- add %%{_mandir}/man1/ImageMagick.* to main package
461
462* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
463- source upgrade
464- remove patch1
465- update %%files
466
467* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
468- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
469  (CAN-2004-0981)
470
471* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
472- move $(pkglibdir)/modules-Q16/*/*.la to main package.
473
474* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
475- source upgrade
476- Patch: change default menu font so display can work without XOrg-75dpi-fonts
477- add missing docs
478- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
479- *.pc should be in -devel package
480- add missing pkg{lib,data}dirs to %%files
481
482* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
483- source upgrade
484- add --without-dot to %%configure option
485- update %%files section
486
487* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
488- source upgrade
489
490* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
491- source upgrade
492
493* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
494- add --without-jbig to %%configure option
495
496* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
497- add --without-lcms to %%configure option
498
499* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
500- source upgrade
501- remove commented lines
502
503* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
504- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
505
506* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
507- source upgrade
508- remove patch for freetype2, no need
509- remove commented lines
510- add --with-quantum-depth=16 --with-modules --enable-lzw
511  --without-frozenpaths to %%configure option
512- remove --with-threads --without-xml from %%configure option
513- update %%files
514
515* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
516- patch update
517- add --without-jp2 to configure option
518- change PerlMagick build method
519
520* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
521- rebuild without jasper-devel
522
523* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
524- source upgrade to 5.5.7-15
525
526* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
527- source upgrade to 5.5.7-13
528- add patch0 to build against freetype2-2.1.7
529
530* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
531- source upgrade to 5.5.7-11
532- clean up spec
533- build without previous package (do not require libMagick.so.0)
534
535* Sun Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
536- source upgrade to 5.5.7-9
537- revised name of pkgconfig files
538- remove BuildPrereq: freetype-devel
539
540* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
541- source upgrade to 5.5.7-6
542- disable all patches
543- revised %%files section
544- disable libtoolize and autotools
545- change PerlMagick build method
546- build without previous package (do not require libMagick.so.5)
547
548* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
549- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
550  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
551
552* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
553- rebuild
554
555* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
556- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
557- FIXME: rpm's macro problem?
558
559- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
560  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
561
562  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
563  - remove unnecessary duplicated %%doc files
564  - --without-xml instead of --without-ttf
565  - eliminate libungif(-devel) from BuildReq/Requires
566  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
567
568  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
569  - add delegetes.mgk (and %%{_libdir}/%%{name})
570
571  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
572  - 5.2.9-0vl4
573  - Sorry, the spec was in Shift_JIS. Fixed.
574
575  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
576  - 5.2.9-0vl3
577  - rebuilt with perl-5.6.1
578  - added Japanese summary and description :-P
579  - added --without-ttf in order to disable freetype2 (SeedPlus) support
580  - added --without-wmf in order to disable libwmf (SeedPlus) support
581
582  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
583  - 5.2.9-0vl2
584  - rebuild on Perl-5.6
585  - use %%{perl_sitearch}
586  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
587
588  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
589  - 5.2.9-0vl1
590  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
591
592* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
593- fix perl paths in file list
594
595* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
596- lib64'ize
597- don't throw stuff in /usr/X11R6, that's for X only
598- remove files we aren't shipping
599
600* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
601- rebuilt with gcc-3.2 (we hope)
602
603* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
604- build using gcc-3.2-0.1
605
606* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
607- fix non-cpp headers in -devel package
608- fix #62157 (wrong path for include files in ImageMagick-devel)
609- fix #63897 (use _target instead of _arch) in libtool workaround
610- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
611
612* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
613- update
614- fix localdoc patch
615- fix %%files section
616- disable nonroot patch
617- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
618- fix libtool workaround
619- moved Magick*-config into -devel package (#64249)
620
621* Sun May 26 2002 Tim Powers <timp@redhat.com>
622- automated rebuild
623
624* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
625- 5.4.6
626
627* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
628- Update to pl 11
629
630* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
631- Update to 5.4.3 pl5; this fixes #58080
632
633* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
634- Patchlevel 3
635
636* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
637- automated rebuild
638
639* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
640- Update to 5.4.2-2
641- Fix #57923, also don't hardcode netscape as html viewer
642
643* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
644- 5.4.1
645- Link against new libstdc++
646
647* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
648- 5.4.0.5
649- Make the error message when trying to display an hpgl file more
650  explicit (#55875)
651
652* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
653- 5.4.0.3
654- Fix names of man pages
655
656* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
657- 5.4.0
658- work around build system breakage causing applications to be named
659  %{_arch}-redhat-linux-foo rather than foo
660
661* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
662- 5.3.9
663
664* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
665- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
666  (#52611)
667
668* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
669- Remove Magick++ includes from -devel, they're already in -c++-devel
670  (#51590)
671
672* Sun Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
673- 5.3.8 (bugfix release)
674
675* Sat Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
676- fix to build Perlmagic on s390 s390x
677
678* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
679- Add delegates.mgk to the package (#50725)
680
681* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
682- 5.3.7
683- Fix build without previously installed ImageMagick-devel (#49816)
684- Move perl bindings to a separate package.
685
686* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
687- Fix build as non-root again
688- Shut up rpmlint
689
690* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
691- 5.3.6
692- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
693
694* Sat Jun 16 2001 Than Ngo <than@redhat.com>
695- update to 5.3.5
696- cleanup specfile
697
698* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
699- 5.3.3-respin, fixes #41196
700
701* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
702- 5.3.3
703- Add a desktop file for "display" (RFE#17417)
704
705* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
706- 5.3.2
707- work around bugs in ia64 glibc headers
708
709* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
710- remove patch for s390, it is not necessary
711
712* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
713- 5.2.7
714
715* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
716- 5.2.6
717
718* Mon Dec 18 2000 Than Ngo <than@redhat.com>
719- ported to s390
720
721* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
722- 5.2.4
723- Fix up and package the C++ bindings in the new c++/c++-devel packages.
724
725* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
726- rebuild against new libpng
727
728* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
729- include images with docs (#10312)
730
731* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
732- don't build with -ggdb, use -g instead.
733
734* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
735- automatic rebuild
736
737* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
738- update to 5.2.2 beta
739
740* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
741- update to 5.2.1, redone patches as they failed
742
743* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
744- remove hacks to move perl man pages
745- don't include the perl*/man stuff, these files go in /usr/share/man now.
746
747* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
748- disable optimization on Alpha and Sparc
749
750* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
751- update to 5.2.0
752- update URL
753- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
754
755* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
756- bootstrap rebuilt to nuke broken libbz2 deps
757- add Prefix: tag such that the FHS macros work properly
758
759* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
760- now compiles with bzip2 1.0
761- changed buildroot to include version
762
763* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
764- fix compilation with new perl
765
766* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
767- 5.1.1
768
769* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
770- Rebuild to get compressed man pages
771
772* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
773- ugly hack to print with lpr instead of lp
774
775* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
776- update to 4.2.9
777
778* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
779- update to 4.2.8
780
781* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
782- include the perl man pages as well
783
784* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
785- remove --enable-16bit because it damages interoperability
786
787* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
788- update to 4.2.2
789- change ChangeLog to refer to actual dates.
790- strip binaries
791
792* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
793- add more files. Oops.
794
795* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
796- auto rebuild in the new build environment (release 2)
797
798* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
799- version 4.2.1
800
801* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
802- changed group
803
804* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
805- hacks to make it work with the new perl
806- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
807- make sure the libraries have the x bit on
808
809* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
810- translations modified for de, fr
811
812* Thu May 07 1998 Prospector System <bugs@redhat.com>
813- translations modified for de, fr, tr
814
815* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
816- updated to 4.0.5
817
818* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
819- updated to 4.0.4
820- added BuildRoot
821
822* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
823- updated from 3.8.3 to 3.9.1
824- removed PNG patch (appears to be fixed)
825
826* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
827- build against new libpng
828
829* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
830- built against glibc
831
832* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
833- updated to version 3.8.3.
834- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.