source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 2023

Revision 2023, 27.5 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild package

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.6.4
5%define Patchlevel 9
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 2%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.bz2
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.bz2
24%endif
25#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
26URL: http://www.imagemagick.org/
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: bzip2-devel
30BuildRequires: cairo-devel
31BuildRequires: freetype2-devel >= 2.1.7
32BuildRequires: fontconfig-devel
33BuildRequires: giflib-devel
34BuildRequires: graphviz-devel
35BuildRequires: lcms-devel
36BuildRequires: libjpeg-turbo-devel
37BuildRequires: libpng-devel >= 1.2.5
38BuildRequires: librsvg2-devel
39BuildRequires: libtiff-devel
40BuildRequires: libxml2-devel
41BuildRequires: libSM-devel
42BuildRequires: libX11-devel
43BuildRequires: libXext-devel
44BuildRequires: libXext-devel
45BuildRequires: OpenEXR-devel
46BuildRequires: perl
47BuildRequires: xorg-x11-server-utils
48BuildRequires: zlib-devel
49
50Requires: bzip2
51Requires: freetype2
52Requires: giflib
53Requires: graphviz
54Requires: lcms
55Requires: libjpeg-turbo
56Requires: libpng
57Requires: libtiff
58Requires: libxml2
59Requires: OpenEXR-libs
60Requires: xorg-x11-server-utils
61Requires: zlib
62
63Vendor: Project Vine
64Distribution: Vine Linux
65Packager: inagaki, iwamoto
66
67%description
68ImageMagick(TM) is an image display and manipulation tool for the X
69Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
70and Photo CD image formats. It can resize, rotate, sharpen, color
71reduce, or add special effects to an image, and when finished you can
72either save the completed work in the original format or a different
73one. ImageMagick also includes command line programs for creating
74animated or transparent .gifs, creating composite images, creating
75thumbnail images, and more.
76
77ImageMagick is one of your choices if you need a program to manipulate
78and dis play images. If you want to develop your own applications
79which use ImageMagick code or APIs, you need to install
80ImageMagick-devel as well.
81
82
83%description -l ja
84ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
85ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
86イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
87出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
88オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
89また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
90サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
91
92画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
93も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
94アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
95インストールして下さい.
96
97%package devel
98Summary: Static libraries and header files for ImageMagick app development.
99Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
100Group: Development/Libraries
101Requires: ImageMagick = %{version}-%{release}
102
103%description devel
104Image-Magick-devel contains the static libraries and header files you'll
105need to develop ImageMagick applications. ImageMagick is an image
106manipulation program.
107
108If you want to create applications that will use ImageMagick code or
109APIs, you need to install ImageMagick-devel as well as ImageMagick.
110You do noy need to install it if you just want to use ImageMagick,
111however.
112
113%description devel -l ja
114ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
115これらは ImageMagick アプリケーションの開発の際に必要となります.
116ImageMagick は画像処理プログラムです.
117
118ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
119この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
120する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
121インストールする必要はありません.
122
123%package perl
124Summary: ImageMagick perl bindings
125Summary(ja): ImageMagick の Perl バインディング
126Group: Development/Libraries
127Requires: ImageMagick = %{version}-%{release}
128Requires: perl >= 5.8.0
129
130%description perl
131Perl bindings to ImageMagick.
132
133Install ImageMagick-perl if you want to use any perl scripts that use
134ImageMagick.
135
136%description perl -l ja
137このパッケージは ImageMagick の Perl バインディングです.
138
139ImageMagick を利用する perl スクリプトを使いたい場合は
140ImageMagick-perl パッケージをインストールして下さい.
141
142
143%package c++
144Summary: ImageMagick Magick++ library (C++ bindings)
145Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
146Group: System Environment/Libraries
147Requires: ImageMagick = %{version}-%{release}
148
149%description c++
150This package contains the Magick++ library, a C++ binding to the ImageMagick
151graphics manipulation library.
152
153Install ImageMagick-c++ if you want to use any applications that use Magick++.
154
155%description c++
156このパッケージには Magick++ ライブラリが収められています.
157Magick++ とは ImageMagick ライブラリの C++ バインディングです.
158
159Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
160パッケージをインストールして下さい.
161
162%package c++-devel
163Summary: C++ bindings for the ImageMagick library
164Summary(ja): ImageMagick ライブラリの C++ バインディング
165Group: Development/Libraries
166Requires: ImageMagick = %{version}-%{release}
167Requires: ImageMagick-c++ = %{version}-%{release}
168Requires: ImageMagick-devel = %{version}-%{release}
169
170%description c++-devel
171ImageMagick-devel contains the static libraries and header files you'll
172need to develop ImageMagick applications using the Magick++ C++ bindings.
173ImageMagick is an image manipulation program.
174
175If you want to create applications that will use Magick++ code
176or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
177ImageMagick.
178You don't need to install it if you just want to use ImageMagick, or if you
179want to develop/compile applications using the ImageMagick C interface,
180however.
181
182%description c++-devel -l ja
183ImageMagick-c++-devel には Magick++ C++ バインディングを使った
184ImageMagick アプリケーション開発に必要なスタティックライブラリと
185ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
186
187Magick++ コードや API を使ったアプリケーションを開発する場合は,
188ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
189インストールする必要があります.
190ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
191を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
192インストールする必要はありません.
193
194
195%prep
196%setup -q -n %{name}-%{VER}-%{Patchlevel}
197
198#patch1 -p1 -b .CVE-2006-5456
199
200%build
201%configure \
202    --enable-silent-rules \
203    --enable-shared \
204    --disable-static \
205    --with-modules \
206    --with-quantum-depth=16 \
207    --without-frozenpaths \
208    --with-x \
209    --without-djvu \
210    --without-fftw \
211    --without-jbig \
212    --without-jp2 \
213    --without-lcms2 \
214    --without-wmf \
215    --with-perl \
216    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
217
218# Disable rpath
219sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
220sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
221
222make %{?_smp_mflags}
223
224%install
225rm -rf $RPM_BUILD_ROOT
226
227make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
228
229# perlmagick: fix perl path of demo files
230%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
231
232# get the perl file list. We know what we need, so this is easy
233perlver=`perl -v |grep built |sed -e "s,.*v,,;s, .*,,"`
234perlmajor=`echo $perlver |sed -e "s,\..*,,"`
235
236find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
237find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
238find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
239
240echo "%defattr(-,root,root)" > perl-pkg-files
241find $RPM_BUILD_ROOT%{_libdir}/perl$perlmajor/vendor_perl/$perlver -type d -name Image >> perl-pkg-files.orig
242sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
243
244# remove duplicated doc files
245rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
246
247# remove files conflict with libtools
248rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
249rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
250
251# remove *.la files
252find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
253
254%clean
255rm -rf $RPM_BUILD_ROOT
256
257%post -p /sbin/ldconfig
258
259%post c++ -p /sbin/ldconfig
260
261%postun -p /sbin/ldconfig
262
263%postun c++ -p /sbin/ldconfig
264
265
266%files
267%defattr(-,root,root)
268%doc www images
269%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt index.html
270%dir %{_libdir}/ImageMagick-%{VER}
271%{_libdir}/ImageMagick-%{VER}/config
272%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16
273%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16/*
274%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.so
275%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.la
276%{_libdir}/libMagickCore.so.*
277%{_libdir}/libMagickWand.so.*
278%{_bindir}/[a-z]*
279%dir %{_datadir}/ImageMagick-%{VER}
280%dir %{_datadir}/ImageMagick-%{VER}/config
281%{_datadir}/ImageMagick-%{VER}/config/*.xml
282%{_datadir}/ImageMagick-%{VER}/config/*.icm
283%{_mandir}/man1/ImageMagick.*
284%{_mandir}/man1/[a-z]*
285
286%files devel
287%defattr(-,root,root)
288%{_bindir}/Magick-config
289%{_bindir}/Wand-config
290%{_bindir}/MagickCore-config
291%{_bindir}/MagickWand-config
292#{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.a
293#{_libdir}/libMagickCore.a
294%{_libdir}/libMagickCore.so
295#{_libdir}/libMagickWand.a
296%{_libdir}/libMagickWand.so
297%{_libdir}/pkgconfig/ImageMagick.pc
298%{_libdir}/pkgconfig/Wand.pc
299%{_libdir}/pkgconfig/MagickCore.pc
300%{_libdir}/pkgconfig/MagickWand.pc
301%{_includedir}/ImageMagick/magick
302%{_includedir}/ImageMagick/wand
303%{_mandir}/man1/Magick-config*
304%{_mandir}/man1/Wand-config*
305%{_mandir}/man1/MagickCore-config*
306%{_mandir}/man1/MagickWand-config*
307
308%files c++
309%defattr(-,root,root)
310%{_libdir}/libMagick++.so.*
311
312%files c++-devel
313%defattr(-,root,root)
314%{_bindir}/Magick++-config
315%{_includedir}/ImageMagick/Magick++
316%{_includedir}/ImageMagick/Magick++.h
317#{_libdir}/libMagick++.a
318%{_libdir}/libMagick++.so
319%{_libdir}/pkgconfig/ImageMagick++.pc
320%{_libdir}/pkgconfig/Magick++.pc
321%{_mandir}/man1/Magick++-config*
322
323%files perl -f perl-pkg-files
324%defattr(-,root,root)
325%{_mandir}/man3/*
326
327%changelog
328* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
329- rebuilt with graphviz-2.26.3 again
330
331* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
332- new upstream release
333- rebuilt with graphviz-2.26.3
334
335* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
336- new upstream release
337
338* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
339- rebuild with rpm-4.8.1 for pkg-config file
340- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
341- change Requires: libjpeg-turbo instead of libjpeg
342
343* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
344- new upstream release
345- built with new toolchain
346- added --disable-static to %%configure, removed static libraries
347
348* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
349- added --without-djvu --without-fftw
350
351* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
352- new upstream release
353
354* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
355- new upstream release
356
357* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
358- new upstream release
359- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
360- add R: graphviz, OpenEXR-libs, ilmbase
361
362* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
363- new upstream release
364- added Packager tag
365
366* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
367- new upstream release
368
369* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
370- new upstream release
371- updated BuildRequires
372
373* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
374- enabled lcms as default.
375
376* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
377- new upstream release
378
379* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
380- new upstream release
381
382* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
383- new upstream release
384
385* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
386- new upstream release
387
388* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
389- new upstream release
390- spec in UTF-8
391
392* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
393- enabled to build with lcms (use '--with lcms' to enable).
394
395* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
396- new upstream release
397- rebuilt with perl-5.10.0
398
399* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
400- new upstream release
401- removed *.la files from devel packages
402
403* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
404- new upstream release
405- change files section to fit new release
406- build under new versioning policy
407
408* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
409- new upstream release
410
411* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
412- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
413- add BuildPrereq: librsvg2-devel
414- add %{?_smp_mflags} to make command arg
415
416* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
417- new upstream release
418- changed Group to Applications/Graphics
419
420* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
421- rebuilt for VineSeed
422
423* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
424- update patch1 for fix CVE-2007-0770
425
426* Wed Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
427- upstream release
428- add patch1 for fix CVE-2006-5456
429
430* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
431- rebuilt (for ppc) to resolve reference to invalid *la files
432
433* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
434- new upstream release
435
436* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
437- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
438
439* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
440- new upstream release
441- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
442- add --with-perl-options to configure option
443
444* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
445- new upstream release
446- build with XOrg-6.9.0
447
448* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
449- new upstream release
450- add %%{_mandir}/man1/ImageMagick.* to main package
451
452* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
453- source upgrade
454- remove patch1
455- update %%files
456
457* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
458- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
459  (CAN-2004-0981)
460
461* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
462- move $(pkglibdir)/modules-Q16/*/*.la to main package.
463
464* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
465- source upgrade
466- Patch: change default menu font so display can work without XOrg-75dpi-fonts
467- add missing docs
468- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
469- *.pc should be in -devel package
470- add missing pkg{lib,data}dirs to %%files
471
472* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
473- source upgrade
474- add --without-dot to %%configure option
475- update %%files section
476
477* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
478- source upgrade
479
480* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
481- source upgrade
482
483* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
484- add --without-jbig to %%configure option
485
486* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
487- add --without-lcms to %%configure option
488
489* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
490- source upgrade
491- remove commented lines
492
493* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
494- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
495
496* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
497- source upgrade
498- remove patch for freetype2, no need
499- remove commented lines
500- add --with-quantum-depth=16 --with-modules --enable-lzw
501  --without-frozenpaths to %%configure option
502- remove --with-threads --without-xml from %%configure option
503- update %%files
504
505* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
506- patch update
507- add --without-jp2 to configure option
508- change PerlMagick build method
509
510* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
511- rebuild without jasper-devel
512
513* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
514- source upgrade to 5.5.7-15
515
516* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
517- source upgrade to 5.5.7-13
518- add patch0 to build against freetype2-2.1.7
519
520* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
521- source upgrade to 5.5.7-11
522- clean up spec
523- build without previous package (do not require libMagick.so.0)
524
525* Sun Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
526- source upgrade to 5.5.7-9
527- revised name of pkgconfig files
528- remove BuildPrereq: freetype-devel
529
530* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
531- source upgrade to 5.5.7-6
532- disable all patches
533- revised %%files section
534- disable libtoolize and autotools
535- change PerlMagick build method
536- build without previous package (do not require libMagick.so.5)
537
538* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
539- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
540  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
541
542* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
543- rebuild
544
545* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
546- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
547- FIXME: rpm's macro problem?
548
549- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
550  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
551
552  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
553  - remove unnecessary duplicated %%doc files
554  - --without-xml instead of --without-ttf
555  - eliminate libungif(-devel) from BuildReq/Requires
556  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
557
558  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
559  - add delegetes.mgk (and %%{_libdir}/%%{name})
560
561  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
562  - 5.2.9-0vl4
563  - Sorry, the spec was in Shift_JIS. Fixed.
564
565  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
566  - 5.2.9-0vl3
567  - rebuilt with perl-5.6.1
568  - added Japanese summary and description :-P
569  - added --without-ttf in order to disable freetype2 (SeedPlus) support
570  - added --without-wmf in order to disable libwmf (SeedPlus) support
571
572  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
573  - 5.2.9-0vl2
574  - rebuild on Perl-5.6
575  - use %%{perl_sitearch}
576  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
577
578  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
579  - 5.2.9-0vl1
580  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
581
582* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
583- fix perl paths in file list
584
585* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
586- lib64'ize
587- don't throw stuff in /usr/X11R6, that's for X only
588- remove files we aren't shipping
589
590* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
591- rebuilt with gcc-3.2 (we hope)
592
593* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
594- build using gcc-3.2-0.1
595
596* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
597- fix non-cpp headers in -devel package
598- fix #62157 (wrong path for include files in ImageMagick-devel)
599- fix #63897 (use _target instead of _arch) in libtool workaround
600- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
601
602* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
603- update
604- fix localdoc patch
605- fix %%files section
606- disable nonroot patch
607- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
608- fix libtool workaround
609- moved Magick*-config into -devel package (#64249)
610
611* Sun May 26 2002 Tim Powers <timp@redhat.com>
612- automated rebuild
613
614* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
615- 5.4.6
616
617* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
618- Update to pl 11
619
620* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
621- Update to 5.4.3 pl5; this fixes #58080
622
623* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
624- Patchlevel 3
625
626* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
627- automated rebuild
628
629* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
630- Update to 5.4.2-2
631- Fix #57923, also don't hardcode netscape as html viewer
632
633* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
634- 5.4.1
635- Link against new libstdc++
636
637* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
638- 5.4.0.5
639- Make the error message when trying to display an hpgl file more
640  explicit (#55875)
641
642* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
643- 5.4.0.3
644- Fix names of man pages
645
646* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
647- 5.4.0
648- work around build system breakage causing applications to be named
649  %{_arch}-redhat-linux-foo rather than foo
650
651* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
652- 5.3.9
653
654* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
655- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
656  (#52611)
657
658* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
659- Remove Magick++ includes from -devel, they're already in -c++-devel
660  (#51590)
661
662* Sun Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
663- 5.3.8 (bugfix release)
664
665* Sat Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
666- fix to build Perlmagic on s390 s390x
667
668* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
669- Add delegates.mgk to the package (#50725)
670
671* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
672- 5.3.7
673- Fix build without previously installed ImageMagick-devel (#49816)
674- Move perl bindings to a separate package.
675
676* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
677- Fix build as non-root again
678- Shut up rpmlint
679
680* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
681- 5.3.6
682- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
683
684* Sat Jun 16 2001 Than Ngo <than@redhat.com>
685- update to 5.3.5
686- cleanup specfile
687
688* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
689- 5.3.3-respin, fixes #41196
690
691* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
692- 5.3.3
693- Add a desktop file for "display" (RFE#17417)
694
695* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
696- 5.3.2
697- work around bugs in ia64 glibc headers
698
699* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
700- remove patch for s390, it is not necessary
701
702* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
703- 5.2.7
704
705* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
706- 5.2.6
707
708* Mon Dec 18 2000 Than Ngo <than@redhat.com>
709- ported to s390
710
711* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
712- 5.2.4
713- Fix up and package the C++ bindings in the new c++/c++-devel packages.
714
715* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
716- rebuild against new libpng
717
718* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
719- include images with docs (#10312)
720
721* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
722- don't build with -ggdb, use -g instead.
723
724* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
725- automatic rebuild
726
727* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
728- update to 5.2.2 beta
729
730* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
731- update to 5.2.1, redone patches as they failed
732
733* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
734- remove hacks to move perl man pages
735- don't include the perl*/man stuff, these files go in /usr/share/man now.
736
737* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
738- disable optimization on Alpha and Sparc
739
740* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
741- update to 5.2.0
742- update URL
743- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
744
745* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
746- bootstrap rebuilt to nuke broken libbz2 deps
747- add Prefix: tag such that the FHS macros work properly
748
749* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
750- now compiles with bzip2 1.0
751- changed buildroot to include version
752
753* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
754- fix compilation with new perl
755
756* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
757- 5.1.1
758
759* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
760- Rebuild to get compressed man pages
761
762* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
763- ugly hack to print with lpr instead of lp
764
765* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
766- update to 4.2.9
767
768* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
769- update to 4.2.8
770
771* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
772- include the perl man pages as well
773
774* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
775- remove --enable-16bit because it damages interoperability
776
777* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
778- update to 4.2.2
779- change ChangeLog to refer to actual dates.
780- strip binaries
781
782* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
783- add more files. Oops.
784
785* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
786- auto rebuild in the new build environment (release 2)
787
788* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
789- version 4.2.1
790
791* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
792- changed group
793
794* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
795- hacks to make it work with the new perl
796- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
797- make sure the libraries have the x bit on
798
799* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
800- translations modified for de, fr
801
802* Thu May 07 1998 Prospector System <bugs@redhat.com>
803- translations modified for de, fr, tr
804
805* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
806- updated to 4.0.5
807
808* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
809- updated to 4.0.4
810- added BuildRoot
811
812* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
813- updated from 3.8.3 to 3.9.1
814- removed PNG patch (appears to be fixed)
815
816* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
817- build against new libpng
818
819* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
820- built against glibc
821
822* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
823- updated to version 3.8.3.
824- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.