source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 12510

Revision 12510, 30.3 KB checked in by tomop, 3 years ago (diff)

updated 11 packages

Field3D-1.7.3-2

ImageMagick?-6.9.11.48-1

OpenEXR-2.5.3-1

OpenImageIO-2.2.9.0-1

babl-0.1.82-1

fmt-7.1.3-2

gegl04-0.4.26-2

gimp-2.10.22-1

hdf5-1.12.0-1

opencv-4.5.0-1

robin-map-0.6.3-4

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.9.11
5%define Patchlevel 48
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 1%{?_dist_release}
17Group: graphics
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: inagaki, iwamoto
21
22License: freeware
23URL: https://legacy.imagemagick.org/
24
25%if "%{Patchlevel}" != ""
26Source: https://imagemagick.org/download/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
27%else
28Source: https://imagemagick.org/download/ImageMagick-%{version}.tar.xz
29%endif
30#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
31
32Buildroot: %{_tmppath}/%{name}-%{version}-root
33BuildRequires: bzip2-devel
34BuildRequires: cairo-devel
35BuildRequires: pango-devel
36BuildRequires: freetype2-devel >= 2.1.7
37BuildRequires: fontconfig-devel
38BuildRequires: giflib-devel
39BuildRequires: graphviz-devel
40BuildRequires: lcms2-devel
41BuildRequires: libjpeg-turbo-devel
42BuildRequires: libpng-devel >= 1.2.5
43BuildRequires: librsvg2-devel
44BuildRequires: libtiff-devel
45BuildRequires: libwebp-devel
46BuildRequires: libxml2-devel
47BuildRequires: libSM-devel
48BuildRequires: libX11-devel
49BuildRequires: libXext-devel
50BuildRequires: OpenEXR-devel
51BuildRequires: perl
52BuildRequires: xorg-x11-server-utils
53BuildRequires: zlib-devel
54BuildRequires: libXt-devel
55BuildRequires: xz-devel
56BuildRequires: xz-lzma-compat
57BuildRequires: libtool-ltdl-devel
58
59Requires: bzip2
60Requires: freetype2
61Requires: giflib
62Requires: graphviz
63Requires: lcms2
64Requires: libjpeg-turbo
65Requires: libpng
66Requires: libtiff
67Requires: libxml2
68Requires: OpenEXR-libs
69Requires: xorg-x11-server-utils
70Requires: zlib
71
72%description
73ImageMagick(TM) is an image display and manipulation tool for the X
74Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
75and Photo CD image formats. It can resize, rotate, sharpen, color
76reduce, or add special effects to an image, and when finished you can
77either save the completed work in the original format or a different
78one. ImageMagick also includes command line programs for creating
79animated or transparent .gifs, creating composite images, creating
80thumbnail images, and more.
81
82ImageMagick is one of your choices if you need a program to manipulate
83and dis play images. If you want to develop your own applications
84which use ImageMagick code or APIs, you need to install
85ImageMagick-devel as well.
86
87%description -l ja
88ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
89ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
90イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
91出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
92オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
93また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
94サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
95
96画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
97も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
98アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
99インストールして下さい.
100
101
102%package devel
103Summary: Static libraries and header files for ImageMagick app development.
104Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
105Group: programming
106Requires: ImageMagick = %{version}-%{release}
107
108%description devel
109Image-Magick-devel contains the static libraries and header files you'll
110need to develop ImageMagick applications. ImageMagick is an image
111manipulation program.
112
113If you want to create applications that will use ImageMagick code or
114APIs, you need to install ImageMagick-devel as well as ImageMagick.
115You do noy need to install it if you just want to use ImageMagick,
116however.
117
118%description devel -l ja
119ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
120これらは ImageMagick アプリケーションの開発の際に必要となります.
121ImageMagick は画像処理プログラムです.
122
123ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
124この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
125する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
126インストールする必要はありません.
127
128
129%package c++
130Summary: ImageMagick Magick++ library (C++ bindings)
131Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
132Group: system
133Requires: ImageMagick = %{version}-%{release}
134
135%description c++
136This package contains the Magick++ library, a C++ binding to the ImageMagick
137graphics manipulation library.
138
139Install ImageMagick-c++ if you want to use any applications that use Magick++.
140
141%description c++ -l ja
142このパッケージには Magick++ ライブラリが収められています.
143Magick++ とは ImageMagick ライブラリの C++ バインディングです.
144
145Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
146パッケージをインストールして下さい.
147
148
149%package c++-devel
150Summary: C++ bindings for the ImageMagick library
151Summary(ja): ImageMagick ライブラリの C++ バインディング
152Group: programming
153Requires: ImageMagick = %{version}-%{release}
154Requires: ImageMagick-c++ = %{version}-%{release}
155Requires: ImageMagick-devel = %{version}-%{release}
156
157%description c++-devel
158ImageMagick-devel contains the static libraries and header files you'll
159need to develop ImageMagick applications using the Magick++ C++ bindings.
160ImageMagick is an image manipulation program.
161
162If you want to create applications that will use Magick++ code
163or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
164ImageMagick.
165You don't need to install it if you just want to use ImageMagick, or if you
166want to develop/compile applications using the ImageMagick C interface,
167however.
168
169%description c++-devel -l ja
170ImageMagick-c++-devel には Magick++ C++ バインディングを使った
171ImageMagick アプリケーション開発に必要なスタティックライブラリと
172ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
173
174Magick++ コードや API を使ったアプリケーションを開発する場合は,
175ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
176インストールする必要があります.
177ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
178を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
179インストールする必要はありません.
180
181
182%package -n perl-Image-Magick
183Summary: ImageMagick perl bindings
184Summary(ja): ImageMagick の Perl バインディング
185Group: programming
186Requires: ImageMagick = %{version}-%{release}
187Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
188Obsoletes: ImageMagick-perl < %{version}-%{release}
189Provides: ImageMagick-perl = %{version}-%{release}
190
191%description -n perl-Image-Magick
192Perl bindings to ImageMagick.
193
194Install ImageMagick-perl if you want to use any perl scripts that use
195ImageMagick.
196
197%description -n perl-Image-Magick -l ja
198このパッケージは ImageMagick の Perl バインディングです.
199
200ImageMagick を利用する perl スクリプトを使いたい場合は
201ImageMagick-perl パッケージをインストールして下さい.
202
203
204%debug_package
205
206
207%prep
208%setup -q -n %{name}-%{VER}-%{Patchlevel}
209
210#patch1 -p1 -b .CVE-2006-5456
211
212
213%build
214%configure \
215    --enable-silent-rules \
216    --enable-shared \
217    --disable-static \
218    --with-modules \
219    --with-quantum-depth=16 \
220    --without-frozenpaths \
221    --with-x \
222    --without-dps \
223    --without-djvu \
224    --without-fftw \
225    --without-jbig \
226    --without-jp2 \
227    --with-lcms2 \
228    --without-wmf \
229    --with-perl \
230    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
231
232# Disable rpath
233sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
234sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
235
236make %{?_smp_mflags}
237
238
239%install
240rm -rf $RPM_BUILD_ROOT
241
242make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
243
244# perlmagick: fix perl path of demo files
245%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
246
247find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
248find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
249find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
250
251echo "%defattr(-,root,root)" > perl-pkg-files
252find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
253sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
254
255# remove duplicated doc files
256rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
257rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
258
259# remove files conflict with libtools
260rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
261rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
262
263# remove *.la files
264# remove only %{_libdir}/*.la
265# If you have removed module-*/*/*.la, it will fail to execute the command.
266find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
267
268rm -rf $RPM_BUILD_ROOT%{_docdir}/ImageMagick-6
269
270
271%clean
272rm -rf $RPM_BUILD_ROOT
273
274
275%post -p /sbin/ldconfig
276
277%post c++ -p /sbin/ldconfig
278
279%postun -p /sbin/ldconfig
280
281%postun c++ -p /sbin/ldconfig
282
283
284%files
285%defattr(-,root,root)
286%license LICENSE
287%doc www images
288%doc ChangeLog NOTICE QuickStart.txt README* NEWS.txt index.html
289%dir %{_libdir}/%{name}-%{VER}
290%dir %{_libdir}/%{name}-%{VER}/config-Q16
291%dir %{_libdir}/%{name}-%{VER}/modules-Q16
292%dir %{_libdir}/%{name}-%{VER}/modules-Q16/*
293%{_sysconfdir}/%{name}-6/*.xml
294%{_libdir}/%{name}-%{VER}/config-Q16/configure.xml
295%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.so
296%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.la
297%{_libdir}/libMagickCore-6.Q16.so.*
298%{_libdir}/libMagickWand-6.Q16.so.*
299%{_bindir}/[a-z]*
300%{_datadir}/%{name}-6/*.xml
301%{_mandir}/man1/ImageMagick.*
302%{_mandir}/man1/[a-z]*
303
304%files devel
305%defattr(-,root,root)
306%{_bindir}/Magick-config
307%{_bindir}/Wand-config
308%{_bindir}/MagickCore-config
309%{_bindir}/MagickWand-config
310%{_libdir}/libMagickCore-6.Q16.so
311%{_libdir}/libMagickWand-6.Q16.so
312%{_libdir}/pkgconfig/ImageMagick-6.Q16.pc
313%{_libdir}/pkgconfig/ImageMagick.pc
314%{_libdir}/pkgconfig/Wand-6.Q16.pc
315%{_libdir}/pkgconfig/Wand.pc
316%{_libdir}/pkgconfig/MagickCore-6.Q16.pc
317%{_libdir}/pkgconfig/MagickCore.pc
318%{_libdir}/pkgconfig/MagickWand-6.Q16.pc
319%{_libdir}/pkgconfig/MagickWand.pc
320%{_includedir}/ImageMagick-6/magick
321%{_includedir}/ImageMagick-6/wand
322%{_mandir}/man1/Magick-config*
323%{_mandir}/man1/Wand-config*
324%{_mandir}/man1/MagickCore-config*
325%{_mandir}/man1/MagickWand-config*
326
327%files c++
328%defattr(-,root,root)
329%{_libdir}/libMagick++-6.Q16.so.*
330
331%files c++-devel
332%defattr(-,root,root)
333%{_bindir}/Magick++-config
334%{_includedir}/ImageMagick-6/Magick++
335%{_includedir}/ImageMagick-6/Magick++.h
336%{_libdir}/libMagick++-6.Q16.so
337%{_libdir}/pkgconfig/ImageMagick++-6.Q16.pc
338%{_libdir}/pkgconfig/ImageMagick++.pc
339%{_libdir}/pkgconfig/Magick++-6.Q16.pc
340%{_libdir}/pkgconfig/Magick++.pc
341%{_mandir}/man1/Magick++-config*
342
343%files -n perl-Image-Magick -f perl-pkg-files
344%defattr(-,root,root)
345%{_mandir}/man3/*
346
347
348%changelog
349* Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.9.11.48-1
350- new upstream release.
351
352* Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.9.10.69-1
353- new upstream release.
354
355* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.4.8-2
356- rebuild with gcc-5.4.0
357
358* Thu Jun  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.9.4.8-1
359- new upstream release.
360
361* Mon May 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.4.0-1
362- new upstream release
363  (including security fix for CVE-2016-3714,3715,3716,3717,3718,4562,4563,4564)
364
365* Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.1.4-1
366- new upstream release
367
368* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.1.2-1
369- new upstream release
370
371* Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.1.1-1
372- new upstream release
373
374* Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.9.0.0-1
375- new upstream release
376- built with OpenEXR 2.2.0
377
378* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.7-1
379- new upstream release
380
381* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.5-1
382- new upstream release
383
384* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.8.0-1
385- new upstream release
386
387* Sun Dec 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.8-1
388- new upstream release
389
390* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.5-1
391- new upstream release
392
393* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.6.8-1
394- new upstream release
395
396* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.9.3-1
397- new upstream release
398
399* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.8.3-1
400- new upstream release
401
402* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.7.6-1
403- new upstream release
404
405* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.6.8-1
406- new upstream release
407
408* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.5.10-1
409- new upstream release
410- add BuildRequires: pango-devel
411- change BuildRequires: lcms2-devel instead of lcms-devel
412
413* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
414- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
415
416* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
417- built with perl-5.12.3
418- changed perl subpackage name
419
420* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
421- new upstream release
422
423* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
424- rebuilt with graphviz-2.26.3 again
425
426* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
427- new upstream release
428- rebuilt with graphviz-2.26.3
429
430* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
431- new upstream release
432
433* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
434- rebuild with rpm-4.8.1 for pkg-config file
435- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
436- change Requires: libjpeg-turbo instead of libjpeg
437
438* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
439- new upstream release
440- built with new toolchain
441- added --disable-static to %%configure, removed static libraries
442
443* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
444- added --without-djvu --without-fftw
445
446* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
447- new upstream release
448
449* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
450- new upstream release
451
452* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
453- new upstream release
454- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
455- add R: graphviz, OpenEXR-libs, ilmbase
456
457* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
458- new upstream release
459- added Packager tag
460
461* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
462- new upstream release
463
464* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
465- new upstream release
466- updated BuildRequires
467
468* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
469- enabled lcms as default.
470
471* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
472- new upstream release
473
474* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
475- new upstream release
476
477* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
478- new upstream release
479
480* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
481- new upstream release
482
483* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
484- new upstream release
485- spec in UTF-8
486
487* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
488- enabled to build with lcms (use '--with lcms' to enable).
489
490* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
491- new upstream release
492- rebuilt with perl-5.10.0
493
494* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
495- new upstream release
496- removed *.la files from devel packages
497
498* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
499- new upstream release
500- change files section to fit new release
501- build under new versioning policy
502
503* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
504- new upstream release
505
506* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
507- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
508- add BuildPrereq: librsvg2-devel
509- add %{?_smp_mflags} to make command arg
510
511* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
512- new upstream release
513- changed Group to Applications/Graphics
514
515* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
516- rebuilt for VineSeed
517
518* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
519- update patch1 for fix CVE-2007-0770
520
521* Thu Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
522- upstream release
523- add patch1 for fix CVE-2006-5456
524
525* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
526- rebuilt (for ppc) to resolve reference to invalid *la files
527
528* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
529- new upstream release
530
531* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
532- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
533
534* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
535- new upstream release
536- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
537- add --with-perl-options to configure option
538
539* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
540- new upstream release
541- build with XOrg-6.9.0
542
543* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
544- new upstream release
545- add %%{_mandir}/man1/ImageMagick.* to main package
546
547* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
548- source upgrade
549- remove patch1
550- update %%files
551
552* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
553- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
554  (CAN-2004-0981)
555
556* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
557- move $(pkglibdir)/modules-Q16/*/*.la to main package.
558
559* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
560- source upgrade
561- Patch: change default menu font so display can work without XOrg-75dpi-fonts
562- add missing docs
563- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
564- *.pc should be in -devel package
565- add missing pkg{lib,data}dirs to %%files
566
567* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
568- source upgrade
569- add --without-dot to %%configure option
570- update %%files section
571
572* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
573- source upgrade
574
575* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
576- source upgrade
577
578* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
579- add --without-jbig to %%configure option
580
581* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
582- add --without-lcms to %%configure option
583
584* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
585- source upgrade
586- remove commented lines
587
588* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
589- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
590
591* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
592- source upgrade
593- remove patch for freetype2, no need
594- remove commented lines
595- add --with-quantum-depth=16 --with-modules --enable-lzw
596  --without-frozenpaths to %%configure option
597- remove --with-threads --without-xml from %%configure option
598- update %%files
599
600* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
601- patch update
602- add --without-jp2 to configure option
603- change PerlMagick build method
604
605* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
606- rebuild without jasper-devel
607
608* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
609- source upgrade to 5.5.7-15
610
611* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
612- source upgrade to 5.5.7-13
613- add patch0 to build against freetype2-2.1.7
614
615* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
616- source upgrade to 5.5.7-11
617- clean up spec
618- build without previous package (do not require libMagick.so.0)
619
620* Mon Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
621- source upgrade to 5.5.7-9
622- revised name of pkgconfig files
623- remove BuildPrereq: freetype-devel
624
625* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
626- source upgrade to 5.5.7-6
627- disable all patches
628- revised %%files section
629- disable libtoolize and autotools
630- change PerlMagick build method
631- build without previous package (do not require libMagick.so.5)
632
633* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
634- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
635  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
636
637* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
638- rebuild
639
640* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
641- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
642- FIXME: rpm's macro problem?
643
644- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
645  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
646
647  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
648  - remove unnecessary duplicated %%doc files
649  - --without-xml instead of --without-ttf
650  - eliminate libungif(-devel) from BuildReq/Requires
651  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
652
653  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
654  - add delegetes.mgk (and %%{_libdir}/%%{name})
655
656  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
657  - 5.2.9-0vl4
658  - Sorry, the spec was in Shift_JIS. Fixed.
659
660  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
661  - 5.2.9-0vl3
662  - rebuilt with perl-5.6.1
663  - added Japanese summary and description :-P
664  - added --without-ttf in order to disable freetype2 (SeedPlus) support
665  - added --without-wmf in order to disable libwmf (SeedPlus) support
666
667  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
668  - 5.2.9-0vl2
669  - rebuild on Perl-5.6
670  - use %%{perl_sitearch}
671  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
672
673  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
674  - 5.2.9-0vl1
675  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
676
677* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
678- fix perl paths in file list
679
680* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
681- lib64'ize
682- don't throw stuff in /usr/X11R6, that's for X only
683- remove files we aren't shipping
684
685* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
686- rebuilt with gcc-3.2 (we hope)
687
688* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
689- build using gcc-3.2-0.1
690
691* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
692- fix non-cpp headers in -devel package
693- fix #62157 (wrong path for include files in ImageMagick-devel)
694- fix #63897 (use _target instead of _arch) in libtool workaround
695- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
696
697* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
698- update
699- fix localdoc patch
700- fix %%files section
701- disable nonroot patch
702- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
703- fix libtool workaround
704- moved Magick*-config into -devel package (#64249)
705
706* Sun May 26 2002 Tim Powers <timp@redhat.com>
707- automated rebuild
708
709* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
710- 5.4.6
711
712* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
713- Update to pl 11
714
715* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
716- Update to 5.4.3 pl5; this fixes #58080
717
718* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
719- Patchlevel 3
720
721* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
722- automated rebuild
723
724* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
725- Update to 5.4.2-2
726- Fix #57923, also don't hardcode netscape as html viewer
727
728* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
729- 5.4.1
730- Link against new libstdc++
731
732* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
733- 5.4.0.5
734- Make the error message when trying to display an hpgl file more
735  explicit (#55875)
736
737* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
738- 5.4.0.3
739- Fix names of man pages
740
741* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
742- 5.4.0
743- work around build system breakage causing applications to be named
744  %{_arch}-redhat-linux-foo rather than foo
745
746* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
747- 5.3.9
748
749* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
750- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
751  (#52611)
752
753* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
754- Remove Magick++ includes from -devel, they're already in -c++-devel
755  (#51590)
756
757* Sat Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
758- 5.3.8 (bugfix release)
759
760* Fri Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
761- fix to build Perlmagic on s390 s390x
762
763* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
764- Add delegates.mgk to the package (#50725)
765
766* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
767- 5.3.7
768- Fix build without previously installed ImageMagick-devel (#49816)
769- Move perl bindings to a separate package.
770
771* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
772- Fix build as non-root again
773- Shut up rpmlint
774
775* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
776- 5.3.6
777- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
778
779* Sat Jun 16 2001 Than Ngo <than@redhat.com>
780- update to 5.3.5
781- cleanup specfile
782
783* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
784- 5.3.3-respin, fixes #41196
785
786* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
787- 5.3.3
788- Add a desktop file for "display" (RFE#17417)
789
790* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
791- 5.3.2
792- work around bugs in ia64 glibc headers
793
794* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
795- remove patch for s390, it is not necessary
796
797* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
798- 5.2.7
799
800* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
801- 5.2.6
802
803* Mon Dec 18 2000 Than Ngo <than@redhat.com>
804- ported to s390
805
806* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
807- 5.2.4
808- Fix up and package the C++ bindings in the new c++/c++-devel packages.
809
810* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
811- rebuild against new libpng
812
813* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
814- include images with docs (#10312)
815
816* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
817- don't build with -ggdb, use -g instead.
818
819* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
820- automatic rebuild
821
822* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
823- update to 5.2.2 beta
824
825* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
826- update to 5.2.1, redone patches as they failed
827
828* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
829- remove hacks to move perl man pages
830- don't include the perl*/man stuff, these files go in /usr/share/man now.
831
832* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
833- disable optimization on Alpha and Sparc
834
835* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
836- update to 5.2.0
837- update URL
838- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
839
840* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
841- bootstrap rebuilt to nuke broken libbz2 deps
842- add Prefix: tag such that the FHS macros work properly
843
844* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
845- now compiles with bzip2 1.0
846- changed buildroot to include version
847
848* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
849- fix compilation with new perl
850
851* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
852- 5.1.1
853
854* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
855- Rebuild to get compressed man pages
856
857* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
858- ugly hack to print with lpr instead of lp
859
860* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
861- update to 4.2.9
862
863* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
864- update to 4.2.8
865
866* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
867- include the perl man pages as well
868
869* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
870- remove --enable-16bit because it damages interoperability
871
872* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
873- update to 4.2.2
874- change ChangeLog to refer to actual dates.
875- strip binaries
876
877* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
878- add more files. Oops.
879
880* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
881- auto rebuild in the new build environment (release 2)
882
883* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
884- version 4.2.1
885
886* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
887- changed group
888
889* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
890- hacks to make it work with the new perl
891- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
892- make sure the libraries have the x bit on
893
894* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
895- translations modified for de, fr
896
897* Thu May 07 1998 Prospector System <bugs@redhat.com>
898- translations modified for de, fr, tr
899
900* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
901- updated to 4.0.5
902
903* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
904- updated to 4.0.4
905- added BuildRoot
906
907* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
908- updated from 3.8.3 to 3.9.1
909- removed PNG patch (appears to be fixed)
910
911* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
912- build against new libpng
913
914* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
915- built against glibc
916
917* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
918- updated to version 3.8.3.
919- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.