source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 10406

Revision 10406, 30.1 KB checked in by Takemikaduchi, 8 years ago (diff)

blender: new upstream release
others: rebuild with gcc-5.4.0

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.9.4
5%define Patchlevel 8
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 2%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20URL: http://www.imagemagick.org/
21
22%if "%{Patchlevel}" != ""
23Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
24%else
25Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.xz
26%endif
27#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
28
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30BuildRequires: bzip2-devel
31BuildRequires: cairo-devel
32BuildRequires: pango-devel
33BuildRequires: freetype2-devel >= 2.1.7
34BuildRequires: fontconfig-devel
35BuildRequires: giflib-devel
36BuildRequires: graphviz-devel
37BuildRequires: lcms2-devel
38BuildRequires: libjpeg-turbo-devel
39BuildRequires: libpng-devel >= 1.2.5
40BuildRequires: librsvg2-devel
41BuildRequires: libtiff-devel
42BuildRequires: libxml2-devel
43BuildRequires: libSM-devel
44BuildRequires: libX11-devel
45BuildRequires: libXext-devel
46BuildRequires: OpenEXR-devel
47BuildRequires: perl
48BuildRequires: xorg-x11-server-utils
49BuildRequires: zlib-devel
50BuildRequires: libXt-devel
51BuildRequires: xz-devel
52BuildRequires: xz-lzma-compat
53BuildRequires: libtool-ltdl-devel
54
55Requires: bzip2
56Requires: freetype2
57Requires: giflib
58Requires: graphviz
59Requires: lcms2
60Requires: libjpeg-turbo
61Requires: libpng
62Requires: libtiff
63Requires: libxml2
64Requires: OpenEXR-libs
65Requires: xorg-x11-server-utils
66Requires: zlib
67
68Vendor: Project Vine
69Distribution: Vine Linux
70Packager: inagaki, iwamoto, Takemikaduchi
71
72%description
73ImageMagick(TM) is an image display and manipulation tool for the X
74Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
75and Photo CD image formats. It can resize, rotate, sharpen, color
76reduce, or add special effects to an image, and when finished you can
77either save the completed work in the original format or a different
78one. ImageMagick also includes command line programs for creating
79animated or transparent .gifs, creating composite images, creating
80thumbnail images, and more.
81
82ImageMagick is one of your choices if you need a program to manipulate
83and dis play images. If you want to develop your own applications
84which use ImageMagick code or APIs, you need to install
85ImageMagick-devel as well.
86
87
88%description -l ja
89ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
90ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
91イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
92出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
93オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
94また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
95サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
96
97画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
98も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
99アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
100インストールして下さい.
101
102%package devel
103Summary: Static libraries and header files for ImageMagick app development.
104Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
105Group: Development/Libraries
106Requires: ImageMagick = %{version}-%{release}
107
108%description devel
109Image-Magick-devel contains the static libraries and header files you'll
110need to develop ImageMagick applications. ImageMagick is an image
111manipulation program.
112
113If you want to create applications that will use ImageMagick code or
114APIs, you need to install ImageMagick-devel as well as ImageMagick.
115You do noy need to install it if you just want to use ImageMagick,
116however.
117
118%description devel -l ja
119ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
120これらは ImageMagick アプリケーションの開発の際に必要となります.
121ImageMagick は画像処理プログラムです.
122
123ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
124この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
125する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
126インストールする必要はありません.
127
128%package c++
129Summary: ImageMagick Magick++ library (C++ bindings)
130Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
131Group: System Environment/Libraries
132Requires: ImageMagick = %{version}-%{release}
133
134%description c++
135This package contains the Magick++ library, a C++ binding to the ImageMagick
136graphics manipulation library.
137
138Install ImageMagick-c++ if you want to use any applications that use Magick++.
139
140%description c++ -l ja
141このパッケージには Magick++ ライブラリが収められています.
142Magick++ とは ImageMagick ライブラリの C++ バインディングです.
143
144Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
145パッケージをインストールして下さい.
146
147%package c++-devel
148Summary: C++ bindings for the ImageMagick library
149Summary(ja): ImageMagick ライブラリの C++ バインディング
150Group: Development/Libraries
151Requires: ImageMagick = %{version}-%{release}
152Requires: ImageMagick-c++ = %{version}-%{release}
153Requires: ImageMagick-devel = %{version}-%{release}
154
155%description c++-devel
156ImageMagick-devel contains the static libraries and header files you'll
157need to develop ImageMagick applications using the Magick++ C++ bindings.
158ImageMagick is an image manipulation program.
159
160If you want to create applications that will use Magick++ code
161or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
162ImageMagick.
163You don't need to install it if you just want to use ImageMagick, or if you
164want to develop/compile applications using the ImageMagick C interface,
165however.
166
167%description c++-devel -l ja
168ImageMagick-c++-devel には Magick++ C++ バインディングを使った
169ImageMagick アプリケーション開発に必要なスタティックライブラリと
170ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
171
172Magick++ コードや API を使ったアプリケーションを開発する場合は,
173ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
174インストールする必要があります.
175ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
176を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
177インストールする必要はありません.
178
179%package -n perl-Image-Magick
180Summary: ImageMagick perl bindings
181Summary(ja): ImageMagick の Perl バインディング
182Group: Development/Libraries
183Requires: ImageMagick = %{version}-%{release}
184Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
185Obsoletes: ImageMagick-perl < %{version}-%{release}
186Provides: ImageMagick-perl = %{version}-%{release}
187
188%description -n perl-Image-Magick
189Perl bindings to ImageMagick.
190
191Install ImageMagick-perl if you want to use any perl scripts that use
192ImageMagick.
193
194%description -n perl-Image-Magick -l ja
195このパッケージは ImageMagick の Perl バインディングです.
196
197ImageMagick を利用する perl スクリプトを使いたい場合は
198ImageMagick-perl パッケージをインストールして下さい.
199
200
201%prep
202%setup -q -n %{name}-%{VER}-%{Patchlevel}
203
204#patch1 -p1 -b .CVE-2006-5456
205
206%build
207%configure \
208    --enable-silent-rules \
209    --enable-shared \
210    --disable-static \
211    --with-modules \
212    --with-quantum-depth=16 \
213    --without-frozenpaths \
214    --with-x \
215    --without-dps \
216    --without-djvu \
217    --without-fftw \
218    --without-jbig \
219    --without-jp2 \
220    --with-lcms2 \
221    --without-wmf \
222    --with-perl \
223    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
224
225# Disable rpath
226sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
227sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
228
229make %{?_smp_mflags}
230
231%install
232rm -rf $RPM_BUILD_ROOT
233
234make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
235
236# perlmagick: fix perl path of demo files
237%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
238
239find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
240find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
241find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
242
243echo "%defattr(-,root,root)" > perl-pkg-files
244find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
245sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
246
247# remove duplicated doc files
248rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
249rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
250
251# remove files conflict with libtools
252rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
253rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
254
255# remove *.la files
256# remove only %{_libdir}/*.la
257# If you have removed module-*/*/*.la, it will fail to execute the command.
258find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
259
260rm -rf $RPM_BUILD_ROOT%{_docdir}/ImageMagick-6
261
262%clean
263rm -rf $RPM_BUILD_ROOT
264
265%post -p /sbin/ldconfig
266
267%post c++ -p /sbin/ldconfig
268
269%postun -p /sbin/ldconfig
270
271%postun c++ -p /sbin/ldconfig
272
273
274%files
275%defattr(-,root,root)
276%doc www images
277%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt NEWS.txt index.html
278%dir %{_libdir}/%{name}-%{VER}
279%dir %{_libdir}/%{name}-%{VER}/config-Q16
280%dir %{_libdir}/%{name}-%{VER}/modules-Q16
281%dir %{_libdir}/%{name}-%{VER}/modules-Q16/*
282%{_sysconfdir}/%{name}-6/*.xml
283%{_libdir}/%{name}-%{VER}/config-Q16/configure.xml
284%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.so
285%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.la
286%{_libdir}/libMagickCore-6.Q16.so.*
287%{_libdir}/libMagickWand-6.Q16.so.*
288%{_bindir}/[a-z]*
289%{_datadir}/%{name}-6/*.xml
290%{_mandir}/man1/ImageMagick.*
291%{_mandir}/man1/[a-z]*
292
293%files devel
294%defattr(-,root,root)
295%{_bindir}/Magick-config
296%{_bindir}/Wand-config
297%{_bindir}/MagickCore-config
298%{_bindir}/MagickWand-config
299%{_libdir}/libMagickCore-6.Q16.so
300%{_libdir}/libMagickWand-6.Q16.so
301%{_libdir}/pkgconfig/ImageMagick-6.Q16.pc
302%{_libdir}/pkgconfig/ImageMagick.pc
303%{_libdir}/pkgconfig/Wand-6.Q16.pc
304%{_libdir}/pkgconfig/Wand.pc
305%{_libdir}/pkgconfig/MagickCore-6.Q16.pc
306%{_libdir}/pkgconfig/MagickCore.pc
307%{_libdir}/pkgconfig/MagickWand-6.Q16.pc
308%{_libdir}/pkgconfig/MagickWand.pc
309%{_includedir}/ImageMagick-6/magick
310%{_includedir}/ImageMagick-6/wand
311%{_mandir}/man1/Magick-config*
312%{_mandir}/man1/Wand-config*
313%{_mandir}/man1/MagickCore-config*
314%{_mandir}/man1/MagickWand-config*
315
316%files c++
317%defattr(-,root,root)
318%{_libdir}/libMagick++-6.Q16.so.*
319
320%files c++-devel
321%defattr(-,root,root)
322%{_bindir}/Magick++-config
323%{_includedir}/ImageMagick-6/Magick++
324%{_includedir}/ImageMagick-6/Magick++.h
325%{_libdir}/libMagick++-6.Q16.so
326%{_libdir}/pkgconfig/ImageMagick++-6.Q16.pc
327%{_libdir}/pkgconfig/ImageMagick++.pc
328%{_libdir}/pkgconfig/Magick++-6.Q16.pc
329%{_libdir}/pkgconfig/Magick++.pc
330%{_mandir}/man1/Magick++-config*
331
332%files -n perl-Image-Magick -f perl-pkg-files
333%defattr(-,root,root)
334%{_mandir}/man3/*
335
336%changelog
337* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.4.8-2
338- rebuild with gcc-5.4.0
339
340* Thu Jun  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.9.4.8-1
341- new upstream release.
342
343* Mon May 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.4.0-1
344- new upstream release
345  (including security fix for CVE-2016-3714,3715,3716,3717,3718,4562,4563,4564)
346
347* Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.1.4-1
348- new upstream release
349
350* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.1.2-1
351- new upstream release
352
353* Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.1.1-1
354- new upstream release
355
356* Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.9.0.0-1
357- new upstream release
358- built with OpenEXR 2.2.0
359
360* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.7-1
361- new upstream release
362
363* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.5-1
364- new upstream release
365
366* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.8.0-1
367- new upstream release
368
369* Sun Dec 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.8-1
370- new upstream release
371
372* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.5-1
373- new upstream release
374
375* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.6.8-1
376- new upstream release
377
378* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.9.3-1
379- new upstream release
380
381* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.8.3-1
382- new upstream release
383
384* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.7.6-1
385- new upstream release
386
387* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.6.8-1
388- new upstream release
389
390* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.5.10-1
391- new upstream release
392- add BuildRequires: pango-devel
393- change BuildRequires: lcms2-devel instead of lcms-devel
394
395* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
396- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
397
398* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
399- built with perl-5.12.3
400- changed perl subpackage name
401
402* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
403- new upstream release
404
405* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
406- rebuilt with graphviz-2.26.3 again
407
408* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
409- new upstream release
410- rebuilt with graphviz-2.26.3
411
412* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
413- new upstream release
414
415* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
416- rebuild with rpm-4.8.1 for pkg-config file
417- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
418- change Requires: libjpeg-turbo instead of libjpeg
419
420* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
421- new upstream release
422- built with new toolchain
423- added --disable-static to %%configure, removed static libraries
424
425* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
426- added --without-djvu --without-fftw
427
428* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
429- new upstream release
430
431* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
432- new upstream release
433
434* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
435- new upstream release
436- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
437- add R: graphviz, OpenEXR-libs, ilmbase
438
439* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
440- new upstream release
441- added Packager tag
442
443* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
444- new upstream release
445
446* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
447- new upstream release
448- updated BuildRequires
449
450* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
451- enabled lcms as default.
452
453* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
454- new upstream release
455
456* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
457- new upstream release
458
459* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
460- new upstream release
461
462* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
463- new upstream release
464
465* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
466- new upstream release
467- spec in UTF-8
468
469* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
470- enabled to build with lcms (use '--with lcms' to enable).
471
472* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
473- new upstream release
474- rebuilt with perl-5.10.0
475
476* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
477- new upstream release
478- removed *.la files from devel packages
479
480* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
481- new upstream release
482- change files section to fit new release
483- build under new versioning policy
484
485* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
486- new upstream release
487
488* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
489- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
490- add BuildPrereq: librsvg2-devel
491- add %{?_smp_mflags} to make command arg
492
493* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
494- new upstream release
495- changed Group to Applications/Graphics
496
497* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
498- rebuilt for VineSeed
499
500* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
501- update patch1 for fix CVE-2007-0770
502
503* Thu Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
504- upstream release
505- add patch1 for fix CVE-2006-5456
506
507* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
508- rebuilt (for ppc) to resolve reference to invalid *la files
509
510* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
511- new upstream release
512
513* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
514- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
515
516* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
517- new upstream release
518- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
519- add --with-perl-options to configure option
520
521* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
522- new upstream release
523- build with XOrg-6.9.0
524
525* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
526- new upstream release
527- add %%{_mandir}/man1/ImageMagick.* to main package
528
529* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
530- source upgrade
531- remove patch1
532- update %%files
533
534* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
535- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
536  (CAN-2004-0981)
537
538* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
539- move $(pkglibdir)/modules-Q16/*/*.la to main package.
540
541* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
542- source upgrade
543- Patch: change default menu font so display can work without XOrg-75dpi-fonts
544- add missing docs
545- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
546- *.pc should be in -devel package
547- add missing pkg{lib,data}dirs to %%files
548
549* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
550- source upgrade
551- add --without-dot to %%configure option
552- update %%files section
553
554* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
555- source upgrade
556
557* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
558- source upgrade
559
560* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
561- add --without-jbig to %%configure option
562
563* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
564- add --without-lcms to %%configure option
565
566* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
567- source upgrade
568- remove commented lines
569
570* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
571- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
572
573* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
574- source upgrade
575- remove patch for freetype2, no need
576- remove commented lines
577- add --with-quantum-depth=16 --with-modules --enable-lzw
578  --without-frozenpaths to %%configure option
579- remove --with-threads --without-xml from %%configure option
580- update %%files
581
582* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
583- patch update
584- add --without-jp2 to configure option
585- change PerlMagick build method
586
587* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
588- rebuild without jasper-devel
589
590* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
591- source upgrade to 5.5.7-15
592
593* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
594- source upgrade to 5.5.7-13
595- add patch0 to build against freetype2-2.1.7
596
597* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
598- source upgrade to 5.5.7-11
599- clean up spec
600- build without previous package (do not require libMagick.so.0)
601
602* Mon Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
603- source upgrade to 5.5.7-9
604- revised name of pkgconfig files
605- remove BuildPrereq: freetype-devel
606
607* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
608- source upgrade to 5.5.7-6
609- disable all patches
610- revised %%files section
611- disable libtoolize and autotools
612- change PerlMagick build method
613- build without previous package (do not require libMagick.so.5)
614
615* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
616- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
617  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
618
619* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
620- rebuild
621
622* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
623- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
624- FIXME: rpm's macro problem?
625
626- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
627  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
628
629  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
630  - remove unnecessary duplicated %%doc files
631  - --without-xml instead of --without-ttf
632  - eliminate libungif(-devel) from BuildReq/Requires
633  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
634
635  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
636  - add delegetes.mgk (and %%{_libdir}/%%{name})
637
638  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
639  - 5.2.9-0vl4
640  - Sorry, the spec was in Shift_JIS. Fixed.
641
642  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
643  - 5.2.9-0vl3
644  - rebuilt with perl-5.6.1
645  - added Japanese summary and description :-P
646  - added --without-ttf in order to disable freetype2 (SeedPlus) support
647  - added --without-wmf in order to disable libwmf (SeedPlus) support
648
649  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
650  - 5.2.9-0vl2
651  - rebuild on Perl-5.6
652  - use %%{perl_sitearch}
653  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
654
655  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
656  - 5.2.9-0vl1
657  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
658
659* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
660- fix perl paths in file list
661
662* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
663- lib64'ize
664- don't throw stuff in /usr/X11R6, that's for X only
665- remove files we aren't shipping
666
667* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
668- rebuilt with gcc-3.2 (we hope)
669
670* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
671- build using gcc-3.2-0.1
672
673* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
674- fix non-cpp headers in -devel package
675- fix #62157 (wrong path for include files in ImageMagick-devel)
676- fix #63897 (use _target instead of _arch) in libtool workaround
677- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
678
679* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
680- update
681- fix localdoc patch
682- fix %%files section
683- disable nonroot patch
684- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
685- fix libtool workaround
686- moved Magick*-config into -devel package (#64249)
687
688* Sun May 26 2002 Tim Powers <timp@redhat.com>
689- automated rebuild
690
691* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
692- 5.4.6
693
694* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
695- Update to pl 11
696
697* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
698- Update to 5.4.3 pl5; this fixes #58080
699
700* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
701- Patchlevel 3
702
703* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
704- automated rebuild
705
706* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
707- Update to 5.4.2-2
708- Fix #57923, also don't hardcode netscape as html viewer
709
710* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
711- 5.4.1
712- Link against new libstdc++
713
714* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
715- 5.4.0.5
716- Make the error message when trying to display an hpgl file more
717  explicit (#55875)
718
719* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
720- 5.4.0.3
721- Fix names of man pages
722
723* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
724- 5.4.0
725- work around build system breakage causing applications to be named
726  %{_arch}-redhat-linux-foo rather than foo
727
728* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
729- 5.3.9
730
731* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
732- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
733  (#52611)
734
735* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
736- Remove Magick++ includes from -devel, they're already in -c++-devel
737  (#51590)
738
739* Sat Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
740- 5.3.8 (bugfix release)
741
742* Fri Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
743- fix to build Perlmagic on s390 s390x
744
745* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
746- Add delegates.mgk to the package (#50725)
747
748* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
749- 5.3.7
750- Fix build without previously installed ImageMagick-devel (#49816)
751- Move perl bindings to a separate package.
752
753* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
754- Fix build as non-root again
755- Shut up rpmlint
756
757* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
758- 5.3.6
759- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
760
761* Sat Jun 16 2001 Than Ngo <than@redhat.com>
762- update to 5.3.5
763- cleanup specfile
764
765* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
766- 5.3.3-respin, fixes #41196
767
768* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
769- 5.3.3
770- Add a desktop file for "display" (RFE#17417)
771
772* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
773- 5.3.2
774- work around bugs in ia64 glibc headers
775
776* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
777- remove patch for s390, it is not necessary
778
779* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
780- 5.2.7
781
782* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
783- 5.2.6
784
785* Mon Dec 18 2000 Than Ngo <than@redhat.com>
786- ported to s390
787
788* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
789- 5.2.4
790- Fix up and package the C++ bindings in the new c++/c++-devel packages.
791
792* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
793- rebuild against new libpng
794
795* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
796- include images with docs (#10312)
797
798* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
799- don't build with -ggdb, use -g instead.
800
801* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
802- automatic rebuild
803
804* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
805- update to 5.2.2 beta
806
807* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
808- update to 5.2.1, redone patches as they failed
809
810* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
811- remove hacks to move perl man pages
812- don't include the perl*/man stuff, these files go in /usr/share/man now.
813
814* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
815- disable optimization on Alpha and Sparc
816
817* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
818- update to 5.2.0
819- update URL
820- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
821
822* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
823- bootstrap rebuilt to nuke broken libbz2 deps
824- add Prefix: tag such that the FHS macros work properly
825
826* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
827- now compiles with bzip2 1.0
828- changed buildroot to include version
829
830* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
831- fix compilation with new perl
832
833* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
834- 5.1.1
835
836* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
837- Rebuild to get compressed man pages
838
839* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
840- ugly hack to print with lpr instead of lp
841
842* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
843- update to 4.2.9
844
845* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
846- update to 4.2.8
847
848* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
849- include the perl man pages as well
850
851* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
852- remove --enable-16bit because it damages interoperability
853
854* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
855- update to 4.2.2
856- change ChangeLog to refer to actual dates.
857- strip binaries
858
859* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
860- add more files. Oops.
861
862* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
863- auto rebuild in the new build environment (release 2)
864
865* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
866- version 4.2.1
867
868* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
869- changed group
870
871* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
872- hacks to make it work with the new perl
873- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
874- make sure the libraries have the x bit on
875
876* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
877- translations modified for de, fr
878
879* Thu May 07 1998 Prospector System <bugs@redhat.com>
880- translations modified for de, fr, tr
881
882* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
883- updated to 4.0.5
884
885* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
886- updated to 4.0.4
887- added BuildRoot
888
889* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
890- updated from 3.8.3 to 3.9.1
891- removed PNG patch (appears to be fixed)
892
893* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
894- build against new libpng
895
896* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
897- built against glibc
898
899* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
900- updated to version 3.8.3.
901- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.