source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 6141

Revision 6141, 28.2 KB checked in by Takemikaduchi, 12 years ago (diff)

esound: rebuild
others: new upstream release

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.7.6
5%define Patchlevel 8
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 1%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.xz
24%endif
25#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
26URL: http://www.imagemagick.org/
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: bzip2-devel
30BuildRequires: cairo-devel
31BuildRequires: pango-devel
32BuildRequires: freetype2-devel >= 2.1.7
33BuildRequires: fontconfig-devel
34BuildRequires: giflib-devel
35BuildRequires: graphviz-devel
36BuildRequires: lcms2-devel
37BuildRequires: libjpeg-turbo-devel
38BuildRequires: libpng-devel >= 1.2.5
39BuildRequires: librsvg2-devel
40BuildRequires: libtiff-devel
41BuildRequires: libxml2-devel
42BuildRequires: libSM-devel
43BuildRequires: libX11-devel
44BuildRequires: libXext-devel
45BuildRequires: OpenEXR-devel
46BuildRequires: perl
47BuildRequires: xorg-x11-server-utils
48BuildRequires: zlib-devel
49BuildRequires: libXt-devel
50BuildRequires: xz-devel
51BuildRequires: xz-lzma-compat
52BuildRequires: libtool-ltdl-devel
53
54Requires: bzip2
55Requires: freetype2
56Requires: giflib
57Requires: graphviz
58Requires: lcms2
59Requires: libjpeg-turbo
60Requires: libpng
61Requires: libtiff
62Requires: libxml2
63Requires: OpenEXR-libs
64Requires: xorg-x11-server-utils
65Requires: zlib
66
67Vendor: Project Vine
68Distribution: Vine Linux
69Packager: inagaki, iwamoto
70
71%description
72ImageMagick(TM) is an image display and manipulation tool for the X
73Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
74and Photo CD image formats. It can resize, rotate, sharpen, color
75reduce, or add special effects to an image, and when finished you can
76either save the completed work in the original format or a different
77one. ImageMagick also includes command line programs for creating
78animated or transparent .gifs, creating composite images, creating
79thumbnail images, and more.
80
81ImageMagick is one of your choices if you need a program to manipulate
82and dis play images. If you want to develop your own applications
83which use ImageMagick code or APIs, you need to install
84ImageMagick-devel as well.
85
86
87%description -l ja
88ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
89ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
90イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
91出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
92オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
93また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
94サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
95
96画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
97も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
98アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
99インストールして下さい.
100
101%package devel
102Summary: Static libraries and header files for ImageMagick app development.
103Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
104Group: Development/Libraries
105Requires: ImageMagick = %{version}-%{release}
106
107%description devel
108Image-Magick-devel contains the static libraries and header files you'll
109need to develop ImageMagick applications. ImageMagick is an image
110manipulation program.
111
112If you want to create applications that will use ImageMagick code or
113APIs, you need to install ImageMagick-devel as well as ImageMagick.
114You do noy need to install it if you just want to use ImageMagick,
115however.
116
117%description devel -l ja
118ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
119これらは ImageMagick アプリケーションの開発の際に必要となります.
120ImageMagick は画像処理プログラムです.
121
122ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
123この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
124する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
125インストールする必要はありません.
126
127%package c++
128Summary: ImageMagick Magick++ library (C++ bindings)
129Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
130Group: System Environment/Libraries
131Requires: ImageMagick = %{version}-%{release}
132
133%description c++
134This package contains the Magick++ library, a C++ binding to the ImageMagick
135graphics manipulation library.
136
137Install ImageMagick-c++ if you want to use any applications that use Magick++.
138
139%description c++
140このパッケージには Magick++ ライブラリが収められています.
141Magick++ とは ImageMagick ライブラリの C++ バインディングです.
142
143Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
144パッケージをインストールして下さい.
145
146%package c++-devel
147Summary: C++ bindings for the ImageMagick library
148Summary(ja): ImageMagick ライブラリの C++ バインディング
149Group: Development/Libraries
150Requires: ImageMagick = %{version}-%{release}
151Requires: ImageMagick-c++ = %{version}-%{release}
152Requires: ImageMagick-devel = %{version}-%{release}
153
154%description c++-devel
155ImageMagick-devel contains the static libraries and header files you'll
156need to develop ImageMagick applications using the Magick++ C++ bindings.
157ImageMagick is an image manipulation program.
158
159If you want to create applications that will use Magick++ code
160or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
161ImageMagick.
162You don't need to install it if you just want to use ImageMagick, or if you
163want to develop/compile applications using the ImageMagick C interface,
164however.
165
166%description c++-devel -l ja
167ImageMagick-c++-devel には Magick++ C++ バインディングを使った
168ImageMagick アプリケーション開発に必要なスタティックライブラリと
169ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
170
171Magick++ コードや API を使ったアプリケーションを開発する場合は,
172ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
173インストールする必要があります.
174ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
175を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
176インストールする必要はありません.
177
178%package -n perl-Image-Magick
179Summary: ImageMagick perl bindings
180Summary(ja): ImageMagick の Perl バインディング
181Group: Development/Libraries
182Requires: ImageMagick = %{version}-%{release}
183Requires: perl >= 5.8.0
184Obsoletes: ImageMagick-perl < %{version}-%{release}
185Provides: ImageMagick-perl = %{version}-%{release}
186
187%description -n perl-Image-Magick
188Perl bindings to ImageMagick.
189
190Install ImageMagick-perl if you want to use any perl scripts that use
191ImageMagick.
192
193%description -n perl-Image-Magick -l ja
194このパッケージは ImageMagick の Perl バインディングです.
195
196ImageMagick を利用する perl スクリプトを使いたい場合は
197ImageMagick-perl パッケージをインストールして下さい.
198
199
200%prep
201%setup -q -n %{name}-%{VER}-%{Patchlevel}
202
203#patch1 -p1 -b .CVE-2006-5456
204
205%build
206%configure \
207    --enable-silent-rules \
208    --enable-shared \
209    --disable-static \
210    --with-modules \
211    --with-quantum-depth=16 \
212    --without-frozenpaths \
213    --with-x \
214    --without-djvu \
215    --without-fftw \
216    --without-jbig \
217    --without-jp2 \
218    --with-lcms2 \
219    --without-wmf \
220    --with-perl \
221    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
222
223# Disable rpath
224sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
225sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
226
227make %{?_smp_mflags}
228
229%install
230rm -rf $RPM_BUILD_ROOT
231
232make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
233
234# perlmagick: fix perl path of demo files
235%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
236
237find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
238find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
239find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
240
241echo "%defattr(-,root,root)" > perl-pkg-files
242find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
243sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
244
245# remove duplicated doc files
246rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
247rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
248
249# remove files conflict with libtools
250rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
251rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
252
253# remove *.la files
254find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
255
256rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{VER}
257
258%clean
259rm -rf $RPM_BUILD_ROOT
260
261%post -p /sbin/ldconfig
262
263%post c++ -p /sbin/ldconfig
264
265%postun -p /sbin/ldconfig
266
267%postun c++ -p /sbin/ldconfig
268
269
270%files
271%defattr(-,root,root)
272%doc www images
273%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt NEWS.txt index.html
274%dir %{_libdir}/ImageMagick-%{VER}
275%{_libdir}/ImageMagick-%{VER}/config
276%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16
277%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16/*
278%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.so
279%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.la
280%{_libdir}/libMagickCore.so.*
281%{_libdir}/libMagickWand.so.*
282%{_bindir}/[a-z]*
283%{_sysconfdir}/%{name}/*.xml
284%{_sysconfdir}/%{name}/*.icc
285%{_mandir}/man1/ImageMagick.*
286%{_mandir}/man1/[a-z]*
287
288%files devel
289%defattr(-,root,root)
290%{_bindir}/Magick-config
291%{_bindir}/Wand-config
292%{_bindir}/MagickCore-config
293%{_bindir}/MagickWand-config
294#{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.a
295#{_libdir}/libMagickCore.a
296%{_libdir}/libMagickCore.so
297#{_libdir}/libMagickWand.a
298%{_libdir}/libMagickWand.so
299%{_libdir}/pkgconfig/ImageMagick.pc
300%{_libdir}/pkgconfig/Wand.pc
301%{_libdir}/pkgconfig/MagickCore.pc
302%{_libdir}/pkgconfig/MagickWand.pc
303%{_includedir}/ImageMagick/magick
304%{_includedir}/ImageMagick/wand
305%{_mandir}/man1/Magick-config*
306%{_mandir}/man1/Wand-config*
307%{_mandir}/man1/MagickCore-config*
308%{_mandir}/man1/MagickWand-config*
309
310%files c++
311%defattr(-,root,root)
312%{_libdir}/libMagick++.so.*
313
314%files c++-devel
315%defattr(-,root,root)
316%{_bindir}/Magick++-config
317%{_includedir}/ImageMagick/Magick++
318%{_includedir}/ImageMagick/Magick++.h
319#{_libdir}/libMagick++.a
320%{_libdir}/libMagick++.so
321%{_libdir}/pkgconfig/ImageMagick++.pc
322%{_libdir}/pkgconfig/Magick++.pc
323%{_mandir}/man1/Magick++-config*
324
325%files -n perl-Image-Magick -f perl-pkg-files
326%defattr(-,root,root)
327%{_mandir}/man3/*
328
329%changelog
330* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.6.8-1
331- new upstream release
332
333* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.5.10-1
334- new upstream release
335- add BuildRequires: pango-devel
336- change BuildRequires: lcms2-devel instead of lcms-devel
337
338* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
339- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
340
341* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
342- built with perl-5.12.3
343- changed perl subpackage name
344
345* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
346- new upstream release
347
348* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
349- rebuilt with graphviz-2.26.3 again
350
351* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
352- new upstream release
353- rebuilt with graphviz-2.26.3
354
355* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
356- new upstream release
357
358* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
359- rebuild with rpm-4.8.1 for pkg-config file
360- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
361- change Requires: libjpeg-turbo instead of libjpeg
362
363* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
364- new upstream release
365- built with new toolchain
366- added --disable-static to %%configure, removed static libraries
367
368* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
369- added --without-djvu --without-fftw
370
371* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
372- new upstream release
373
374* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
375- new upstream release
376
377* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
378- new upstream release
379- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
380- add R: graphviz, OpenEXR-libs, ilmbase
381
382* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
383- new upstream release
384- added Packager tag
385
386* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
387- new upstream release
388
389* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
390- new upstream release
391- updated BuildRequires
392
393* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
394- enabled lcms as default.
395
396* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
397- new upstream release
398
399* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
400- new upstream release
401
402* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
403- new upstream release
404
405* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
406- new upstream release
407
408* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
409- new upstream release
410- spec in UTF-8
411
412* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
413- enabled to build with lcms (use '--with lcms' to enable).
414
415* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
416- new upstream release
417- rebuilt with perl-5.10.0
418
419* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
420- new upstream release
421- removed *.la files from devel packages
422
423* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
424- new upstream release
425- change files section to fit new release
426- build under new versioning policy
427
428* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
429- new upstream release
430
431* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
432- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
433- add BuildPrereq: librsvg2-devel
434- add %{?_smp_mflags} to make command arg
435
436* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
437- new upstream release
438- changed Group to Applications/Graphics
439
440* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
441- rebuilt for VineSeed
442
443* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
444- update patch1 for fix CVE-2007-0770
445
446* Wed Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
447- upstream release
448- add patch1 for fix CVE-2006-5456
449
450* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
451- rebuilt (for ppc) to resolve reference to invalid *la files
452
453* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
454- new upstream release
455
456* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
457- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
458
459* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
460- new upstream release
461- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
462- add --with-perl-options to configure option
463
464* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
465- new upstream release
466- build with XOrg-6.9.0
467
468* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
469- new upstream release
470- add %%{_mandir}/man1/ImageMagick.* to main package
471
472* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
473- source upgrade
474- remove patch1
475- update %%files
476
477* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
478- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
479  (CAN-2004-0981)
480
481* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
482- move $(pkglibdir)/modules-Q16/*/*.la to main package.
483
484* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
485- source upgrade
486- Patch: change default menu font so display can work without XOrg-75dpi-fonts
487- add missing docs
488- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
489- *.pc should be in -devel package
490- add missing pkg{lib,data}dirs to %%files
491
492* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
493- source upgrade
494- add --without-dot to %%configure option
495- update %%files section
496
497* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
498- source upgrade
499
500* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
501- source upgrade
502
503* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
504- add --without-jbig to %%configure option
505
506* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
507- add --without-lcms to %%configure option
508
509* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
510- source upgrade
511- remove commented lines
512
513* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
514- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
515
516* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
517- source upgrade
518- remove patch for freetype2, no need
519- remove commented lines
520- add --with-quantum-depth=16 --with-modules --enable-lzw
521  --without-frozenpaths to %%configure option
522- remove --with-threads --without-xml from %%configure option
523- update %%files
524
525* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
526- patch update
527- add --without-jp2 to configure option
528- change PerlMagick build method
529
530* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
531- rebuild without jasper-devel
532
533* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
534- source upgrade to 5.5.7-15
535
536* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
537- source upgrade to 5.5.7-13
538- add patch0 to build against freetype2-2.1.7
539
540* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
541- source upgrade to 5.5.7-11
542- clean up spec
543- build without previous package (do not require libMagick.so.0)
544
545* Sun Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
546- source upgrade to 5.5.7-9
547- revised name of pkgconfig files
548- remove BuildPrereq: freetype-devel
549
550* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
551- source upgrade to 5.5.7-6
552- disable all patches
553- revised %%files section
554- disable libtoolize and autotools
555- change PerlMagick build method
556- build without previous package (do not require libMagick.so.5)
557
558* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
559- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
560  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
561
562* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
563- rebuild
564
565* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
566- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
567- FIXME: rpm's macro problem?
568
569- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
570  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
571
572  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
573  - remove unnecessary duplicated %%doc files
574  - --without-xml instead of --without-ttf
575  - eliminate libungif(-devel) from BuildReq/Requires
576  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
577
578  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
579  - add delegetes.mgk (and %%{_libdir}/%%{name})
580
581  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
582  - 5.2.9-0vl4
583  - Sorry, the spec was in Shift_JIS. Fixed.
584
585  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
586  - 5.2.9-0vl3
587  - rebuilt with perl-5.6.1
588  - added Japanese summary and description :-P
589  - added --without-ttf in order to disable freetype2 (SeedPlus) support
590  - added --without-wmf in order to disable libwmf (SeedPlus) support
591
592  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
593  - 5.2.9-0vl2
594  - rebuild on Perl-5.6
595  - use %%{perl_sitearch}
596  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
597
598  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
599  - 5.2.9-0vl1
600  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
601
602* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
603- fix perl paths in file list
604
605* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
606- lib64'ize
607- don't throw stuff in /usr/X11R6, that's for X only
608- remove files we aren't shipping
609
610* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
611- rebuilt with gcc-3.2 (we hope)
612
613* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
614- build using gcc-3.2-0.1
615
616* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
617- fix non-cpp headers in -devel package
618- fix #62157 (wrong path for include files in ImageMagick-devel)
619- fix #63897 (use _target instead of _arch) in libtool workaround
620- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
621
622* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
623- update
624- fix localdoc patch
625- fix %%files section
626- disable nonroot patch
627- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
628- fix libtool workaround
629- moved Magick*-config into -devel package (#64249)
630
631* Sun May 26 2002 Tim Powers <timp@redhat.com>
632- automated rebuild
633
634* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
635- 5.4.6
636
637* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
638- Update to pl 11
639
640* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
641- Update to 5.4.3 pl5; this fixes #58080
642
643* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
644- Patchlevel 3
645
646* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
647- automated rebuild
648
649* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
650- Update to 5.4.2-2
651- Fix #57923, also don't hardcode netscape as html viewer
652
653* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
654- 5.4.1
655- Link against new libstdc++
656
657* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
658- 5.4.0.5
659- Make the error message when trying to display an hpgl file more
660  explicit (#55875)
661
662* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
663- 5.4.0.3
664- Fix names of man pages
665
666* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
667- 5.4.0
668- work around build system breakage causing applications to be named
669  %{_arch}-redhat-linux-foo rather than foo
670
671* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
672- 5.3.9
673
674* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
675- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
676  (#52611)
677
678* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
679- Remove Magick++ includes from -devel, they're already in -c++-devel
680  (#51590)
681
682* Sun Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
683- 5.3.8 (bugfix release)
684
685* Sat Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
686- fix to build Perlmagic on s390 s390x
687
688* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
689- Add delegates.mgk to the package (#50725)
690
691* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
692- 5.3.7
693- Fix build without previously installed ImageMagick-devel (#49816)
694- Move perl bindings to a separate package.
695
696* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
697- Fix build as non-root again
698- Shut up rpmlint
699
700* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
701- 5.3.6
702- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
703
704* Sat Jun 16 2001 Than Ngo <than@redhat.com>
705- update to 5.3.5
706- cleanup specfile
707
708* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
709- 5.3.3-respin, fixes #41196
710
711* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
712- 5.3.3
713- Add a desktop file for "display" (RFE#17417)
714
715* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
716- 5.3.2
717- work around bugs in ia64 glibc headers
718
719* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
720- remove patch for s390, it is not necessary
721
722* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
723- 5.2.7
724
725* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
726- 5.2.6
727
728* Mon Dec 18 2000 Than Ngo <than@redhat.com>
729- ported to s390
730
731* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
732- 5.2.4
733- Fix up and package the C++ bindings in the new c++/c++-devel packages.
734
735* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
736- rebuild against new libpng
737
738* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
739- include images with docs (#10312)
740
741* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
742- don't build with -ggdb, use -g instead.
743
744* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
745- automatic rebuild
746
747* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
748- update to 5.2.2 beta
749
750* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
751- update to 5.2.1, redone patches as they failed
752
753* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
754- remove hacks to move perl man pages
755- don't include the perl*/man stuff, these files go in /usr/share/man now.
756
757* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
758- disable optimization on Alpha and Sparc
759
760* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
761- update to 5.2.0
762- update URL
763- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
764
765* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
766- bootstrap rebuilt to nuke broken libbz2 deps
767- add Prefix: tag such that the FHS macros work properly
768
769* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
770- now compiles with bzip2 1.0
771- changed buildroot to include version
772
773* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
774- fix compilation with new perl
775
776* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
777- 5.1.1
778
779* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
780- Rebuild to get compressed man pages
781
782* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
783- ugly hack to print with lpr instead of lp
784
785* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
786- update to 4.2.9
787
788* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
789- update to 4.2.8
790
791* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
792- include the perl man pages as well
793
794* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
795- remove --enable-16bit because it damages interoperability
796
797* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
798- update to 4.2.2
799- change ChangeLog to refer to actual dates.
800- strip binaries
801
802* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
803- add more files. Oops.
804
805* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
806- auto rebuild in the new build environment (release 2)
807
808* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
809- version 4.2.1
810
811* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
812- changed group
813
814* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
815- hacks to make it work with the new perl
816- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
817- make sure the libraries have the x bit on
818
819* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
820- translations modified for de, fr
821
822* Thu May 07 1998 Prospector System <bugs@redhat.com>
823- translations modified for de, fr, tr
824
825* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
826- updated to 4.0.5
827
828* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
829- updated to 4.0.4
830- added BuildRoot
831
832* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
833- updated from 3.8.3 to 3.9.1
834- removed PNG patch (appears to be fixed)
835
836* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
837- build against new libpng
838
839* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
840- built against glibc
841
842* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
843- updated to version 3.8.3.
844- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.