source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 3013

Revision 3013, 27.6 KB checked in by inagaki, 13 years ago (diff)

update: ImageMagick?

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.6.8
5%define Patchlevel 5
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 1%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.bz2
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.bz2
24%endif
25#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
26URL: http://www.imagemagick.org/
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: bzip2-devel
30BuildRequires: cairo-devel
31BuildRequires: freetype2-devel >= 2.1.7
32BuildRequires: fontconfig-devel
33BuildRequires: giflib-devel
34BuildRequires: graphviz-devel
35BuildRequires: lcms-devel
36BuildRequires: libjpeg-turbo-devel
37BuildRequires: libpng-devel >= 1.2.5
38BuildRequires: librsvg2-devel
39BuildRequires: libtiff-devel
40BuildRequires: libxml2-devel
41BuildRequires: libSM-devel
42BuildRequires: libX11-devel
43BuildRequires: libXext-devel
44BuildRequires: OpenEXR-devel
45BuildRequires: perl
46BuildRequires: xorg-x11-server-utils
47BuildRequires: zlib-devel
48
49Requires: bzip2
50Requires: freetype2
51Requires: giflib
52Requires: graphviz
53Requires: lcms
54Requires: libjpeg-turbo
55Requires: libpng
56Requires: libtiff
57Requires: libxml2
58Requires: OpenEXR-libs
59Requires: xorg-x11-server-utils
60Requires: zlib
61
62Vendor: Project Vine
63Distribution: Vine Linux
64Packager: inagaki, iwamoto
65
66%description
67ImageMagick(TM) is an image display and manipulation tool for the X
68Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
69and Photo CD image formats. It can resize, rotate, sharpen, color
70reduce, or add special effects to an image, and when finished you can
71either save the completed work in the original format or a different
72one. ImageMagick also includes command line programs for creating
73animated or transparent .gifs, creating composite images, creating
74thumbnail images, and more.
75
76ImageMagick is one of your choices if you need a program to manipulate
77and dis play images. If you want to develop your own applications
78which use ImageMagick code or APIs, you need to install
79ImageMagick-devel as well.
80
81
82%description -l ja
83ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
84ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
85イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
86出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
87オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
88また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
89サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
90
91画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
92も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
93アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
94インストールして下さい.
95
96%package devel
97Summary: Static libraries and header files for ImageMagick app development.
98Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
99Group: Development/Libraries
100Requires: ImageMagick = %{version}-%{release}
101
102%description devel
103Image-Magick-devel contains the static libraries and header files you'll
104need to develop ImageMagick applications. ImageMagick is an image
105manipulation program.
106
107If you want to create applications that will use ImageMagick code or
108APIs, you need to install ImageMagick-devel as well as ImageMagick.
109You do noy need to install it if you just want to use ImageMagick,
110however.
111
112%description devel -l ja
113ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
114これらは ImageMagick アプリケーションの開発の際に必要となります.
115ImageMagick は画像処理プログラムです.
116
117ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
118この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
119する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
120インストールする必要はありません.
121
122%package perl
123Summary: ImageMagick perl bindings
124Summary(ja): ImageMagick の Perl バインディング
125Group: Development/Libraries
126Requires: ImageMagick = %{version}-%{release}
127Requires: perl >= 5.8.0
128
129%description perl
130Perl bindings to ImageMagick.
131
132Install ImageMagick-perl if you want to use any perl scripts that use
133ImageMagick.
134
135%description perl -l ja
136このパッケージは ImageMagick の Perl バインディングです.
137
138ImageMagick を利用する perl スクリプトを使いたい場合は
139ImageMagick-perl パッケージをインストールして下さい.
140
141
142%package c++
143Summary: ImageMagick Magick++ library (C++ bindings)
144Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
145Group: System Environment/Libraries
146Requires: ImageMagick = %{version}-%{release}
147
148%description c++
149This package contains the Magick++ library, a C++ binding to the ImageMagick
150graphics manipulation library.
151
152Install ImageMagick-c++ if you want to use any applications that use Magick++.
153
154%description c++
155このパッケージには Magick++ ライブラリが収められています.
156Magick++ とは ImageMagick ライブラリの C++ バインディングです.
157
158Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
159パッケージをインストールして下さい.
160
161%package c++-devel
162Summary: C++ bindings for the ImageMagick library
163Summary(ja): ImageMagick ライブラリの C++ バインディング
164Group: Development/Libraries
165Requires: ImageMagick = %{version}-%{release}
166Requires: ImageMagick-c++ = %{version}-%{release}
167Requires: ImageMagick-devel = %{version}-%{release}
168
169%description c++-devel
170ImageMagick-devel contains the static libraries and header files you'll
171need to develop ImageMagick applications using the Magick++ C++ bindings.
172ImageMagick is an image manipulation program.
173
174If you want to create applications that will use Magick++ code
175or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
176ImageMagick.
177You don't need to install it if you just want to use ImageMagick, or if you
178want to develop/compile applications using the ImageMagick C interface,
179however.
180
181%description c++-devel -l ja
182ImageMagick-c++-devel には Magick++ C++ バインディングを使った
183ImageMagick アプリケーション開発に必要なスタティックライブラリと
184ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
185
186Magick++ コードや API を使ったアプリケーションを開発する場合は,
187ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
188インストールする必要があります.
189ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
190を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
191インストールする必要はありません.
192
193
194%prep
195%setup -q -n %{name}-%{VER}-%{Patchlevel}
196
197#patch1 -p1 -b .CVE-2006-5456
198
199%build
200%configure \
201    --enable-silent-rules \
202    --enable-shared \
203    --disable-static \
204    --with-modules \
205    --with-quantum-depth=16 \
206    --without-frozenpaths \
207    --with-x \
208    --without-djvu \
209    --without-fftw \
210    --without-jbig \
211    --without-jp2 \
212    --without-lcms2 \
213    --without-wmf \
214    --with-perl \
215    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
216
217# Disable rpath
218sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
219sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
220
221make %{?_smp_mflags}
222
223%install
224rm -rf $RPM_BUILD_ROOT
225
226make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
227
228# perlmagick: fix perl path of demo files
229%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
230
231# get the perl file list. We know what we need, so this is easy
232perlver=`perl -v |grep built |sed -e "s,.*v,,;s, .*,,"`
233perlmajor=`echo $perlver |sed -e "s,\..*,,"`
234
235find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
236find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
237find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
238
239echo "%defattr(-,root,root)" > perl-pkg-files
240find $RPM_BUILD_ROOT%{_libdir}/perl$perlmajor/vendor_perl/$perlver -type d -name Image >> perl-pkg-files.orig
241sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
242
243# remove duplicated doc files
244rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
245
246# remove files conflict with libtools
247rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
248rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
249
250# remove *.la files
251find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
252
253%clean
254rm -rf $RPM_BUILD_ROOT
255
256%post -p /sbin/ldconfig
257
258%post c++ -p /sbin/ldconfig
259
260%postun -p /sbin/ldconfig
261
262%postun c++ -p /sbin/ldconfig
263
264
265%files
266%defattr(-,root,root)
267%doc www images
268%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt index.html
269%dir %{_libdir}/ImageMagick-%{VER}
270%{_libdir}/ImageMagick-%{VER}/config
271%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16
272%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16/*
273%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.so
274%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.la
275%{_libdir}/libMagickCore.so.*
276%{_libdir}/libMagickWand.so.*
277%{_bindir}/[a-z]*
278%dir %{_datadir}/ImageMagick-%{VER}
279%dir %{_datadir}/ImageMagick-%{VER}/config
280%{_datadir}/ImageMagick-%{VER}/config/*.xml
281%{_datadir}/ImageMagick-%{VER}/config/*.icm
282%{_mandir}/man1/ImageMagick.*
283%{_mandir}/man1/[a-z]*
284
285%files devel
286%defattr(-,root,root)
287%{_bindir}/Magick-config
288%{_bindir}/Wand-config
289%{_bindir}/MagickCore-config
290%{_bindir}/MagickWand-config
291#{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.a
292#{_libdir}/libMagickCore.a
293%{_libdir}/libMagickCore.so
294#{_libdir}/libMagickWand.a
295%{_libdir}/libMagickWand.so
296%{_libdir}/pkgconfig/ImageMagick.pc
297%{_libdir}/pkgconfig/Wand.pc
298%{_libdir}/pkgconfig/MagickCore.pc
299%{_libdir}/pkgconfig/MagickWand.pc
300%{_includedir}/ImageMagick/magick
301%{_includedir}/ImageMagick/wand
302%{_mandir}/man1/Magick-config*
303%{_mandir}/man1/Wand-config*
304%{_mandir}/man1/MagickCore-config*
305%{_mandir}/man1/MagickWand-config*
306
307%files c++
308%defattr(-,root,root)
309%{_libdir}/libMagick++.so.*
310
311%files c++-devel
312%defattr(-,root,root)
313%{_bindir}/Magick++-config
314%{_includedir}/ImageMagick/Magick++
315%{_includedir}/ImageMagick/Magick++.h
316#{_libdir}/libMagick++.a
317%{_libdir}/libMagick++.so
318%{_libdir}/pkgconfig/ImageMagick++.pc
319%{_libdir}/pkgconfig/Magick++.pc
320%{_mandir}/man1/Magick++-config*
321
322%files perl -f perl-pkg-files
323%defattr(-,root,root)
324%{_mandir}/man3/*
325
326%changelog
327* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
328- new upstream release
329
330* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
331- rebuilt with graphviz-2.26.3 again
332
333* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
334- new upstream release
335- rebuilt with graphviz-2.26.3
336
337* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
338- new upstream release
339
340* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
341- rebuild with rpm-4.8.1 for pkg-config file
342- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
343- change Requires: libjpeg-turbo instead of libjpeg
344
345* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
346- new upstream release
347- built with new toolchain
348- added --disable-static to %%configure, removed static libraries
349
350* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
351- added --without-djvu --without-fftw
352
353* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
354- new upstream release
355
356* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
357- new upstream release
358
359* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
360- new upstream release
361- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
362- add R: graphviz, OpenEXR-libs, ilmbase
363
364* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
365- new upstream release
366- added Packager tag
367
368* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
369- new upstream release
370
371* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
372- new upstream release
373- updated BuildRequires
374
375* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
376- enabled lcms as default.
377
378* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
379- new upstream release
380
381* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
382- new upstream release
383
384* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
385- new upstream release
386
387* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
388- new upstream release
389
390* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
391- new upstream release
392- spec in UTF-8
393
394* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
395- enabled to build with lcms (use '--with lcms' to enable).
396
397* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
398- new upstream release
399- rebuilt with perl-5.10.0
400
401* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
402- new upstream release
403- removed *.la files from devel packages
404
405* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
406- new upstream release
407- change files section to fit new release
408- build under new versioning policy
409
410* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
411- new upstream release
412
413* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
414- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
415- add BuildPrereq: librsvg2-devel
416- add %{?_smp_mflags} to make command arg
417
418* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
419- new upstream release
420- changed Group to Applications/Graphics
421
422* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
423- rebuilt for VineSeed
424
425* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
426- update patch1 for fix CVE-2007-0770
427
428* Wed Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
429- upstream release
430- add patch1 for fix CVE-2006-5456
431
432* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
433- rebuilt (for ppc) to resolve reference to invalid *la files
434
435* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
436- new upstream release
437
438* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
439- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
440
441* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
442- new upstream release
443- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
444- add --with-perl-options to configure option
445
446* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
447- new upstream release
448- build with XOrg-6.9.0
449
450* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
451- new upstream release
452- add %%{_mandir}/man1/ImageMagick.* to main package
453
454* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
455- source upgrade
456- remove patch1
457- update %%files
458
459* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
460- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
461  (CAN-2004-0981)
462
463* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
464- move $(pkglibdir)/modules-Q16/*/*.la to main package.
465
466* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
467- source upgrade
468- Patch: change default menu font so display can work without XOrg-75dpi-fonts
469- add missing docs
470- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
471- *.pc should be in -devel package
472- add missing pkg{lib,data}dirs to %%files
473
474* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
475- source upgrade
476- add --without-dot to %%configure option
477- update %%files section
478
479* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
480- source upgrade
481
482* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
483- source upgrade
484
485* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
486- add --without-jbig to %%configure option
487
488* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
489- add --without-lcms to %%configure option
490
491* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
492- source upgrade
493- remove commented lines
494
495* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
496- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
497
498* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
499- source upgrade
500- remove patch for freetype2, no need
501- remove commented lines
502- add --with-quantum-depth=16 --with-modules --enable-lzw
503  --without-frozenpaths to %%configure option
504- remove --with-threads --without-xml from %%configure option
505- update %%files
506
507* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
508- patch update
509- add --without-jp2 to configure option
510- change PerlMagick build method
511
512* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
513- rebuild without jasper-devel
514
515* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
516- source upgrade to 5.5.7-15
517
518* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
519- source upgrade to 5.5.7-13
520- add patch0 to build against freetype2-2.1.7
521
522* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
523- source upgrade to 5.5.7-11
524- clean up spec
525- build without previous package (do not require libMagick.so.0)
526
527* Sun Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
528- source upgrade to 5.5.7-9
529- revised name of pkgconfig files
530- remove BuildPrereq: freetype-devel
531
532* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
533- source upgrade to 5.5.7-6
534- disable all patches
535- revised %%files section
536- disable libtoolize and autotools
537- change PerlMagick build method
538- build without previous package (do not require libMagick.so.5)
539
540* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
541- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
542  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
543
544* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
545- rebuild
546
547* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
548- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
549- FIXME: rpm's macro problem?
550
551- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
552  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
553
554  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
555  - remove unnecessary duplicated %%doc files
556  - --without-xml instead of --without-ttf
557  - eliminate libungif(-devel) from BuildReq/Requires
558  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
559
560  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
561  - add delegetes.mgk (and %%{_libdir}/%%{name})
562
563  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
564  - 5.2.9-0vl4
565  - Sorry, the spec was in Shift_JIS. Fixed.
566
567  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
568  - 5.2.9-0vl3
569  - rebuilt with perl-5.6.1
570  - added Japanese summary and description :-P
571  - added --without-ttf in order to disable freetype2 (SeedPlus) support
572  - added --without-wmf in order to disable libwmf (SeedPlus) support
573
574  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
575  - 5.2.9-0vl2
576  - rebuild on Perl-5.6
577  - use %%{perl_sitearch}
578  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
579
580  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
581  - 5.2.9-0vl1
582  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
583
584* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
585- fix perl paths in file list
586
587* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
588- lib64'ize
589- don't throw stuff in /usr/X11R6, that's for X only
590- remove files we aren't shipping
591
592* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
593- rebuilt with gcc-3.2 (we hope)
594
595* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
596- build using gcc-3.2-0.1
597
598* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
599- fix non-cpp headers in -devel package
600- fix #62157 (wrong path for include files in ImageMagick-devel)
601- fix #63897 (use _target instead of _arch) in libtool workaround
602- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
603
604* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
605- update
606- fix localdoc patch
607- fix %%files section
608- disable nonroot patch
609- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
610- fix libtool workaround
611- moved Magick*-config into -devel package (#64249)
612
613* Sun May 26 2002 Tim Powers <timp@redhat.com>
614- automated rebuild
615
616* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
617- 5.4.6
618
619* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
620- Update to pl 11
621
622* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
623- Update to 5.4.3 pl5; this fixes #58080
624
625* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
626- Patchlevel 3
627
628* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
629- automated rebuild
630
631* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
632- Update to 5.4.2-2
633- Fix #57923, also don't hardcode netscape as html viewer
634
635* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
636- 5.4.1
637- Link against new libstdc++
638
639* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
640- 5.4.0.5
641- Make the error message when trying to display an hpgl file more
642  explicit (#55875)
643
644* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
645- 5.4.0.3
646- Fix names of man pages
647
648* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
649- 5.4.0
650- work around build system breakage causing applications to be named
651  %{_arch}-redhat-linux-foo rather than foo
652
653* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
654- 5.3.9
655
656* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
657- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
658  (#52611)
659
660* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
661- Remove Magick++ includes from -devel, they're already in -c++-devel
662  (#51590)
663
664* Sun Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
665- 5.3.8 (bugfix release)
666
667* Sat Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
668- fix to build Perlmagic on s390 s390x
669
670* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
671- Add delegates.mgk to the package (#50725)
672
673* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
674- 5.3.7
675- Fix build without previously installed ImageMagick-devel (#49816)
676- Move perl bindings to a separate package.
677
678* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
679- Fix build as non-root again
680- Shut up rpmlint
681
682* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
683- 5.3.6
684- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
685
686* Sat Jun 16 2001 Than Ngo <than@redhat.com>
687- update to 5.3.5
688- cleanup specfile
689
690* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
691- 5.3.3-respin, fixes #41196
692
693* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
694- 5.3.3
695- Add a desktop file for "display" (RFE#17417)
696
697* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
698- 5.3.2
699- work around bugs in ia64 glibc headers
700
701* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
702- remove patch for s390, it is not necessary
703
704* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
705- 5.2.7
706
707* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
708- 5.2.6
709
710* Mon Dec 18 2000 Than Ngo <than@redhat.com>
711- ported to s390
712
713* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
714- 5.2.4
715- Fix up and package the C++ bindings in the new c++/c++-devel packages.
716
717* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
718- rebuild against new libpng
719
720* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
721- include images with docs (#10312)
722
723* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
724- don't build with -ggdb, use -g instead.
725
726* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
727- automatic rebuild
728
729* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
730- update to 5.2.2 beta
731
732* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
733- update to 5.2.1, redone patches as they failed
734
735* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
736- remove hacks to move perl man pages
737- don't include the perl*/man stuff, these files go in /usr/share/man now.
738
739* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
740- disable optimization on Alpha and Sparc
741
742* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
743- update to 5.2.0
744- update URL
745- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
746
747* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
748- bootstrap rebuilt to nuke broken libbz2 deps
749- add Prefix: tag such that the FHS macros work properly
750
751* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
752- now compiles with bzip2 1.0
753- changed buildroot to include version
754
755* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
756- fix compilation with new perl
757
758* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
759- 5.1.1
760
761* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
762- Rebuild to get compressed man pages
763
764* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
765- ugly hack to print with lpr instead of lp
766
767* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
768- update to 4.2.9
769
770* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
771- update to 4.2.8
772
773* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
774- include the perl man pages as well
775
776* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
777- remove --enable-16bit because it damages interoperability
778
779* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
780- update to 4.2.2
781- change ChangeLog to refer to actual dates.
782- strip binaries
783
784* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
785- add more files. Oops.
786
787* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
788- auto rebuild in the new build environment (release 2)
789
790* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
791- version 4.2.1
792
793* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
794- changed group
795
796* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
797- hacks to make it work with the new perl
798- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
799- make sure the libraries have the x bit on
800
801* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
802- translations modified for de, fr
803
804* Thu May 07 1998 Prospector System <bugs@redhat.com>
805- translations modified for de, fr, tr
806
807* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
808- updated to 4.0.5
809
810* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
811- updated to 4.0.4
812- added BuildRoot
813
814* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
815- updated from 3.8.3 to 3.9.1
816- removed PNG patch (appears to be fixed)
817
818* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
819- build against new libpng
820
821* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
822- built against glibc
823
824* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
825- updated to version 3.8.3.
826- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.