source: projects/specs/trunk/G/GConf2/GConf2-vl.spec @ 6890

Revision 6890, 15.9 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define libxml2_version 2.7.8
4%define orbit2_version 2.14.19
5%define glib2_version 2.32.0
6%define dbus_version 1.4.0
7%define dbus_glib_version 0.88
8
9Summary: A process-transparent configuration system
10Summary(ja): プロセス透過型設定システム
11Name: GConf2
12Version: 3.2.5
13Release: 2%{?_dist_release}
14License: LGPL
15Group: System Environment/Base
16Source: http://ftp.gnome.org/pub/GNOME/sources/GConf/3.2/GConf-%{version}.tar.xz
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18URL: http://www.gnome.org
19BuildRequires: libxml2-devel >= %{libxml2_version}
20BuildRequires: ORBit2-devel >= %{orbit2_version}
21BuildRequires: glib2-devel >= %{glib2_version}
22BuildRequires: dbus-devel >= %{dbus_version}
23BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
24BuildRequires: gtk3-devel
25BuildRequires: openldap-devel
26BuildRequires: gtk-doc >= 0.9
27BuildRequires: polkit-devel >= 0.99
28BuildRequires: gobject-introspection-devel
29Requires: dbus
30
31Patch0: GConf-2.18.0.1-reload.patch
32# http://bugzilla.gnome.org/show_bug.cgi?id=568845
33Patch1: GConf-gettext.patch
34
35Vendor: Project Vine
36Distribution: Vine Linux
37Packager: Takemikaduchi
38
39
40%description
41GConf is a process-transparent configuration database API used to
42store user preferences. It has pluggable backends and features to
43support workgroup administration.
44
45%description -l ja
46GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
47ベースの API です。バックエンドに接続しワークグループ管理をサポー
48トする機能を持っています。
49
50%package devel
51Summary: Headers and libraries for GConf development
52Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
53Group: Development/Libraries
54Requires: %{name} = %{version}
55Requires: ORBit2-devel >= %{orbit2_version}
56Requires: glib2-devel >= %{glib2_version}
57
58%description devel
59GConf development package. Contains files needed for doing
60development using GConf.
61
62%description -l ja devel
63GConf 開発パッケージです。GConf を使って開発するために必要なファ
64イルが含まれています。
65
66%package gtk
67Summary: Graphical GConf utilities
68Summary(ja): GConf グラフィカルユーティリティ
69Group: System Environment/Base
70Requires: %{name} = %{version}-%{release}
71
72%description gtk
73The GConf2-gtk package contains graphical GConf utilities
74which require GTK+.
75
76%description -l ja gtk
77GConf2-gtk パッケージには gtk3 を利用したグラフィカルな GConf
78ユーティリティが含まれています。
79
80
81
82%if %{build_compat32}
83#######################################################################
84# compat32
85%package -n compat32-%{name}
86Summary: A process-transparent configuration system
87Summary(ja): プロセス透過型設定システム
88Group: System Environment/Base
89Requires: compat32-glib2 >= %{glib2_version}
90
91%description -n compat32-%{name}
92GConf is a process-transparent configuration database API used to
93store user preferences. It has pluggable backends and features to
94support workgroup administration.
95
96%description -l ja -n compat32-%{name}
97GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
98ベースの API です。バックエンドに接続しワークグループ管理をサポー
99トする機能を持っています。
100
101%package -n compat32-%{name}-devel
102Summary: Headers and libraries for GConf development
103Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
104Group: Development/Libraries
105Requires: compat32-%{name} = %{version}
106Requires: %{name} = %{version}
107Requires: compat32-glib2 >= %{glib2_version}
108
109%description -n compat32-%{name}-devel
110GConf development package. Contains files needed for doing
111development using GConf.
112
113%description -l ja -n compat32-%{name}-devel
114GConf 開発パッケージです。GConf を使って開発するために必要なファ
115イルが含まれています。
116
117%endif
118
119%prep
120%setup -q -n GConf-%{version}
121
122%patch0 -p1 -b .reload
123%patch1 -p1 -b .gettext
124
125%build
126%configure --disable-gtk-doc --disable-static --enable-defaults-service --with-gtk=3.0
127%__make %{?_smp_mflags}
128
129%install
130rm -fr $RPM_BUILD_ROOT
131%__make install DESTDIR=$RPM_BUILD_ROOT
132
133mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas
134mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.system
135
136rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
137rm -f $RPM_BUILD_ROOT/%{_libdir}/GConf/2/*.la
138rm -f $RPM_BUILD_ROOT/%{_libdir}/gio/modules/*.la
139
140%find_lang %name
141
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145%post
146/sbin/ldconfig
147if [ $1 -gt 1 ]; then
148    if ! fgrep -q gconf.xml.system %{_sysconfdir}/gconf/2/path; then
149        sed -i -e 's@xml:readwrite:$(HOME)/.gconf@&\n\n# Location for system-wide settings.\nxml:readonly:/etc/gconf/gconf.xml.system@' %{_sysconfdir}/gconf/2/path
150    fi
151fi
152   
153%postun -p /sbin/ldconfig
154
155%files -f %{name}.lang
156%defattr(-, root, root)
157%doc COPYING ChangeLog NEWS README backends/README.evoldap
158%config %{_sysconfdir}/gconf/2/path
159%config %{_sysconfdir}/gconf/2/evoldap.conf
160%dir %{_sysconfdir}/gconf
161%dir %{_sysconfdir}/gconf/2
162%dir %{_sysconfdir}/gconf/gconf.xml.defaults
163%dir %{_sysconfdir}/gconf/gconf.xml.mandatory
164%dir %{_sysconfdir}/gconf/gconf.xml.system
165%dir %{_sysconfdir}/gconf/schemas
166%{_bindir}/*
167%{_libexecdir}/*
168%{_libdir}/*.so.*
169%dir %{_libdir}/GConf
170%dir %{_libdir}/GConf/2
171%{_libdir}/GConf/2/*.so
172%{_libdir}/girepository-1.0
173%{_mandir}/man1/*
174%{_datadir}/sgml/gconf/gconf-1.0.dtd
175%{_datadir}/GConf
176%{_sysconfdir}/dbus-1/system.d/org.gnome.GConf.Defaults.conf
177%{_datadir}/polkit-1/actions/org.gnome.gconf.defaults.policy
178%{_datadir}/dbus-1/system-services/org.gnome.GConf.Defaults.service
179%{_datadir}/dbus-1/services/org.gnome.GConf.service
180%{_sysconfdir}/xdg/autostart/gsettings-data-convert.desktop
181%{_libdir}/gio/modules/libgsettingsgconfbackend.so
182
183%files devel
184%defattr(-, root, root)
185%{_libdir}/*.so
186%{_includedir}/gconf
187%{_datadir}/aclocal/*.m4
188%{_datadir}/gtk-doc
189%{_datadir}/gir-1.0
190%{_libdir}/pkgconfig/*
191
192%files gtk
193%defattr(-, root, root)
194%{_libexecdir}/gconf-sanity-check-2
195
196%if %{build_compat32}
197%files -n compat32-%{name}
198%defattr(-,root,root,-)
199%{_libdir}/*.so.*
200%dir %{_libdir}/GConf
201%dir %{_libdir}/GConf/2
202%{_libdir}/GConf/2/*.so
203%{_libdir}/girepository-1.0
204%{_libdir}/gio/modules/libgsettingsgconfbackend.so
205
206%files -n compat32-%{name}-devel
207%defattr(-, root, root)
208%{_libdir}/*.so
209
210%endif
211
212%changelog
213* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.5-1
214- remove *.pc from compat32-%{name}-devel
215
216* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.5-1
217- new upstream release
218
219* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
220- new upstream release
221
222* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
223- new upstream release
224
225* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
226- new upstream release
227
228* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
229- new upstream release
230
231* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
232- new upstream release
233
234* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.6-1
235- new upstream release
236- remove Patch2
237
238* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
239- new upstream release
240- change configure option (from --with-gtk=2.0 to --with-gtk=3.0)
241- replace Patch2 (GConf2-3.1.4-gsettings-data-convert.patch)
242- delete Patch3,4
243
244* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
245- add gtk subpackage to include gconf-sanity-check-2
246- add --with-gtk=2.0
247
248* Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
249- new upstream release
250
251* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
252- new upstream release
253- add BuildRequires: gobject-introspection-devel
254- create compat32-%{name} package
255
256* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.28.1-2
257- build with rpm-4.8.1-1 for pkg-config file
258
259* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
260- new upstream release
261- drop Patch2, Patch3, Patch4
262
263* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
264- import upstream patches from fedora
265  - Patch1: gettext fix
266  - Patch2: avoid crash wen gconftool-2 cant read the db
267  - Patch3: make the defaults mechanism use the right polkit actions
268  - Patch4: donot catch segv etc. let abrt catch them
269- build with polkit, add BR: polkit-devel
270
271* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-1
272- new upstream release
273
274* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
275- add BR: dbus-devel, dbus-glib-devel (<BTS:0700>)
276
277* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
278- new upstream release
279
280* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
281- drop obsolete patch1
282
283* Sun Mar 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.0-2
284- rebuilt with openldap-2.4.11
285
286* Thu Mar 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
287- new upstream release
288
289* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
290- new upstream release
291
292* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.23.2-1
293- new upstream release
294
295* Tue Jul 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.22.0-2
296- spec in UTF-8
297
298* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
299- new upstream release
300
301* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
302- new upstream release
303- removed Prereq: install-info
304
305* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl2
306- rebuild with new environment
307
308* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
309- new upstream release
310
311* Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.14.0-0vl5
312- add BuildRequires: gtk2-devel
313
314* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.14.0-0vl4
315- rebuilt with openldap-2.3.27-0vl1
316
317* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 2.14.0-0vl3
318- rebuilt with openldap-2.3.24-0vl1
319
320* Tue May 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
321- add BuildRequires: openldap-devel
322
323* Sun Mar 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
324- new upstream release
325
326* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
327- reload gconf2 when schema is added/removed (patch0 from mdk)
328- only sync db once when installing multiple schemas. (patch1 from fc)
329
330* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
331- new upstream release
332
333* Wed Jan 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
334- new upstream release
335
336* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
337- new upstream release
338
339* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.92-0vl1
340- new upstream release
341
342* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
343- new upstream release
344
345* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
346- new upstream version
347
348* Thu Nov 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
349- add Japanese summaries and descriptions.
350  thanks to spec file translation project.
351
352* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
353- new upstream release
354
355* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0.1-0vl1
356- new upstream release
357
358* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
359- new upstream release
360
361* Tue Sep 02 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.3-0vl1
362- new upstream release
363
364* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
365- new upstream release
366- fix specfile kanjicode
367
368* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
369- new upstream release
370
371* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90-0vl1
372- new upstream release
373
374* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
375- build for Vine Linux
376
377* Fri Aug 30 2002 Havoc Pennington <hp@redhat.com>
378- add GCONF_LOCAL_LOCKS mode, and syslog encoding patch from tagoh
379
380* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
381- add dialog to offer to delete gconf locks
382
383* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
384- 1.2.1
385- include libexecdir stuff
386
387* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
388- move .pc fle to -devel package
389
390* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
391- automated rebuild
392
393* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
394- automated rebuild
395
396* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
397- fix warning on gnome-panel install
398
399* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
400- 1.2.0
401- own libdir/GConf/2 directory
402- include gtk-doc docs
403- don't include static lib for backend modules
404
405* Thu Jun 06 2002 Havoc Pennington <hp@redhat.com>
406- rebuild in different environment
407
408* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
409- 1.1.11
410- remove AUTHORS for rpmlint
411
412* Sun May 26 2002 Tim Powers <timp@redhat.com>
413- automated rebuild
414
415* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
416- rebuild in different environment
417
418* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
419- rebuild in different environment
420
421* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
422- 1.1.10
423
424* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
425- 1.1.9
426
427* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
428- 1.1.8
429- remove .la files
430
431* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
432- Version 1.1.6
433- Rebuild for dependencies
434
435* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
436- automated rebuild
437
438* Fri Jan  4 2002 Havoc Pennington <hp@redhat.com>
439- 1.1.5.93 snap with important bugfix so gconf actually works
440
441* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
442- 1.1.5.92 snap with GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
443
444* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
445- 1.1.5.91 snap with gconf.m4 fix for libgnome
446
447* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
448- since every other build seems to avoid libglib-1.3.so.11,
449  rebuild and hope
450
451* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
452- cvs snap 1.1.5.90
453
454* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
455- GConf 1.1.5, glib 1.3.11
456
457* Sat Oct 27 2001 Havoc Pennington <hp@redhat.com>
458- rebuild for glib 1.3.10
459
460* Sun Oct 14 2001 Havoc Pennington <hp@redhat.com>
461- 1.1.3
462
463* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
464- cvs snap, remove bonobo-activation deps
465
466* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
467- update to new CVS snap, rebuild
468
469* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
470- create gconf2 rpm based on gconf1, comment out pofiles
471- include .pc files
472
473* Fri Sep 14 2001 Havoc Pennington <hp@redhat.com>
474- fix description/summary
475
476* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
477- Add po files from sources.redhat.com
478
479* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
480- Add po files from sources.redhat.com
481
482* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
483- upgrade to 1.0.4 release I just made
484- fixes #51223, syslog spew
485
486* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
487- move gconf-config to devel RPM
488
489* Mon Jul 23 2001 Havoc Pennington <hp@redhat.com>
490- how many releases of GConf can I make before it works?
491
492* Sun Jul 22 2001 Havoc Pennington <hp@redhat.com>
493- Upgrade to 1.0.2 (which contains only bugfixes that
494  I reviewed and/or wrote myself)
495
496* Wed Jul 18 2001 Havoc Pennington <hp@redhat.com>
497- create the %{_sysconfdir}/gconf/gconf.xml.defaults directory
498
499* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
500- Install the .la files in the devel package.
501
502* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
503- Use %%{_tmppath}
504- Move the .so files to the devel subpackage
505- langify
506- Move changelog to the end, where it should be :)
507- Don't specify (a bad) doc directory
508- Don't define name, version and release and use it in the rpm headers later
509- Remove "Packager:"
510- s/Copyright/License/
511
512* Fri Jun 22 2001 Havoc Pennington <hp@redhat.com>
513- add --direct option to gconftool to avoid spawning oafd,
514  then commented out gconftool entirely since it checks
515  whether gconfd is running and that spawns oafd anyhow.
516  oafd simply needs to exit when unused.
517
518* Tue May 15 2001 Havoc Pennington <hp@redhat.com>
519- Fix post, pointed out by Bill
520
521* Mon May 14 2001 Havoc Pennington <hp@redhat.com>
522- Upgrade to 1.0.1
523
524* Tue Apr 17 2001 Jonathan Blandford <jrb@redhat.com>
525- Import to Red Hat build system.
526
527* Sun Jun 11 2000  Eskil Heyn Olsen <deity@eazel.com>
528
529- Created the .spec file
Note: See TracBrowser for help on using the repository browser.