source: projects/specs/tags/6_0_REL/t/tzdata/tzdata-vl.spec @ 3534

Revision 3534, 10.9 KB checked in by owa, 13 years ago (diff)

rebuit

Line 
1Summary: Timezone data
2Summary(ja): タイムゾーンのデータ
3Name: tzdata
4Version: 2010l
5%define tzdata_version 2010l
6%define tzcode_version 2010l
7Release: 2%{?_dist_release}
8
9License: Public Domain
10Group: System Environment/Base
11URL: ftp://elsie.nci.nih.gov/pub/
12
13# The tzdata-base-0.tar.bz2 is a simple building infrastructure and
14# a test suite.  It is occasionally updated from glibc sources, and as
15# such is under LGPLv2+, but none of this ever gets to be part of
16# final zoneinfo files.
17Source0: tzdata-base-0.tar.bz2
18# These are official upstream.
19Source1: ftp://elsie.nci.nih.gov/pub/tzdata%{tzdata_version}.tar.gz
20Source2: ftp://elsie.nci.nih.gov/pub/tzcode%{tzcode_version}.tar.gz
21Source3: javazic.tar.gz
22
23Patch0: javazic-fixup.patch
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildArch: noarch
27BuildRequires: gawk, glibc, perl
28BuildRequires: java-devel
29BuildRequires: glibc-common >= 2.5.90-7
30Conflicts: glibc-common <= 2.3.2-63
31
32
33%description
34This package contains data files with rules for various timezones around
35the world.
36
37%description -l ja
38このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
39
40%package java
41Summary: Timezone data for Java
42Group: System Environment/Base
43
44%description java
45This package contains timezone information for use by Java runtimes.
46
47
48%prep
49%setup -n tzdata
50mkdir tzdata%{tzdata_version}
51tar xzf %{SOURCE1} -C tzdata%{tzdata_version}
52mkdir tzcode%{tzcode_version}
53tar xzf %{SOURCE2} -C tzcode%{tzcode_version}
54sed -e 's|@objpfx@|'`pwd`'/obj/|' \
55    -e 's|@datadir@|%{_datadir}|' \
56  Makeconfig.in > Makeconfig
57
58mkdir javazic
59tar zxf %{SOURCE3} -C javazic
60pushd javazic
61%patch0
62
63# Hack alert! sun.tools may be defined and installed in the
64# VM. In order to guarantee that we are using IcedTea/OpenJDK
65# for creating the zoneinfo files, rebase all the packages
66# from "sun." to "rht.". Unfortunately, gcj does not support
67# any of the -Xclasspath options, so we must go this route
68# to ensure the greatest compatibility.
69mv sun rht
70find . -type f -name '*.java' -print0 \
71    | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
72                         -e 's:sun\.util\.:rht.util.:g'
73popd
74
75
76%build
77make
78grep -v tz-art.htm tzcode%{tzcode_version}/tz-link.htm > tzcode%{tzcode_version}/tz-link.html
79
80pushd javazic
81javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
82popd
83pushd tzdata%{tzdata_version}
84java -classpath ../javazic/ rht.tools.javazic.Main -V %{version} \
85  -d ../zoneinfo/java \
86  africa antarctica asia australasia europe northamerica pacificnew \
87  southamerica backward etcetera solar87 solar88 solar89 systemv \
88  ../javazic/tzdata_jdk/gmt ../javazic/tzdata_jdk/jdk11_backward
89popd
90
91
92%install
93rm -fr $RPM_BUILD_ROOT
94sed -i 's|@install_root@|%{buildroot}|' Makeconfig
95make install
96
97cp -pr zoneinfo/java $RPM_BUILD_ROOT%{_datadir}/javazi
98
99%check
100echo ====================TESTING=========================
101make check
102echo ====================TESTING END=====================
103
104
105%clean
106rm -fr $RPM_BUILD_ROOT
107
108
109%files
110%defattr(-,root,root)
111%{_datadir}/zoneinfo
112%doc tzcode%{tzcode_version}/README
113%doc tzcode%{tzcode_version}/Theory
114%doc tzcode%{tzcode_version}/tz-link.html
115
116%files java
117%defattr(-,root,root)
118%{_datadir}/javazi
119
120%changelog
121* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
122- rebuilt with rpm-4.8.1-3
123
124* Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
125- update to tzdata-2010l, tzcode-2010l
126- added java subpackage
127
128* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
129- update to tzdata-2009d, tzcode-2009d
130- spec in utf-8
131
132* Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
133- update to tzdata-2008b, tzcode-2008a
134
135* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
136- initial build for VineSeed
137
138* Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
139- Upstream 2007d
140  - Mongolia has abolished DST.
141  - Turkey will use EU rules this year, changing at 01:00 UTC rather
142    than 01:00 standard time.
143  - Cuba observed DST starting Sunday.
144  - Resolute, Nunavut switched from Central to Eastern time last
145    November.
146
147* Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
148- Upstream 2007c
149  - Pulaski County, Indiana, switched back to eastern time.
150  - Turkey switches at 01:00 standard time, not at 01:00 UTC.
151- Upstream 2007b
152  - Changes to the commentary in "leapseconds".
153- Upstream 2007a
154  - Updates to Bahamas, they will be in sync with 2007 US DST change
155  - New zone Australia/Eucla
156  - Africa/Asmera renamed to Africa/Asmara, link created
157  - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
158
159* Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
160- Upstream 2006p
161  - Covers changes from 2006m-2 and 2006m-3
162  - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
163
164* Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
165- Patch for Western Australia DST trial
166
167* Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
168- Proposed upstream patch (#210058)
169  - Jordan will switch to winter time on October 27, not September 29
170  - Brazil's DST this year is the first Sunday in November to the last
171    Sunday in February.  (Thanks to Frederico A. C. Neves.)
172  - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
173  - Commentary and past timestamps changes
174
175* Tue Oct  3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
176- Upstream 2006m:
177  - Adjustments for Egypt, Palestine, Uruguay
178  - Better description of `until' field in zic (8) manpage
179
180* Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
181- Upstream 2006k, 2006l:
182  - Adjustments for Egypt, Palestine, Cuba, Honduras
183  - Documentation changes
184
185* Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
186- Upstream 2006j
187  - Honduras stopped observing DST on Monday at 00:00
188  - America/Bermuda will follow the US's lead next year
189  - America/Moncton will use US-style rules next year
190  - New Zone America/Blanc-Sablon, for Canadians who observe AST all
191    year
192  - New zone: America/Atikokan instead of America/Coral_Harbour
193  - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
194  - Historical changes
195  - Commentary updates
196- Upstream 2006i
197  - localtime.c fixes
198- Upstream 2006h
199  - zic leapsecond fix
200
201* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
202- rebuild
203
204* Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
205- Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
206- Nicaragua updates
207
208* Tue May  2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
209- Upstream 2006f
210  - America/Guatemala observes DST between Apr/30 and Oct/1
211  - Historical changes for Nicaragua
212  - Update of America/Indiana/Vincennes in zone table
213
214* Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
215- Upstream 2006d
216  - Haiti observes DST
217  - Sri Lanka change actually took effect Apr/15
218  - All Canada is now scheduled for 2007 US DST rules
219  - Some historical fixes
220
221* Thu Apr  6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
222- Upstream 2006c
223  - Time-related changes:
224    - dozens of historical and commentary changes
225    - Iran stopped observing DST
226    - Sri Lanka switches from UTC+6 to UTC+5:30
227    - America/Thule and America/Edmonton will adopt new US rules,
228      starting 2007
229    - Tunisia is adopting regular DST
230  - Code:
231    - asctime.c: Chages in format strings to silent gcc warnings
232    - removing K&R notation from function signatures
233    - few fixes across the code
234
235* Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
236- Patch for Sri Lanka time zone change (#184514)
237
238* Thu Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
239- Upstream 2006b:
240  - using tz64code version, as 32 is legacy according to tzdata ML
241  - new manual pages for ctime, strftime, tzset
242  - some source code reorganizations
243  - no timezone/dst rule updates
244
245* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
246- Small changes in tst-timezone.c
247
248* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
249- Upstream 2006a:
250  - private.h(scheck): changing char* to char const*
251  - Rule changes for Palestine, zone changes for Indiana/US, both
252    changes for Canada.
253  - Many related doc changes.
254- Naming scheme in spec file doesn't use %%{name}, but tzdata.
255
256* Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
257- 2005r-3
258  - Meta changes.  Renaming tzdata.tar.bz2 file to tzdata$ver-base,
259    so that it won't clash across updates.
260
261* Thu Jan  5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
262- 2005r
263  - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
264    northamerica to guard against old files with obsolete information
265    being left in the time zone binary directory.
266  - Changes for countries that are supposed to join 2007 US DST
267    change.  This includes most of Canada, however entries already in
268    the database (Alberta, British Columbia, Newfoundland, Northwest
269    Territories, and Yukon) were left alone for the time being.
270  - Fixes in zdump.c (abbrok): conditions are chained, and the string
271    is checked for emptiness.
272
273* Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
274- 2005q
275  - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
276  - SystemV timezone changes
277
278* Wed Nov  2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
279- 2005n
280  - changes for Kyrgyzstan and Uruguay
281- fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
282  make check), update tst-timezone.c from glibc CVS (#172102)
283
284* Tue Sep  6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
285- 2005m
286  - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
287    Australia, Kazakhstan
288  - historical timezone data changes for Japan, Poland, Northern Ireland and
289    Mali
290  - timezone name change for East Timor
291
292* Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
293- 2005k
294  - leap seconds update
295
296* Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
297- 2005i
298  - updates for Iran, Haiti and Nicaragua
299
300* Mon Apr  4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
301- 2005h
302  - fixes for Kazakhstan
303
304* Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
305- 2005g
306  - fixes for Uruguay
307- include README and Theory from tzcode tarball in %{_docdir};
308  Theory includes a good summary of how the timezone data files
309  are supposed to be named
310
311* Tue Mar  1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
312- 2005f
313  - more updates for Israel, updates for Azerbaijan
314
315* Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
316- 2005c
317  - updates for Israel and Paraguay
318
319* Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
320- 2004g (#141107)
321  - updates for Cuba
322
323* Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
324- 2004e (#135194)
325  - updates for Brazil, Uruguay and Argentina
326
327* Wed Aug  4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
328- 2004b
329
330* Mon Oct  6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
331- 2003d
332
333* Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
334- 2003c
335- updates for Brazil (#104840)
336
337* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
338- rebuilt
339
340* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
341- initial package
Note: See TracBrowser for help on using the repository browser.