source: projects/specs/tags/6_0_REL/nonfree/self-build-gpac/gpac-vl.spec @ 3538

Revision 3538, 10.6 KB checked in by munepi, 13 years ago (diff)

updated self-build-{ffmpeg,gpac,vlc}-vl.spec

Line 
1%define with_static   1
2
3Name:        gpac
4Summary:     MPEG-4 multimedia framework
5Version:     0.4.5
6Release:     11%{?_dist_release}
7License:     LGPLv2+
8Group:       System Environment/Libraries
9URL:         http://gpac.sourceforge.net/
10Source0:     http://downloads.sourceforge.net/gpac/gpac-%{version}.tar.gz
11#Source0:     http://rpms.kwizart.net/fedora/SOURCE/gpac-%{version}-repack.tar.bz2
12#Source9:     gpac-snapshot.sh
13Patch0:      gpac-0.4.5-makefix.patch
14Patch1:      gpac-0.4.5-soname.patch
15Patch2:      gpac-0.4.5-amr.patch
16Patch3:      gpac-0.4.5-lib64.patch
17Patch4:      gpac-0.4.5-system_openjpeg.patch
18Patch6:      gpac-0.4.5-shared_sggen.patch
19Patch7:      gpac-0.4.5-libxml2.patch
20Patch8:      gpac-ppc64.patch
21Patch9:      gpac-0.4.5-ffmpeg.patch
22
23BuildRoot:   %{_tmppath}/%{name}-%{version}-%{release}-root
24
25BuildRequires:  ImageMagick
26BuildRequires:  SDL-devel
27BuildRequires:  librsvg2-devel >= 2.5.0
28BuildRequires:  libGLU-devel
29BuildRequires:  freeglut-devel
30BuildRequires:  freetype2-devel >= 2.1.4
31BuildRequires:  libjpeg-devel
32BuildRequires:  libpng-devel >= 1.2.5
33BuildRequires:  libxml2-devel
34BuildRequires:  openssl-devel
35#BuildRequires:  openjpeg-devel
36BuildRequires:  pulseaudio-libs-devel
37BuildRequires:  zlib-devel
38BuildRequires:  libogg-devel libvorbis-devel libtheora-devel
39BuildRequires:  libXt-devel
40BuildRequires:  libXpm-devel
41BuildRequires:  libXv-devel
42#BuildRequires:  wxGTK-devel
43BuildRequires:  xmlrpc-epi-devel
44%{?_with_mozilla:BuildRequires: gecko-devel}
45#BuildRequires:  doxygen
46BuildRequires:  desktop-file-utils
47%{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
48# *-devel packages provided by other self-build-* should only be listed
49# in self-build-%{name}.spec as PreReq.
50#BuildRequires:  a52dec-devel
51#BuildRequires:  faad2-devel
52#BuildRequires:  libmad-devel
53#BuildRequires:  xvidcore-devel >= 1.0.0
54##BuildRequires:  ffmpeg-devel
55
56
57%description
58GPAC is a multimedia framework based on the MPEG-4 Systems standard developed
59from scratch in ANSI C.  The original development goal is to provide a clean,
60small and flexible alternative to the MPEG-4 Systems reference software.
61
62GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
63X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
64MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
65for MP4 and 3GPP(2) files and many tools for scene descriptions
66(MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
67
68%package        libs
69Summary:        Library for %{name}
70Group:          System Environment/Libraries
71
72%description    libs
73The %{name}-libs package contains library for %{name}.
74
75
76%package  devel
77Summary:  Development libraries and files for %{name}
78Group:    Development/Libraries
79Requires: %{name}-libs = %{version}-%{release}
80
81
82%description  devel
83Development libraries and files for gpac.
84
85
86%if %{with_static}
87%package  devel-static
88Summary:  Development libraries and files for %{name}
89Group:    Development/Libraries
90Requires: %{name}-devel = %{version}-%{release}
91
92
93%description  devel-static
94Static library for gpac.
95%endif
96
97
98%prep
99%setup -q -n gpac
100## remove extra_libs directory
101%__rm -rf extra_libs
102
103%patch0 -p1 -b .makefix
104%patch1 -p1 -b .soname
105%patch2 -p1 -b .amr
106%ifarch x86_64
107%patch3 -p1 -b .lib64
108%endif
109#%patch4 -p1 -b .openjpeg
110%patch6 -p1 -b .shared
111%patch7 -p1 -b .libxml2
112%patch8 -p1 -b .ppc64
113%patch9 -p1 -b .ffmpeg
114
115## kwizart - enable dynamic mode - hardcoded with patch2
116# define SONAME number from the first number of gpac version.
117#define soname libgpac.so.0
118#sed -i.soname -e 's|EXTRALIBS+=$(GPAC_SH_FLAGS)|EXTRALIBS+=$(GPAC_SH_FLAGS)\nLDFLAGS+="-Wl,-soname,%{soname}"|' src/Makefile
119
120# # Update doxygen
121# pushd doc
122# doxygen -u
123# popd
124
125# Fix encoding warnings
126%__cp -p Changelog Changelog.origine
127iconv -f ISO-8859-1 -t UTF8 Changelog.origine >  Changelog
128touch -r Changelog.origine Changelog
129%__rm -rf Changelog.origine
130
131%__cp -p doc/ipmpx_syntax.bt doc/ipmpx_syntax.bt.origine
132iconv -f ISO-8859-1 -t UTF8 doc/ipmpx_syntax.bt.origine >  doc/ipmpx_syntax.bt
133touch -r doc/ipmpx_syntax.bt.origine doc/ipmpx_syntax.bt
134%__rm -rf doc/ipmpx_syntax.bt.origine
135
136
137# executable ./configure
138chmod +x configure
139
140%build
141%configure \
142    --X11-path=%{_prefix} \
143    %{?_with_mozilla:--mozdir=%{_libdir}/mozilla/plugins} \
144    --enable-pic \
145    --disable-static \
146    --disable-wx \
147    --extra-cflags="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -D_GNU_SOURCE=1" \
148    --disable-oss-audio \
149    --use-js=no \
150    --use-openjpeg=local \
151    ;
152
153# Parallele build will fail
154%__make all OPTFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC"
155#{?_smp_mflags}
156%__make sggen OPTFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC"
157#{?_smp_mflags}
158
159# ## kwizart - build doxygen doc for devel
160# pushd doc
161# doxygen
162# popd
163
164%install
165%__rm -rf $RPM_BUILD_ROOT
166%__make DESTDIR=$RPM_BUILD_ROOT install install-lib
167
168## kwizart - rpmlint gpac no-ldconfig-symlink
169%__ln_s -f libgpac.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgpac.so.0
170%__ln_s -f libgpac.so.0 $RPM_BUILD_ROOT%{_libdir}/libgpac.so
171
172#Install generated sggen binaries
173for b in MPEG4 SVG X3D; do
174  pushd applications/generators/${b}
175    %__install -pm 0755 ${b}Gen $RPM_BUILD_ROOT%{_bindir}
176  popd
177done
178
179# #Fix doxygen timestamp
180# touch -r Changelog doc/html/*
181
182
183%clean
184%__rm -rf $RPM_BUILD_ROOT
185
186%post libs -p /sbin/ldconfig
187
188%postun libs -p /sbin/ldconfig
189
190
191%files
192%defattr(-,root,root,-)
193%doc AUTHORS BUGS Changelog COPYING README TODO
194%{_bindir}/MP4*
195%{_bindir}/*Gen
196%{_datadir}/gpac/
197%{_mandir}/man1/*.1.*
198
199%files libs
200%defattr(-,root,root)
201%{_libdir}/libgpac.so.*
202%{_libdir}/gpac/
203
204%files devel
205%doc doc/CODING_STYLE doc/ipmpx_syntax.bt
206%defattr(-,root,root)
207%{_includedir}/gpac/
208%{_libdir}/libgpac.so
209
210%if %{with_static}
211%files devel-static
212%defattr(-,root,root,-)
213%{_libdir}/libgpac_static.a
214%else
215%exclude %{_libdir}/libgpac_static.a
216%endif
217
218
219%changelog
220* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
221- rebuilt with internal openjpeg
222  - added --use-openjpeg=local in configure options
223- added --enable-pic in configure options
224
225* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-10
226- rebuild
227
228* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-9
229- removed doxygen support
230
231* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-8
232- change release to sync with self-build-gpac
233
234* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-7
235- rebuild
236
237* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-6
238- added --use-js=no in configure
239- added devel-static subpackage
240
241* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.7.4-5
242- change release to sync with self-build-gpac
243
244* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-4
245- change release to sync with self-build-gpac
246
247* Thu Mar 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-3
248- applied gpac-0.4.5-ffmpeg.patch (RPM Fusion #454)
249- corrected default %%defattr
250
251* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-2
252- dropped BuildRequires: ffmpeg-devel as self-build-ffmpeg
253  - rebuilt with ffmpeg-devel by self-build-ffmpeg
254
255* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-1
256- initial build based on RPM Fusion
257  - without Osmo4 and its plugins for Mozilla browsers
258  - added --disable-wx in configure options
259  - included %%{_libdir}/libgpac_static.a in devel subpackage
260
261* Sun Dec 28 2008 kwizart < kwizart at gmail.com > - 0.4.5-3
262- Fix -devel doc timestamp which leads to multilib conflict
263  ( RPM Fusion #270 )
264
265* Thu Dec 18 2008 kwizart < kwizart at gmail.com > - 0.4.5-2
266- Fix for ppc64
267
268* Wed Dec 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-1
269- Update to 0.4.5 (final)
270- Drop upstreamed patches - Rewrite some
271- Add More BR.
272- Conditionalize --with mozilla amr
273
274* Mon Sep  8 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.5.20080217cvs
275- Fix for Large File Support (was livna #2075 )
276
277* Mon Feb 25 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.3.20080217cvs
278- Enable devel-static
279- Conditionalize Osmo4 (buggy).
280- Clean the spec
281
282* Sun Feb 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.2.20080217cvs
283- Update to 20080217.
284- Split libs.
285- Use the new amr nosrc scheme (need an end-users rebuilt to add support to it).
286- Add openjpeg-devel missing BR
287- Static patching instead of dyn patch when possible.
288- Disable %%{smp_mflags} (it tries to build the bin before the lib is ready)
289- Define soname as libgpac.so.0 (instead of libgpac.so.%%version )
290- Exclude static lib
291
292* Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.5-0.1.20080211cvs
293- Use %%{smp_mflags}
294- Oops, we're actually 0.4.5
295- Fix gpac so filenames
296- Only install nposmozilla when %%{with_firefox} is set
297
298* Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.4-3.20080211cvs
299- Update to 20080211cvs
300- Disable osmozilla, doesn't build with xulrunner
301- Fix builds with gcc 4.3
302
303* Sat Dec 15 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-2
304- Rebuild for rawhide
305
306* Tue Oct 16 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-1
307- Update to v4.4
308
309* Sat May 26 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070526
310- Update to cvs 20070526
311- Enable conditional build ( 3gpp firefox )
312
313* Wed Apr 11 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070411
314- Update to cvs 20070411
315
316* Thu Dec 08 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061208.1.kwizart.fc6
317- Update to 20061208
318- Uses firefox-devel (since fc6!)
319- Drop tutorial
320- Use version-DEV-date with libgpac.so
321- Disabled osmozilla
322- Fix soname
323- Enabled gprof
324
325* Tue Oct 17 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061017.1_FC5
326- gpac snapshot.sh
327- Revert Patch osmozilla.cpp (v1.17 - build error from gpac/internal/terminal_dev.h)
328- TODO: - no-soname make option for libgpac.so
329  - static lib in devel - needed ?
330  - osmozilla - xpt link problem.
331  - Osmo4: segmentation fault on exit.
332  - MP4Client: segmentation fault on launch.
333  - The program 'Osmo4' received an X Window System error:
334  "The error was 'BadMatch (invalid parameter attributes)'.
335  (Details: serial 37 error_code 8 request_code 42 minor_code 0)"
336  - MP4Box -version display: GPAC version 0.4.3-DEV (try to display cvs )
337
338* Sat Oct 15 2006 kwizart < kwizart at gmail.com > - 0.4.2-rc2.1_FC5
339- Update to 0.4.2cvs20061017
340- Use DESTDIR=RPM_BUILD_ROOT in various Makefile.
341- Enable mozilla plugin: osmozilla.
342- Enable AMR_NB_FLOAT and AMR_WB_FLOAT / bundle AMR_NB_FIXED (but not used by default).
343- Provide documentation html in doc .
344- Provide tutorial from http://www.wildamerica.com/pages/Marty.html
345- Various corrections.
346
347* Fri Sep 01 2006 Anssi Hannula <anssi@zarb.org> 0.4.1-0.20060630.2plf2007.0
348- lib64 fixes
349
350* Fri Jan 30 2006 Austin Acton <austin@mandriva.org> 0.4.1-0.20060630.1plf2007.0
351- initial package
Note: See TracBrowser for help on using the repository browser.