source: projects/specs/trunk/nonfree/self-build-gpac/gpac-vl.spec @ 5297

Revision 5297, 10.5 KB checked in by munepi, 12 years ago (diff)

updated self-build-* packages: new x264 ABI and ffmpeg 0.9

Line 
1%define svndate  20111217
2
3%define with_static   1
4
5Name:        gpac
6Summary:     MPEG-4 multimedia framework
7Version:     0.4.6
8Release:     1%{?svndate:.svn%svndate}%{?_dist_release}
9License:     LGPLv2+
10Group:       System Environment/Libraries
11URL:         http://gpac.sourceforge.net/
12#Source0:     http://downloads.sourceforge.net/gpac/gpac-%{version}.tar.gz
13Source0:     gpac-%{svndate}.tar.bz2
14Source9:     gpac-snapshot-vine.sh
15
16Patch1:      gpac-0.4.6_15-soname.patch
17Patch2:      gpac-0.4.6-amr.patch
18Patch5:      gpac-0.4.6-js_cflags.patch
19
20BuildRoot:   %{_tmppath}/%{name}-%{version}-%{release}-root
21
22BuildRequires:  ImageMagick
23BuildRequires:  SDL-devel
24BuildRequires:  librsvg2-devel >= 2.5.0
25BuildRequires:  libGLU-devel
26BuildRequires:  freeglut-devel
27BuildRequires:  freetype2-devel >= 2.1.4
28BuildRequires:  libjpeg-devel
29BuildRequires:  libpng-devel >= 1.2.5
30BuildRequires:  libxml2-devel
31BuildRequires:  openssl-devel
32#BuildRequires:  openjpeg-devel
33BuildRequires:  pulseaudio-libs-devel
34BuildRequires:  zlib-devel
35BuildRequires:  libogg-devel libvorbis-devel libtheora-devel
36BuildRequires:  libXt-devel
37BuildRequires:  libXpm-devel
38BuildRequires:  libXv-devel
39#BuildRequires:  wxGTK-devel
40BuildRequires:  xmlrpc-epi-devel
41%{?_with_mozilla:BuildRequires: gecko-devel}
42#BuildRequires:  doxygen
43BuildRequires:  desktop-file-utils
44%{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
45# *-devel packages provided by other self-build-* should only be listed
46# in self-build-%{name}.spec as PreReq.
47#BuildRequires:  a52dec-devel
48#BuildRequires:  faad2-devel
49#BuildRequires:  libmad-devel
50#BuildRequires:  xvidcore-devel >= 1.0.0
51##BuildRequires:  ffmpeg-devel
52
53
54%description
55GPAC is a multimedia framework based on the MPEG-4 Systems standard developed
56from scratch in ANSI C.  The original development goal is to provide a clean,
57small and flexible alternative to the MPEG-4 Systems reference software.
58
59GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
60X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
61MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
62for MP4 and 3GPP(2) files and many tools for scene descriptions
63(MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
64
65%package        libs
66Summary:        Library for %{name}
67Group:          System Environment/Libraries
68
69%description    libs
70The %{name}-libs package contains library for %{name}.
71
72
73%package  devel
74Summary:  Development libraries and files for %{name}
75Group:    Development/Libraries
76Requires: %{name}-libs = %{version}-%{release}
77
78
79%description  devel
80Development libraries and files for gpac.
81
82
83%if %{with_static}
84%package  devel-static
85Summary:  Development libraries and files for %{name}
86Group:    Development/Libraries
87Requires: %{name}-devel = %{version}-%{release}
88
89
90%description  devel-static
91Static library for gpac.
92%endif
93
94
95%prep
96%setup -q -n gpac
97## remove extra_libs directory
98%__rm -rf extra_libs
99
100%patch1 -p1 -b .soname
101%patch2 -p1 -b .amr
102%patch5 -p1 -b .jscflags
103
104## kwizart - enable dynamic mode - hardcoded with patch2
105# define SONAME number from the first number of gpac version.
106#define soname libgpac.so.0
107#sed -i.soname -e 's|EXTRALIBS+=$(GPAC_SH_FLAGS)|EXTRALIBS+=$(GPAC_SH_FLAGS)\nLDFLAGS+="-Wl,-soname,%{soname}"|' src/Makefile
108
109# Fix encoding warnings
110%__cp -p Changelog Changelog.origine
111iconv -f ISO-8859-1 -t UTF8 Changelog.origine >  Changelog
112touch -r Changelog.origine Changelog
113%__rm -rf Changelog.origine
114
115%__cp -p doc/ipmpx_syntax.bt doc/ipmpx_syntax.bt.origine
116iconv -f ISO-8859-1 -t UTF8 doc/ipmpx_syntax.bt.origine >  doc/ipmpx_syntax.bt
117touch -r doc/ipmpx_syntax.bt.origine doc/ipmpx_syntax.bt
118%__rm -rf doc/ipmpx_syntax.bt.origine
119
120
121# executable ./configure
122chmod +x configure
123
124%build
125%configure \
126    --X11-path=%{_prefix} \
127    %{?_with_mozilla:--mozdir=%{_libdir}/mozilla/plugins} \
128    --enable-pic \
129    --disable-static \
130    --disable-wx \
131    --extra-cflags="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -D_GNU_SOURCE=1" \
132    --disable-oss-audio \
133    %{?_with_amr:--enable-amr} \
134    --use-js=no \
135    ;
136    # --use-openjpeg=local \
137
138# Parallele build will fail
139%__make all OPTFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC"
140#{?_smp_mflags}
141%__make sggen OPTFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC"
142#{?_smp_mflags}
143
144# ## kwizart - build doxygen doc for devel
145# pushd doc
146# doxygen
147# popd
148
149%install
150%__rm -rf $RPM_BUILD_ROOT
151%__make DESTDIR=$RPM_BUILD_ROOT install install-lib
152
153#hack
154%if %{_lib} == "lib64"
155  %__mv $RPM_BUILD_ROOT%{_prefix}/lib $RPM_BUILD_ROOT%{_libdir}
156%endif
157
158## kwizart - rpmlint gpac no-ldconfig-symlink
159#%__ln_s -f libgpac.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgpac.so.0
160%__ln_s -f libgpac.so.%{version}-DEV $RPM_BUILD_ROOT%{_libdir}/libgpac.so.0
161%__ln_s -f libgpac.so.0 $RPM_BUILD_ROOT%{_libdir}/libgpac.so
162
163#Install generated sggen binaries
164for b in MPEG4 SVG X3D; do
165  pushd applications/generators/${b}
166    %__install -pm 0755 ${b}Gen $RPM_BUILD_ROOT%{_bindir}
167  popd
168done
169
170# #Fix doxygen timestamp
171# touch -r Changelog doc/html/*
172
173
174%clean
175%__rm -rf $RPM_BUILD_ROOT
176
177%post libs -p /sbin/ldconfig
178
179%postun libs -p /sbin/ldconfig
180
181
182%files
183%defattr(-,root,root,-)
184%doc AUTHORS BUGS Changelog COPYING README TODO
185%{_bindir}/MP4*
186%{_bindir}/*Gen
187%{_datadir}/gpac/
188%{_mandir}/man1/*.1.*
189
190%files libs
191%defattr(-,root,root)
192%{_libdir}/libgpac.so.*
193%{_libdir}/gpac/
194
195%files devel
196%doc doc/CODING_STYLE doc/ipmpx_syntax.bt
197%defattr(-,root,root)
198%{_includedir}/gpac/
199%{_libdir}/libgpac.so
200
201%if %{with_static}
202%files devel-static
203%defattr(-,root,root,-)
204%{_libdir}/libgpac_static.a
205%else
206%exclude %{_libdir}/libgpac_static.a
207%endif
208
209
210%changelog
211* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-1.svn20111217
212- update snapshot svn20111217
213- removed upstreamed/obsolated patches
214
215* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
216- rebuilt with internal openjpeg
217  - added --use-openjpeg=local in configure options
218- added --enable-pic in configure options
219
220* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-10
221- rebuild
222
223* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-9
224- removed doxygen support
225
226* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-8
227- change release to sync with self-build-gpac
228
229* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-7
230- rebuild
231
232* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-6
233- added --use-js=no in configure
234- added devel-static subpackage
235
236* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.7.4-5
237- change release to sync with self-build-gpac
238
239* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-4
240- change release to sync with self-build-gpac
241
242* Thu Mar 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-3
243- applied gpac-0.4.5-ffmpeg.patch (RPM Fusion #454)
244- corrected default %%defattr
245
246* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-2
247- dropped BuildRequires: ffmpeg-devel as self-build-ffmpeg
248  - rebuilt with ffmpeg-devel by self-build-ffmpeg
249
250* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-1
251- initial build based on RPM Fusion
252  - without Osmo4 and its plugins for Mozilla browsers
253  - added --disable-wx in configure options
254  - included %%{_libdir}/libgpac_static.a in devel subpackage
255
256* Sun Dec 28 2008 kwizart < kwizart at gmail.com > - 0.4.5-3
257- Fix -devel doc timestamp which leads to multilib conflict
258  ( RPM Fusion #270 )
259
260* Thu Dec 18 2008 kwizart < kwizart at gmail.com > - 0.4.5-2
261- Fix for ppc64
262
263* Wed Dec 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-1
264- Update to 0.4.5 (final)
265- Drop upstreamed patches - Rewrite some
266- Add More BR.
267- Conditionalize --with mozilla amr
268
269* Mon Sep  8 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.5.20080217cvs
270- Fix for Large File Support (was livna #2075 )
271
272* Mon Feb 25 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.3.20080217cvs
273- Enable devel-static
274- Conditionalize Osmo4 (buggy).
275- Clean the spec
276
277* Sun Feb 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.2.20080217cvs
278- Update to 20080217.
279- Split libs.
280- Use the new amr nosrc scheme (need an end-users rebuilt to add support to it).
281- Add openjpeg-devel missing BR
282- Static patching instead of dyn patch when possible.
283- Disable %%{smp_mflags} (it tries to build the bin before the lib is ready)
284- Define soname as libgpac.so.0 (instead of libgpac.so.%%version )
285- Exclude static lib
286
287* Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.5-0.1.20080211cvs
288- Use %%{smp_mflags}
289- Oops, we're actually 0.4.5
290- Fix gpac so filenames
291- Only install nposmozilla when %%{with_firefox} is set
292
293* Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.4-3.20080211cvs
294- Update to 20080211cvs
295- Disable osmozilla, doesn't build with xulrunner
296- Fix builds with gcc 4.3
297
298* Sat Dec 15 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-2
299- Rebuild for rawhide
300
301* Tue Oct 16 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-1
302- Update to v4.4
303
304* Sat May 26 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070526
305- Update to cvs 20070526
306- Enable conditional build ( 3gpp firefox )
307
308* Wed Apr 11 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070411
309- Update to cvs 20070411
310
311* Thu Dec 08 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061208.1.kwizart.fc6
312- Update to 20061208
313- Uses firefox-devel (since fc6!)
314- Drop tutorial
315- Use version-DEV-date with libgpac.so
316- Disabled osmozilla
317- Fix soname
318- Enabled gprof
319
320* Tue Oct 17 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061017.1_FC5
321- gpac snapshot.sh
322- Revert Patch osmozilla.cpp (v1.17 - build error from gpac/internal/terminal_dev.h)
323- TODO: - no-soname make option for libgpac.so
324  - static lib in devel - needed ?
325  - osmozilla - xpt link problem.
326  - Osmo4: segmentation fault on exit.
327  - MP4Client: segmentation fault on launch.
328  - The program 'Osmo4' received an X Window System error:
329  "The error was 'BadMatch (invalid parameter attributes)'.
330  (Details: serial 37 error_code 8 request_code 42 minor_code 0)"
331  - MP4Box -version display: GPAC version 0.4.3-DEV (try to display cvs )
332
333* Sat Oct 15 2006 kwizart < kwizart at gmail.com > - 0.4.2-rc2.1_FC5
334- Update to 0.4.2cvs20061017
335- Use DESTDIR=RPM_BUILD_ROOT in various Makefile.
336- Enable mozilla plugin: osmozilla.
337- Enable AMR_NB_FLOAT and AMR_WB_FLOAT / bundle AMR_NB_FIXED (but not used by default).
338- Provide documentation html in doc .
339- Provide tutorial from http://www.wildamerica.com/pages/Marty.html
340- Various corrections.
341
342* Fri Sep 01 2006 Anssi Hannula <anssi@zarb.org> 0.4.1-0.20060630.2plf2007.0
343- lib64 fixes
344
345* Fri Jan 30 2006 Austin Acton <austin@mandriva.org> 0.4.1-0.20060630.1plf2007.0
346- initial package
Note: See TracBrowser for help on using the repository browser.