source: projects/specs/tags/6_0_REL/lib/libr/librsvg2/librsvg2-vl.spec @ 2219

Revision 2219, 9.4 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release

Line 
1%define __libtoolize :
2
3%define libxml2_version 2.7.7
4%define gtk2_version 2.22.1
5%define freetype_version 2.4.2
6%define popt_version 1.14
7%define libart_version 2.3.21
8%define cairo_version 1.10.0
9%define libgnomeui_version 2.24.4
10%define gnome_vfs_version 2.24.4
11%define dbus_version 1.4.0
12%define dbus_glib_version 0.88
13%define avahi_glib_version 0.6.23
14%define libcroco_version 0.6.2
15%define libgsf_version 1.14.19
16
17Name:    librsvg2
18Summary: An SVG library based on libart.
19Summary(ja): libart ベースの SVG ライブラリ
20Version: 2.32.1
21Release: 1%{?_dist_release}
22License: LGPL
23Group: System Environment/Libraries
24Source: librsvg-%{version}.tar.bz2
25
26Requires(post,postun): gtk2 >= %{gtk2_version}
27Requires(post): dbus-glib >= %{dbus_glib_version}
28Requires(post): avahi-glib >= %{avahi_glib_devel}
29Requires(post): libgsf, libcroco
30Requires: gtk2 >= %{gtk2_version}
31Requires: libxml2 >= %{libxml2_version}
32Requires: popt >= %{popt_version}
33Requires: freetype2 >= %{freetype_version}
34Requires: libpng
35BuildRequires: libpng-devel
36BuildRequires: gtk2-devel >= %{gtk2_version}
37BuildRequires: libxml2-devel >= %{libxml2_version}
38BuildRequires: freetype2-devel >= %{freetype_version}
39BuildRequires: cairo-devel >= %{cairo_version}
40BuildRequires: dbus-glib-devel >= %{dbus_glib_devel}
41BuildRequires: avahi-glib-devel >= %{avahi_glib_devel}
42BuildRequires: libcroco-devel >= %{libcroco_version}
43BuildRequires: libgsf-devel >= %{libgsf_version}
44BuildRoot: %{_tmppath}/%{name}-%{version}-root
45
46%description
47An SVG library based on libart.
48
49%description -l ja
50libart ベースの SVG ライブラリです
51
52
53%package devel
54Summary: Libraries and include files for developing with librsvg.
55Summary(ja): librsvg の開発用ライブラリおよびヘッダファイル
56Group: Development/Libraries
57Requires: %{name} = %{version}
58Requires: gtk2-devel >= %{gtk2_version}
59Requires: libxml2-devel >= %{libxml2_version}
60Requires: freetype2-devel >= %{freetype_version}
61Requires: libgsf-devel, libcroco-devel
62
63%description devel
64This package provides the necessary development libraries and include
65files to allow you to develop with librsvg.
66
67%prep
68%setup -q -n librsvg-%{version}
69
70%build
71%configure --disable-gtk-doc \
72           --with-svgz \
73           --enable-gtk-theme \
74           --with-croco \
75           --disable-static
76%__make %{?_smp_mflags}
77
78%install
79rm -rf $RPM_BUILD_ROOT
80make install DESTDIR=$RPM_BUILD_ROOT
81
82rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
83rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/engines/libsvg.*a
84rm -f $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbuf*.*a
85rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post
91/sbin/ldconfig
92if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
93  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
94fi ||:
95
96%postun
97/sbin/ldconfig
98if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
99  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
100fi ||:
101
102%files
103
104%defattr(-, root, root)
105%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
106%{_bindir}/*
107%{_libdir}/*.so.*
108%{_libdir}/gtk-2.0/*/engines/*.so
109%{_libdir}/gdk-pixbuf-2.0/*/loaders/*.so
110%{_mandir}/man1/*
111%{_datadir}/pixmaps/*
112%{_datadir}/themes/bubble/gtk-2.0/*
113
114%files devel
115%defattr(-, root, root)
116%{_libdir}/*.so
117%{_includedir}/librsvg-2.0/librsvg
118%{_libdir}/pkgconfig/librsvg-2.0.pc
119%{_datadir}/gtk-doc/html/rsvg-2.0
120
121%changelog
122* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
123- new upstream release
124
125* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
126- new upstream release
127- remove BuildRequires: popt, libart_lgpl, libgnomeui-devel, gnome-vfs2-devel
128- remove Requires: libart_lgpl
129- add configure option (--disable-static)
130- remove unrecognized configure option (--enable-gnome-vfs, --disable-mozilla-plugins)
131- fix %install, %files, %post and %postun
132
133* Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.26.3-1
134- build with rpm-4.8.1-1 for pkg-config file
135
136* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.3-1
137- new upstream release
138
139* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
140- new upstream release
141- remove static libs
142
143* Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1vl5
144- new upstream release
145- spec in UTF-8
146
147* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
148- new upstream release
149
150* Sat Mar  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl2
151- rebuilt with libgsf-1.14.8
152
153* Sat Sep  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
154- new upstream release
155
156* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-0vl1
157- new upstream release
158- add BuildRequires: dbus-glib-devel, avahi-glib-devel
159- add BuildRequires: libgsf-devel, libcroco-devel
160- add Requires(post): dbus-glib, avahi-glib, libgsf, libcroco
161- add Requires(post,postun): glib2
162
163* Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl5
164- rebuild with gtk+-2.10
165
166* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl4
167- rebuilt without libgsf-devel
168
169* Tue Jun 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl3
170- update %%post scripts to use %%{_sysconfdir}/gtk-2.0/%%{_arch}/gd-pixbuf.loaders
171  for biarch support. (TODO: add compat32)
172
173* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl2
174- rebuild
175
176* Mon May 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.4-0vl1
177- new upstream release
178
179* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
180- new upstream release
181
182* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
183- new upstream release
184
185* Wed Oct 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.7-0vl1
186- new upstream release
187- added --disable-gtk-doc option
188
189* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
190- new upstream release
191- added gtk-doc to devel package
192
193* Sun Oct  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
194- new upstream release
195- added Japanese description
196- added --without-svgz option (because it requires libgsf)
197
198* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
199- new upstream release
200
201* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
202- new upstream release
203
204* Fri Jun 18 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl4
205- rebuilt to avoid unwanted dependency (libgsf)
206
207* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
208- add gdk-pixbuf-query-loaders to post/postun script.
209
210* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
211- rebuild with gtk+-2.4.0
212
213* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
214- new upstream release
215
216* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl2
217- fix kanji code of spec file
218- fix file entry, add missing files
219
220* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
221- new upstream release
222
223* Sat Jul 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl2
224- added --without-svgz and --without-gimp to %configure
225
226* Thu Jul 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl1
227- new upstream release
228- added %{_bindir}/rsvg and %{_mandir}/man1/* to main package
229- added %{_libdir}/gtk-2.0/* to devel package
230
231* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
232- new upstream release
233
234* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
235- new upstream release
236
237* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
238- new upstream release
239
240* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
241- build for Vine Linux
242- new upstream release from gnome-2.1.4
243
244* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
245- 2.0.1
246
247* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
248- automated rebuild
249
250* Sun May 26 2002 Tim Powers <timp@redhat.com>
251- automated rebuild
252
253* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
254- rebuild in different environment
255
256* Thu May 02 2002 Havoc Pennington <hp@redhat.com>
257- rebuild in different environment
258
259* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
260- 1.1.6
261
262* Mon Feb 11 2002 Alex Larsson <alexl@redhat.com> 1.1.3-1
263- Update to 1.1.3
264
265* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
266- automated rebuild
267
268* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
269- new CVS snap 1.1.0.91
270- remove automake/autoconf calls
271
272* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
273- convert to librsvg2 RPM
274
275* Tue Oct 23 2001 Havoc Pennington <hp@redhat.com>
276- 1.0.2
277
278* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
279- Add a patch that moves the includes to librsvg-1/librsvg
280- in preparation for a later librsvg 2 library.
281
282* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
283- build requires gnome-libs-devel, #49509
284
285* Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
286- own /usr/include/librsvg
287
288* Wed Jul 18 2001 Akira TAGOH <tagoh@redhat.com> 1.0.0-4
289- fixed the linefeed problem in multibyte environment. (Bug#49310)
290
291* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
292- put .la file back in package
293
294* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
295- Put changelog at the end
296- Move .so files to devel subpackage
297- Don't mess with ld.so.conf
298- Don't use %%{prefix}, this isn't a relocatable package
299- Don't define a bad docdir
300- Add BuildRequires
301- Use %%{_tmppath}
302- Don't define name, version etc. on top of the file (why do so many do that?)
303- s/Copyright/License/
304
305* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
306- Put into Red Hat Build system
307
308* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
309- removed obsoletes from sub packages and added mozilla and trilobite
310subpackages
311
312* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
313- created this thing
314
Note: See TracBrowser for help on using the repository browser.