source: projects/specs/trunk/lib/libr/librsvg2/librsvg2-vl.spec @ 4616

Revision 4616, 9.7 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define __libtoolize :
2
3%define libxml2_version 2.7.7
4%define gtk2_version 2.22.1
5%define gdk_pixbuf2 1.3.7
6%define gtk3_version 3.0.0
7%define freetype_version 2.4.2
8%define popt_version 1.14
9%define libart_version 2.3.21
10%define cairo_version 1.10.0
11%define libgnomeui_version 2.24.4
12%define gnome_vfs_version 2.24.4
13%define dbus_version 1.4.0
14%define dbus_glib_version 0.88
15%define avahi_glib_version 0.6.23
16%define libcroco_version 0.6.2
17%define libgsf_version 1.14.19
18
19Name:    librsvg2
20Summary: An SVG library based on libart.
21Summary(ja): libart ベースの SVG ライブラリ
22Version: 2.34.0
23Release: 1%{?_dist_release}
24License: LGPL
25Group: System Environment/Libraries
26Source: librsvg-%{version}.tar.bz2
27
28Patch0: librsvg2-2.34.0-git20110728.patch
29
30Requires(post,postun): gtk2 >= %{gtk2_version}
31Requires(post): dbus-glib >= %{dbus_glib_version}
32Requires(post): avahi-glib >= %{avahi_glib_devel}
33Requires(post): libgsf, libcroco
34Requires: gtk2 >= %{gtk2_version}
35Requires: gtk3 >= %{gtk3_version}
36Requires: libxml2 >= %{libxml2_version}
37Requires: popt >= %{popt_version}
38Requires: freetype2 >= %{freetype_version}
39Requires: libpng
40BuildRequires: libpng-devel
41BuildRequires: gtk2-devel >= %{gtk2_version}
42BuildRequires: gtk3-devel >= %{gtk3_version}
43BuildRequires: libxml2-devel >= %{libxml2_version}
44BuildRequires: freetype2-devel >= %{freetype_version}
45BuildRequires: cairo-devel >= %{cairo_version}
46BuildRequires: dbus-glib-devel >= %{dbus_glib_devel}
47BuildRequires: avahi-glib-devel >= %{avahi_glib_devel}
48BuildRequires: libcroco-devel >= %{libcroco_version}
49BuildRequires: libgsf-devel >= %{libgsf_version}
50BuildRoot: %{_tmppath}/%{name}-%{version}-root
51
52Vendor: Project Vine
53Distribution: Vine Linux
54
55%description
56An SVG library based on libart.
57
58%description -l ja
59libart ベースの SVG ライブラリです
60
61
62%package devel
63Summary: Libraries and include files for developing with librsvg.
64Summary(ja): librsvg の開発用ライブラリおよびヘッダファイル
65Group: Development/Libraries
66Requires: %{name} = %{version}
67Requires: gdk-pixbuf2-devel >= %{gdk_pixbug2_version}
68Requires: cairo-devel >= %{cairo_version}
69
70%description devel
71This package provides the necessary development libraries and include
72files to allow you to develop with librsvg.
73
74%prep
75%setup -q -n librsvg-%{version}
76%patch0 -p1
77
78%build
79autoreconf -if
80%configure --disable-gtk-doc \
81           --with-svgz \
82           --enable-gtk-theme \
83           --with-croco \
84           --disable-static
85%__make %{?_smp_mflags}
86
87%install
88rm -rf $RPM_BUILD_ROOT
89make install DESTDIR=$RPM_BUILD_ROOT
90
91rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
92rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/engines/libsvg.*a
93rm -f $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbuf*.*a
94rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%post
100/sbin/ldconfig
101if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
102  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
103fi ||:
104
105%postun
106/sbin/ldconfig
107if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
108  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
109fi ||:
110
111%files
112
113%defattr(-, root, root)
114%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
115%{_bindir}/*
116%{_libdir}/*.so.*
117%{_libdir}/gtk-2.0/*/engines/*.so
118%{_libdir}/gdk-pixbuf-2.0/*/loaders/*.so
119%{_mandir}/man1/*
120%{_datadir}/pixmaps/*
121%{_datadir}/themes/bubble/gtk-2.0/*
122%{_datadir}/themes/bubble/gtk-3.0/*
123
124%files devel
125%defattr(-, root, root)
126%{_libdir}/*.so
127%{_includedir}/librsvg-2.0/librsvg
128%{_libdir}/pkgconfig/librsvg-2.0.pc
129%{_datadir}/gtk-doc/html/rsvg-2.0
130
131%changelog
132* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
133- new upstream release
134- add Patch0 (librsvg2-2.34.0-git20110728.patch)
135
136* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
137- new upstream release
138
139* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
140- new upstream release
141- remove BuildRequires: popt, libart_lgpl, libgnomeui-devel, gnome-vfs2-devel
142- remove Requires: libart_lgpl
143- add configure option (--disable-static)
144- remove unrecognized configure option (--enable-gnome-vfs, --disable-mozilla-plugins)
145- fix %install, %files, %post and %postun
146
147* Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.26.3-1
148- build with rpm-4.8.1-1 for pkg-config file
149
150* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.3-1
151- new upstream release
152
153* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
154- new upstream release
155- remove static libs
156
157* Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1vl5
158- new upstream release
159- spec in UTF-8
160
161* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
162- new upstream release
163
164* Sat Mar  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl2
165- rebuilt with libgsf-1.14.8
166
167* Sat Sep  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
168- new upstream release
169
170* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-0vl1
171- new upstream release
172- add BuildRequires: dbus-glib-devel, avahi-glib-devel
173- add BuildRequires: libgsf-devel, libcroco-devel
174- add Requires(post): dbus-glib, avahi-glib, libgsf, libcroco
175- add Requires(post,postun): glib2
176
177* Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl5
178- rebuild with gtk+-2.10
179
180* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl4
181- rebuilt without libgsf-devel
182
183* Tue Jun 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl3
184- update %%post scripts to use %%{_sysconfdir}/gtk-2.0/%%{_arch}/gd-pixbuf.loaders
185  for biarch support. (TODO: add compat32)
186
187* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl2
188- rebuild
189
190* Mon May 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.4-0vl1
191- new upstream release
192
193* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
194- new upstream release
195
196* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
197- new upstream release
198
199* Wed Oct 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.7-0vl1
200- new upstream release
201- added --disable-gtk-doc option
202
203* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
204- new upstream release
205- added gtk-doc to devel package
206
207* Sun Oct  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
208- new upstream release
209- added Japanese description
210- added --without-svgz option (because it requires libgsf)
211
212* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
213- new upstream release
214
215* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
216- new upstream release
217
218* Fri Jun 18 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl4
219- rebuilt to avoid unwanted dependency (libgsf)
220
221* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
222- add gdk-pixbuf-query-loaders to post/postun script.
223
224* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
225- rebuild with gtk+-2.4.0
226
227* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
228- new upstream release
229
230* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl2
231- fix kanji code of spec file
232- fix file entry, add missing files
233
234* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
235- new upstream release
236
237* Sat Jul 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl2
238- added --without-svgz and --without-gimp to %configure
239
240* Thu Jul 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl1
241- new upstream release
242- added %{_bindir}/rsvg and %{_mandir}/man1/* to main package
243- added %{_libdir}/gtk-2.0/* to devel package
244
245* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
246- new upstream release
247
248* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
249- new upstream release
250
251* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
252- new upstream release
253
254* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
255- build for Vine Linux
256- new upstream release from gnome-2.1.4
257
258* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
259- 2.0.1
260
261* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
262- automated rebuild
263
264* Sun May 26 2002 Tim Powers <timp@redhat.com>
265- automated rebuild
266
267* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
268- rebuild in different environment
269
270* Thu May 02 2002 Havoc Pennington <hp@redhat.com>
271- rebuild in different environment
272
273* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
274- 1.1.6
275
276* Mon Feb 11 2002 Alex Larsson <alexl@redhat.com> 1.1.3-1
277- Update to 1.1.3
278
279* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
280- automated rebuild
281
282* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
283- new CVS snap 1.1.0.91
284- remove automake/autoconf calls
285
286* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
287- convert to librsvg2 RPM
288
289* Tue Oct 23 2001 Havoc Pennington <hp@redhat.com>
290- 1.0.2
291
292* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
293- Add a patch that moves the includes to librsvg-1/librsvg
294- in preparation for a later librsvg 2 library.
295
296* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
297- build requires gnome-libs-devel, #49509
298
299* Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
300- own /usr/include/librsvg
301
302* Wed Jul 18 2001 Akira TAGOH <tagoh@redhat.com> 1.0.0-4
303- fixed the linefeed problem in multibyte environment. (Bug#49310)
304
305* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
306- put .la file back in package
307
308* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
309- Put changelog at the end
310- Move .so files to devel subpackage
311- Don't mess with ld.so.conf
312- Don't use %%{prefix}, this isn't a relocatable package
313- Don't define a bad docdir
314- Add BuildRequires
315- Use %%{_tmppath}
316- Don't define name, version etc. on top of the file (why do so many do that?)
317- s/Copyright/License/
318
319* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
320- Put into Red Hat Build system
321
322* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
323- removed obsoletes from sub packages and added mozilla and trilobite
324subpackages
325
326* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
327- created this thing
328
Note: See TracBrowser for help on using the repository browser.