source: projects/specs/tags/6_0_REL/l/lyx/lyx-vl.spec @ 4218

Revision 4218, 7.3 KB checked in by munepi, 13 years ago (diff)

updated lyx-vl.spec: new upstream release

Line 
1%define texmf           %{_datadir}/texmf
2%define build_texmf     %{buildroot}%{texmf}
3
4%define exec_texhash  [ -x %{_bindir}/texhash     ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash 2>/dev/null
5
6Summary: WYSIWYM (What You See Is What You Mean) word processor with LaTeX output
7Summary(ja): LaTeX 形式で保存できるワードプロセッサ
8Name: lyx
9Version: 2.0.0
10Release: 1%{?_dist_release}
11License: GPLv2+
12Group: Applications/Editors
13URL: http://www.lyx.org/
14Source0: ftp://ftp.lyx.org/pub/lyx/stable/lyx-%{version}.tar.xz
15
16Source1: lyxrc.dist
17Source10: lyx.desktop
18
19## upstreamable patches
20# submitted, but upstream rejected it.  we currently agree to disagree.
21Patch50: lyx-2.0.0rc1-xdg_open.patch
22# hunspell pkgconfig support
23Patch51: lyx-2.0.0-hunspell_pkgconfig.patch
24
25# vine
26
27
28# BuildRequires: aiksaurus-devel
29# BuildRequires:   aspell-devel
30BuildRequires:   enchant-devel
31BuildRequires:   hunspell-devel
32BuildRequires:   libboost-devel
33BuildRequires:   libboost-filesystem
34BuildRequires:   libboost-signals
35BuildRequires:   libboost-regex
36BuildRequires:   desktop-file-utils
37BuildRequires:   gettext
38BuildRequires:   python
39BuildRequires:   xorg-x11-devel
40BuildRequires:   qt4-devel
41BuildRequires:   libpng-devel
42BuildRequires:   glib2-devel
43BuildRequires:   zlib-devel
44
45Requires(post):  texlive-common
46Requires(postun): texlive-common
47Requires:        ghostscript
48Requires:        python
49Requires:        qt4
50Requires:        latex-xft-fonts
51
52Requires:        xdg-utils
53Requires:        rcs
54
55BuildRoot: %{_tmppath}/%{name}-%{version}-root
56
57Vendor:       Project Vine
58Distribution: Vine Linux
59
60
61%description
62LyX is a modern approach to writing documents which breaks with the
63obsolete "typewriter paradigm" of most other document preparation
64systems.
65
66It is designed for people who want professional quality output
67with a minimum of time and effort, without becoming specialists in
68typesetting.
69
70The major innovation in LyX is WYSIWYM (What You See Is What You Mean).
71That is, the author focuses on content, not on the details of formatting.
72This allows for greater productivity, and leaves the final typesetting
73to the backends (like LaTeX) that are specifically designed for the task.
74
75With LyX, the author can concentrate on the contents of his writing,
76and let the computer take care of the rest.
77
78This is LyX built with the Qt frontend.
79
80%description -l ja
81LaTeX形式で出力もできるワードプロセッサです。数式の入力も簡単にできます。
82特別な知識が無くても、最小限の努力でプロ並の出力を得られるように設計
83してあります。
84
85
86%prep
87%setup -q
88
89%patch50 -p1 -b .xdg_open
90%patch51 -p1 -b .hunspell_pkgconfig
91
92./autogen.sh
93
94
95%build
96%configure \
97    --disable-dependency-tracking \
98    --disable-rpath \
99    --enable-build-type=release \
100    --disable-debug \
101    --enable-optimization="%{optflags}" \
102    --without-included-boost \
103    --enable-shared \
104    --disable-static \
105    \
106    --with-frontend=qt4 \
107    --without-aiksaurus \
108    --with-enchant \
109    --with-hunspell \
110    ;
111%__make %{?_smp_mflags}
112
113# # make sure all .gmo files are regenerated from .po files
114# (cd po; make update-gmo)
115
116
117%install
118%__rm -rf ${RPM_BUILD_ROOT}
119%__make DESTDIR=${RPM_BUILD_ROOT} install
120
121# misc/extras
122%__install -p -m644 -D %{SOURCE1} %{buildroot}%{_datadir}/lyx/lyxrc.dist
123
124# Set up the lyx-specific class files where TeX can see them
125%__mkdir_p %{build_texmf}/tex/latex
126%__mv %{buildroot}%{_datadir}/lyx/tex %{build_texmf}/tex/latex/lyx
127
128# desktop & icon
129desktop-file-install --vendor="vine" \
130  --dir="${RPM_BUILD_ROOT}%{_datadir}/applications" %{SOURCE10}
131%__install -p -D -m644 lib/images/lyx.png \
132  %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/lyx.png
133
134# ghost'd files
135touch %{buildroot}%{_datadir}/lyx/lyxrc.defaults
136touch %{buildroot}%{_datadir}/lyx/{packages,textclass}.lst
137
138# unpackaged files
139%__rm -rf %{buildroot}%{_datadir}/lyx/fonts
140
141%find_lang %{name}
142
143
144%clean
145%__rm -rf ${RPM_BUILD_ROOT}
146
147
148%post
149touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
150
151%postun
152if [ $1 -eq 0 ] ; then
153    %{exec_texhash} >& /dev/null
154    update-desktop-database -q &> /dev/null
155    touch --no-create %{_datadir}/icons/hicolor &> /dev/null
156    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
157fi
158
159%posttrans
160%{exec_texhash} >& /dev/null
161update-desktop-database -q &> /dev/null
162touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
163gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
164
165
166%files -f %{name}.lang
167%defattr(-,root,root,-)
168%doc ABOUT-NLS ANNOUNCE COPYING README UPGRADING NEWS lib/CREDITS
169%{_bindir}/*
170%{_datadir}/lyx/
171%{texmf}/tex/latex/lyx/
172%{_datadir}/applications/*.desktop
173%{_datadir}/icons/hicolor/*/*/*
174%{_mandir}/man*/*
175%config(noreplace) %{_datadir}/lyx/lyxrc.dist
176%ghost %{_datadir}/lyx/lyxrc.defaults
177%ghost %{_datadir}/lyx/*.lst
178%ghost %{_datadir}/lyx/doc/LaTeXConfig.lyx
179
180
181%changelog
182* Sat Jun 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
183- new upstream release
184- dropped BuildRequires: aspell-devel
185- added BuildRequires:
186  - libboost-regex
187  - enchant-devel
188  - hunspell-devel
189
190* Thu Dec 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.8-1
191- new upstream release
192
193* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.7-1
194- new upstream release
195- TeX Live 2009
196  - dropped Requires: xdvik, dvipdfmx
197
198* Sun Jan 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.5-1
199- new upstream release
200- updated Patch0: lyx-1.6.5-xdg_open.patch
201
202* Sun Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.3-1
203- new upstream release
204  - dropped old source files
205- change License: GPLv2+
206- added lyx.desktop
207- added BuildRequires:
208  - aspell-devel
209  - desktop-file-utils
210  - gettext
211  - python
212  - qt4-devel
213  - zlib-devel
214  - libboost-devel
215  - libboost-filesystem
216  - libboost-signals
217  - libpng-devel
218  - glib2-devel
219- added Requires:
220  - ghostscript
221  - dvipdfmx
222  - xdvik
223  - qt4
224  - xdg-utils
225- optimized some configure options
226
227* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.4-1vl5
228- applied new versioning policy, spec in utf-8
229
230* Sat Apr 07 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
231- updated to 1.4.4 with the most recent CJK patch
232- updated Patch1
233
234* Sat Dec 30 2006 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.4.2-0vl1
235- base spec file : Vine Linux BTS #219
236  * Mon Nov  6 2006 M.H
237  - new upstream release
238  - base spec file CJK-LyX-qt.spec and VinePlus lyx.spec
239
240* Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.4-0vl3
241- changed Group to Applications/Editors
242
243* Sat Jan 28 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org>
244- rebuild with qt-3.3.5
245
246* Sun Jun 13 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.3.4-0vl1
247- new upstream version
248- change frontend, xforms -> qt
249- require tetex, qt, latex-xft-fonts
250- change applnk file
251- change Group
252
253* Thu Aug 21 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.1.6fix4-0vl1
254- new upstream version
255- add mime-info
256- minor change in spec file
257
258* Sat Nov 11 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
259- 1.0.3_jp-4
260- added BuildPrereq:
261
262* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
263- 1.0.3_jp-3
264- minor change in spec file
265- build for Vine Linux 2.1
266
267* Wed Jan  5 2000 Jun Nishii <jun@vinelinux.org>
268- change group
269
270* Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
271- updated to lyx-1.0.3
272- rebuild for Vine Linux 2.0
273
274* Wed May 5 1999 Jun Nishii <jun@vinelinux.org>
275- merged Japanese Documents
276
277* Tue May 4 1999 Jun Nishii <jun@vinelinux.org>
278- first build
279
Note: See TracBrowser for help on using the repository browser.