source: projects/specs/tags/6_0_REL/g/gnutls/gnutls-vl.spec @ 3397

Revision 3397, 12.4 KB checked in by iwaim, 13 years ago (diff)

gnutls-2.10.5-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        GNU TLS Library
4Summary(ja):    GNU TLS ライブラリ
5Name:           gnutls
6Version:        2.10.5
7Release:        2%{?_dist_release}
8License:        GPLv3+ and LGPLv2+
9# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
10Group:          System Environment/Libraries
11URL:            http://www.gnutls.org/
12#Source0:       ftp://ftp.gnutls.org/pub/gnutls/devel/%{name}-%{version}.tar.gz
13#Source1:       ftp://ftp.gnutls.org/pub/gnutls/devel/%{name}-%{version}.tar.gz.sig
14# XXX patent tainted SRP code removed.
15Source0:        %{name}-%{version}.tar.bz2
16Source1:        libgnutls-config
17
18#patches from fedora development
19#Patch1: gnutls-2.10.2-rpath.patch
20Patch2: gnutls-2.8.6-link-libgcrypt.patch
21# Remove nonexisting references from texinfo file
22Patch3: gnutls-2.10.1-nosrp.patch
23# Backport from upstream git
24Patch4: gnutls-2.10.1-handshake-errors.patch
25
26
27BuildRoot:      %{_tmppath}/%{name}-%{version}-root
28
29BuildRequires:  libgcrypt-devel >= 1.2.2, zlib-devel libtasn1-devel gmp-devel
30BuildRequires:  gettext readline-devel libtool
31BuildRequires:  guile-devel >= 1.8.6
32BuildRequires:  lzo-devel
33Requires:       libgcrypt >= 1.2.2, zlib
34Requires:       lzo
35
36Requires(post):   ldconfig
37Requires(postun): ldconfig
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41
42%description
43GnuTLS is a project that aims to develop a library which provides a secure
44layer, over a reliable transport layer. Currently the GnuTLS library implements
45the proposed standards by the IETF's TLS working group.
46#'
47
48%package devel
49Summary:        Development files for the GnuTLS package.
50Summary(ja):    GnuTLS の開発用ファイル
51Group:          Development/Libraries
52Requires:       %{name} = %{version}-%{release}
53Requires:       libgcrypt-devel, zlib-devel, pkgconfig
54Requires:       libtasn1-devel
55Requires(post,preun): /sbin/install-info
56
57%description devel
58GnuTLS is a project that aims to develop a library which provides a secure
59layer, over a reliable transport layer. Currently the GnuTLS library implements
60the proposed standards by the IETF's TLS working group.
61
62This package contains files needed for developing applications with the GnuTLS
63library.
64#'
65
66%package utils
67Summary:        Command line tools for TLS protocol.
68Summary(ja):    GnuTLS のコマンドラインツール
69Group:          Applications/System
70Requires:       %{name} = %{version}-%{release}
71
72%description utils
73GnuTLS is a project that aims to develop a library which provides a secure
74layer, over a reliable transport layer. Currently the GnuTLS library implements
75the proposed standards by the IETF's TLS working group.
76
77This package contains command line TLS client and server and certificate
78manipulation tools.
79#'
80
81%package guile
82Summary: Guile bindings for the GNUTLS library
83Group: Development/Libraries
84Requires: %{name} = %{version}-%{release}
85Requires: guile
86
87%description guile
88GnuTLS is a project that aims to develop a library which provides a secure
89layer, over a reliable transport layer. Currently the GnuTLS library implements
90the proposed standards by the IETF's TLS working group.
91This package contains Guile bindings for the library.
92#'
93
94%package -n compat32-%{name}
95Summary:        GNU TLS Library
96Summary(ja):    GNU TLS ライブラリ
97Group:          System Environment/Libraries
98Requires:       compat32-%{name} = %{version}-%{release}
99
100%description -n compat32-%{name}
101GnuTLS is a project that aims to develop a library which provides a secure
102layer, over a reliable transport layer. Currently the GnuTLS library implements
103the proposed standards by the IETF's TLS working group.
104#'
105
106%package -n compat32-%{name}-devel
107Summary:        Development files for the GnuTLS package.
108Summary(ja):    GnuTLS の開発用ファイル
109Group:          Development/Libraries
110Requires:       compat32-%{name} = %{version}-%{release}
111Requires:       %{name}-devel = %{version}-%{release}
112Requires:       compat32-libgcrypt-devel, compat32-zlib-devel
113Requires(post,preun): /sbin/install-info
114
115%description -n compat32-%{name}-devel
116GnuTLS is a project that aims to develop a library which provides a secure
117layer, over a reliable transport layer. Currently the GnuTLS library implements
118the proposed standards by the IETF's TLS working group.
119
120This package contains files needed for developing applications with the GnuTLS
121library.
122#'
123
124%package -n compat32-%{name}-guile
125Summary: Guile bindings for the GNUTLS library
126Group: Development/Libraries
127Requires: compat32-%{name} = %{version}-%{release}
128Requires: %{name}-guile = %{version}-%{release}
129
130%description -n compat32-%{name}-guile
131GnuTLS is a project that aims to develop a library which provides a secure
132layer, over a reliable transport layer. Currently the GnuTLS library implements
133the proposed standards by the IETF's TLS working group.
134This package contains Guile bindings for the library.
135#'
136
137%prep
138%setup -q
139#%patch1 -p1 -b .rpath
140%patch2 -p1 -b .link
141%patch3 -p1 -b .nosrp
142%patch4 -p1 -b .errors
143
144for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
145    touch lib/$i
146done
147
148%build
149autoreconf
150%configure \
151        --with-lzo \
152        --with-included-libcfg \
153        --disable-srp-authentication \
154        --disable-static \
155        --disable-srp-authentication
156#       --with-included-libtasn1 \
157#       --with-included-opencdk \
158#       --with-included-lzo \
159make
160cp lib/COPYING COPYING.LIB
161
162%install
163%__rm -rf %{buildroot}
164%makeinstall
165
166rm -f $RPM_BUILD_ROOT%{_bindir}/srptool
167rm -f $RPM_BUILD_ROOT%{_bindir}/gnutls-srpcrypt
168# replace libgnutls*-config
169%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-config
170%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-extra-config
171
172rm -f $RPM_BUILD_ROOT%{_mandir}/man1/srptool.1
173rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
174rm -f $RPM_BUILD_ROOT%{_infodir}/dir
175rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
176rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.a
177
178# remove unneeded files
179%__rm -f %{buildroot}%{_libdir}/*.la
180
181%find_lang libgnutls
182
183%check
184make check
185
186%clean
187rm -rf %{buildroot}
188
189%post -p /sbin/ldconfig
190
191%postun -p /sbin/ldconfig
192
193%post devel
194if [ -f %{_infodir}/gnutls.info.gz ]; then
195    /sbin/install-info %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
196fi
197
198%preun devel
199if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
200   /sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
201fi
202
203%post guile -p /sbin/ldconfig
204
205%postun guile -p /sbin/ldconfig
206
207%post -n compat32-%{name} -p /sbin/ldconfig
208
209%postun -n compat32-%{name} -p /sbin/ldconfig
210
211%post -n compat32-%{name}-guile -p /sbin/ldconfig
212
213%postun -n compat32-%{name}-guile -p /sbin/ldconfig
214
215%files -f libgnutls.lang
216%defattr(-,root,root,-)
217%{_libdir}/libgnutls*.so.*
218%doc COPYING COPYING.LIB README AUTHORS
219
220%files devel
221%defattr(-,root,root,-)
222%{_bindir}/libgnutls*-config
223%{_includedir}/*
224#%{_libdir}/libgnutls*.a
225%{_libdir}/libgnutls*.so
226%{_libdir}/pkgconfig/*.pc
227%{_mandir}/man3/*
228%{_infodir}/gnutls*
229
230%files utils
231%defattr(-,root,root,-)
232%{_bindir}/certtool
233%{_bindir}/psktool
234%{_bindir}/gnutls*
235%{_mandir}/man1/*
236%doc doc/certtool.cfg
237
238%files guile
239%defattr(-,root,root,-)
240%{_libdir}/libguile*.so*
241%{_datadir}/guile/site/gnutls
242%{_datadir}/guile/site/gnutls.scm
243
244%if %{build_compat32}
245%files -n compat32-%{name}
246%defattr(-,root,root,-)
247%{_libdir}/libgnutls*.so.*
248
249%files -n compat32-%{name}-devel
250%defattr(-,root,root,-)
251#%{_libdir}/libgnutls*.a
252%{_libdir}/libgnutls*.so
253%{_libdir}/pkgconfig/*.pc
254
255%files -n compat32-%{name}-guile
256%defattr(-,root,root,-)
257%{_libdir}/libguile*.so*
258%endif
259
260%changelog
261* Sun Apr 10 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-2
262- add Requires: libtasn1-devel for devel subpackage
263
264* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-1
265- new upstream release
266
267* Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.4-1
268- new upstream release
269
270* Tue Nov 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.3-1
271- new upstream release
272- dropt patch1
273
274* Sun Oct 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.2-1
275- new upstream release
276- added patch1,2,3,4 from Fedora development
277- added BuildRequires: gettext readline-devel libtool
278- added configure option
279  --disable-static,--disable-srp-authentication
280  - dropt *.a files from -devel package again
281
282* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.6-2
283- build with rpm-4.8.1-1 for pkg-config file
284
285* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
286- new upstream release
287- applied new naming policy to spec
288
289* Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
290- new upstream release
291
292* Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
293- new upstream release
294
295* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
296- new upstream release
297
298* Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
299- new upstream release with security fix (handling X.509 CN or SAN fields)
300
301* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
302- added compat32 package for x86_64 arch support
303
304* Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
305- new upstream release
306- added autoreconf
307- deleted libguile*.a
308- dropt Patch3
309- added %post guile, %postun guile
310
311* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
312- drop *.a files from -devel package
313- build with system lzo
314
315* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
316- new upstream release with security fixes (CVE-2009-1415,1416,1417)
317
318* Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.6-1vl5
319- update to 2.6.5
320
321* Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
322- spec in UTF-8
323
324* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
325- update to 2.6.4
326- modifeid Source0
327
328* Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
329- add BuildRequires: guile-devel >= 1.8.6
330
331* Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
332- update to 2.6.3
333- import from fedora developing's 2.6.3
334  - License tag fixed
335- dropped patch0, patch1, patch2
336- added patch3
337- added BuildRequires: gmp-devel
338- add new sub-package: guile
339  - added %package guile, %description guile, %files guile
340
341* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
342- used %%{?_dist_release} macro
343
344* Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
345- update to 1.6.3 (use no-SRP source)
346- import from fedora core's 1.6.3-2
347  - nosrc.tar.bz2 (source0)
348  - license tag fix
349- build with system libtasn1
350
351* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
352- update to 1.4.5 (use no-SRP source)
353- import from fedora core's 1.4.5-1
354  - nosrc.tar.bz2 (source0)
355- drop obsolete cve-2006-4790.patch (patch3)
356
357* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
358- [SECURITY] update to 1.4.1 (use no-SRP source)
359- import from fedora core's 1.4.1-2
360  - nosrp.tar.bz2 (source0)
361  - libgnutls-config (source1)
362  - nosrc.patch (patch0)
363  - enable-psk.patch (patch1)
364  - cve-2006-4790.patch (patch3)
365- update required version of libgcrypt (>= 1.2.2)
366- add Requires: pkgconfig to -devel package
367- add %%check section
368- update %%files
369- add new sub-package: utils
370
371* Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
372- [SECURITY FIX] upstream release
373  - record packet parsing denial of service (CAN-2005-1431)
374
375* Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
376- initial build for Vine Linux
377- upstream release
378
379* Wed Mar  2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
380- gcc4 rebuild
381
382* Tue Jan  4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
383- add gnutls Requires zlib-devel (#144069)
384
385* Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
386- Make gnutls-devel Require libgcrypt-devel
387
388* Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
389- rebuild with release++, otherwise unchanged.
390
391* Tue Sep  7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
392- patent tainted SRP code removed.
393
394* Sun Sep  5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
395- update to 1.0.20.
396- add --with-included-opencdk --with-included-libtasn1
397- add --with-included-libcfg --with-included-lzo
398- add --disable-srp-authentication.
399- do "make check" after build.
400
401* Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
402- upgrade to 0.9.2
403
404* Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
405- update to 0.4.4.
406
407* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
408- automated rebuild
409
410* Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
411- update to 0.4.3.
412
413* Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
414- update to 0.4.2.
415- change license to LGPL.
416- include splint annotations patch.
417
418* Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
419- update to 0.4.0
420
421* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
422- update to 0.3.2
423
424* Wed Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
425- add a URL
426
427* Wed Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
428- initial package
Note: See TracBrowser for help on using the repository browser.