source: projects/specs/trunk/g/gnutls/gnutls-vl.spec @ 5263

Revision 5263, 13.3 KB checked in by kudoh, 13 years ago (diff)

gnutls-vl.spec

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        GNU TLS Library
4Summary(ja):    GNU TLS ライブラリ
5Name:           gnutls
6Version:        2.12.14
7Release:        1%{?_dist_release}
8License:        GPLv3+ and LGPLv2+
9# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
10Group:          System Environment/Libraries
11URL:            http://www.gnutls.org/
12#Source0:       ftp://ftp.gnutls.org/pub/gnutls/devel/%{name}-%{version}.tar.gz
13#Source1:       ftp://ftp.gnutls.org/pub/gnutls/devel/%{name}-%{version}.tar.gz.sig
14# XXX patent tainted SRP code removed.
15Source0:        %{name}-%{version}.tar.bz2
16Source1:        libgnutls-config
17
18#patches from fedora development
19Patch1: gnutls-2.12.11-rpath.patch
20Patch2: gnutls-2.8.6-link-libgcrypt.patch
21# Remove nonexisting references from texinfo file
22Patch3: gnutls-2.12.2-nosrp.patch
23# Skip tests that are expected to fail on libgcrypt build
24Patch4: gnutls-2.12.7-dsa-skiptests.patch
25
26BuildRoot:      %{_tmppath}/%{name}-%{version}-root
27
28BuildRequires: libgcrypt-devel >= 1.2.2, zlib-devel libtasn1-devel gmp-devel
29BuildRequires: gettext readline-devel libtool
30BuildRequires: guile-devel >= 1.8.6
31BuildRequires: lzo-devel nettle-devel
32Requires:       libgcrypt >= 1.2.2, zlib
33Requires:       lzo
34
35Requires(post):   ldconfig
36Requires(postun): ldconfig
37
38Vendor:         Project Vine
39Distribution:   Vine Linux
40
41%description
42GnuTLS is a project that aims to develop a library which provides a secure
43layer, over a reliable transport layer. Currently the GnuTLS library implements
44the proposed standards by the IETF's TLS working group.
45#'
46
47%package devel
48Summary:        Development files for the GnuTLS package.
49Summary(ja):    GnuTLS の開発用ファイル
50Group:          Development/Libraries
51Requires:       %{name} = %{version}-%{release}
52Requires:       libgcrypt-devel, zlib-devel, pkgconfig
53Requires:       libtasn1-devel
54Requires(post,preun): /sbin/install-info
55
56%description devel
57GnuTLS is a project that aims to develop a library which provides a secure
58layer, over a reliable transport layer. Currently the GnuTLS library implements
59the proposed standards by the IETF's TLS working group.
60
61This package contains files needed for developing applications with the GnuTLS
62library.
63#'
64
65%package utils
66Summary:        Command line tools for TLS protocol.
67Summary(ja):    GnuTLS のコマンドラインツール
68Group:          Applications/System
69Requires:       %{name} = %{version}-%{release}
70
71%description utils
72GnuTLS is a project that aims to develop a library which provides a secure
73layer, over a reliable transport layer. Currently the GnuTLS library implements
74the proposed standards by the IETF's TLS working group.
75
76This package contains command line TLS client and server and certificate
77manipulation tools.
78#'
79
80%package guile
81Summary: Guile bindings for the GNUTLS library
82Group: Development/Libraries
83Requires: %{name} = %{version}-%{release}
84Requires: guile
85
86%description guile
87GnuTLS is a project that aims to develop a library which provides a secure
88layer, over a reliable transport layer. Currently the GnuTLS library implements
89the proposed standards by the IETF's TLS working group.
90This package contains Guile bindings for the library.
91#'
92
93%package c++
94Summary: The C++ interface to GnuTLS
95Group: System Environment/Libraries
96Requires: %{name}%{?_isa} = %{version}-%{release}
97
98%description c++
99GnuTLS is a project that aims to develop a library which provides a secure
100layer, over a reliable transport layer. Currently the GnuTLS library implements
101the proposed standards by the IETF's TLS working group.
102This package contains the C++ interface for the GnuTLS library.
103#'
104
105%package -n compat32-%{name}
106Summary:        GNU TLS Library
107Summary(ja):    GNU TLS ライブラリ
108Group:          System Environment/Libraries
109Requires:       compat32-%{name} = %{version}-%{release}
110
111%description -n compat32-%{name}
112GnuTLS is a project that aims to develop a library which provides a secure
113layer, over a reliable transport layer. Currently the GnuTLS library implements
114the proposed standards by the IETF's TLS working group.
115#'
116
117%package -n compat32-%{name}-devel
118Summary:        Development files for the GnuTLS package.
119Summary(ja):    GnuTLS の開発用ファイル
120Group:          Development/Libraries
121Requires:       compat32-%{name} = %{version}-%{release}
122Requires:       %{name}-devel = %{version}-%{release}
123Requires:       compat32-libgcrypt-devel, compat32-zlib-devel
124Requires(post,preun): /sbin/install-info
125
126%description -n compat32-%{name}-devel
127GnuTLS is a project that aims to develop a library which provides a secure
128layer, over a reliable transport layer. Currently the GnuTLS library implements
129the proposed standards by the IETF's TLS working group.
130
131This package contains files needed for developing applications with the GnuTLS
132library.
133#'
134
135%package -n compat32-%{name}-guile
136Summary: Guile bindings for the GNUTLS library
137Group: Development/Libraries
138Requires: compat32-%{name} = %{version}-%{release}
139Requires: %{name}-guile = %{version}-%{release}
140
141%description -n compat32-%{name}-guile
142GnuTLS is a project that aims to develop a library which provides a secure
143layer, over a reliable transport layer. Currently the GnuTLS library implements
144the proposed standards by the IETF's TLS working group.
145This package contains Guile bindings for the library.
146#'
147
148%prep
149%setup -q
150%patch1 -p1 -b .rpath
151%patch2 -p1 -b .link
152%patch3 -p1 -b .nosrp
153%patch4 -p1 -b .skiptests
154
155for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
156    touch lib/$i
157done
158
159%build
160#autoreconf
161%configure --with-libtasn1-prefix=%{_prefix} \
162        --with-lzo \
163        --with-included-libcfg \
164        --disable-openssl-compatibility \
165        --disable-srp-authentication \
166        --disable-static \
167        --disable-srp-authentication \
168        --disable-rpath \
169        --with-libgcrypt
170#       --with-included-libtasn1 \
171#       --with-included-opencdk \
172#       --with-included-lzo \
173make
174cp lib/COPYING COPYING.LIB
175
176%install
177%__rm -rf %{buildroot}
178%makeinstall
179
180rm -f $RPM_BUILD_ROOT%{_bindir}/srptool
181rm -f $RPM_BUILD_ROOT%{_bindir}/gnutls-srpcrypt
182# replace libgnutls*-config
183%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-config
184%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-extra-config
185
186rm -f $RPM_BUILD_ROOT%{_mandir}/man1/srptool.1
187rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
188rm -f $RPM_BUILD_ROOT%{_infodir}/dir
189rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
190rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.a
191
192# remove unneeded files
193%__rm -f %{buildroot}%{_libdir}/*.la
194
195%find_lang libgnutls
196
197%check
198make check
199
200%clean
201rm -rf %{buildroot}
202
203%post -p /sbin/ldconfig
204
205%postun -p /sbin/ldconfig
206
207%post devel
208if [ -f %{_infodir}/gnutls.info.gz ]; then
209    /sbin/install-info %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
210fi
211
212%preun devel
213if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
214   /sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
215fi
216
217%post guile -p /sbin/ldconfig
218
219%postun guile -p /sbin/ldconfig
220
221%post -n compat32-%{name} -p /sbin/ldconfig
222
223%postun -n compat32-%{name} -p /sbin/ldconfig
224
225%post -n compat32-%{name}-guile -p /sbin/ldconfig
226
227%postun -n compat32-%{name}-guile -p /sbin/ldconfig
228
229%files -f libgnutls.lang
230%defattr(-,root,root,-)
231%{_libdir}/libgnutls*.so.*
232%{_libdir}/libgnutls-extra.so.*
233%doc COPYING COPYING.LIB README AUTHORS
234
235%files devel
236%defattr(-,root,root,-)
237%{_bindir}/libgnutls*-config
238%{_includedir}/*
239%{_libdir}/libgnutls*.so
240%{_libdir}/pkgconfig/*.pc
241%{_mandir}/man3/*
242%{_infodir}/gnutls*
243%{_infodir}/pkcs11-vision.png.gz
244
245%files utils
246%defattr(-,root,root,-)
247%{_bindir}/certtool
248%{_bindir}/psktool
249%{_bindir}/p11tool
250%{_bindir}/gnutls*
251%{_mandir}/man1/*
252%doc doc/certtool.cfg
253
254%files guile
255%defattr(-,root,root,-)
256%{_libdir}/libguile*.so*
257%{_datadir}/guile/site/gnutls
258%{_datadir}/guile/site/gnutls.scm
259
260%files c++
261%{_libdir}/libgnutlsxx.so.*
262
263%if %{build_compat32}
264%files -n compat32-%{name}
265%defattr(-,root,root,-)
266%{_libdir}/libgnutls*.so.*
267
268%files -n compat32-%{name}-devel
269%defattr(-,root,root,-)
270#%{_libdir}/libgnutls*.a
271%{_libdir}/libgnutls*.so
272%{_libdir}/pkgconfig/*.pc
273
274%files -n compat32-%{name}-guile
275%defattr(-,root,root,-)
276%{_libdir}/libguile*.so*
277%endif
278
279%changelog
280* Sun Nov 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-1
281- new upstream release
282- synced Fedora development package
283- add new sub-package: c++
284
285* Sun Apr 10 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-2
286- add Requires: libtasn1-devel for devel subpackage
287
288* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-1
289- new upstream release
290
291* Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.4-1
292- new upstream release
293
294* Tue Nov 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.3-1
295- new upstream release
296- dropt patch1
297
298* Sun Oct 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.2-1
299- new upstream release
300- added patch1,2,3,4 from Fedora development
301- added BuildRequires: gettext readline-devel libtool
302- added configure option
303  --disable-static,--disable-srp-authentication
304  - dropt *.a files from -devel package again
305
306* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.6-2
307- build with rpm-4.8.1-1 for pkg-config file
308
309* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
310- new upstream release
311- applied new naming policy to spec
312
313* Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
314- new upstream release
315
316* Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
317- new upstream release
318
319* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
320- new upstream release
321
322* Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
323- new upstream release with security fix (handling X.509 CN or SAN fields)
324
325* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
326- added compat32 package for x86_64 arch support
327
328* Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
329- new upstream release
330- added autoreconf
331- deleted libguile*.a
332- dropt Patch3
333- added %post guile, %postun guile
334
335* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
336- drop *.a files from -devel package
337- build with system lzo
338
339* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
340- new upstream release with security fixes (CVE-2009-1415,1416,1417)
341
342* Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.5-1vl5
343- update to 2.6.5
344
345* Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
346- spec in UTF-8
347
348* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
349- update to 2.6.4
350- modifeid Source0
351
352* Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
353- add BuildRequires: guile-devel >= 1.8.6
354
355* Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
356- update to 2.6.3
357- import from fedora developing's 2.6.3
358  - License tag fixed
359- dropped patch0, patch1, patch2
360- added patch3
361- added BuildRequires: gmp-devel
362- add new sub-package: guile
363  - added %package guile, %description guile, %files guile
364
365* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
366- used %%{?_dist_release} macro
367
368* Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
369- update to 1.6.3 (use no-SRP source)
370- import from fedora core's 1.6.3-2
371  - nosrc.tar.bz2 (source0)
372  - license tag fix
373- build with system libtasn1
374
375* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
376- update to 1.4.5 (use no-SRP source)
377- import from fedora core's 1.4.5-1
378  - nosrc.tar.bz2 (source0)
379- drop obsolete cve-2006-4790.patch (patch3)
380
381* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
382- [SECURITY] update to 1.4.1 (use no-SRP source)
383- import from fedora core's 1.4.1-2
384  - nosrp.tar.bz2 (source0)
385  - libgnutls-config (source1)
386  - nosrc.patch (patch0)
387  - enable-psk.patch (patch1)
388  - cve-2006-4790.patch (patch3)
389- update required version of libgcrypt (>= 1.2.2)
390- add Requires: pkgconfig to -devel package
391- add %%check section
392- update %%files
393- add new sub-package: utils
394
395* Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
396- [SECURITY FIX] upstream release
397  - record packet parsing denial of service (CAN-2005-1431)
398
399* Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
400- initial build for Vine Linux
401- upstream release
402
403* Wed Mar  2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
404- gcc4 rebuild
405
406* Tue Jan  4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
407- add gnutls Requires zlib-devel (#144069)
408
409* Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
410- Make gnutls-devel Require libgcrypt-devel
411
412* Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
413- rebuild with release++, otherwise unchanged.
414
415* Tue Sep  7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
416- patent tainted SRP code removed.
417
418* Sun Sep  5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
419- update to 1.0.20.
420- add --with-included-opencdk --with-included-libtasn1
421- add --with-included-libcfg --with-included-lzo
422- add --disable-srp-authentication.
423- do "make check" after build.
424
425* Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
426- upgrade to 0.9.2
427
428* Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
429- update to 0.4.4.
430
431* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
432- automated rebuild
433
434* Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
435- update to 0.4.3.
436
437* Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
438- update to 0.4.2.
439- change license to LGPL.
440- include splint annotations patch.
441
442* Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
443- update to 0.4.0
444
445* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
446- update to 0.3.2
447
448* Wed Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
449- add a URL
450
451* Wed Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
452- initial package
Note: See TracBrowser for help on using the repository browser.