source: projects/specs/tags/6_0_REL/g/gnome-web-photo/gnome-web-photo-vl.spec @ 848

Revision 848, 5.6 KB checked in by kazutaka, 14 years ago (diff)

remove %{gecko_version} macro and specify explicit minimum version

Line 
1%define build_vine5 0
2%define build_vine6 0
3
4%if "%{?_dist_release}" == "vl5"
5%define build_vine5 1
6%endif
7%if "%{?_dist_release}" == "vl6"
8%define build_vine6 1
9%endif
10
11Summary:        HTML pages thumbnailer
12Summary(ja):    HTML ページのサムネール作成ツール
13Name:           gnome-web-photo
14Version:        0.9
15Release:        4%{?_dist_release}
16License:        LGPLv2+
17Group:          Applications/Internet
18URL:            http://ftp.gnome.org/pub/GNOME/sources/gnome-web-photo/%{version}/
19Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-web-photo/%{version}/%{name}-%{version}.tar.bz2
20Patch0:         gnome-web-photo-xulrunner192.patch
21
22BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
23Requires(post): GConf2
24Requires(preun):GConf2
25Requires:       gecko-libs >= 1.9
26BuildRequires:  gtk2-devel >= 2.10.0
27BuildRequires:  libxml2-devel
28BuildRequires:  gnome-vfs2-devel
29BuildRequires:  gecko-devel >= 1.9
30BuildRequires:  gecko-devel-unstable >= 1.9
31BuildRequires:  libjpeg-devel
32BuildRequires:  gettext intltool
33
34Packager:       kazutaka
35
36%description
37gnome-web-photo contains a thumbnailer that will be used by
38GNOME applications, including the file manager, to generate
39screenshots of web pages.
40
41%prep
42%setup -q
43
44%if %{build_vine6}
45%patch0 -p1 -b .xulrunner192
46%endif
47
48%build
49%configure
50%{__make} %{?_smp_mflags}
51
52%install
53%{__rm} -rf $RPM_BUILD_ROOT
54export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
55%{__make} DESTDIR=$RPM_BUILD_ROOT install
56unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
57
58%{__mv} $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/thumbnailer.schemas \
59        $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas
60
61%find_lang %{name}
62
63%post
64export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
65gconftool-2 --makefile-install-rule \
66        %{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas >& /dev/null
67
68%pre
69if [ "$1" -gt 1 ]; then
70    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
71    gconftool-2 --makefile-uninstall-rule                               \
72        %{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas            \
73        >& /dev/null || :
74fi
75
76%preun
77if [ "$1" -eq 0 ]; then
78    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
79    gconftool-2 --makefile-uninstall-rule \
80      %{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas >& /dev/null
81fi
82
83%clean
84%{__rm} -rf $RPM_BUILD_ROOT
85
86%files -f %{name}.lang
87%defattr(-,root,root,-)
88%doc ChangeLog AUTHORS README TODO COPYING.README
89%{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas
90%{_bindir}/gnome-web-photo
91%{_bindir}/gnome-web-print
92%{_bindir}/gnome-web-thumbnail
93%{_datadir}/gnome-web-photo
94
95%changelog
96* Sat Apr 17 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9-4
97- remove %%{gecko_version} macro and specify explicit minimum version
98
99* Sat Mar 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9-3
100- rebuild with xulrunner-%{gecko_version}
101
102* Wed Jan 27 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9-2
103- rebuild with xulrunner-%{gecko_version}
104- add Patch0 to fix xulrunner-1.9.2 build
105
106* Fri Jan 15 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9-1
107- new upstream release
108- build with xulrunner-1.9.1.7 (gecko-libs)
109
110* Thu Nov 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8-1
111- initial build for Vine Linux based on fedora development
112
113* Fri Sep 11 2009 Jan Horak <jhorak@redhat.com> - 0.8-6
114- Rebuild against newer gecko
115
116* Thu Aug 06 2009 Jan Horak <jhorak@redhat.com> - 0.8-5
117- Rebuild against newer gecko
118
119* Tue Aug 04 2009 Jan Horak <jhorak@redhat.com> - 0.8-4
120- Rebuild against newer gecko
121
122* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8-3
123- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
124
125* Mon Jul 20 2009 Jan Horak <jhorak@redhat.com> - 0.8-2
126- Rebuild against newer gecko
127
128* Tue Jun 30 2009 Matthias Clasen <mclasen@redhat.com> - 0.8-1
129- Update to 0.8
130
131* Mon Apr 27 2009 Christopher Aillon <caillon@redhat.com> - 0.7-2
132- Rebuild against newer gecko
133
134* Mon Apr 13 2009 Matthias Clasen <mclasen@redhat.com> - 0.7-1
135- Update to 0.7
136
137* Tue Mar 24 2009 Jan Horak <jhorak@redhat.com> - 0.6-2
138- Fix for rebuild against newer gecko
139
140* Tue Mar 17 2009 Matthias Clasen <mclasen@redhat.com> - 0.6-1
141- Update to 0.6
142
143* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-14
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
145
146* Tue Jan 06 2009 Christopher Aillon <caillon@redhat.com> - 0.3-13
147- Rebuild against newer gecko
148
149* Wed Nov 12 2008 Christopher Aillon <caillon@redhat.com> - 0.3-12
150- Rebuild against newer gecko
151
152* Wed Mar 12 2008 Marco Pesenti Gritti <mpg@redhat.com> - 0.3-11
153- Better xulrunner-1.9 patch which also works with very long pages
154
155* Fri Mar  7 2008 Marco Pesenti Gritti <mpg@redhat.com> - 0.3-10
156- Add patch to make it work with xulrunner 1.9
157
158* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.3-9
159- Autorebuild for GCC 4.3
160
161* Tue Nov 27 2007 Christopher Aillon <caillon@redhat.com> - 0.3-8
162- Rebuild against newer gecko
163
164* Fri Nov 23 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-7
165- Rebuilding against xulrunner will require a lot of porting,
166  disable for now
167
168* Fri Nov 16 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-6
169- Try to rebuild with xulrunner
170
171* Thu Oct 25 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-5
172- Rebuild for new Gecko, tighten dependencies
173
174* Mon Sep 10 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-4
175- Fix license, as mentioned by Kevin Fenzi
176
177* Thu Sep 06 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-3
178- Update following Matthias Clasen's comments
179
180* Wed Sep 05 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-2
181- Update following Peter Gordon's comments
182
183* Tue Mar 20 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-1
184- First post!
185
Note: See TracBrowser for help on using the repository browser.