source: projects/specs/trunk/g/gnome-web-photo/gnome-web-photo-vl.spec @ 521

Revision 521, 5.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_vine5 0
2%define build_vine6 0
3
4%if "%{?_dist_release}" == "vl5"
5%define build_vine5 1
6%endif
7%if "%{?_dist_release}" == "vl6"
8%define build_vine6 1
9%endif
10
11%if %{build_vine5}
12%define gecko_version 1.9.1.8
13%endif
14%if %{build_vine6}
15%define gecko_version 1.9.2
16%endif
17
18Summary:        HTML pages thumbnailer
19Summary(ja):    HTML ページのサムネール作成ツール
20Name:           gnome-web-photo
21Version:        0.9
22Release:        3%{?_dist_release}
23License:        LGPLv2+
24Group:          Applications/Internet
25URL:            http://ftp.gnome.org/pub/GNOME/sources/gnome-web-photo/%{version}/
26Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-web-photo/%{version}/%{name}-%{version}.tar.bz2
27Patch0:         gnome-web-photo-xulrunner192.patch
28
29BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
30Requires(post): GConf2
31Requires(preun):GConf2
32Requires:       gecko-libs = %{gecko_version}
33BuildRequires:  gtk2-devel >= 2.10.0
34BuildRequires:  libxml2-devel
35BuildRequires:  gnome-vfs2-devel
36BuildRequires:  gecko-devel = %{gecko_version}
37BuildRequires:  gecko-devel-unstable = %{gecko_version}
38BuildRequires:  libjpeg-devel
39BuildRequires:  gettext intltool
40
41Packager:       kazutaka
42
43%description
44gnome-web-photo contains a thumbnailer that will be used by
45GNOME applications, including the file manager, to generate
46screenshots of web pages.
47
48%prep
49%setup -q
50
51%if %{build_vine6}
52%patch0 -p1 -b .xulrunner192
53%endif
54
55%build
56%configure
57%{__make} %{?_smp_mflags}
58
59%install
60%{__rm} -rf $RPM_BUILD_ROOT
61export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
62%{__make} DESTDIR=$RPM_BUILD_ROOT install
63unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
64
65%{__mv} $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/thumbnailer.schemas \
66        $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas
67
68%find_lang %{name}
69
70%post
71export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
72gconftool-2 --makefile-install-rule \
73        %{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas >& /dev/null
74
75%pre
76if [ "$1" -gt 1 ]; then
77    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
78    gconftool-2 --makefile-uninstall-rule                               \
79        %{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas            \
80        >& /dev/null || :
81fi
82
83%preun
84if [ "$1" -eq 0 ]; then
85    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
86    gconftool-2 --makefile-uninstall-rule \
87      %{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas >& /dev/null
88fi
89
90%clean
91%{__rm} -rf $RPM_BUILD_ROOT
92
93%files -f %{name}.lang
94%defattr(-,root,root,-)
95%doc ChangeLog AUTHORS README TODO COPYING.README
96%{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas
97%{_bindir}/gnome-web-photo
98%{_bindir}/gnome-web-print
99%{_bindir}/gnome-web-thumbnail
100%{_datadir}/gnome-web-photo
101
102%changelog
103* Sat Mar 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9-3
104- rebuild with xulrunner-%{gecko_version}
105
106* Wed Jan 27 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9-2
107- rebuild with xulrunner-%{gecko_version}
108- add Patch0 to fix xulrunner-1.9.2 build
109
110* Fri Jan 15 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9-1
111- new upstream release
112- build with xulrunner-1.9.1.7 (gecko-libs)
113
114* Thu Nov 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8-1
115- initial build for Vine Linux based on fedora development
116
117* Fri Sep 11 2009 Jan Horak <jhorak@redhat.com> - 0.8-6
118- Rebuild against newer gecko
119
120* Thu Aug 06 2009 Jan Horak <jhorak@redhat.com> - 0.8-5
121- Rebuild against newer gecko
122
123* Tue Aug 04 2009 Jan Horak <jhorak@redhat.com> - 0.8-4
124- Rebuild against newer gecko
125
126* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8-3
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
128
129* Mon Jul 20 2009 Jan Horak <jhorak@redhat.com> - 0.8-2
130- Rebuild against newer gecko
131
132* Tue Jun 30 2009 Matthias Clasen <mclasen@redhat.com> - 0.8-1
133- Update to 0.8
134
135* Mon Apr 27 2009 Christopher Aillon <caillon@redhat.com> - 0.7-2
136- Rebuild against newer gecko
137
138* Mon Apr 13 2009 Matthias Clasen <mclasen@redhat.com> - 0.7-1
139- Update to 0.7
140
141* Tue Mar 24 2009 Jan Horak <jhorak@redhat.com> - 0.6-2
142- Fix for rebuild against newer gecko
143
144* Tue Mar 17 2009 Matthias Clasen <mclasen@redhat.com> - 0.6-1
145- Update to 0.6
146
147* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-14
148- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
149
150* Tue Jan 06 2009 Christopher Aillon <caillon@redhat.com> - 0.3-13
151- Rebuild against newer gecko
152
153* Wed Nov 12 2008 Christopher Aillon <caillon@redhat.com> - 0.3-12
154- Rebuild against newer gecko
155
156* Wed Mar 12 2008 Marco Pesenti Gritti <mpg@redhat.com> - 0.3-11
157- Better xulrunner-1.9 patch which also works with very long pages
158
159* Fri Mar  7 2008 Marco Pesenti Gritti <mpg@redhat.com> - 0.3-10
160- Add patch to make it work with xulrunner 1.9
161
162* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.3-9
163- Autorebuild for GCC 4.3
164
165* Tue Nov 27 2007 Christopher Aillon <caillon@redhat.com> - 0.3-8
166- Rebuild against newer gecko
167
168* Fri Nov 23 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-7
169- Rebuilding against xulrunner will require a lot of porting,
170  disable for now
171
172* Fri Nov 16 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-6
173- Try to rebuild with xulrunner
174
175* Thu Oct 25 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-5
176- Rebuild for new Gecko, tighten dependencies
177
178* Mon Sep 10 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-4
179- Fix license, as mentioned by Kevin Fenzi
180
181* Thu Sep 06 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-3
182- Update following Matthias Clasen's comments
183
184* Wed Sep 05 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-2
185- Update following Peter Gordon's comments
186
187* Tue Mar 20 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-1
188- First post!
189
Note: See TracBrowser for help on using the repository browser.