source: projects/specs/tags/6_0_REL/g/gnome-sharp2/gnome-sharp2-vl.spec @ 2347

Revision 2347, 5.5 KB checked in by Takemikaduchi, 13 years ago (diff)

mono: fix for ppc, gnome-sharp2: add BR: libSM-devel, gnome-desktop-sharp2: change BR: gnome-panel-devel

Line 
1%define mono_dir %(/usr/bin/monodir)
2%define _name gnome-sharp
3Summary: .Net Language Bindings for Gnome
4Summary(ja): Mono 用 GNOME バインディング
5Name: gnome-sharp2
6Version: 2.24.1
7Release: 7%{?_dist_release}
8License: GNU General ublic License (GPL), GNU Library General Public License v. 2.0 and 2.1 (LGPL)
9Group: Development/Libraries
10URL: http://gtk-sharp.sf.net
11Source: %{_name}-%{version}.tar.bz2
12Patch2: gnome-sharp-find_gtkhtml_ver.patch
13Patch3: gnome-sharp-2.24.1-TestXfer.patch
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: gtk-sharp2 gtk-sharp2-gapi
16BuildRequires: librsvg2-devel
17BuildRequires: mono-devel monodoc
18BuildRequires: vte-devel gtkhtml3-devel
19BuildRequires: libSM-devel
20%define env_options export MONO_SHARED_DIR=/tmp
21
22%description
23This package contains Mono bindings for Gnome.
24
25
26%package -n gnome-sharp2-complete
27Group: Development/Libraries
28Summary: GTK+ and GNOME bindings for Mono (virtual package)
29Requires: art-sharp2 = %{version}-%{release}
30Requires: gconf-sharp2 = %{version}-%{release}
31Requires: gnome-sharp2 = %{version}-%{release}
32Requires: gnome-vfs-sharp2 = %{version}-%{release}
33#Requires: glib-sharp2 >= 2.10.3
34
35%description -n gnome-sharp2-complete
36Gtk# is a library that allows you to build fully native graphical GNOME
37applications using Mono. Gtk# is a binding to GTK+, the cross platform
38user interface toolkit used in GNOME. It includes bindings for Gtk,
39Atk, Pango, Gdk, libgnome, libgnomeui and libgnomecanvas.  (Virtual
40package which depends on all gtk-sharp2 subpackages)
41
42
43%package -n gnome-vfs-sharp2
44Summary: Mono bindings for gnomevfs
45Group: Development/Libraries
46Requires: gnome-vfs2
47
48%description -n gnome-vfs-sharp2
49This package contains Mono bindings gnomevfs.
50
51
52%package -n art-sharp2
53Summary: Mono bindings for libart
54Group: Development/Libraries
55Requires: libart_lgpl
56
57%description -n art-sharp2
58This package contains Mono bindings for libart.
59
60
61%package -n gconf-sharp2
62Summary: Mono bindings for gconf
63Group: Development/Libraries
64
65%description -n gconf-sharp2
66This package contains Mono bindings for gconf and gconf peditors.
67
68
69%prep
70%setup -q -n %{_name}-%{version}
71%patch3 -p1 -b .TestXfer
72autoreconf -f -i
73
74
75%build
76export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
77export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
78%configure \
79        --libexecdir=%{_prefix}/lib \
80        --enable-debug
81make
82
83%install
84export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
85%makeinstall
86
87## remove unuse files
88rm -f $RPM_BUILD_ROOT%{_libdir}/*.*a
89rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug/%{_libdir}/libgnomesharpglue-2.so.debug
90rm -f $RPM_BUILD_ROOT%{_prefix}/src/debug/gnome-sharp-*/gnome/glue/*.c
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95
96%files -n gnome-sharp2-complete
97%defattr(-, root, root)
98## This is the 'base' package so we put the common dirs of all in this package
99# Otherwise, this package doesn't get created!
100%dir %{mono_dir}/gtk-sharp-2.0
101%dir %{_prefix}/lib/gtk-sharp-2.0
102
103%files -n gnome-sharp2
104%defattr(-,root,root)
105%{_libdir}/libgnomesharpglue-2.so
106%{_libdir}/pkgconfig/gnome-sharp-2.0.pc
107%{mono_dir}/gac/*gnome-sharp
108%{mono_dir}/gtk-sharp-2.0/*gnome-sharp.dll
109%{_datadir}/gapi-2.0/gnome-api.xml
110
111
112%files -n gnome-vfs-sharp2
113%defattr(-,root,root)
114%{_libdir}/pkgconfig/gnome-vfs-sharp-2.0.pc
115%{mono_dir}/gac/*gnome-vfs-sharp
116%{mono_dir}/gtk-sharp-2.0/*gnome-vfs-sharp.dll
117%{_datadir}/gapi-2.0/gnome-vfs-api.xml
118
119
120%files -n art-sharp2
121%defattr(-,root,root)
122%{_libdir}/pkgconfig/art-sharp-2.0.pc
123%{mono_dir}/gac/*art-sharp
124%{mono_dir}/gtk-sharp-2.0/*art-sharp.dll
125%{_datadir}/gapi-2.0/art-api.xml
126
127
128%files -n gconf-sharp2
129%defattr(-, root, root)
130%{_bindir}/gconfsharp2-schemagen
131%{_libdir}/pkgconfig/gconf-sharp-2.0.pc
132%{_prefix}/lib/gtk-sharp-2.0/gconfsharp-schemagen.exe
133%{mono_dir}/gac/*gconf-sharp
134%{mono_dir}/gtk-sharp-2.0/*gconf-sharp.dll
135# Other distros place these in gnome-sharp2??
136%{_libdir}/pkgconfig/gconf-sharp-peditors-2.0.pc
137%{mono_dir}/gac/*gconf-sharp-peditors
138%{mono_dir}/gtk-sharp-2.0/*gconf-sharp-peditors.dll
139
140
141%changelog
142* Tue Dec 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-7
143- add BuildRequires: libSM-devel
144
145* Sat Oct 09 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.1-6
146- added gnome-sharp-2.24.1-TestXfer.patch
147- rebuilt with mono-2.8
148
149* Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.1-5
150- build with rpm-4.8.1-1 for pkg-config file
151
152* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.1-4
153- rebuilt with new environment
154
155* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-3
156- rebuilt with latest rpm to update mono-dependencies
157- dropt BR: libgnomedb-devel
158
159* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-2
160- changed Group to Development/Libraries
161
162* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-1
163- updated to 2.24.1
164
165* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.0-1
166- initial build for VineSeed
167        - updated gnome-sharp2 to 2.20.0
168        - added japanese summary
169        - applied vine versioning policy
170        - spec in utf-8
171
172* Thu Apr 24 2008 wberrier@suse.de
173- Update to 2.12.1
174  * Bugfix in GLib ref management for Gnome.Program crash in
175  gnome-sharp
176* Thu Apr  3 2008 wberrier@novell.com
177- Can now build 2.16 and 2.20 from the same spec
178- Update to 2.20.0
179  - Updated bindings to coincide with gtk# 2.12
180  - Removed bindings: gtkhtml#, rsvg#, and vte#
181* Wed Mar 26 2008 wberrier@novell.com
182- Update to 2.16.1
183  - Allow storage of empty lists in gconf
184  - Bug fixes:
185  - [GConf] Impossible to set empty list values (bnc#325516)
186  - Comment #8 of bnc#327058 (incorrect p/invoke bindings)
187* Tue Jul  3 2007 wberrier@suse.de
188- Initial package of gnome-sharp2 2.16.0
189  - (Split from gtk-sharp 2.8.3)
Note: See TracBrowser for help on using the repository browser.