source: projects/specs/tags/6_0_REL/f/freetype/freetype-vl.spec @ 1228

Revision 1228, 7.9 KB checked in by Takemikaduchi, 14 years ago (diff)

fix BTS:1005 and BTS:1006

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary: A free and portable TrueType font rendering engine.
3Name: freetype
4Version: 1.3.1
5Release: 7%{?_dist_release}
6License: BSD-like
7Group: System Environment/Libraries
8URL: http://www.freetype.org
9Source: freetype-%{version}.tar.gz
10Source1: ttmkfdir.tar.gz
11Patch0: freetype-1.2-fixpath.patch
12Patch1: freetype-1.3.1-foundrynames.patch
13Patch2: freetype-1.3.1-ftdump-gcc3.patch
14Patch3: freetype-1.3.1-config.sub-x86_64.patch
15Patch4: freetype-1.3.1-ltconfig-compat32.patch
16
17Buildroot: %{_tmppath}/%{name}-%{version}-root
18Obsoletes: freetype-utils
19BuildRequires:  libX11-devel
20BuildRequires:  libXt-devel
21BuildRequires:  imake
22
23%description
24The FreeType engine is a free and portable TrueType font rendering
25engine, developed to provide TrueType support for a variety of
26platforms and environments. FreeType is a library which can open and
27manages font files as well as efficiently load, hint and render
28individual glyphs. FreeType is not a font server or a complete
29text-rendering library.
30
31%package utils
32Summary: Several utilities to manipulate and examine TrueType fonts.
33Group: Applications/Publishing
34
35%description utils
36This package contains several utilities which allow you to view and
37manipulate TrueType fonts.  They are mainly useful for debugging and
38testing purposes, and are not required for using the FreeType
39library.
40
41%package devel
42Summary: Header files and static library for development with FreeType.
43Group: Development/Libraries
44Requires:       %{name} = %{version}-%{release}
45
46%description devel
47The freetype-devel package contains the header files and static
48library needed to develop or compile applications which use the
49FreeType TrueType font rendering library.
50
51Install freetype-devel if you want to develop FreeType
52applications. If you simply want to run existing applications, you
53won't need this package.
54
55%if %{build_compat32}
56## to build compat32 for x86_64 architecture support
57%package -n compat32-%{name}
58Summary: A free and portable TrueType font rendering engine.
59Group: System Environment/Libraries
60%description -n compat32-%{name}
61The FreeType engine is a free and portable TrueType font rendering
62engine, developed to provide TrueType support for a variety of
63platforms and environments. FreeType is a library which can open and
64manages font files as well as efficiently load, hint and render
65individual glyphs. FreeType is not a font server or a complete
66text-rendering library.
67
68%package -n compat32-%{name}-devel
69Summary: Header files and static library for development with FreeType.
70Group: Development/Libraries
71Requires: compat32-%{name} = %{version}
72%description -n compat32-%{name}-devel
73The freetype-devel package contains the header files and static
74library needed to develop or compile applications which use the
75FreeType TrueType font rendering library.
76
77Install freetype-devel if you want to develop FreeType
78applications. If you simply want to run existing applications, you
79won't need this package.
80%endif
81
82%prep
83%setup -q
84mkdir ttmkfdir
85tar xz -C ttmkfdir -f %{SOURCE1}
86%patch0 -p1 -b .fixpath
87%patch1 -p1 -b .foundrynames
88%patch2 -p1 -b .ftdump-gcc3
89%patch3 -p1 -b .config.sub-x86_64
90%if %{build_compat32}
91%patch4 -p1 -b .ltconfig-compat32
92%endif
93
94%build
95%if %{build_compat32}
96export CC='gcc -m32'
97%endif
98##libtoolize --copy --force
99./configure --prefix=%{_prefix} \
100        --with-cflags="$RPM_OPT_FLAGS" \
101        --disable-debug \
102        --enable-static --enable-shared \
103        --with-locale-dir=%{_localedir} \
104        --libdir=%{_libdir} \
105        --x-libraries=%{_libdir} \
106        --target=%{_target_platform}
107
108make
109
110%if 0
111make -C ttmkfdir CC="gcc $RPM_OPT_FLAGS"
112
113(cd contrib/ttf2pk
114./configure --prefix=%{_prefix} \
115        --mandir=%{_mandir} \
116        --with-cflags="$RPM_OPT_FLAGS"
117make
118)
119%endif
120
121#       --libdir=$RPM_BUILD_ROOT%{_libdir} \
122%install
123rm -rf $RPM_BUILD_ROOT
124make prefix=$RPM_BUILD_ROOT%{_prefix} \
125        libdir=$RPM_BUILD_ROOT%{_libdir} \
126        install \
127        gnulocaledir=$RPM_BUILD_ROOT%{_localedir}
128%if 0
129install -m 755 ttmkfdir/ttmkfdir $RPM_BUILD_ROOT%{_bindir}
130%endif
131
132(cd $RPM_BUILD_ROOT%{_includedir}
133for i in freetype/*.h
134do
135    ln -sf $i .
136done
137)
138
139%if 0
140(cd contrib/ttf2pk
141make prefix=$RPM_BUILD_ROOT%{_prefix} \
142        mandir=$RPM_BUILD_ROOT%{_mandir} \
143        install
144mkdir -p $RPM_BUILD_ROOT%{_datadir}/ttf2pk
145cp data/* $RPM_BUILD_ROOT%{_datadir}/ttf2pk
146)
147%endif
148
149# remove unpackaged files
150rm -rf $RPM_BUILD_ROOT%{_bindir}
151
152%post -p /sbin/ldconfig
153
154%postun -p /sbin/ldconfig
155
156%if %{build_compat32}
157%post -n compat32-%{name} -p /sbin/ldconfig
158%postun -n compat32-%{name} -p /sbin/ldconfig
159%endif
160
161%clean
162rm -rf $RPM_BUILD_ROOT
163
164%files
165%defattr(-,root,root)
166%{_libdir}/libttf.la
167%{_libdir}/libttf.so.*
168%{_datadir}/locale/*/LC_MESSAGES/*
169%doc README  announce docs
170
171%if 0
172%files utils
173%defattr(-,root,root)
174%{_bindir}/*
175%{_mandir}/man1/*
176%{_datadir}/ttf2pk/
177%endif
178
179%files devel
180%defattr(-,root,root)
181%{_includedir}/*
182%{_libdir}/libttf.so
183%{_libdir}/libttf.a
184
185## to build compat32 for x86_64 architecture support
186%if %{build_compat32}
187%files -n compat32-%{name}
188%defattr(-,root,root)
189%{_libdir}/libttf.la
190%{_libdir}/libttf.so.*
191
192%files -n compat32-%{name}-devel
193%defattr(-,root,root)
194%{_libdir}/libttf.so
195%{_libdir}/libttf.a
196%endif
197
198%changelog
199* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.1-7
200- add Requires: %{name} = %{version}-%{release} (devel package)
201- add BuildRequires: libX11-devel, libXt-devel, imake
202- change configure option
203    (from "--x-libraries=%{_prefix}/X11R6/%{_lib}" to "--x-libraries=%{_libdir}")
204
205* Wed Mar 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.1-6
206- obsolete freetype-utils
207
208* Thu Feb 23 2006 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5vl5
209- fixed libdir to configure and to make install
210
211* Mon Feb 13 2006 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5vl4
212- dropt libtoolize
213- added freetype-1.3.1-ftdump-gcc3.patch
214- added freetype-1.3.1-config.sub-x86_64.patch
215- added freetype-1.3.1-ltconfig-compat32.patch
216- added options --libdir, --x-libraries, --target to configure
217- added URL
218- changed Copyright to License
219- changed direct path strings to macros
220
221* Sat Mar 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.1-5vl3
222- rebuilt with new toolchains
223
224* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
225- 1.3.1-5vl2
226- rebuilt with new %%{_mandir} for VineSeed
227
228* Wed Aug  2 2000 Jun Nishii <jun@vinelinux.org>
229- 1.3.1-5vl1
230- follow RHL62
231
232* Sat Jan 22 2000 Jun Nishii <jun@vinelinux.org>
233- added %defattr
234
235* Tue Jan 11 2000 Jun Nishii <jun@vinelinux.org>
236- added bins from contrib/ttf2pk
237
238* Tue Nov 23 1999 Norihito Ohmori <ohmori@flatout.org>
239- modified for Vine Linux
240
241* Wed Nov 10 1999 Norihito Ohmori <nono@kondara.org>
242- add /usr/bin/{ftmetric,ftsbit,ftstrtto} to freetype-utils (jitterbug #88)
243
244* Mon Nov 8 1999 Toru Hoshina <t@kondara.org>
245- be a NoSrc :-P
246
247* Wed Oct 14 1999 Norihito Ohmori <nono@kondara.org>
248- freetype-current dated Oct 12 1999.
249
250* Sat Oct 9 1999 Toru Hoshina <t@kondara.org>
251- freetype-current dated Oct 3 1999.
252
253* Thu Aug 19 1999 Preston Brown <pbrown@redhat.com>
254- newer ttmkfdir that works better, moved ttmkfdir to /usr/bin from /usr/sbin
255- freetype utilities moved to subpkg, X dependency removed from main pkg
256- libttf.so symlink moved to devel pkg
257
258* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
259- strip binaries
260
261* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
262- auto rebuild in the new build environment (release 5)
263
264* Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
265- fixed the %doc file list
266
267* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
268- Injected new description and group.
269
270* Mon Feb 15 1999 Preston Brown <pbrown@redhat.com>
271- added ttmkfdir
272
273* Tue Feb 02 1999 Preston Brown <pbrown@redhat.com>
274- update to 1.2
275
276* Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
277- call libtoolize to sanitize config.sub and get ARM support
278- dispoze of the patch (not necessary anymore)
279
280* Wed Oct 21 1998 Preston Brown <pbrown@redhat.com>
281- post/postun sections for ldconfig action.
282
283* Tue Oct 20 1998 Preston Brown <pbrown@redhat.com>
284- initial RPM, includes normal and development packages.
Note: See TracBrowser for help on using the repository browser.